14:00:29 <ohiojoe> #startmeeting 2017-12-07 - Documentation Interest Group Meeting
14:00:29 <pinesol_green> Meeting started Thu Dec  7 14:00:29 2017 US/Eastern.  The chair is ohiojoe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:29 <pinesol_green> The meeting name has been set to '2017_12_07___documentation_interest_group_meeting'
14:00:43 <ohiojoe> agenda can be found online at:
14:00:46 <ohiojoe> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20171207-agenda
14:00:59 <ohiojoe> #topic Introductions: please paste "#info <username> is <name> <affiliation>" to identify who you are and what organization, if any, you represent
14:01:26 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:01:37 <ohiojoe> #info ohiojoe is Joe Knueven, Germantown Public Library, Consortium of Ohio Libraries
14:01:52 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:54 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:03:28 <ohiojoe> #topic Old Business
14:03:30 <abneiman> #info abneiman is Andrea Neiman, EOLI
14:03:30 <ohiojoe> #topic Progress on Web Client docs
14:06:02 <ohiojoe> any thoughts on this?  it reminds me that I had a few action items on my to-do list from last month that I didn't get done yet
14:08:09 <sandbergja> I don't know -- do we need a new approach, or to bring new volunteers in?
14:08:23 <sandbergja> I don't know how much action there has been on the Web Client docs recently
14:08:43 <kmlussier> I haven't found that the web client doc days have been very effective.
14:09:03 <sandbergja> do we have a sense for how much XUL-specific stuff remains in the documentation?
14:09:27 <sandbergja> and how much confusion the XUL-specific stuff is causing?
14:09:56 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:webclient
14:11:16 <jihpringle> do we maybe need to update that page to reflect the re-org?
14:11:36 <sandbergja> jihpringle: perhaps
14:12:18 <sandbergja> it feels like we have a lot of docs revision/cleanup projects going right now, and maybe we could combine them somehow?
14:12:55 <jihpringle> what if we had one wiki page per manual that listed chapters/sections that needed review as well as a list of topics that needed to be added?
14:13:07 <jihpringle> combining review and missing docs into one page
14:13:41 <sandbergja> I like that idea!
14:14:06 <jihpringle> list of topics needing documentation could include new web client features and old ported from xul features
14:15:04 <ohiojoe> That sounds like it'd help focus what resources we have on the places where we'll do the most good
14:15:20 <jihpringle> I'd be happy to set up wiki pages to match our list of EG 3.0 manuals if we want to go forward with this
14:16:59 <ohiojoe> that sounds like a good plan to me..
14:17:09 <sandbergja> jihpringle++
14:17:15 <ohiojoe> #action jihpringle will set up wiki pages to match the list of EG 3.0 manuals
14:18:28 <jihpringle> if everyone agress, I'm going to use the 3.0 page as the starting point and divide up the info on that page into the specific manuals - https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:3.0_needs
14:18:35 <jihpringle> agress = agrees
14:19:27 <jihpringle> any objections?
14:19:44 <ohiojoe> jihpringle++
14:20:33 <sandbergja> no objections
14:20:33 <ohiojoe> perhaps in the same vein I could collapse that old business item into the ongoing item on documenting the EG 3.0 new features?
14:20:58 <jihpringle> that makes sense to me
14:21:00 <kmlussier> +1
14:22:00 <ohiojoe> well, with what sounds like a solid plan for that, let's move along..
14:22:13 <ohiojoe> #topic Previous action items
14:23:13 <ohiojoe> kmlussier:  do you have any update on item #3, identifying unclaimed bite sized tasks for new DIG participants, since I know you need to leave shortly..
14:24:41 <kmlussier> Sorry, no, that one slipped my mind. Could you add another action item for me on that one?
14:25:28 <ohiojoe> no worries, I can leave that in there
14:26:16 <ohiojoe> which is as good a time as any for me to say that I have work to do on #4, 8 & 11 that thanks to local circumstances did not occur this past month
14:27:03 <ohiojoe> My intention is to push out the info I meant to share in November on #11 there by the end of the week and email out to the general EG list for volunteers today or tomorrow as well..
14:28:41 <jihpringle> I'll follow up on #1 and #2 with Christineb (she had training this morning so sends her regrets for missing the meeting)
14:29:05 <jihpringle> #6 is done and being used - https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg:clean_up
14:29:23 <jihpringle> but I think maybe needs to be included in the new wiki pages for the 3.0 manuals as well
14:30:14 <sandbergja> Could you add another action item for #10 for me, please?
14:30:44 <ohiojoe> when I read #6 I was thinking that it did sound like it tied into what we just decided a minute ago..
14:31:04 <ohiojoe> #action kmlussier will identify unclaimed bite sized tasks for new DIG participants
14:31:20 <ohiojoe> #action sandbergja will share asciidoc level knowledge of how to work with the new manuals
14:32:46 <ohiojoe> wow, it looks like that only leaves the "everyone" action items that we haven't mentioned or otherwise given an update on..
14:34:05 <ohiojoe> and from my reading, it looks like those three (#5, 7 & 9) are still relevant, so I'm thinking we should keep them on the agenda for now..
14:34:41 <jihpringle> agreed, I think those ones will be ongoing for a while
14:36:53 <ohiojoe> well, with that said, is there any additional to report or discuss in the area of previous action items?
14:40:20 <ohiojoe> #topic Ongoing business
14:40:31 <ohiojoe> #topic Progress on documenting new features in Evergreen 3.0 (and previous)
14:41:32 <ohiojoe> does anyone have anything to share/discuss here?  We kind of talked about it a earlier...
14:42:33 <jihpringle> we're still in the early stages but we're going to be redoing all of our Sitka specific documentation before our next upgrade in May (either to 3.0 or 3.1) and we're moving to asciidoc with our repos in github
14:43:04 <jihpringle> so once we get going it should be much easier for us to share our docs back to the community docs and for others to copy and paste from our repos
14:44:36 <ohiojoe> that's great news!
14:44:38 <ohiojoe> jihpringle++
14:45:09 <jihpringle> big thanks to everyone who answered our questions about how the community docs are set up
14:46:29 <jihpringle> once we start documentating new features I'll try and make sure we push back any that aren't already documented
14:48:13 <sandbergja> Sitka is so cool!  Thanks to jihpringle and all of your colleagues!
14:49:06 <jihpringle> sandbergja: thanks for the help getting us going :)
14:52:19 <ohiojoe> with that said..  that leaves only one item from the agenda...
14:52:23 <ohiojoe> #topic Progress on documentation launchpad bugs
14:52:56 <ohiojoe> does anyone have any thoughts here before we wrap up for today (it feels so odd to actually get through the whole agenda.. )
14:53:15 <sandbergja> I think I'm good
14:54:33 <jihpringle> would it be helpful to reference the bugs on the wiki page for the applicable manual?
14:54:50 <jihpringle> looks like some of the bugs are about sections that are out of date or missing
14:56:13 <sandbergja> that sounds helpful!  Having a one-stop shop for documentation work on a particular manual seems really useful.
14:56:42 <jihpringle> k, I'll combine everything :)
14:57:01 <sandbergja> Thanks!
14:57:01 <ohiojoe> that sounds helpful to me too..  should also help in terms of communicating back to those who are looking for those docs that they've been created or updated..
14:58:27 <ohiojoe> well, if there's nothing else..
14:58:27 <ohiojoe> thank you everyone
14:58:27 <ohiojoe> #endmeeting