15:00:06 <gmcharlt> #startmeeting Evergreen development meeting, 4 April 2018
15:00:06 <pinesol_green> Meeting started Wed Apr  4 15:00:06 2018 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__4_april_2018'
15:00:12 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2018-04-04
15:00:16 <gmcharlt> #topic Introductions
15:00:26 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:00:34 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:00:42 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:00:42 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Coop (Sitka)
15:01:09 <abneiman> #info abneiman = Andrea Neiman, Equinox
15:01:27 <JBoyer> #info JBoyer = Jason Boyer, IN State Library
15:01:39 <berick> #info berick = Bill Erickson, KCLS
15:02:19 <gmcharlt> #topic Action items from last meeting
15:02:33 <gmcharlt> a couple are going to be carried forward :(
15:02:40 <gmcharlt> #action gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:02:47 <gmcharlt> #action gmcharlt will work on patches destined for a release of OpenSRF 3.0.1 in Feburary
15:02:57 <gmcharlt> #action now April
15:03:06 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:03:14 <gmcharlt> dbwells: did you happen to have a chance to tweak the downloads page to make Hatch more visible?
15:03:28 <dbwells> Yes, I made a number of small changes to the downloads page.
15:03:40 <gmcharlt> dbwells++
15:03:51 <dbwells> I hope they are generally under the guise of not quite identfiable improvements :)
15:04:08 <gmcharlt> #info dbwells make some improvements to the downloads page
15:04:20 <gmcharlt> #topic OpenSRF release
15:04:27 <gmcharlt> #info OpenSRF 3.0.1 remains a work in progress
15:04:37 <gmcharlt> and now to the exciting bit
15:04:41 <gmcharlt> #topic Evergreen release
15:04:46 <gmcharlt> #info 3.0.1 is released!
15:04:48 <gmcharlt> dbwells++
15:04:54 <bshum> 3.1.0 maybe
15:04:56 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:04:59 <gmcharlt> bah
15:05:04 <gmcharlt> #info 3.1.0 is released
15:05:06 <gmcharlt> *cough*
15:05:13 <JBoyer> dbwells++ # RM and downloads page
15:05:16 <miker> #info miker = Mike Rylander, EOLI
15:05:18 <gmcharlt> dbwells: anything you wish to say about the release?
15:05:44 <dbs> #info dbs = Dan Scott, Laurentian University
15:05:54 <dbs> dbwells++
15:05:57 <jeffdavis> dbwells++ contributors++
15:06:13 <dbwells> Not really, but just to say I hope to send some sort of "closeout" message to the list later on this week ;)
15:06:40 <gmcharlt> dbwells++
15:06:47 <remingtron> dbwells++
15:06:47 <gmcharlt> any questions about the release?
15:08:13 <kmlussier> Should we have a blog post announcement of the release? I know we had an announcement for the list.
15:08:27 * kmlussier usually steals from the blog post when writing the press release.
15:08:56 <gmcharlt> yeah, I was thinking of writing it tomorrow if folks are amenable
15:09:33 <dbwells> gmcharlt++
15:09:48 <kmlussier> gmcharlt: Thanks!
15:10:01 <kmlussier> dbwells++ gmcharlt++ contributors++
15:10:25 <gmcharlt> #action gmcharlt will put up a blog post announcing 3.1.0 on 4/5
15:13:19 <gmcharlt> on to new business
15:13:58 <gmcharlt> #topic Bug 1538675: Opening catalog link in a new tab forces user out of web client
15:13:59 <pinesol_green> Launchpad bug 1538675 in Evergreen "webclient: Opening link in a new tab from the catalog forces user out of client" [Medium,Confirmed] https://launchpad.net/bugs/1538675
15:14:07 <jeffdavis> I added that one.
15:14:32 <jeffdavis> I've suggested an approach in the bug but I don't know whether it's a good idea.
15:16:04 <jeffdavis> Specifically, replacing the context menu in the catalog iframe with a custom menu to control links opened in a new tab/window.
15:16:50 <miker> jeffdavis: unfortunately, that leaves ctrl-click (maybe it's just me that uses that?)
15:16:59 * berick was thinking the same
15:17:04 <miker> but maybe we can capture that too, via onclick?
15:17:43 <miker> and also ctrl-enter for keyboard activation
15:18:06 * JBoyer loves Ctrl/Command-click + middle click...
15:18:24 <miker> aye, middle click, too
15:19:28 <kmlussier> I would like to see CTRL-click work too, but if it turned out it was more complex or not as easily doable, the context menu would be nice to allow some way to open records in a new tab.
15:19:36 <miker> we could, when loading inside the webstaff wrapper, pass a cgi param. when that's missing and it's a staff login, redirect to the wrapper version
15:20:25 <miker> which would put the param in place, avoiding a loop
15:21:14 <jeff> +1 to trying that over trying to override
15:21:37 <jeffdavis> I like that much better too
15:22:25 <miker> I don't know that we can completely duplicate what would happen in a single-click tab -- other params and such
15:22:51 <miker> it would really only be workable for "dumb" record display links
15:23:06 <miker> maybe that's enough
15:23:26 <jeffdavis> AFAICT our handling of regular clicks on iframe links is pretty basic to begin with
15:23:49 <miker> well, I'm thinking about the place-hold link on a format-restricted metarecord, say
15:24:30 <miker> but maybe we can, instead of doing a dumb wrap, force the iframe src to be what it would have been, rather that constructing it from scratch...
15:26:50 <dbwells> One possible issue with the CGI-param would be the iframe links which function "normally" now (pagination, etc.), to avoid false re-wraps.  But, I do think this plan is overall on the right track.
15:28:24 <jeff> can browsers be relied upon to have "open link in new tab" (via modified click, context menu) use the src= attribute of the link while other "normal" interactions (click or keyboard activation of the link) fire an event?
15:28:36 <miker> dbwells: ah, indeed.  we might have to teach mk_url() to always add a param if it exists, of test to see if we're inside an iframe, and inject <input type=hidden> vars or something
15:29:01 <dbwells> And maybe this is what miker was suggesting most recently, but we might also consider moving the "special" link logic to the TPAC itself, so when in client mode, the most salient links are actually the full client links right from the get-go.
15:29:15 <jeff> oh, that might not actually help due to other complexities of the iframe... nevermind, probably.
15:29:57 <miker> there's probably a seed of a plan in there somewhere :) ... TUITS!
15:30:08 <jeff> we do control the iframe and the contents within, so if we need to modify both sides to have a solid fix...
15:30:14 <jeff> :-)
15:30:53 * miker eyeballs fragments... are you useful?
15:31:08 * dbwells needs to duck out for another event, will keep his eye on the bug/logs
15:32:38 <gmcharlt> great, I love it when a plan starts to coalesce ;)
15:33:18 <gmcharlt> #topic Selecting 3.2 release manager
15:35:59 <gmcharlt> As I mentioned on the wiki, my proposal is to email a formal call tomorrow, deadline on 4/20, and IRC vote (if needed) on 4/25
15:36:04 <gmcharlt> thoughts?
15:37:05 <kmlussier> Sounds good to me.
15:37:11 <JBoyer> Sounds like a reasonable timeline
15:37:38 <jeffdavis> +1
15:37:43 * gmcharlt prepares the Lasso of Voluntelling +1
15:37:53 <gmcharlt> #action gmcharlt will issue call for RM for 3.2 on 4/5
15:38:03 <JBoyer> gmcharlt++
15:38:06 <gmcharlt> #info Deadline for nominations will be 4/20; vote, if necessary, will be held on 4/25
15:38:12 <gmcharlt> OK, any other topics?
15:39:23 <gmcharlt> going once
15:40:23 <cesardv> #info cesardv = Cesar Velez, EOLI
15:40:28 * JBoyer scratches his nose, checks his pocket, eventually realizes he is not at an auction.
15:40:33 <gmcharlt> heh
15:40:35 <gmcharlt> ok, thanks folks
15:40:37 <gmcharlt> #endmeeting