15:03:00 <dbwells> #startmeeting Development meeting, 11 July 2018
15:03:00 <pinesol_green> Meeting started Wed Jul 11 15:03:00 2018 US/Eastern.  The chair is dbwells. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:00 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:00 <pinesol_green> The meeting name has been set to 'development_meeting__11_july_2018'
15:03:24 <kmlussier> dbwells++
15:03:30 <berick> dbwells++
15:03:32 <dbwells> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2018-07-11
15:03:32 <berick> thanks dbwells
15:03:46 <dbwells> #topic Introductions
15:04:21 <berick> #info berick = Bill Erickson @ KCLS
15:04:25 <csharp> #info csharp = Chris Sharp, GPLS
15:04:29 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:04:33 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:04:39 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:04:42 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:04:46 <miker> #info miker = Mike Rylander, EOLI
15:05:06 <cesardv> #info cesardv = Cesar Velez, EOLI
15:05:18 <JBoyer> #info JBoyer = Jason Boyer, ISL
15:05:20 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:06:19 <dbwells> #topic Action Items from Last Meeting
15:06:38 <dbwells> #item gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:07:22 <kmlussier> I don't think #item does anything.
15:08:16 <dbwells> kmlussier: ok, I was going off the last meeting log.  I'll do info instead.  Thank you
15:08:33 <dbwells> #info gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:09:18 <dbwells> Not seeing gmcharlt so far today.  I'll go through these kinda fast, so please stop me if needed.
15:09:33 <dbwells> #info gmcharlt will do a bugfix release of OpenSRF 3.0.2, particularly upon successful testing of bug 1774703
15:09:33 <pinesol_green> Launchpad bug 1774703 in OpenSRF "Websockets processes locked at 100% CPU" [Undecided,Confirmed] https://launchpad.net/bugs/1774703
15:09:43 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:09:51 <gmcharlt> (also temporarily double-booked)
15:10:06 <dbwells> gmcharlt: Good afternoon!
15:10:49 <miker> should we circle back around to gmcharlt after other stuff?
15:11:07 <dbwells> miker: sounds good
15:11:17 <dbwells> #info csharp will upload an update for the Hatch FF add-on
15:11:46 <csharp> yeah, I haven't done that yet :-(
15:12:05 * csharp will get with JBoyer in the next week or so to discuss next steps
15:12:06 <dbwells> no problem
15:12:12 <JBoyer> +!
15:12:12 <dbwells> #action csharp will upload an update for the Hatch FF add-on
15:12:44 * gmcharlt is now single-booked
15:14:25 <dbwells> gmcharlt: Are there specifc action items you would like to give an update on and/or carry over to August?
15:14:33 <gmcharlt> yeah, sec
15:14:40 <gmcharlt> #action gmcharlt will do a bugfix release of OpenSRF 3.0.2, particularly upon successful testing of bug 1774703
15:14:41 <pinesol_green> Launchpad bug 1774703 in OpenSRF "Websockets processes locked at 100% CPU" [Undecided,Confirmed] https://launchpad.net/bugs/1774703
15:14:41 <dbwells> sure
15:14:55 <gmcharlt> #action  gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:16:08 <gmcharlt> (and that's it for me at the moment)
15:17:13 <dbwells> gmcharlt: Thank you.  Do you also want to carry over the OpenSRF 3.1.0 roadmap and the angular meeting action items?
15:17:17 <gmcharlt> yeah
15:17:37 <dbwells> #action gmcharlt will put out a call for roadmap entries for OpenSRF 3.1.0
15:17:37 <gmcharlt> #action Galen will start a OpenSRF 3.1.0 roadmap and issue calls for entries
15:17:49 <dbwells> oh, sorry
15:17:59 <gmcharlt> what is #action'ed twice will get done for the next meeting ;)
15:18:02 <gmcharlt> no worries!
15:18:44 <dbwells> #action gmcharlt to work with berick to see about setting up some kind of presentation/meeting to discuss angular
15:18:48 * csharp files away "you only used #action once" excuse for future meetings
15:18:58 <dbwells> #topic OpenSRF Release - Time for an LP 3.1 series?
15:19:17 <berick> i added that question, btw, but I think gmcharlt action kind of answers that
15:19:34 <gmcharlt> yeah, I and went ahead and registered the series now
15:19:37 <dbwells> Okay, sounds good.
15:19:43 <gmcharlt> so... target away!
15:19:45 <berick> gmcharlt: oh cool, thanks
15:20:06 <dbwells> #topic Evergreen Releases
15:21:17 <dbwells> #info Evergreen 3.1.3 and 3.0.9 were released on 06/28/18
15:22:02 <berick> and 2.12 is now EOL?
15:22:09 <dbwells> Thank you to all the Buildmaster folks who played a role on those releases.
15:22:16 <dbwells> Yes, 2.12 is security only.
15:22:33 <berick> i think we're past security, even (according to calendar)
15:22:43 <dbwells> Ah, perhaps you are right.
15:22:47 <csharp> dbwells++ #wranglin'
15:22:51 <gmcharlt> https://wiki.evergreen-ils.org/doku.php?id=dev:release_process:schedule
15:22:58 <gmcharlt> "It's dead, Jim!"
15:23:19 <dbwells> #info A moment of silence was observed for 2.12.
15:23:21 <kmlussier> Yes, we're past security.
15:23:21 * gmcharlt edits it to add 3.1; will ask for double-checking my calculations in a omently
15:24:08 <dbwells> berick: Anything to add for 3.2?
15:24:24 <kmlussier> I can take 2.12 off the downloads page.
15:24:34 <berick> 5 weeks till feature slush for 3.2.
15:24:47 <berick> i'd like to get some of the bigger ones merged earlier, though
15:24:59 <berick> to limit the inevitible chaos
15:25:23 <berick> feature list reminder: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.2
15:25:51 <berick> I'm prepared to merge 1766716 as soon as my final comments are addressed
15:25:54 <gmcharlt> (https://wiki.evergreen-ils.org/doku.php?id=dev:release_process:schedule reading for double-checking)
15:26:15 <berick> i have another item on that list noted already in this meeting
15:26:23 <berick> anything else on that list ready ready for review?
15:26:58 <berick> (that's not mine, anyway)
15:27:35 <berick> in any event, i'm on hand to help reivew / merge any of those big-ticket items sooner than later
15:27:47 <dbwells> berick++
15:27:52 <dbwells> Any questions for berick before we move ahead?
15:27:57 <miker> berick: I shall comment thereon
15:28:05 <berick> miker++
15:28:24 <JBoyer> berick++
15:29:17 <dbwells> #topic New Business
15:29:30 <dbwells> #topic Feedback on bug #1750894 needed
15:29:31 <pinesol_green> Launchpad bug 1750894 in Evergreen "Wishlist: Store web staff workstation settings on the server" [Wishlist,New] https://launchpad.net/bugs/1750894
15:29:39 <berick> carry over from last meeting, I should have added an action item
15:30:15 <berick> this one's fairly disruptive and will require ang6 coding post-merge, so I'm hoping to merge well before the 3.2 cut-off
15:30:47 <berick> and I expects a dragon or 2 may lurk, yar
15:31:18 <berick> it could also affect other features in development
15:31:22 <kmlussier> I can commit to looking at it over the next week.
15:31:31 * JBoyer will also try to poke at it a bit soon
15:32:06 <JBoyer> I have some thoughts re: workstations too. (for another time)
15:32:13 <dbwells> berick: can you maybe explain a bit more about "require ang6 coding post-merge" ?
15:32:16 * Dyrcona didn't get past blowing up his node installation with an upgrade to look at it.
15:33:28 <berick> dbwells: if we have any desire to merge the ang6 stuff in 3.2, the client-side code from 1750894 will have to be ported for parity.  i've been holding off on it in case any major changes occur in the bug.
15:34:55 <dbwells> berick: Oh, I understand now, thanks.
15:35:32 <berick> kmlussier: JBoyer: how many #action's can I put you down for? ;)
15:35:37 <berick> i'll start with 1
15:35:47 <dbwells> I was thinking of the statement with the reverse effect, that somehow merging this would require us to use ang6 is some place.
15:36:08 <berick> #action kmlussier and JBoyer to review https://launchpad.net/bugs/1750894
15:36:08 <pinesol_green> Launchpad bug 1750894 in Evergreen "Wishlist: Store web staff workstation settings on the server" [Wishlist,New]
15:36:15 <berick> dbwells: ah, no, nothing like that
15:36:21 <JBoyer> 1 action is probably what I can commit to currently. ;)
15:36:22 <pinesol_green> [evergreen|Mike Rylander] LP#1736269: Mark Missing Pieces is non-functional - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=1524b7b>
15:37:19 <dbwells> Well, that's the end of the agenda.  Anything else for the good of the order?
15:38:15 <csharp> well, as one of the newest core committers, I have found a need for some sort of procedural/best practices guide, which I'm willing to help create
15:38:39 <cesardv> csharp++
15:38:40 <csharp> not sure if that's better as a hack-a-way-ish goal or what
15:39:10 <JBoyer> the kind of high-bandwidth discussion that can be had in person seems helpful.
15:39:32 <csharp> yeah, I was thinking the same thing, so maybe something to tack on to the hackaway agenda
15:39:47 <csharp> I don't think it would take very long with the right people around
15:40:18 <dbwells> Actually, I have one quick thing to mention as well.  With the July 4th holiday, the buildmasters would like to push the July release back a week to 07/25.  So that's the current plan unless there are strong objections.
15:40:51 <miker> I OB-- no I don't
15:40:56 <JBoyer> +1
15:41:06 <kmlussier> Either way. With csharp
15:41:09 <kmlussier> gah
15:41:22 <kmlussier> With csharp's merges, there's plenty to add to a release, but I don't mind waiting either. :)
15:41:33 <gmcharlt> +1
15:41:45 <csharp> yeah, I'm just sweeping up signed-off or easily tested bugs
15:43:03 <dbwells> okay,
15:43:18 <berick> csharp++
15:43:20 <dbwells> #agreed July point releases will be scheduled for July 25
15:43:35 <dbwells> And with that...
15:43:44 <dbwells> #endmeeting