15:04:35 <kmlussier> #startmeeting Evergreen Developer Meeting 2018-09-05
15:04:35 <pinesol> Meeting started Wed Sep  5 15:04:35 2018 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:35 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:35 <pinesol> The meeting name has been set to 'evergreen_developer_meeting_2018_09_05'
15:05:15 <kmlussier> #info Agenda is available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2018-09-05
15:05:23 <kmlussier> #topic Introductions
15:05:26 <Dyrcona> #info Dyrcona is Jason Stephenson, CW MARS.
15:05:34 <gmcharlt> #info Galen Charlton, Equinox
15:05:35 <dpearl> #info DPearl = Dan Pearl, C/W MARS Inc.
15:05:37 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:05:39 <miker> #info miker = Mike Rylander, EOLI
15:05:40 <stephengwills> #info Stephen Wills rep: Maine Balsam Consortium
15:05:46 <abneiman> #info abneiman, Andrea Buntz Neiman, Equinox
15:05:47 <berick> #info berick Bill Erickson, KCLS
15:05:49 <JBoyer> #info JBoyer is Jason Boyer, IN State Lib
15:06:24 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:06:48 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:06:57 <rhamby_> #info rhamby_ = Rogan Hamby, EOLI
15:06:57 <kmlussier> #topic Action Items from Last Meeting
15:07:16 <kmlussier> gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:07:22 <kmlussier> gmcharlt: How's that going?
15:07:58 <gmcharlt> working on it, but will be doing OpenSRF stuff after the 3.2 beta merge window closes tomorrow
15:08:21 <kmlussier> gmcharlt: OK, do you want me to add an action for it again?
15:08:26 <gmcharlt> kmlussier: sure
15:08:37 <kmlussier> #action gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:08:52 <kmlussier> That's our only action item.
15:09:15 <kmlussier> #topic OpenSRF Updates
15:10:14 <kmlussier> gmcharlt: Anything more to add other than you'll be working on OpenSRF stuff after the beta merge window closes?
15:10:24 <gmcharlt> kmlussier: nope
15:10:51 <kmlussier> #info gmcharlt will be working on OpenSRF after the Evergreen beta merge window closes.
15:11:05 <kmlussier> #topic Evergreen updates
15:11:08 <miker> I'd like to get some more eyes (thanks, Dyrcona) on the changes I attempted for newer ejabberd's
15:11:19 <miker> oh... missed my chance :)
15:11:23 <Dyrcona> heh.
15:11:37 <kmlussier> miker: That's okay. We can discuss it now.
15:11:47 <Dyrcona> I was thinking of adding that we should really add SASL and TLS support for XMPP with OpenSRF.
15:11:51 <berick> i was hoping to circle back to miker's code when I get a little more time
15:12:15 <miker> Dyrcona: agreed ... but, tuits (for me, right now, anyway)
15:12:16 <Dyrcona> I am also planning to have another look at it soonish.
15:12:21 <kmlussier> Is there a bug number for that?
15:12:33 <miker> looking...
15:13:05 <jeff> bug 1703411?
15:13:07 <pinesol> Launchpad bug 1703411 in OpenSRF "OpenSRF: XMPP Non-SASL auth is being phased out" [Medium,Confirmed] https://launchpad.net/bugs/1703411
15:13:29 <miker> jeff: yep
15:13:31 <Dyrcona> Yeah
15:13:33 <JBoyer> Would those changes require explicit support in Evergreen? If not that would relieve a little pressure since OpenSRF releases are more "as-needed"
15:13:41 * Dyrcona had just found it in browser history.
15:13:46 <miker> JBoyer: no, just rebuilding
15:14:13 <miker> JBoyer: and that's my hope, too
15:14:18 <JBoyer> +1
15:14:20 <berick> should probably split those bugs into 2
15:14:27 <Dyrcona> Or three?
15:14:42 <Dyrcona> Or, you mean separating the Evergreen bug from OpenSRF?
15:15:10 <berick> a bug for schema changes and a bug for SASL changes
15:15:16 <miker> well, splitting sasl and attributes
15:15:26 <berick> yeah
15:15:30 <miker> what berick said
15:16:13 <Dyrcona> OK. that's what I thought at first.
15:16:20 <miker> anyway, I know it's busy right this moment, so "soon" is great for me
15:16:31 <kmlussier> Would anyone like to take an action item to look at miker's code?
15:17:10 <berick> i can
15:17:39 <kmlussier> berick++
15:18:27 <kmlussier> #action berick will review miker's ejabberd changes for bug 1703411
15:18:28 <pinesol> Launchpad bug 1703411 in OpenSRF "OpenSRF: XMPP Non-SASL auth is being phased out" [Medium,Confirmed] https://launchpad.net/bugs/1703411
15:18:59 <kmlussier> OK, anything else for OpenSRF?
15:19:04 <kmlussier> Sorry to have rushed it earlier. :)
15:19:10 <berick> one thing..
15:19:24 <berick> do we have a general sense of when the next release will be (gmcharlt?)
15:19:50 <gmcharlt> berick: I'm shooting for beta around the same time as general release of Evergreen 3.2.0
15:20:15 <berick> thanks gmcharlt
15:20:34 <kmlussier> #info gmcharlt is planning an OpenSRF beta release around the same time as the 3.2.0 release
15:20:58 <kmlussier> #topic Evergreen update (for real this time)
15:21:05 <kmlussier> berick, you have the floor
15:21:38 * berick clears throat
15:22:11 <berick> in reverse of the list, I need volunteers to help with building, documentation, etc for the Beta
15:22:20 <dbwells> I've put myself on the sheet for the beta build, and remingtron will do a test install, but more testers are always welcome.
15:22:42 <berick> thanks dbwells and remingtron
15:22:53 <Dyrcona> I can test.
15:23:06 <berick> thanks Dyrcona
15:23:09 <JBoyer> I'll give at least a live-data upgrade a shot.
15:23:20 <kmlussier> berick: sandbergj is usually pretty good about taking care of release notes.
15:23:50 <berick> kmlussier: even for the major releases?  wasn't sure if that usually fell under the regular process
15:24:11 <dbwells> I have also put myself (for now) and the release notes line, but plan to ask sandbergja if she wants to give it a go.
15:24:33 <berick> awesome
15:24:53 <berick> note to self: save some time to review the DB upgrade in depth Friday
15:25:33 <berick> ok and.
15:25:49 <berick> discussed earlier today in IRC, bug merge cut-off for beta1 will be tomorrow night
15:25:52 <berick> (thursday)
15:26:08 <berick> so we can start the build steps first thing Friday
15:26:25 <berick> i expect there will be a bump or two given the late mergeds of xul stuff, angular stuff
15:26:32 <berick> *merges
15:26:36 <berick> which leads me to...
15:26:50 <berick> any last minute OMGNO's on either the xul or angular stuff?
15:27:15 <berick> (note I'm running the angular stuff through build tests to today on the current code)
15:27:59 <gmcharlt> so just to give an update on the XUL-disabling stuff
15:28:18 <gmcharlt> it is going to be *easy* to revert if we end up not running with it before release of 3.2.0
15:28:50 * dbwells steps out quietly
15:29:10 <gmcharlt> as the only thing it's going to do is to coerce the STAFF_CLIENT_STAMP_ID to "legacy" (and manage the xul/server symlnk) and update some bits in the document
15:29:44 <gmcharlt> if you want a staff client, you'll be able to have it by explicitly supplying STAFF_CLIENT_STAMP_ID in the make install step and run the make_release step to build a client for you
15:29:47 <berick> gmcharlt: any changes to the make_release script to bypass building?
15:29:55 <berick> or maybe there's a flag for that, can't remember
15:30:01 <gmcharlt> yeah, there's a flag
15:30:25 <berick> great
15:31:08 * gmcharlt notes that there are a couple webstaff interfaces that still iframe in xhtml interfacs udner /xul/server
15:31:10 <Dyrcona> I'm a bit concerned about the XUL link, because I swear that I've seen parts of the web staff client fail without it.
15:31:23 <gmcharlt> so outright removal won't be possible in 3.2
15:31:24 <Dyrcona> heh.
15:31:49 * JBoyer must also disappear. Micro update re: bug 1731922, it's been well tested, the version on the AMO site is fine for testing, you just need to make sure your hatch.bat has the changes in that branch. Will answer any Qs tomorrow
15:31:51 <pinesol> Launchpad bug 1731922 in Evergreen "Firefox add-on for Hatch" [Wishlist,Confirmed] https://launchpad.net/bugs/1731922
15:32:00 <kmlussier> gmcharlt: Do we have a list of those interfaces?
15:32:06 <berick> good targets for early angular porting
15:32:10 <gmcharlt> kmlussier: user permission editor is one
15:32:46 * kmlussier won't be sad to see that interface ported to angular.
15:33:09 <gmcharlt> looks like a copy admin interfaces (unless they happened to be swept away in the ang6 branch)
15:34:08 <berick> stat cat editor
15:34:21 <berick> at least, that's one
15:34:32 <berick> (not ported to angular, but in /xul/server/)
15:34:40 <kmlussier> Would it be helpful to add a LP bug so that we can get started early on those for the 3.3 release process?
15:34:49 <Dyrcona> +1
15:35:01 <berick> yes
15:35:19 * kmlussier can do that.
15:35:33 <berick> cash reports too, looks like
15:37:13 <kmlussier> Is there anything else for Evergreen updates? How are things going with the angular branch?
15:38:05 <berick> i'm putting final touches on release notes
15:38:15 <berick> as I build the code on new dev VMs
15:38:57 <berick> once i'm happy with that, I'm going to squash it all down to just 2 or 3 commits
15:39:19 <berick> angularjs changes, new angular stuff, and release notes
15:39:25 <berick> oh and a db update for workstation settings
15:39:35 <berick> i'll keep the original branch around for history
15:39:43 <berick> well, branches
15:39:48 <berick> that should be wrapped up today
15:39:58 <kmlussier> Great! Do you need volunteers to test it or are they already lined up?
15:40:09 <berick> I do need volunteers
15:40:31 * gmcharlt volunteers
15:40:35 <berick> main test targets are: ability to build/install/run etc. and testing the ACQ admin UI's to make sure they function as expected
15:40:36 <Dyrcona> I can probably test it again tomorrow.
15:40:44 <berick> there's a lit of the UI's in the release notes that will be ang6-based
15:40:58 <berick> s/lit/list/
15:41:12 <berick> but basically got to admin -> acq admin and poke around
15:41:46 <berick> i'll update the LP when I'm done and slap a pullrequest on
15:41:46 <kmlussier> #action gmcharlt and Dyrcona to test ang6 branch once it is squashed.
15:41:53 <berick> thanks gmcharlt, Dyrcona
15:42:05 <kmlussier> berick++ gmcharlt++ Dyrcona++
15:42:10 <berick> oh, one thing I wanted to mention...
15:42:17 <berick> since we're just doing grid UI's for now
15:43:26 <berick> the grid has some additional niceties.  arrow keyboard navigation (all directions), drag-drop column positioning works, Enter==dbl-click, verticall expand rows to see more content, inline translations editor
15:43:57 <Dyrcona> berick++
15:43:59 <berick> good to test some of that too
15:44:02 <kmlussier> Ooh! People are going to be happy to see drag-drop column positioning.
15:44:41 <berick> everything else should be the same
15:44:53 <kmlussier> OK we have about 15 minutes left. Do we have anything else on Evergreen updates or on any other topic?
15:45:41 <berick> none from me
15:45:48 <berick> thanks for all the bug/feature work everyone!
15:46:05 <kmlussier> berick: Thanks for all the cat herding!
15:46:39 <kmlussier> OK, I guess that's a wrap then.
15:46:45 <kmlussier> #endmeeting