14:00:49 <ohiojoe> #startmeeting 2018-09-06 – Documentation Interest Group Meeting
14:00:49 <pinesol> Meeting started Thu Sep  6 14:00:49 2018 US/Eastern.  The chair is ohiojoe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:49 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:49 <pinesol> The meeting name has been set to '2018_09_06___documentation_interest_group_meeting'
14:00:55 <ohiojoe> #topic agenda
14:01:01 <ohiojoe> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20180906-agenda
14:01:13 <ohiojoe> #topic Introductions: please paste "#info <username> is <name> <affiliation>" to identify who you are and what organization, if any, you represent
14:01:45 <ohiojoe> #info ohiojoe is Joe Knueven,  an Evergreen enthusiast
14:02:10 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:02:17 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:02:20 <abneiman> #info abneiman is Andrea Neiman, Equinox
14:04:21 <ohiojoe> #topic Ongoing Business
14:04:30 <ohiojoe> #topic Progress on documenting new features in Evergreen 3.1 (and previous)
14:06:05 <sandbergja> Just a note that I'll be putting together the 3.2 release notes tonight
14:06:21 <sandbergja> So more sweet features to look forward to!
14:06:24 <abneiman> Not for 3.1, but I have a handful of adocs ready for some upcoming 3.2 features -- where would you like me to PR them?
14:07:25 <remingtron> abneiman: I'd prefer a working repo branch, but github works too
14:08:05 <remingtron> sandbergja++ #releasenotes wrangler
14:08:08 <ohiojoe> I probably need to change that to 3.2 and previous actually..  I thought about that when I put it together..
14:08:16 <abneiman> remingtron: right, I meant, is there a specific directory within github where you'd like me to put them?
14:08:21 <ohiojoe> sandbergja++
14:08:41 <sandbergja> abneiman++ #always does such great documentation
14:09:16 <abneiman> sandbergja: thanks, but I can only take credit for the adoc conversion!  The hard part was done by my colleagues :)
14:10:33 <sandbergja> abneiman: would you be able to add them to the existing docs structure, and then add references to root.adoc and the other manual root files, so they show up in the official manuals?
14:10:53 <remingtron> abneiman: oh, right, sorry.
14:10:53 <sandbergja> I'm happy to help out if you have any questions
14:11:18 <abneiman> sandberja: I will try! I'm still learning the docs process.  Will give you a yell if needed, thanks :)
14:11:40 <sandbergja> Sounds great!
14:12:23 <sandbergja> I'm also wondering if I could be more helpful when putting together release notes, for the non-Equinox features
14:13:18 <sandbergja> I'm happy to add new 3.2 features to the Documentation Needs list on the wiki as I work on the release notes
14:13:30 <abneiman> sandbergja: I'd like to learn how to compile release notes, in case you are not available (or would like a break)
14:14:05 <sandbergja> Also, if the release notes for a 3.2 feature seem good, is it okay if I just add them to the documentation proper, rather than the docs needs list?
14:14:44 <remingtron> sandbergja: Yes! Streamlined!
14:14:55 <kmlussier> sandbergja: Yes, I think there was an entry for the permission group tree that could go directly in the docs.
14:15:06 <sandbergja> abneiman: Sure!  It would be great to have more backup!
14:15:07 <kmlussier> It even came with screenshots!
14:15:17 <ohiojoe> streamlining is rarely a bad thing
14:15:33 <sandbergja> FYI, the release notes process is here:
14:15:36 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:release_notes_process
14:16:04 <sandbergja> also, I'm pretty new to the release notes process, kmlussier is the release notes expert!
14:16:42 <kmlussier> sandbergja is an expert by now! :)
14:18:28 <sandbergja> kmlussier: awww, shucks!  Thanks!
14:19:11 <ohiojoe> this feels like a good time to say thank you to you all for what you do to get docs written and out the door  (colleagues included.. :-)  )
14:19:29 <ohiojoe> with that, do we have anything else on this topic?
14:19:30 <remingtron> everybody++
14:19:53 <remingtron> Just a quick note about the to-do page:
14:19:55 <remingtron> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:20:34 <remingtron> I've tried to add an entry for each easy/bitesize task near the top, to make it easier for new contributors to jump in
14:20:43 <remingtron> As always, edits/improvements are welcome!
14:22:04 <sandbergja> I like the bitesize tasks at the top!
14:22:11 <sandbergja> remingtron++
14:22:30 <ohiojoe> remingtron++
14:22:35 <ohiojoe> I agree
14:22:57 <ohiojoe> something I can try to jump in on once my evenings free up a bit..
14:23:18 <sandbergja> One question about the consolidated documentation needs page: should we eventually remove the completed parts?
14:23:49 <sandbergja> I see a few strikethroughs from a while ago
14:23:54 <remingtron> sandbergja: yes, I think so
14:25:32 <sandbergja> It always feels so good when the docs needs pages on the wiki get smaller! :-D
14:25:49 <ohiojoe> probably a good idea..  worst case, we clear those and they get added back if someone sees something new that needs done in/on that area..
14:28:47 <ohiojoe> well, I could try to go through there and tidy those up a bit if you all would like..
14:29:39 <sandbergja> ohiojoe++ # that would be super
14:30:24 <ohiojoe> do you see any value in keeping the completed tasks listed any place else or shall I just delete them?  I always get nervous about deleting things if they could have some utility to the community..
14:31:42 <sandbergja> I think the completed tasks are already available two places: in the wiki page history, and in the git commits of the actual doumentation files in the repository
14:31:56 <ohiojoe> excellent, delete it is then..
14:32:01 <ohiojoe> #action ohiojoe will tidy up the Evergreen Documentation Needs page
14:32:14 <ohiojoe> ok, do we have anything else here?
14:32:34 <remingtron> one more quick thing
14:32:44 <ohiojoe> please :-)
14:33:24 <remingtron> If anyone wants to review docs that someone else has already written, check the to-do page for the "Fix me!" flag
14:34:28 <remingtron> I've been using that flag for drafts that have been shared but not committed yet
14:34:33 <remingtron> that's all!
14:35:12 <ohiojoe> and with that, it looks like it's time to jump to one on one and small group collaboration..
14:35:29 <sandbergja> Yay!  I'm excited!
14:35:31 <ohiojoe> #topic one on one and small group collaboration on documentation
14:35:50 <ohiojoe> I figured we should stay "in session" since we agreed that this would be part of the meeting
14:36:28 <sandbergja> abneiman: do you want to work together on something?  Either release note process or getting your adoc into the structure of the docs folder?
14:37:27 <abneiman> sandbergja: sure, how about we try the latter?
14:38:45 <abneiman> The first one I have is Batch Actions, which belongs under OPAC
14:39:44 <remingtron> ohiojoe: I'm not able to grab a task right now, but you can ping me if you get stuck on anything.
14:40:03 <sandbergja> So, I would say that it should be included in both the OPAC manual and the consolidated manual
14:40:31 <sandbergja> So, it would be a three-step process
14:40:33 <ohiojoe> remingtron:  thank you.  I was thinking I'd see if I can get anything started on one of those bite sized tasks..
14:41:04 <sandbergja> 1) add your adoc to an appropriate folder (Evergreen/docs/opac seems good)
14:41:30 <sandbergja> 2) add a reference to that file in docs/root.adoc for the consolidated manual
14:41:52 <sandbergja> 3) add a reference to your file in docs/root_opac.adoc to add it to the OPAC manual
14:42:47 <abneiman> ok, proceeding
14:48:17 <abneiman> sandbergja: done
14:49:06 <abneiman> no wait, skipped a step
14:50:26 <abneiman> NOW done
14:51:09 <sandbergja> abneiman++
14:51:11 <sandbergja> Yay!
14:51:32 <abneiman> does it look correct from your end?
14:56:24 <sandbergja> abneiman: let me see
14:57:59 <abneiman> sandbergja++
15:00:50 <sandbergja> abneiman: I'm just not sure about one thing
15:01:40 <sandbergja> I didn't see the screenshots in the docs/media folder, and I didn't see a pull request of yours adding them.  But they are showing up just fine here: https://github.com/evergreen-library-system/Evergreen/pull/64?
15:01:56 <sandbergja> Did I miss where you added those screenshots to the repository?
15:02:13 <abneiman> sandbergja: I added them as attachments on the pullrequest in github, which is how I'd been told to do it?
15:02:36 <abneiman> If a separate PR to docs/media is preferred I can do that
15:02:42 <sandbergja> Oh, interesting!  I just don
15:02:59 <sandbergja> ^ I didn't know about those
15:03:19 <sandbergja> I think we're probably good, then. :-)
15:03:39 <abneiman> cool!  that was less intimidating that I thought it would be.  Thanks for your help!  sandbergja++
15:03:50 <ohiojoe> abneiman++
15:03:55 <ohiojoe> sandbergja++
15:04:27 <ohiojoe> and with that, I'm going to go ahead and close the meeting.  feel free to keep collaborating if you have time.. :-)
15:04:48 <ohiojoe> #endmeeting