15:07:38 <kmlussier> #startmeeting 2018-10-10 Evergreen developers meeting
15:07:38 <pinesol> Meeting started Wed Oct 10 15:07:38 2018 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:38 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:38 <pinesol> The meeting name has been set to '2018_10_10_evergreen_developers_meeting'
15:07:43 <JBoyer> kmlussier++
15:08:19 <kmlussier> #info Meeting agenda is available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2018-10-10
15:08:23 <kmlussier> #topic Introductions
15:08:28 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:08:36 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:08:45 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:08:46 <JBoyer> #info JBoyer is Jason Boyer, IN State Lib
15:08:53 <miker> #info miker = Mike Rylander, EOLI (now having to miss the meeting ... arg, sorry)
15:09:03 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:09:04 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:09:14 <abneiman> #info abneiman, Andrea Neiman, Equinox
15:09:17 <berick> #info berick Bill Erickson, KCLS
15:09:22 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:09:28 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
15:09:57 <cesardv_> #info cesardv, cesar velez, EOLI
15:10:11 <kmlussier> #topic Action Items from Last Meeting
15:10:26 <kmlussier> gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:10:58 <gmcharlt> still on my plate; now that 3.2.0 is out the door, I will turn my attention to OpenSRF releases
15:11:23 <kmlussier> OK, I'll add that action item for next month's meeting then.
15:11:31 <kmlussier> #action gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:12:02 <kmlussier> #info berick has reviewed miker's ejabberd changes for bug 1703411
15:12:03 <pinesol> Launchpad bug 1703411 in OpenSRF "OpenSRF: XMPP Non-SASL auth is being phased out" [Medium,Confirmed] https://launchpad.net/bugs/1703411
15:12:25 <kmlussier> #info gmcharlt and Dyrcona to tested the ang6 branch
15:12:37 <kmlussier> Is there anything else to say about the action items from the previous meeting?
15:13:18 <kmlussier> #topic OpenSRF 3.1 beta release
15:13:32 <kmlussier> gmcharlt?
15:13:40 <Dyrcona> I think that bug 1703411 should actually be bug 1793356.
15:13:42 <pinesol> Launchpad bug 1703411 in OpenSRF "OpenSRF: XMPP Non-SASL auth is being phased out" [Medium,Confirmed] https://launchpad.net/bugs/1703411
15:13:43 <pinesol> Launchpad bug 1793356 in OpenSRF "Ejabberd strips custom XML attributes" [Medium,Fix committed] https://launchpad.net/bugs/1793356
15:13:44 <gmcharlt> #info OpenSRF 3.1 beta will be released before the hack-a-way; hopefully sooner rather than later
15:14:16 <kmlussier> Dyrcona: Did I misidentify it in the original action?
15:14:38 <Dyrcona> kmlussier: The code moved to a different bug, so I guess so.
15:14:40 <berick> the bug later migrated
15:15:10 <gmcharlt> *insert spider vs. bug migration joke here*
15:15:17 * Dyrcona didn't think of that when reviewing the agenda earlier.
15:15:35 <kmlussier> #info Correction: berick reviewed miker's ejabberd changes for bug 1793356
15:15:36 <pinesol> Launchpad bug 1793356 in OpenSRF "Ejabberd strips custom XML attributes" [Medium,Fix committed] https://launchpad.net/bugs/1793356
15:16:18 <kmlussier> gmcharlt: Are there any OpenSRF bugs that need to be reviewed to help with the release?
15:18:01 <gmcharlt> for the beta, as many eyes as possible on the websocketd patch woudl be great
15:18:33 <JBoyer> I'm hoping to throw some tuits in that direction soon.
15:18:58 * berick is running it on a large test cluster as of 2 weeks ago
15:19:03 <JBoyer> berick++
15:19:13 <kmlussier> #help websocketd patch needs review from as many people as possible.
15:19:15 <Dyrcona> I'm running websocketd in production with OpenSRF 3.0.1 if that means anything.
15:19:18 <stephengwills> #info stephengwills Maine Balsam Libraries
15:20:07 <JBoyer> Dyrcona, that sounds promising, none of the old pegged /dead processes, etc.?
15:20:30 <Dyrcona> No problems at all so far.
15:20:38 <JBoyer> Nice.
15:20:56 <Dyrcona> Seems to be less load on the servers, too.
15:21:26 <kmlussier> Is there anything else we need to discuss for the OpenSRF release before we move on to Evergreen updates?
15:21:29 <berick> i'm planning to post a LP patch for removal of apache2-websockets, but presumably that will not be in 3.1
15:22:10 <gmcharlt> berick: yeah, I'd go so far as a deprecation in 3.1, but not a removal
15:22:20 <berick> gmcharlt: what I figured, thanks
15:22:55 <kmlussier> #info apache2-websockets to be deprecated in 3.1, with removal planned for 3.2.
15:23:01 <Dyrcona> Well,it just steps in the README.
15:23:13 <Dyrcona> I say get rid of them.
15:24:10 <gmcharlt> we'll use a smaller font ;)
15:24:28 <kmlussier> #topic Evergreen 3.2 updates
15:24:40 <kmlussier> berick: Do you have any 3.2 updates for us?
15:24:42 <Dyrcona> <marquee> Don't install this! It's garbage! </marquee>
15:24:59 <berick> kmlussier: not really.  i have not heard a lot, I think people are easing into it
15:25:23 <berick> we'll be settling in to the usual release schedule now
15:25:38 <kmlussier> Well, we have had a release since the last meeting. :)
15:25:45 <berick> haha
15:25:54 <kmlussier> #info 3.2.0 was released on October 3
15:26:00 <kmlussier> Just so that we get it into the minutes.
15:26:05 <berick> kmlussier++
15:26:35 <dbwells> berick++
15:26:35 <kmlussier> berick++ # Managing the release schedule.
15:27:50 <kmlussier> #topic Possible extension of 3.0 to one more maintenance release
15:28:17 <kmlussier> I added this topic to the agenda because we found some regressions when CW MARS updated to the latest 3.0 maintenance release over the weekend.
15:28:39 <kmlussier> I would like to suggest that we do one more 3.0 maintenance release that's limited to addressing regressions only.
15:28:45 <gmcharlt> I'm amenable to that extension, but I think we should nix any other backports
15:28:50 <gmcharlt> IOW, what kmlussier said
15:29:16 <berick> +1
15:29:18 <berick> keep it stable
15:29:26 <Dyrcona> I concur, and I could volunteer to release it/manage it.
15:29:37 <JBoyer> Since it was backports that caused the problem, we could just strip out the couple of commits, release 3.0.13 tomorrow and call it fixed?
15:30:10 <kmlussier> Do we know exactly which commits caused the problems?
15:30:11 <JBoyer> (I say that because I thought the issue had been narrowed down to something specific, the hover tags or something similar?)
15:30:21 <kmlussier> JBoyer: No, that's another issue.
15:30:27 <JBoyer> Then don't mind me. :(
15:30:35 <Dyrcona> Well, those tootips do cause problems.
15:30:40 <kmlussier> I don't think the tooltips were backported, were they?
15:30:52 <Dyrcona> They were. I did it.
15:30:56 <dbwells> JBoyer: I thought the same thing at first.
15:31:15 <kmlussier> bug 1796971 and bug 1796978 are the two issues.
15:31:18 <pinesol> Launchpad bug 1796971 in Evergreen 3.1 "Web Client: Unable to Add Items from Item Status or Holdings View" [High,Confirmed] https://launchpad.net/bugs/1796971
15:31:19 <pinesol> Launchpad bug 1796978 in Evergreen 3.2 "Web client cannot create two or more copies at the same time" [High,Confirmed] https://launchpad.net/bugs/1796978
15:31:28 <kmlussier> But if the tooltips were backported, I think that one should be addressed to.
15:31:33 <dbwells> Also, +1 to another release to fix those bugs, and maybe the hover one, too.
15:31:37 <kmlussier> s/to/too
15:31:46 <JBoyer> I'm also +1 for one more fix release, no more backports, and we can figure out what happened another day. :)
15:32:04 <Dyrcona> Well, we could always have a formal vote for the release, but I don't hear any opposition so far.
15:32:30 <kmlussier> Are there any objections? Also, are there any objections to Dyrcona managing the release?
15:32:35 <gmcharlt> as far as the tooltips are concerned, I'm inclined to suggest an outright reversion for rel_3_0; leaving an eventually proper fix for rel_3_1 and later
15:32:46 <kmlussier> +1
15:32:53 <JBoyer> +1 to gmcharlt's suggestion also.
15:32:56 <gmcharlt> anyway, no objection to Dyrcona managing another 3.0.x
15:33:07 <jeff> +1 overall to the above
15:33:09 <dbwells> Dyrcona: startvote: Who wants to have a vote on another release?  ;)
15:33:27 <kmlussier> heh
15:33:27 * JBoyer vanishes.
15:33:35 * kmlussier waves to a disappearing JBoyer
15:33:40 <Dyrcona> No need to vote at this point.
15:33:41 <gmcharlt> I never met a metavote I didn't like
15:33:43 <Dyrcona> :)
15:33:44 <gmcharlt> ^ not truth
15:33:47 <gmcharlt> er, ^^^
15:33:51 <Dyrcona> heh
15:33:58 <kmlussier> Dyrcona: Do you have a date by which you want to have the last 3.0 release out?
15:34:39 <kmlussier> Actually, the next maintenance release is next week already, isn't it? It goes by so quickly.
15:35:23 <berick> last one was delayed, iirc
15:35:51 <Dyrcona> Next week works if there are fixes for the two bugs above, though it could wait for the next monthly releases.
15:36:11 * Dyrcona suspects the dates will move again.
15:36:32 <kmlussier> #action Dyrcona to manage one last maintenance release for 3.0 that will be limited to fixing three specific regressions: bug 1796978, bug 1796971 and bug 1797007.
15:36:36 <pinesol> Launchpad bug 1796978 in Evergreen 3.2 "Web client cannot create two or more copies at the same time" [High,Confirmed] https://launchpad.net/bugs/1796978
15:36:36 <Dyrcona> I will go ahead and revert the tooltips from rel_3_0 after the meeting.
15:36:37 <pinesol> Launchpad bug 1796971 in Evergreen 3.1 "Web Client: Unable to Add Items from Item Status or Holdings View" [High,Confirmed] https://launchpad.net/bugs/1796971
15:36:38 <pinesol> Launchpad bug 1797007 in Evergreen 3.2 "Tooltips cause grid slowness" [Undecided,Confirmed] https://launchpad.net/bugs/1797007
15:36:47 <kmlussier> Dyrcona++
15:37:42 <kmlussier> #topic Evergreen 3.3 Release Manager
15:38:28 <kmlussier> We probably should be putting out a call for RM for the next Evergreen Release.
15:38:30 <gmcharlt> so... we have enough time to do the usual call for noms + vote in time to finsih up by the hack-a-way
15:38:45 <gmcharlt> shall we do that? I'm happy to do the legwork
15:38:49 <berick> +1
15:38:54 <berick> gmcharlt++
15:38:56 <kmlussier> +1
15:39:10 <kmlussier> gmcharlt++
15:39:20 <jeff> +1 / gmcharlt++
15:40:14 <kmlussier> OK, then, that brings us to the end of the agenda. Does anyone have anything else they want to discuss?
15:40:25 <gmcharlt> #action gmcharlt will issue a call for 3.3 release manager using the usual procedure
15:41:15 <kmlussier> heh, I thought I had already done the action item. Thanks gmcharlt!
15:42:25 <kmlussier> OK, I have one small announcement for those who don't know yet. I'm going to be leaving MassLNC at the end of November. My new job is going to be taking me out of the Evergreen community, so this is probably my penultimate dev meeting.
15:42:46 <Dyrcona> kmlussier++
15:42:55 <berick> kmlussier++ # can't say it enough
15:43:01 <dbwells> kmlussier++
15:43:09 <kmlussier> But I've had a blast hanging out with all of you in the #evergreen channel. I'm hoping our paths cross again sometime in the future.
15:43:17 <gmcharlt> kmlussier++ # and don't be a stranger!
15:43:20 <remingtron> kmlussier++ #thanks a million!
15:43:36 <abneiman> kmlussier++
15:43:53 <kmlussier> But, really, I just wanted to gather some last-minute karma before I left. ;)
15:44:03 <kmlussier> #endmeeting