#evergreen: Evergreen Development Meeting, 6 February 2019

Meeting started by gmcharlt at 15:04:43 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2019-02-06 (gmcharlt, 15:04:53)

  1. Introductions (gmcharlt, 15:05:02)
    1. Dyrcona is Jason Stephenson, CW MARS (Dyrcona, 15:05:10)
    2. gmcharlt = Galen Charlton, EOLI (gmcharlt, 15:05:16)
    3. dpearl is Dan Pearl, CWMARS Inc. (dpearl, 15:05:20)
    4. abowling is Adam Bowling, Emerald Data Networks (abowling, 15:05:22)
    5. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 15:05:30)
    6. JBoyer = Jason Boyer, Evergreen Indina, ISL (JBoyer, 15:05:31)
    7. miker = Mike Rylander, EOLI (miker, 15:05:34)
    8. dbwells is Dan Wells, Hekman Library (Calvin College) (dbwells, 15:05:36)
    9. abneiman is Andrea Buntz Neiman, EOLI (abneiman, 15:05:36)
    10. berick Bill Erickson, KCLS (berick, 15:05:54)
    11. Stephengwill working with Maine Balsam Library Consortium (stephengwills, 15:06:03)
    12. rhamby is Rogan Hamby, EOLI (rhamby, 15:06:13)
    13. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:06:42)
    14. Bmagic = Blake GH, MOBIUS (Bmagic, 15:07:14)

  2. Action items from previous meeting (gmcharlt, 15:07:49)
    1. New Hatch release has been made (gmcharlt, 15:09:08)
    2. ACTION: Bmagic, berick, gsams et al will poke more on the Dymo branch (gmcharlt, 15:10:24)

  3. OpenSRF release (gmcharlt, 15:10:52)
    1. OpenSRF 3.1.0 was released on 2019-01-17 (gmcharlt, 15:11:07)
    2. AGREED: patch for removing Trusty Tahr support will be applied for a 3.1.1 release (gmcharlt, 15:22:52)
    3. AGREED: apache2-websockets instructions will be removed or seriously deemphasized for a 3.1.1 release (gmcharlt, 15:23:11)
    4. ACTION: gmcharlt will open a bug to continue discussions about osrf_control or other means of websocketd startup management (gmcharlt, 15:23:35)
    5. ACTION: gmcharlt will open bug about whether to require OpenSRF 3.1.x for Evergreen 3.3 (gmcharlt, 15:27:58)

  4. Evergreen release (gmcharlt, 15:28:25)
    1. Evergreen 3.3 release update from dbwells: http://libmail.georgialibraries.org/pipermail/open-ils-general/2019-February/015605.html (gmcharlt, 15:30:23)
    2. AGREED: we're amenable to XUL removal continuing in for 3.3 to a degree that it may no longer be an option for use (gmcharlt, 15:45:43)
    3. ACTION: dbwells will contribute time to XUL removal prior to release (gmcharlt, 15:45:54)
    4. Hatch version 0.2.0 released including Firefox support released. (gmcharlt, 15:46:27)

  5. Should we remove Java libs from OpenSRF and Evergreen? (gmcharlt, 15:47:36)
    1. ACTION: Dyrcona will query the dev community to see if any users of OpenSRF's Java bindings are still out there? (gmcharlt, 15:52:11)

  6. Should we update or remove Python libs from OpenSRF and Evergreen? (gmcharlt, 15:52:19)
    1. ACTION: gmcharlt will send query about (a) whether there are any active users of Evergreen's Python bindings and (b) volunteers to help maintain it and ideally upgrade to 3.x (gmcharlt, 15:58:43)

  7. Miscellenaous (gmcharlt, 15:59:03)
    1. Beware update to Angular 7 requires npm update (or rm -rf node_modules; npm install) in Open-ILS/src/eg2 (gmcharlt, 15:59:05)
    2. ACTION: remingtron will run poll to see if a new standing day/time for the dev meeting would be better (gmcharlt, 16:02:06)
    3. Hope to get some movement on bug 1811288 since it will impact most of the active Angular dev branches. (gmcharlt, 16:02:18)


Meeting ended at 16:04:53 US/Eastern (full logs).

Action items

  1. Bmagic, berick, gsams et al will poke more on the Dymo branch
  2. gmcharlt will open a bug to continue discussions about osrf_control or other means of websocketd startup management
  3. gmcharlt will open bug about whether to require OpenSRF 3.1.x for Evergreen 3.3
  4. dbwells will contribute time to XUL removal prior to release
  5. Dyrcona will query the dev community to see if any users of OpenSRF's Java bindings are still out there?
  6. gmcharlt will send query about (a) whether there are any active users of Evergreen's Python bindings and (b) volunteers to help maintain it and ideally upgrade to 3.x
  7. remingtron will run poll to see if a new standing day/time for the dev meeting would be better


Action items, by person

  1. berick
    1. Bmagic, berick, gsams et al will poke more on the Dymo branch
  2. Bmagic
    1. Bmagic, berick, gsams et al will poke more on the Dymo branch
  3. dbwells
    1. dbwells will contribute time to XUL removal prior to release
  4. Dyrcona
    1. Dyrcona will query the dev community to see if any users of OpenSRF's Java bindings are still out there?
  5. gmcharlt
    1. gmcharlt will open a bug to continue discussions about osrf_control or other means of websocketd startup management
    2. gmcharlt will open bug about whether to require OpenSRF 3.1.x for Evergreen 3.3
    3. gmcharlt will send query about (a) whether there are any active users of Evergreen's Python bindings and (b) volunteers to help maintain it and ideally upgrade to 3.x
  6. gsams
    1. Bmagic, berick, gsams et al will poke more on the Dymo branch
  7. remingtron
    1. remingtron will run poll to see if a new standing day/time for the dev meeting would be better


People present (lines said)

  1. gmcharlt (97)
  2. berick (40)
  3. Dyrcona (33)
  4. JBoyer (23)
  5. miker (22)
  6. csharp (16)
  7. dbwells (11)
  8. abowling (9)
  9. sandbergja (7)
  10. pinesol (5)
  11. stephengwills (4)
  12. jeffdavis (3)
  13. jeff (2)
  14. remingtron (2)
  15. dpearl (1)
  16. gsams (1)
  17. Bmagic (1)
  18. rhamby (1)
  19. abneiman (1)


Generated by MeetBot 0.1.4.