#evergreen: Development Meeting, 4 June 2019

Meeting started by gmcharlt at 15:00:25 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2019-06-04 (gmcharlt, 15:00:31)

  1. Introductions (gmcharlt, 15:00:36)
    1. gmcharlt = Galen Charlton, Equinox, 3.4 RM (gmcharlt, 15:00:47)
    2. JBoyer = Jason Boyer (JBoyer, 15:00:49)
    3. sandbergja = Jane Sandberg, Linn-Benton Community College (sandbergja, 15:01:03)
    4. rhamby = Rogan Hamby (rhamby, 15:01:04)
    5. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:15)
    6. dbs = Dan Scott, Laurentian University (dbs, 15:01:22)
    7. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:01:36)
    8. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:01:41)
    9. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:01:57)

  2. Action items from previous meetings (gmcharlt, 15:03:17)
    1. miker = Mike Rylander, EOLI (miker, 15:04:48)
    2. dbwells has started work on porting Syrup to Python 3; one blocker is updating a z3950 module that doesnt' yet have a python3 equivalent (gmcharlt, 15:14:03)
    3. some initial additional promises of assistance for the python3 OpenSRF binding have been made (gmcharlt, 15:14:48)
    4. Call for additional buildmaster to be deferred until closer to August (gmcharlt, 15:15:04)
    5. ACTION: gmcharlt will work on upgrading ng-bootstrap past 3.3.0 for 3.4; will also evalulate whether that might be a safe backport to 3.3.x (gmcharlt, 15:15:48)

  3. OpenSRF release (gmcharlt, 15:15:57)
    1. ACTION: gmcharlt will cut OpenSRF bugfixes releases on 7 June (gmcharlt, 15:16:10)

  4. Evergreen update (gmcharlt, 15:21:18)
    1. Feedback Fest #1 happened - https://wiki.evergreen-ils.org/doku.php?id=dev:3.4:feedback_fest_1 (gmcharlt, 15:21:32)
    2. So did Bug Squashing Week - https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing:2019-05 (gmcharlt, 15:21:54)

  5. Hatch update (gmcharlt, 15:29:49)
  6. Bug discussion (gmcharlt, 15:31:16)
    1. Call for testers for Hatch ombnibus bug 1830391 (https://bugs.launchpad.net/evergreen/+bug/1830391) (gmcharlt, 15:37:00)


Meeting ended at 15:58:23 US/Eastern (full logs).

Action items

  1. gmcharlt will work on upgrading ng-bootstrap past 3.3.0 for 3.4; will also evalulate whether that might be a safe backport to 3.3.x
  2. gmcharlt will cut OpenSRF bugfixes releases on 7 June


Action items, by person

  1. gmcharlt
    1. gmcharlt will work on upgrading ng-bootstrap past 3.3.0 for 3.4; will also evalulate whether that might be a safe backport to 3.3.x
    2. gmcharlt will cut OpenSRF bugfixes releases on 7 June


People present (lines said)

  1. gmcharlt (70)
  2. miker (19)
  3. JBoyer (18)
  4. dbwells (14)
  5. pinesol (9)
  6. Dyrcona (7)
  7. sandbergja (6)
  8. jeff (6)
  9. phasefx (5)
  10. dbs (2)
  11. remingtron (1)
  12. rhamby (1)


Generated by MeetBot 0.1.4.