14:00:11 <dluch> #startmeeting 2019-06-06 - Documentation Interest Group
14:00:11 <pinesol> Meeting started Thu Jun  6 14:00:11 2019 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <pinesol> The meeting name has been set to '2019_06_06___documentation_interest_group'
14:00:25 <dluch> The agenda can be found here: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20190606-agenda
14:00:38 <dluch> #topic Introductions
14:00:45 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:00:57 <dluch> #info dluch is Debbie Luchenbill, MOBIUS - DIG meeting facilitator
14:01:02 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:12 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:01:15 <abneiman> #info abneiman, Andrea Buntz Neiman, Equinox
14:01:58 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:28 <cmalm> #info cmal is Carissa Malmgren, Roanoke Public Library (Texas)
14:02:34 <remingtron> cmalm: welcome!
14:02:44 <dluch> cmalm: welcome!
14:04:05 <cmalm> remingtron: thank you!
14:04:13 <cmalm> dluch: thank you!
14:04:32 <dluch> Thank you all for coming!
14:05:03 <dluch> Anyone else, please feel free to introduce yourself as you come into the meeting
14:05:04 <dluch> #topic Old Business: Conference wrap-up
14:05:16 <dluch> sandbergja: Thank you for leading DIG at the conference!
14:05:25 <dluch> Minutes from that meeting are at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20190426-minutes
14:05:32 <dluch> sandbergja++
14:05:38 <sandbergja> Happy to do it -- it was a good time.
14:05:47 <dluch> sandbergja: Did you have anything you wanted to say about the DIG meeting at conference?
14:06:00 <dluch> (else you wanted to say, lol)
14:06:29 <sandbergja> I'm really interested in learning more about Antora -- Bmagic's presentation was really cool!
14:07:06 <sandbergja> That's all I can think of at this time. :-)
14:07:15 <dluch> Great, thanks!
14:07:18 <dluch> Thanks, also, to everyone who came to the hackfest and especially to everyone who helped new folks get started and acclimated! I think we had 3 or 4 brand new people (?).
14:07:54 <remingtron> hurray for brand new people!
14:07:54 <dluch> Anyone else?  Comments, questions related to conference DIG stuff?
14:08:35 <dluch> Yes!
14:09:03 <dluch> #topic Documentation contributions and collaboration
14:09:16 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:09:27 <dluch> There are LOTS of documentation needs and several that have been identified as easy tasks for new folks.
14:09:46 <dluch> Any other disucssion on documentation needs and/or the list?
14:10:03 <dluch> We will be taking the latter part of this meeting to work on docs
14:11:04 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:11:14 <dluch> We came up with these roles a few years ago, if I remember correctly, but I'm not sure we've ever had all of them filled.  So if anyone would like to fill a particular role, please feel free to volunteer!
14:11:28 <dluch> And is there anyone listed in a role they would like to pull back from?
14:11:50 <dluch> Also, the Facilitator role includes coordinating training and I just wanted to mention that, while I'm perfectly happy to coordinate training for the hackfest (or otherwise) that we might want, I'll be tapping others to actually do the training.  ;-)
14:12:53 <remingtron> dluch: sounds good! the facilitating/coordinating is certainly a piece we've been lacking in DIG.
14:13:11 <dluch> Oh, speaking of facilitator role, can someone with website updating privileges update the DIG listing on the committees page?  https://evergreen-ils.org/communicate/committees/
14:14:14 <sandbergja> dluch: I can check to see if I have that permission
14:14:29 <dluch> sandbergja: Thanks!
14:14:54 <dluch> #topic Evergreen Quick Start documentation
14:15:05 <abneiman> sandbergja: I definitely have website perms if it turns out you don't
14:15:17 <dluch> sandbergja: Did you add this to the agenda? Can you talk about this?
14:15:23 <dluch> abneiman: Thank you!
14:15:38 <sandbergja> Yes!  That was me.
14:15:44 <dluch> Take it away!
14:15:46 <sandbergja> This is an idea that came up in the NW Evergreen User Symposium + the hackfest
14:15:56 <sandbergja> We were talking about the documentation needs of folks like volunteers, student workers, and others who don't have much of a library background.
14:16:21 <sandbergja> (and don't have much patience for huge manuals of documentation with lots of library concepts)
14:16:50 <sandbergja> So we came up with the idea of providing quick starts
14:16:59 <sandbergja> naming credits go to abneiman
14:17:02 <sandbergja> The goal is to make a pair of 1 video + 1 one-page reference sheet, with jargon-free, local policy-free, non-customized instructions
14:17:13 <sandbergja> To cover the most fundamental tasks in Evergreen, like check in, check out, attach a holding to a bib record, etc.
14:17:21 <sandbergja> I've experimented a bit with making the one-pager in asciidoc, and came up with this:
14:17:25 <sandbergja> #link http://www.sandbox.lbcc.linnlibraries.org/Evergreen/docs/quickstarts/check_out.html
14:17:32 <sandbergja> But, uh, I was thinking that it would be worth it to consider technologies other than asciidoc too, like Google Docs or the wiki
14:17:37 <sandbergja> Some pros and cons here:
14:17:42 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:quickstarts
14:17:46 <sandbergja> What do you all think?
14:18:32 <remingtron> I think asciidoc is still a strong choice
14:18:45 <dluch> I think that's an awesome idea!
14:18:45 <remingtron> especially with the ability to edit and preview in GitHub
14:18:53 <remingtron> and yes, I love the idea too
14:19:08 <abneiman> yeah, agreed with asciidoc -- unless/until we wholesale switch to something else.
14:19:38 <remingtron> I totally support having a different stylesheet if we think it would benefit the different audience
14:19:39 <abneiman> Also, I love having the use case at the top of your demo doc sandbergja
14:20:12 <dluch> Yes!  The use case is a great feature!
14:20:49 <sandbergja> Thanks!  If you do print preview, the video disappears, and the link url appears, which I was pretty proud of :-D
14:21:33 <sandbergja> But fitting it all on one page really depends on what browsers, fonts, settings you happen to have
14:21:39 <dluch> sandbergja++
14:21:43 <dluch> So, sandbergja, how would you envision DIG adopting this idea?  Add quick starts to the list of docs needs or keep it on a separate page, or...?
14:22:04 <sandbergja> Good question!
14:22:40 <remingtron> is the "one page" goal specifically about printing to a single sheet of paper? Or generally a "one screenful" idea?
14:23:23 <sandbergja> I was thinking printing to one sheet of paper
14:24:22 <dluch> I can see how keeping it to one sheet would be really helpful for those kinds of "casual" ILS users.  And those who supervise/train them.
14:24:30 <remingtron> maybe we could have a PDF version (semi-hand-crafted) for the actual printing
14:25:04 <remingtron> since predictable printing from a browser seems hard.
14:25:10 <sandbergja> agreed
14:25:20 <sandbergja> I had some issues getting a2x and fop to do a one-pager
14:26:09 <sandbergja> and finally realized I was in way over my head
14:26:36 <sandbergja> So I think it would be helpful for somebody who is more familiar with those technologies to put together a working proof of concept
14:27:52 <dluch> Lol.  I don't even know what those are.
14:28:15 <sandbergja> they are the tools we use to convert asciidoc into PDFs currently
14:28:23 <dluch> Oh, I just looked it up
14:28:27 <dluch> gotcha
14:28:37 <sandbergja> And fop seems to get really complicated really fast
14:29:26 <sandbergja> ...which was part of my thought in suggesting a really familiar tool like Google Docs
14:31:53 <remingtron> could we make the single-page printing a secondary goal of the project? start with simple AsciiDoc files?
14:32:02 <dluch> So, sandbergja, would you like someone else to try converting your sample page into a 1-page pdf?
14:32:20 <remingtron> or does that remove too much of the value?
14:32:27 <dluch> That seems like a good way to start, remingtron.
14:33:01 <sandbergja> agreed, that seems like a good way to get the project off the ground
14:33:30 <sandbergja> We'd also need to figure out the topics that should have a quickstart
14:33:50 <sandbergja> but that can be a discussion for another time
14:33:55 <remingtron> sandbergja: do you have ideas already that you could add to the "needs" wiki page?
14:33:58 <remingtron> to get us started
14:34:44 <dluch> Yes!  That seems like something we can all be thinking about for the next meeting, too.
14:35:00 <alynn26_> I say add it to the wiki.
14:35:12 <dluch> I like the idea of keeping everything together on the "needs" wiki but do we need to worry about the page getting too long?
14:36:50 <sandbergja> remingtron: just check in, check out, and adding holdings -- I'm sure there are others
14:36:50 <remingtron> dluch: my only concern about length of that page is: Keep the "stuff for new contributors" at the top.
14:37:18 <remingtron> I'm personally happy to swim through a long wiki page
14:37:22 <dluch> remingtron: yes, good idea, so that's always uber-visible and easy to find
14:38:09 <dluch> So, we can add a new section to the Needs wiki for Quick Starts and start adding things there as we think of them.  Sound like a plan?
14:38:34 <dluch> Do we need to make an action?  We haven't made any this meeting, lol.
14:38:58 <remingtron> dluch: you can give that action to me if you want, but I have to leave the meeting. See you all later!
14:39:19 <dluch> Thanks, remingtron!  Bye!
14:39:52 <dluch> #action remingtron will create a new "Quick Starts" section to the Documentation Needs wiki and we will all add ideas there
14:40:15 <dluch> Any other things we need to talk about related to this agenda item?
14:40:56 <dluch> Thanks, sandbergja and the NW Evergreen User Symposium for this great idea!
14:41:09 <dluch> #topic Other Business
14:41:23 <dluch> Anyone have other DIG business they want to talk about today?
14:42:16 <dluch> Okay, then...
14:42:17 <dluch> #topic One on one and small group documentation collaboration
14:42:38 <dluch> We have about 20 minutes.  What's everyone working on?
14:43:20 <abneiman> I'm still planning to follow remington's suggestion to add a commit with index terms to this PR https://github.com/evergreen-library-system/Evergreen/pull/79
14:44:30 <abneiman> also, cmalm, if you have questions for any of us please feel free to ask :)
14:45:06 <dluch> +1
14:45:10 <dluch> I need to go through the needs list and take some new things.
14:45:53 <sandbergja> I think I'll try to write a script for a video for the check out quick start
14:48:37 <jihpringle> sandbergja: we did a check out video with the basics for 3.1 - https://www.youtube.com/watch?v=e074WkZ8xBo
14:49:21 <sandbergja> jihpringle++
14:49:24 <sandbergja> Thank you!
14:49:28 <jihpringle> if it's helpful as a starting point you can find the script here - https://docs.google.com/document/d/1inzm9es731Ut6-LjvFyPdsbXTGIzx3WJec9fhRSglqo/edit?usp=sharing
14:52:10 <sandbergja> it really is -- this is excellent
14:52:40 <jihpringle> for our new videos we've been trying to ensure we include closed captioning so the scripts for all should be available through the transcripts (I'm also happy to share out the actual scripts if that's easier for copy/pasting/adapting)
14:53:34 <dluch> jihpringle: That's fantastic!
15:00:20 <dluch> We're at the hour mark, so I'm going to close the DIG Meeting.  Thanks for coming and collaborating, everyone!
15:00:33 <dluch> #endmeeting