14:01:17 <dluch> #startmeeting 2019-07-11 - Documentation Interest Group
14:01:17 <pinesol> Meeting started Thu Jul 11 14:01:17 2019 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <pinesol> The meeting name has been set to '2019_07_11___documentation_interest_group'
14:01:25 <dluch> The agenda can be found here:
14:01:44 <dluch> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20190711-agenda
14:01:44 <dluch> #topic Introductions
14:01:50 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:58 <dluch> #info dluch is Debbie Luchenbill, MOBIUS - DIG meeting facilitator
14:02:34 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:02:48 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:03:30 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:03:43 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin University)
14:05:51 <dluch> Thank you all for coming!  Anyone joining us later, feel free to introduce yourself then!
14:06:15 <dluch> Jumping into some FYIs
14:06:17 <dluch> #topic Ongoing Information: Documentation contributions and collaboration
14:06:26 <dluch> #info You can find the Documentation Needs List at
14:06:36 <dluch> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:06:43 <Christineb> #info Christineb is Christine Burns, BC Libraries Cooperative
14:06:45 <dluch> There are LOTS of documentation needs and several that have been identified as easy tasks for new folks.
14:06:53 <dluch> #info DIG Roles can be found at
14:07:02 <dluch> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:07:11 <dluch> If anyone would like to fill a particular role, please feel free to volunteer!
14:07:25 <dluch> #topic Old and Ongoing Business: Evergreen Quick Start documentation
14:07:35 <dluch> I see the Quick Start section added to the Docs Needs wiki:
14:07:42 <dluch> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:07:54 <dluch> remingtron: was that you?
14:08:35 <dluch> There are also a few topics there, so thanks, folks, for getting that started.  As we mentioned last time, we can all add things there.
14:09:03 <dluch> #idea At the last meeting, we'd talked about making very simple, no-jargon very short text guides plus short video guides for new or "casual" users.
14:09:07 <remingtron> dluch: uh, yes, I think so!
14:09:18 <dluch> #idea We also decided to stick with asciidoc for now, with a possible future goal of converting into single-page documents (pdf or something)
14:09:32 <dluch> remingtron: Thanks!
14:09:47 <dluch> sandbergja has a proof of concept:
14:09:56 <dluch> #link http://www.sandbox.lbcc.linnlibraries.org/Evergreen/docs/quickstarts/check_out.html
14:10:08 <dluch> sandbergja: Can you lead us through a refresher on this topic?
14:10:32 <sandbergja> Sure!  I haven't really done much since last meeting on these
14:10:46 <sandbergja> And I think you explained it really well, dluch!
14:11:32 <sandbergja> The fundamental idea is to meet the needs of new Evergreen users who don't have much background with libraries, library jargon, ILSs, etc.
14:11:44 <sandbergja> Like volunteers, student workers, etc.
14:12:07 <sandbergja> So that they don't have to dig through the massive Evergreen manuals :-D
14:12:23 <sandbergja> Even though we love those manuals
14:12:37 <dluch> Which is awesome!  Even though we do love them, lol
14:12:43 <dluch> So, what are our next steps?
14:13:00 <dluch> I also haven't done anything from last time,
14:13:09 <dluch> So I'm going to make an official
14:13:10 <sandbergja> I'd like to finish a video to go with that proof of concept link
14:13:13 <dluch> #action Add ideas for very simple topics we can cover to the Quick Starts section of the wiki
14:13:32 <dluch> Can I make an action item for you for that?
14:13:37 <sandbergja> Yes, please do!
14:14:17 <dluch> #action sandbergja will make a video to go with the proof of concept link
14:14:25 <sandbergja> And then we can evaluate it all as a unit!
14:14:39 <dluch> Sounds good!
14:14:57 <dluch> Anything else we want to do now, or is that good for this month?
14:15:43 <sandbergja> I don't have anything else to say on quick starts, but I'm very happy to hear anybody's feedback, either on IRC or by email
14:16:07 <dluch> sandbergja++
14:16:20 <Christineb> sandbergja++
14:16:42 <dluch> #topic Old and Ongoing Business: Committees page updated
14:16:43 <abneiman> sandbergja++
14:16:51 <dluch> I didn't make it an action item last meeting (I forgot about those until later in the meeting, lol), but thank you to whoever updated the page!
14:17:00 <dluch> #link https://evergreen-ils.org/communicate/committees/
14:17:33 <dluch> Any other old business I forgot about before moving on?
14:18:07 <dluch> #topic New Business: Possible updates to terminology/style guide
14:18:26 <dluch> #info Background info at
14:18:32 <dluch> #link https://webaim.org/discussion/mail_thread?thread=9306
14:18:50 <dluch> What are people's thoughts on this topic?
14:19:26 <sandbergja> #link https://georgialibraries.markmail.org/thread/jztoghclirjd4k2f
14:19:38 <sandbergja> there is the discussion we had on the email list
14:20:04 <dluch> Oh, thanks!
14:20:22 <dluch> Ignore my earlier link!
14:21:01 <sandbergja> I thought that we had a good conversation on the mailing list!
14:21:10 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:21:12 <sandbergja> I don't know how we want to follow it up, though
14:21:56 <sandbergja> FWIW, I think that "press" and "select" seem like better options than "click", since they are more inclusive of all the various ways people could use Evergreen
14:22:02 <abneiman> Off the cuff, I like "select" (I'm not sure why Microsoft lady is so opposed to it?) and I agree that avoiding operated would be preferable
14:22:03 <Christineb> I think it is a good idea for us to work towards this
14:22:21 <abneiman> and yeah, I agree with the general goal of more accessibility-inclusive language
14:22:26 <Christineb> +1 avoid operated
14:22:27 <sandbergja> But I don't know that we need to do a massive find and replace this moment
14:22:30 <dluch> I also like "select".  And really don't like operated
14:22:59 <Bmagic> select++
14:23:29 <abneiman> Perhaps we could update the style guide to suggest using "select" going forward, and the find-and-replace can be a separate thing
14:23:45 <Christineb> I think that is a good idea
14:23:46 <remingtron> I'd probably choose "press", rather than select
14:23:54 <dluch> abneiman: I like that idea
14:24:23 <jihpringle> is there a second term we like if there are multiple steps?
14:24:27 <Christineb> to me "press" still sounds like a physical action
14:24:35 <dluch> Does press still mean a physical thing, though
14:24:41 <dluch> lol, yes
14:24:44 <Christineb> :)
14:24:49 <Christineb> select seems more generic
14:25:00 <sandbergja> "press the button" or "press the link" sounds more idiomatic than "select the button" or "select the link" to me
14:25:12 <Bmagic> sandbergja: the sandbox docs looks like antora pages
14:25:33 <jihpringle> ie. Select the Actions menu and select Edit Due Date  versus   Select the Actions menu and choose/pick Edit Due Date  ??
14:25:36 <dluch> jihpringle: like we select something and then have a different word for the next step that's not select?  To avoid the repetition?
14:25:59 <jihpringle> dluch: exactly
14:26:10 <sandbergja> Bmagic: I should have just used antora! :-)
14:26:19 <dluch> haha, yes, your example
14:26:28 <abneiman> jihpringle: +1 to that, I'd go with "choose" I think
14:26:44 <dluch> Or maybe, like, one word for if it's a menu and one for if it's a button?
14:26:53 <dluch> Also +1 to choose
14:28:30 <sandbergja> Also, for users with touchscreen devices, "pressing" a button would actually be a physical action
14:28:49 <Christineb> select Acquistions -> choose Load MARC Order Records...   what about form entry?
14:28:57 <Christineb> complete the fields?
14:29:24 <dluch> Okay, so how do we feel about slightly modifying abneiman's idea to update the style guide to use "select" and "choose" going forward?  Then find-and-replace later?
14:29:53 <Christineb> would you use "select the check box?"
14:30:01 <abneiman> I typically use "enter" for forms -- "enter the required information"
14:30:06 <Christineb> select the checkbox
14:30:11 <dluch> Hmm.  I like complete.  It's...more complete than "fill in" or something
14:30:23 <abneiman> also, since we're talking about it, here's the current style guide: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_style_guide#wording
14:30:25 <dluch> Oh, enter is also good
14:30:35 <dluch> Thanks, abneiman!
14:31:08 <Christineb> Enter or Type a value into the text box - get rid of "Type"
14:31:13 <sandbergja> Christineb: I like "check the checkbox" or "uncheck the checkbox", but I don't know about a more general "set the checkbox to the value you want" term
14:31:15 <dluch> So we really already have several of those
14:31:41 <abneiman> +1 to removing Type and +1 to using check/uncheck checkbox
14:31:50 <Christineb> yeah it looks like just click and right click need to be replaced
14:31:50 <dluch> +1
14:31:53 <Christineb> +1
14:32:04 <jihpringle> +1
14:32:31 <abneiman> so right click presents an interesting quandary. sandbergja do you have a sense of what might be a preferable term there?
14:33:08 <sandbergja> I think right click can just stay right click
14:34:58 <sandbergja> I don't think there's a fantastic alternative for right clicks for users who are using a phone or tablet
14:35:19 <dluch> I was just doing a quick search to see if I could find anything other than right click, but couldn't
14:35:22 <abneiman> sometimes it's long-click, but nowhere near universal
14:35:29 <abneiman> (for mobile devices)
14:35:34 <dluch> true
14:35:35 <sandbergja> Or for keyboard-only users (there are some keyboard shortcuts that do similar things, but not consistently throughout Evergreen)
14:36:13 <jihpringle> is there anywhere in Evergreen where right-clicking is the only way to access something?
14:36:17 <sandbergja> So probably right click is the most accurate without over-promising
14:36:33 <sandbergja> jihpringle: good question!
14:37:06 <abneiman> jihpringle: in the web client, I would hope not - there were probably some in XUL
14:37:12 <dluch> Yeah.  I saw something that said a context menu was what you got when you right click, but I don't think that's a term anyone would get, lol.  "open the context menu"
14:37:48 <jihpringle> I wonder if it would make sense to have an intro blurb that says for these common functions you can also access them by right-clicking/long-clicking etc. depending on your device and take it out of the specific instructions
14:37:55 <abneiman> in the web client, right-click in grids is typically open the actions menu (which has its own access point at the top of the grid). Other right click things in the web client are browser tasks, like open in new tab.
14:38:02 <cmal> In the MARC edit interface, there are field add/edit/delete menus that (afaik) are only accessed via right-clicking
14:38:49 <abneiman> oh, good point cmal
14:38:57 <dluch> Oh, yes, true
14:39:18 <sandbergja> cmal: good point!
14:39:24 <abneiman> cmal++
14:39:33 <dluch> cmal++
14:39:34 <jihpringle> is that how we want MARC Edit to continue working long term or should those menus be accessible in another way when MARC Edit it angularized?
14:39:56 <jihpringle> (might be a questions for the cataloguing working group)
14:40:00 <jihpringle> cmal++
14:40:29 <abneiman> jihpringle: I'm in favor of moving towards an accessible solution, and we can definitely put that on the CWG agenda for discussion next month
14:40:35 <dluch> Good question, jihpringle.  That does seem like a good question for the cataloging group.
14:41:28 <dluch> Awesome.  Okay, so summing up, it seems like we can...
14:41:36 <sandbergja> FWIW, it seems like you can open those menus in the MARC record using the keyboard shortcut Shift+F10, but then you can't use the keyboard to choose anything from those menus
14:41:57 <abneiman> I'll take an action item for bringing it up with CWG, since I'm on the CWG organizing committee
14:41:59 <sandbergja> But that's more a bug than a documentation issue. :-)
14:42:19 <dluch> #agree to removing "Type" from the style guide and change "Click" to "Select"
14:43:13 <dluch> #action abneiman will add talking about MARC Edit, right-clicking, and accessibility with the CWG
14:43:27 <remingtron> dluch: I feel like we hadn't quick settled on "select" vs. "press", but I missed some of the discussion
14:43:38 <remingtron> hadn't *quite* settled
14:44:14 <dluch> remingtron: it seemed like most people thought "press" was too indicative of a physical action.
14:44:36 <dluch> But is there more discussion on that?
14:45:35 <remingtron> I don't feel strongly about it, just wanted to make sure we were all happy with it, and I believe that now :)
14:45:52 <dluch> Okay, great.  :-)
14:45:54 <dluch> I can take an action to update the style guide, unless someone else wants to?
14:46:31 <sandbergja> dluch++
14:46:31 <dluch> #action dluch will update the style guide with the agree-upon changes
14:46:51 <dluch> Okay, moving on
14:46:52 <dluch> #topic New Business: Cataloging Working Group (CWG) and DIG Collaboration
14:47:07 <dluch> jweston contacted me about talking with CWG about DIG and how catalogers can be more involved
14:47:24 <dluch> I spoke at their meeting on Tuesday and told them about DIG.
14:47:43 <dluch> We also talked about specifically inviting them for our August meeting, since that would be more a working meeting.
14:47:54 <dluch> And also putting together a special "training" session for them before that, about using IRC and some DIG basics.
14:48:39 <dluch> Since IRC is how DIG meets, we thought catalogers who wanted to be more involved in docs should/could learn about how to use it
14:48:50 <dluch> What do we think about this idea?
14:49:14 <remingtron> sounds great
14:49:26 <jihpringle> +1
14:49:44 <abneiman> +1
14:49:55 <cmal> +1
14:49:59 <sandbergja> +1
14:50:00 <dluch> I'm pretty excited about it!  Catalogers will definitely have good insight on those docs.
14:50:06 <dluch> Excellent!
14:50:09 <dluch> Who is willing to help with a training session and DIG intro?
14:51:05 <abneiman> I can help with that
14:51:11 <dluch> jweston and I (and whoever else is interested) were going to correspond tomorrow, probably, to talk more details, but the session would probably be via conference call later in July
14:51:24 <dluch> abneiman++
14:51:44 <remingtron> just a comment: I'd rather focus the catalogers on reviewing/writing content rather than AsciiDoc or other technical details.
14:52:14 <dluch> remingtron that sounds like a good idea
14:52:26 <abneiman> +1 remingtron
14:52:56 <abneiman> let them be the workflow experts, we can asciidocifiy things later
14:53:09 <dluch> +1
14:53:52 <dluch> #action abneiman and dluch will work with jweston on an IRC and DIG intro session for CWG later in July
14:54:28 <dluch> #action August meeting will focus on cataloging docs and welcoming new CWG folks to DIG
14:54:37 <dluch> Sound okay?
14:54:50 <sandbergja> sounds excellent!
14:54:51 <remingtron> yes
14:54:57 <sandbergja> abneiman++
14:54:58 <sandbergja> dluch++
14:55:25 <dluch> Awesome!
14:55:41 <dluch> Anyone have other DIG business they want to talk about today?
14:57:22 <dluch> We are close to the hour mark, so no collaboration time this month (sorry), but great discussion today!
14:57:40 <dluch> Next meeting will be August 1.  Same bat time, same bat channel.  Very brief meeting then, and mostly collaboration time.
14:58:00 <dluch> Thanks for coming everyone!
14:58:13 <remingtron> dluch++ #oldschool batman reference
14:58:19 <dluch> :-D
14:58:48 <dluch> #endmeeting