14:00:11 <dluch> #startmeeting 2019-08-01 - Documentation Interest Group Meeting
14:00:11 <pinesol> Meeting started Thu Aug  1 14:00:11 2019 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <pinesol> The meeting name has been set to '2019_08_01___documentation_interest_group_meeting'
14:00:33 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20190801-agenda
14:00:34 <dluch> Welcome everyone!  Today's meeting will be collaboration and working on documentation, with a focus on cataloging documentation.
14:00:45 <dluch> #topic Introductions
14:00:52 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:00 <dluch> #info dluch is Debbie Luchenbill, MOBIUS - DIG meeting facilitator
14:01:24 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:01:27 <cmalm> #info cmalm is Carissa Malmgren, Roanoke Public Library
14:01:31 <kcoleman> #info kcoleman is Kate Coleman, Jefferson County Library Technical Services Managers (Missouri Evergreen)
14:01:48 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:50 <tkatie217> #info tkatie217 is Katie Greenleaf Martin, blair co library system in PA (SPARK/PaILS)
14:02:00 <bjwillis> #info bjwillis is Beth Willis, North of Boston Library Exchange, Inc, Cataloging Librarian
14:02:19 <alynn26_> #info alynn26 is Lynn Floyd Anderson County Library, SCLends
14:03:15 <bjwillis> #info North of Boston Library Exchange (aka NOBLE), part of MassLNC
14:05:11 <dluch> Thank you all for coming! If you pop in later, feel free to introduce yourself when you arrive.
14:05:27 <dluch> #topic Ongoing Information: Documentation contributions and collaboration
14:05:34 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:05:39 <cschroth> #info cschroth is Chrisy Schroth, Kenton County Public Library, Asst Cataloger and Serials Coordinator
14:05:45 <dluch> There are LOTS of documentation needs and several that have been identified as easy tasks for new folks.
14:05:47 <ipatrick> #info ipatrick is Irene Patrick  State Library of NC, part of NC Cardinal
14:05:56 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:06:03 <dluch> If anyone would like to fill a particular role, please feel free to volunteer!
14:06:14 <dluch> Welcome!
14:06:34 <dluch> #topic Business
14:06:45 <dluch> #info We will catch up on action items and other business at the September meeting
14:06:53 <dluch> That said, is there anything pressing anyone needs to bring up?
14:07:35 <abneiman> dluch: just noting that I asked gmcharlt about Equinox providing a 3.4 test server for docs purposes, and we will be able to do that around 3.4-beta time
14:08:01 <alynn26_> That's going to be handy.
14:08:10 <dluch> Excellent!  Thanks, abneiman!  And thanks gmcharlt!
14:08:12 <dluch> abneiman++
14:08:18 <dluch> gmcharlt++
14:08:31 <tkatie217> I can ask this on the list as well - but I was wondering if someone could do builds of the individual manuals (circulation, cataloging, etc) for 3.3? Dan Scott did the whole one but I'd love to have it broken out so I can use that in upgrade training :)
14:10:09 <dluch> Can anyone who's been active since we've been breaking out the manuals speak to this question?  abneiman, sandbergja, alynn26, remingtron?
14:11:43 <alynn26_> rsoulliere usually handles this, he is currently on sabbatical.
14:12:23 <abneiman> no, sorry, I am no help here - though this does raise the issue of perhaps we should have a DIG backup to rsoulliere
14:12:31 <tkatie217> I'll send Dan a note and ask. And when rsoulliere is back he'll update the docs.evergreen-ils.org site
14:12:50 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College, running late
14:12:57 <dluch> Thanks, alynn26.  tkatie217, you may have to wait until rsoulliere gets back and I will also add for after that time that we maybe need another person who can do this
14:13:02 <alynn26_> Sometime in September from what I understand.
14:13:13 <dluch> Lol, yes, abneiman!  +1 to a DIG backup
14:13:29 <alynn26_> +1 for a backup.
14:13:36 <dbs> #info dbs is Dan Scott, Laurentian
14:13:39 <tkatie217> thanks dluch :)  sounds good.
14:14:05 <dbs> tkatie217: I can give the broken-out manuals a shot
14:14:05 <dluch> Alrighty, moving on...
14:14:14 <dluch> Thanks, dbs!
14:14:21 <sandbergja> dbs++
14:14:32 <dluch> dbs++
14:14:37 <tkatie217> merci, dbs
14:14:46 <alynn26_> dbs++
14:15:10 <abneiman> dbs++
14:15:56 <dluch> #action DIG will get a backup person(s) for future docs manual updates
14:16:13 <dluch> #action dbs will give the broken-out manuals a shot :-)
14:16:32 <dluch> #topic Collaboration time - Cataloging Focused!
14:16:40 <dluch> #info abneiman and I led a training on Tuesday about DIG and IRC for the Cataloging Working Group.  Thanks, jweston, for organizing everything, and welcome to any new folks from CWG!
14:16:50 <dluch> #info Here's the link to the notes: http://bit.ly/2YiEb5Z
14:16:57 <dluch> #info Here's the link to the recording: http://bit.ly/2MyXIYr
14:17:05 <dluch> #info Both can also be found on the CWG wiki: https://wiki.evergreen-ils.org/doku.php?id=cataloging
14:17:12 <dluch> abneiman++
14:17:17 <dluch> jweston++
14:17:52 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes ("#action "), but it's not necessary.
14:18:15 <dluch> New folks, this is a great time to ask questions or to take some set-aside time to begin reviewing cataloging documentation, as discussed at the webinar Tuesday.
14:18:31 <sandbergja> I'm going to work on reviewing some of the documentation changes here: https://github.com/evergreen-library-system/Evergreen/pulls
14:18:49 <sandbergja> It looks like there are some cataloging-related ones in there!
14:19:12 <dluch> Woot!  Thanks, sandbergja!
14:19:15 <abneiman> per remingtron's comment here https://github.com/evergreen-library-system/Evergreen/pull/79#issuecomment-486374774 (and my intention to do it *cough* three months ago), I'm planning to add a commit to those docs with index terms
14:19:18 <cmalm> I've been working on a local cataloging manual for 3.2 that covers I think just about everything. Would it be helpful to submit it to the group?
14:19:54 <sandbergja> cmalm: yes yes yes!
14:20:16 <dluch> abneiman: sounds great!
14:20:16 <abneiman> (btw, jweston sends her regards to DIG, she is on a call and is unable to join today)
14:20:17 <sandbergja> Our documentation about some cataloging topics (like the MARC editor, for instance) are almost non-existant
14:20:44 <sandbergja> So it would be great if we could borrow some of your manual, cmalm
14:20:45 <cmalm> That's partly why I started the one I'm doing, lol
14:20:57 <abneiman> cmalm: that's great!
14:21:03 <dluch> cmalm: Yes!!  That would be awesome!
14:22:36 <dluch> It would be especially helpful to check that there isn't anything that's specific to only your local settings/procedures.  But anything would be a huge help!
14:22:43 <cmalm> Is emailing it to dluch the best route? It's currently a huge Word doc.
14:22:59 <sandbergja> To Github experts out there (dbs?): how can I get access to close other users' pull requests?
14:23:16 <cmalm> I don't think gsams has changed much locally, but I'll double check!
14:23:45 <dluch> You can definitely email it to me, though sending it to the docs list would be even better.  open-ils-documentation@list.georgialibraries.org
14:24:00 <remingtron> sandbergja: I'll check on github
14:24:05 <alynn26_> I'm working on the glossary, I'm looking for terms that need defining.
14:24:15 <sandbergja> remingtron: thanks!
14:24:26 <gsams> We haven't changed much of anything locally with regards to the manual
14:25:53 <alynn26_> For the catalogers, any terms you know  that would trick up anyone.
14:26:05 <dluch> Great, alynn26, thanks!  Is there any particular area you're needing terms for?  Or do you just want people to toss them at you?
14:26:13 <dluch> Lol.  Never mind
14:26:47 <cmalm> I've included a short glossary in the manual I'm working on, but definitely feel like I stumbled my way through a few of the definitions, lol
14:27:04 <dbs> tkatie217: all of the manuals are now at http://evergreen-ils.org/~denials/
14:27:09 <alynn26_> Toss them to me.  If you have a definition that would be great.
14:27:51 <tkatie217> lol 'the tarball edition!' thanks dbs ++
14:28:06 <dluch> dbs++
14:28:11 <abneiman> dbs++ indeed
14:28:31 <alynn26_> cmalm, send me your glossary, and I'll add them. lfloyd@andersonlibrary.org.
14:28:46 <kcoleman> I was going to look at the Additional fixed fields area that are in the needs page, but the link takes me to the 2.10 release notes. I remember from yesterday dluch saying to work with newest first, so is there somewhere else I should be going? #newb
14:28:49 <cmalm> alynn26_ will do!
14:29:04 <remingtron> sandbergja: I invited you to the EG Core team on Github
14:29:11 <sandbergja> remingtron++ # thanks for giving me keys to the Github kingdom!
14:29:39 <alynn26_> Kcoleman, that may be the most recent.
14:30:07 <dluch> kcoleman: I was actually just about to ask cmalm...does your manual cover that Additional fixed fields (or, really, all the fixed fields) from https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs?
14:30:22 <cmalm> Not yet
14:31:18 <dluch> Then kcoleman, please do!  For reviewing the manuals, we suggest starting with the newest, but for unmet docs needs like that one, I'd say start with the oldest, because it's been undocumented the longest!
14:31:52 <jihpringle> kcoleman, cmalm: if it's helpful we have 3.1 docs on the leader, 008 and 007
14:31:54 <jihpringle> http://docs.libraries.coop/sitka/_editing_marc_record_leader_and_fixed_field_008.html
14:32:00 <jihpringle> http://docs.libraries.coop/sitka/_fixed_field_007_physical_characteristics_wizard.html
14:32:26 <dluch> Ooo, excellent.  jihpringle++
14:32:30 <dbs> jihpringle++
14:32:32 <dbs> sitka++
14:33:00 <abneiman> sandbergja (or others) - does the placement of index terms in the file matter? i.e. should they go at the top of the page, before the header? or what?
14:33:04 <bjwillis> alynn26: are you including serials-related glossary terms?
14:33:07 * abneiman has never done index terms
14:33:33 <kcoleman> OK, still need my hand held a bit. Do I just start a fresh doc and start documenting these fixed fields (following the style guide)?
14:33:57 <cmalm> jihpringle++
14:34:36 <kcoleman> Or work off what @jihpringle started?
14:34:45 <dbs> abneiman: generally just under the relevant header, IIRC
14:34:56 <abneiman> dbs: thanks!
14:34:59 <sandbergja> abneiman: they can go anywhere in the page
14:35:02 <dluch> kcoleman: No problem!  Since Sitka already has the docs that jihpringle linked above, you can start with those.
14:35:07 <dluch> Lol, yes!
14:35:18 <abneiman> sandbergja: thanks@
14:35:22 <sandbergja> docs/opac/using_the_public_access_catalog.adoc is a good example
14:35:34 <sandbergja> with So Many Indexterms!
14:36:19 <abneiman> sandbergja: great example, thank you
14:36:35 <dluch> kcoleman: You can review them, see if there's anything you think could/should be added.  Or, if they look pretty fine as-is, see if jihpringle and sitka are okay with us adding them into the official docs.
14:36:55 <jihpringle> they can absolutely be added to the official docs
14:36:59 <dluch> :-)
14:37:07 <sandbergja> yboston++ # making such a great example of indexterms in that file
14:37:08 <jihpringle> there may be Sitka specific stuff that needs to be taken out
14:39:36 <pinesol> Showing latest 5 of 7 commits to Evergreen...
14:39:37 <pinesol> [evergreen|Bill Erickson] LP1823367 Ang catalog replace 'Volume' with 'Call Number' - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=e1b5a8b>
14:39:38 <pinesol> [evergreen|Dan Wells] LP1823367 Re-fix Copy to Item name changes - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=3bcffcf>
14:39:39 <pinesol> [evergreen|Dan Wells] LP1823367 Move away from "volume" moniker internally - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=87208fd>
14:39:40 <pinesol> [evergreen|Bill Erickson] LP1823367 Volume moniker migration continued - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=67533c7>
14:39:41 <pinesol> [evergreen|Galen Charlton] LP#1823367: (follow-up) revert renaming of eg.cat.transfer_target_vol - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=e4c7118>
14:41:10 <bjwillis> I'm new to DIG and have a question.  On the documentation needs page there is a reference to LP #1716473; we don't have this fix on our current release, but I can use a community server to generate screenshots.  Is that right?
14:41:11 <pinesol> Launchpad bug 1716473 in Evergreen "Proposal for webstaff UI: Hide fields in copy editor, rather than disabling them" [Undecided,Fix released] https://launchpad.net/bugs/1716473
14:41:44 <dluch> bjwillis: Correct!
14:41:46 <alynn26> bjwillis: that is correct
14:43:28 <dluch> Right now, the newest-version community server is on 3.3.0, so that would probably be the best for screen shots (assuming the fix has been included in that version)
14:43:37 <pinesol> [evergreen|Kristy Bauman] Docs: LP1826263: Update batch_importing_MARC.adoc - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=09389c0>
14:44:26 <bjwillis> dluch: alynn26: OK, thank you. I will make that my first documentation effort.  I don't have a WIKI account.  Should I request one?
14:44:45 <dluch> Sure!
14:44:58 <sandbergja> tkatie217++ #taking such good notes during the DIG hackfest!
14:45:45 <tkatie217> haha I do <3  notes, sandbergja :)
14:48:24 <abneiman> sandbergja: index terms added, if you're in a mergin' frame of mind https://github.com/evergreen-library-system/Evergreen/pull/79
14:48:32 <dluch> kcoleman: you can also request a wiki account if you want to add yourself as working on the fixed fields ones.  Or, if you or bjwillis don't want to do that now, I'll be happy to add you.
14:48:44 <dluch> (add you as working on those items)
14:50:15 <sandbergja> abneiman: exciting!  I'll take a look
14:55:34 <abneiman> for the room, am I the last one to learn this? (because I learned it fairly recently, and I don't see it in the docs) - if you type ? in a webclient screen (as long as you don't have cursor focus in an entry box), you will see a list of keyboard shortcuts
14:56:35 <cmalm> I had no idea. That's really neat!
14:56:53 * dluch mind blown
14:57:04 <dbs> abneiman: nope, didn't know that!
14:57:37 <abneiman> alrighty, I'm going to toss up a quick entry in docs to that effect
14:57:49 <bjwillis> dluch: please do add me.  I have requested an account for the future. Thanks!
14:58:21 <sandbergja> abneiman: no way!  I didn't know that at all
14:58:35 <dbs> (the shortcuts don't seem to work in Firefox on Linux under Gnome but that's probably a Gnome thing)
14:59:42 <dluch> bjwillis: will do!  sandbergja: do you have wiki-account-granting powers?
15:00:05 <stephengwills> obviously an unGnome command.
15:00:27 <dbs> correction: ALT+s works, but none of the F-keys do
15:00:40 <dbs> stephengwills++ # and groan
15:01:49 <dbs> dluch: I still have wiki-account-granting-powers
15:02:20 <dluch> Great, dbs!  bjwillis just requested an account.
15:02:44 <dluch> We are at time for the DIG.  Thanks for all the great work, everyone!  Feel free to keep going!
15:02:54 <dluch> Next meeting will be September 5.  Same time, same place.  Business meeting first then collaboration time.
15:03:03 <dluch> Thanks for coming, everyone!
15:03:10 <bjwillis> Thanks to all for your help getting started!
15:03:26 <dluch> #endmeeting