14:00:12 <dluch> #startmeeting 2019-09-05 - Documentation Interest Group Meeting
14:00:12 <pinesol> Meeting started Thu Sep  5 14:00:12 2019 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <pinesol> The meeting name has been set to '2019_09_05___documentation_interest_group_meeting'
14:00:20 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20190905-agenda
14:00:32 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation.
14:00:41 <dluch> #topic Introductions
14:00:50 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:00:58 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:19 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:01:20 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:01:20 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:27 <alynn26> #info alynn26 is Lynn Floyd, Anderson County Library, SCLends
14:03:20 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:03:32 <dluch> #topic Ongoing Information: Documentation contributions and collaboration
14:03:39 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:03:49 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:03:58 <dluch> If anyone would like to fill a particular role, please feel free to volunteer!
14:04:11 <dluch> #topic Old and Ongoing Business
14:04:19 <dluch> #info Previous Action Items
14:04:27 <dluch> How are we doing on these?  I'll take them in order...
14:04:40 <dluch> #1, adding ideas for simple topics in the Quick Starts section of the wiki (https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs, scroll past the Easy Tasks section).  I see a few there
14:05:34 <dluch> Any comments or discussion on this one?
14:05:52 <dluch> And should we continue having it as an action item?
14:08:02 <dluch> Well, hearing crickets, I will go ahead and leave it on
14:08:27 <dluch> #action Everyone will continue adding ideas for simple topics to the Quick Starts section of the wiki
14:08:36 <dluch> #2, sandbergja: video for proof of concept there?
14:08:50 <sandbergja> I will have to defer that until next time
14:09:02 <dluch> Okay, cool
14:09:31 <dluch> #action sandbergja will create a video to go with the proof of concept for Quick Starts
14:09:38 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin University)
14:10:00 <dluch> #3, abneiman: Did CWG talk about MARC Edit, right-clicking, and accessibility?  Or will that be a future meeting?
14:10:30 <dluch> I don't think abneiman is here...sandbergja or anyone else on the CWG meeting, do you remember?
14:10:43 <dluch> (I don't remember, lol)
14:10:53 <sandbergja> There was a brief discussion
14:11:11 <dluch> Should we keep it as an action item?
14:11:36 <sandbergja> I think we can let it be on CWG's plate for now. :-)
14:11:44 <dluch> Awesome
14:11:47 <dluch> #4, I updated the style guide with our changes from the July meeting.
14:11:54 <sandbergja> dluch++
14:12:04 <dluch> #5, abneiman and I worked with jweston and did the IRC and DIG intro session for CWG on July 30.  Several new folks were at the August DIG meeting (and, hopefully, back today)!  See the August minutes for links to the recording and notes.  We also gave a brief recap at the August CWG meeting.
14:12:15 <dluch> abneiman++, jweston++
14:12:38 <dluch> #6, August DIG meeting did focus on cataloging docs and welcoming CWG folks to DIG!
14:13:03 <dluch> And we got some great additions!
14:13:50 <dluch> #7, DIG will get a backup person(s) for future docs manual updates.
14:13:56 <jweston> "#info jweston is Jennifer Weston, Equinox
14:14:06 <dluch> This came up because rsoulliere was on sabbatical (welcome back, rsoulliere!) and we needed the 3.3 docs broken into manuals.
14:14:15 <jweston> apologies for joining late - on another call
14:14:19 <dluch> We decided it would be a good idea to have one or more people to help out, in cases like this. I'd imagine you would start by working with rsoulliere to find out how/what he does.
14:14:27 <dluch> jweston: no worries!
14:14:35 <jweston> CWG will take the action item for MARC Edit
14:15:03 <bwillis> #info bwillis is Beth Willis, NOBLE
14:15:05 <dluch> Excellent, thank you!
14:15:16 <dluch> #action CWG will talk about MARC Edit, right-clicking, and accessibility
14:15:31 <sandbergja> catalogers++
14:15:47 <dluch> Is anyone interested in taking on this role (re #7 above)?
14:16:33 <sandbergja> I think an answer to action item #7 might become clearer after some discussion of New Business c
14:17:03 <dluch> Okay.  We'll table that until later, then.
14:17:08 <dluch> #8, dbs did give the broken out manuals a shot during the August meeting...he put them at http://evergreen-ils.org/~denials/.  Thanks again, dbs!
14:17:15 <dluch> dbs++
14:17:16 <rsoulliere> I will have more info about the server situation.
14:17:26 <remingtron> dbs++
14:17:32 <dluch> Then sandberja made a copy of the docs on a test page, http://docs-testing.evergreen-ils.org/.  Thanks, sandberja!
14:17:38 <dluch> sandbergja++
14:17:48 <jweston> dbs++
14:17:48 <dluch> Thanks, rsoulliere
14:17:52 <remingtron> sandbergja++
14:17:53 <jweston> sandbergja++
14:18:24 <dluch> So, I had a question about if it is okay to move that to the official docs?  But should that wait until later, too?
14:19:09 <sandbergja> I think that goes with rsoulliere's conversation about servers
14:19:20 <dluch> Cool.
14:19:25 <dluch> Any other old or ongoing business to discuss?
14:20:12 <dluch> Okay, moving on...
14:20:20 <dluch> #topic New Business
14:20:31 <dluch> #info Adding 3.3 documentation nees to our wiki page (see link above)
14:20:41 <dluch> We have some things needed from 3.2 but nothing added for 3.3, as far as I can tell.
14:20:50 <dluch> Can we make an action item for everyone to add to it or would someone like to spearhead the process?
14:21:02 <remingtron> I'm seeing some for 3.3 already on the needs list
14:21:53 <remingtron> dluch: is anything specific missing that you're aware of?
14:22:11 <dluch> In the Easy list?  I don't see any in the main "undocumneted" section
14:22:45 <remingtron> yeah, I see some under "Architecture", "Cataloging", ...
14:22:47 <dluch> remingtron: No, honestly, I haven't looked at it at all, I just saw there weren't any [3.3] designated things.  Maybe we don't need them
14:23:08 <dluch> Ha!  Yep, I see 'em now.
14:23:25 <remingtron> there aren't any in the first few subsections (like "Administration"), but I think those were completed already
14:23:45 <sandbergja> There are a few features where the release notes were just really good, so I just copy/pasted them into the official docs, rather than adding them to the docs needs
14:24:13 <sandbergja> So there are probably a few features missing from the docs list because of that
14:25:00 <remingtron> sandbergja: missing? or completed-before-they-could-be-added? :)
14:25:12 <sandbergja> missing, but missing in a good way? :-)
14:25:26 <dluch> :-)
14:25:29 <dluch> Okay, great.  So, we can just let that one be, then.
14:25:46 <dluch> But, if anyone does see anything not documented, add it to the wiki or send it to the list!
14:25:55 <dluch> #info New Docs committer: Andrea Buntz Neiman!
14:26:02 <dluch> abneiman was added as a new docs committer in August!  Congratulations, abneiman!
14:26:10 <dluch> That means that she will be able to push documentation commits to master.
14:26:11 <jweston> abneiman++
14:26:17 <dluch> abneiman++
14:26:27 <sandbergja> abneiman++
14:26:32 <alynn26> abneiman++
14:26:39 <dluch> And thanks to sandbergja and the rest of the docs committers for taking this action!
14:27:05 <remingtron> has she been given the powers, or do we need to request that still?
14:27:18 <sandbergja> I think we need to request it still
14:27:26 <sandbergja> remingtron: do you know the process for that?
14:28:33 <remingtron> my process would be: read the "git" and "contributing" wiki pages, and if that doesn't answer it, ask core committers who can do it
14:28:59 <dluch> So, will someone who's already a docs committer take that on?
14:30:08 <sandbergja> I can do that
14:30:20 <dluch> sandbergja++
14:30:49 <remingtron> sounds like gmcharlt might be a git admin
14:30:59 <remingtron> based on this page: https://wiki.evergreen-ils.org/doku.php?id=website_administration
14:31:00 <dluch> #action sandbergja will explore how to and then request abneiman be given docs committing privileges
14:31:08 <jweston> is there a list of docs committers -- so we can routinely thank you all?
14:31:08 <gmcharlt> remingtron: ayup
14:32:05 <sandbergja> gmcharlt: what's your preferred way for DIG to request that someone (abneiman) get docs commit privileges?
14:32:37 <gmcharlt> jweston: at the moment, rsoulliere ysuarez Hilary Caws-Elwitt akilsdonk rsteed stompro sandbergja jpresley
14:32:43 <gmcharlt> sandbergja: emai to gitadmin@evergreen-ils.org
14:32:53 <sandbergja> gmcharlt++
14:32:55 <sandbergja> thanks!  Will do
14:32:59 <jweston> gmcharlt++
14:33:16 <dluch> Awesome.
14:33:20 <dluch> gmcharlt++
14:33:43 <dluch> #info Documentation server needs
14:34:04 <dluch> I wasn't sure who added this one, but rsoulliere, it was you, I assume
14:34:11 <rsoulliere> At Mohawk, library access to servers required to maintain the docs is being questioned by IT. We are still negotiating with our IT overlords to regain access. Could http://docs-testing.evergreen-ils.org be made the live docs server since it is working? In fact, we should probably have multiple servers at a few institutions in a mirror set up for mo
14:34:11 <rsoulliere> re  reliability/redundancy going forward.
14:34:37 <dluch> Take it away!
14:37:11 <dluch> redundancy does sound like a good idea
14:37:18 <gmcharlt> rsoulliere: from the perspective of a member of the infrastructure team... we would be happy to accommodate
14:37:54 <gmcharlt> specificaly, working out a plan to put on a new docs VM on the hosting platform that GPLS and BOR are kindly continuing to donate to the project
14:37:55 <dluch> gmcharlt: I was just in the middle of typing a question about that.  Good, thanks!
14:38:29 <gmcharlt> if docs-testing becomes the new one, we'll need to plan on moving it to the new GPLS hosting anyway, but we can readily sort out such details
14:39:52 <rsoulliere> Was there any assistance you needed from me by working on the server or developing a git repo with the tools/instructions for setting up? Or was that covered?
14:39:55 <dluch> so, is that something the infrastructure team can take on to tackle?
14:40:38 <gmcharlt> yeah, in conjunction with rsoulliere (and yeah, I think we would want help and/or infodumps to make sure that the setup is suitable for the docs needs)
14:40:50 <gmcharlt> feel free to give me joint action item
14:41:11 <dluch> excellent, thank you all!
14:41:24 <sandbergja> One question I have: BMagic has been talking about moving our docs generation to use antora
14:41:45 <sandbergja> And I'm wondering how that fits in
14:41:51 <sandbergja> (or doesn't)
14:41:59 <dluch> #action gmcharlt and rsoulliere will work together to move the docs server
14:42:35 <dluch> Hmm.  Good question
14:42:54 <sandbergja> It seems like the server moving will have to happen sooner rather than later, while antora might be more of a project
14:43:21 <sandbergja> (my impressions, at least)
14:43:25 <dluch> Agreed
14:43:32 <remingtron> agreed
14:43:56 <gmcharlt> also agreed; I don't think implementing Antora woudl be a big deal from the infrastructure team's POV (in terms of providing access and server resources)
14:44:03 <gmcharlt> but probably best to focus on the move first
14:44:21 <sandbergja> that sounds like a plan, then
14:44:28 <dluch> Yes!
14:44:48 <dluch> Are we ready to move on, then, or do you have more on this, rsoulliere?  (or anyone)
14:45:03 <rsoulliere> I am good to move on.
14:45:18 <dluch> #info October meeting date
14:45:20 <sandbergja> rsoulliere++
14:45:23 <sandbergja> gmcharlt++
14:45:45 <dluch> I'm going to be at the Missouri Library Association conference when we'd normally have our next DIG meeting, October 3.  Would it be okay to reschedule to the 10th instead?  Or someone could volunteer to facilitate on the 3rd, without me.
14:46:12 <dluch> (and yes, rsoulliere++, gmcharlt++ !!)
14:46:27 <sandbergja> The 10th works for me
14:46:32 <jihpringle> for me too
14:46:49 <remingtron> me too
14:46:56 <jweston> me too
14:47:21 <dluch> Okay, great!
14:47:24 <dluch> #agree to move the October DIG meeting to the 10th.
14:47:38 <dluch> Is there any other new business we need to discuss?
14:48:01 <alynn26> me three.
14:49:16 <dluch> Alrighty, then...
14:49:20 <dluch> #topic Collaboration time
14:49:43 <dluch> We have about 10 minutes left.  Do we want to use it for collaboration/working time or just end the meeting early?
14:52:07 <dluch> Hearing nothing, I'm going to vote for ending the meeting  ;-)
14:52:20 <dluch> Thanks for all the great work, everyone!
14:52:29 <dluch> Next meeting will be October 10.  Same time, same place.  It will be primarily collaboration time.
14:52:35 <alynn26> vote end early.
14:52:45 <jweston> Thank you!  dluch++
14:52:53 <jihpringle> dluch++
14:53:06 <dluch> #endmeeting