14:13:31 <sandbergja> #startmeeting Evergreen Documentation Interest Group (DIG) Meeting
14:13:31 <pinesol> Meeting started Thu Dec  5 14:13:31 2019 US/Eastern.  The chair is sandbergja. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:13:31 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:13:31 <pinesol> The meeting name has been set to 'evergreen_documentation_interest_group__dig__meeting'
14:13:38 <sandbergja> Welcome, everyone!
14:14:12 <sandbergja> You can find the agenda at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20191205-agenda
14:14:12 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:14:23 <sandbergja> #topic Introductions
14:14:26 <sandbergja> Please let us know who you are
14:14:31 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:14:31 <dluch> #info dluch is Debbie Luchenbill, MOBIUS  I finally made it in!
14:14:36 <rfrasur> #info rfrasur is Ruth Frasur, Evergreen Indiana, ECDI
14:14:41 <sandbergja> #chair dluch
14:14:41 <pinesol> Current chairs: dluch sandbergja
14:14:43 <alynn26> dluch++
14:14:46 <sandbergja> dluch++
14:14:56 <remingtron> #info remingtron is Remington Steed, Hekman Library, Calvin University
14:15:02 <dluch> sandbergja++  Thanks for getting started!!
14:15:14 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:15:16 <sandbergja> Glad you are here!  We just started introductions.  We can't get far without you, dluch!! :-D
14:15:28 <dluch> Aww, thanks.  :)
14:15:46 <tkatie217> #info tkatie217 is Katie Greenleaf Martin, Blair Co Libraries/ SPARK-PaILS
14:16:07 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:16:41 <jweston> #info jweston is Jennifer Weston, Equinox
14:17:23 <dluch> Thank you all for coming! If you join in later, feel free to introduce yourself when you arrive.
14:17:31 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:17:39 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:17:47 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:17:54 <dbs> #info dbs is Dan Scott, Laurentian University
14:17:55 <dluch> #topic Business
14:18:42 <dluch> Do we have an update on this?  @gmcharlt?
14:19:06 <remingtron> gmcharlt: is out of office this afternoon
14:19:14 <remingtron> (I was informed by abneiman)
14:19:32 <dluch> Thanks, remingtron and abneiman!  Anybody know the progress of this?
14:20:05 <abneiman> I do not have any specific updates, other than that I have delivered nudges :)
14:20:16 <tkatie217> Am I correct in assuming that we need to move the server in order to get updated docs for 3.3 and 3.4 on the website?
14:20:16 <remingtron> dluch: FYI, I didn't see you post the topic
14:20:19 <dluch> :-)   abneiman++
14:20:28 <remingtron> tkatie217: that's right
14:20:59 <dbs> tkatie217: fwiw I posted PDF builds of several 3.4 manuals at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs
14:21:06 <abneiman> dbs has posted some ... yes, that :)
14:21:09 <sandbergja> dbs++
14:21:10 <abneiman> dbs++
14:21:22 <tkatie217> that was going to be my next question - I have builds of 3.3 but not 3.4. thanks :)
14:21:25 <dluch> dbs++
14:21:55 <dluch> Okay, we'll catch up more on the server move next meeting
14:22:01 <dluch> #info Quick update on Antora progress
14:22:11 <sandbergja> if anybody needs HTML versions, I can hop onto docs-testing.evergreen-ils.org and generate them there
14:22:21 <sandbergja> actually... I should just do that
14:22:29 <dluch> sandbergja++
14:22:44 <tkatie217> sandbergja++ please :)
14:22:44 <dbs> sandbergja++
14:23:05 <dluch> (remingtron: did the info Antora item come through above?)
14:23:15 <remingtron> dluch: yes!
14:23:21 <dluch> Awesome.
14:23:56 <dluch> So, remingtron and bmagic: Where are we with Antora and what's the numbering issue?
14:24:33 <remingtron> I've pushed all of the navigation files into Bmagic's collab branch, in rough draft form
14:24:40 <remingtron> I'm currently cleaning them up a little
14:25:33 <dluch> Great!  remingtron++
14:25:37 <dluch> What's next?
14:25:58 <remingtron> Bmagic posted a new live Antora server above a few minutes ago...
14:26:00 <dluch> (I think bmagic is packing up from the offsite meeting we just had.)
14:26:13 <remingtron> #link http://antora.mobiusconsortium.org/prod
14:26:31 <Cody> Hey all, I'm trying to build a custom catalog search for my local library and struggling with the documentation. http://docs.evergreen-ils.org/reorg/3.0/integrations/index.html seems to be the correct page to start. Is there any way to get JSON or is it only XML?
14:27:55 <remingtron> Anyone can help by testing that server and emailing the DIG list (or posting on IRC) any problems they find. There are some obvious ones, and probably many small ones.
14:28:58 <remingtron> Cody: Hi! We're holding a Documentation Interest Group meeting here right now, should end shortly, then someone can hopefully answer your question.
14:29:00 <dbs> Cody: we're in the middle of a meeting atm but right now there's only XML
14:29:00 <dluch> Cody: we're using the IRC channel for the DIG meeting right now, but I'm sure someone can help after!
14:29:13 <dluch> lol.  Jinx, remingtron
14:29:27 <Cody> ok, sorry about that
14:29:36 <dluch> No worries!
14:29:36 <sandbergja> Cody: no worries!
14:29:48 <dluch> Okay, so I'm going to set an action item for all of us on this one
14:30:03 <remingtron> dluch: great
14:30:33 <dluch> #action Everyone will test the new Antora server and email the DIG list (or IRC) with problems (or suggestions)
14:30:52 <dluch> #info We will catch up on other action items and business at the January meeting
14:31:10 <dluch> #info January meeting date
14:31:56 <dluch> The first Thursday in January is the 1st.  I am definitely not going to be at work that day and assume most of you won't, either.  So, is the following Thursday, January 9, okay with everyone?
14:32:38 <abneiman> 9th is fine with me
14:32:52 <jweston> dluch the first Thursday is Jan 2nd but moving it to the 9th sounds fine to me
14:33:19 <remingtron> sounds good
14:33:40 <dluch> jweston: Thank you for that correction!
14:34:08 <alynn26> sounds good
14:34:26 <dluch> Okay, so I WILL be at work on the 2nd, but I still think we should move it to the 9th, which is why I put it on the agenda, I guess.  LOL.
14:34:28 <dluch> Great.
14:34:42 <dluch> January meeting will be on the 9th, same time as usual
14:34:52 <jweston> dluch++
14:35:12 <dluch> #info Anything else pressing?
14:35:47 <dluch> Today's meeting is mainly for collaboration time, so we'll do more business things in January
14:36:11 <dluch> #topic Collaboration time
14:36:17 <jweston> question - is the Antora new link from bmagic going to be open and available for a few days?
14:36:18 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:36:52 <dluch> I believe so
14:37:03 <abneiman> I'll be (finally) committing some docs written by Equinox staff for some 3.4 features
14:37:07 <jweston> thanks
14:37:10 <remingtron> I'm about to push my navigation cleanups to the Antora branch. Then anyone else is welcome to help there.
14:37:21 <abneiman> sandbergja: standby for handholding, please ;-)
14:37:53 <sandbergja> abneiman: sure!  I will also try to sneak in some review of our docs pull requests in Github
14:41:44 <dluch> A couple months ago, I made a pull request for the registration/patron edit form field descriptions I'd finished and then I completely forgot about checking back on it.  Did anyone see that and pull it in?  I can't even find it now, lol.
14:41:45 <sandbergja> remingtron: at this point, should we put new content into the antora branch too?
14:42:13 <remingtron> sandbergja: Yes!
14:42:18 <remingtron> thanks for thinking of that!
14:42:41 <sandbergja> dluch: is it this one? https://github.com/evergreen-library-system/Evergreen/pull/88
14:42:47 <abneiman> remingtron: sandbergja: should I hold off pushing my docs them?
14:43:13 <remingtron> abneiman: no, don't need to delay
14:43:22 <dluch> sandbergja: Yes!  Thank you for finding it!
14:43:32 <remingtron> just open an LP maybe for adding to the antora docs also
14:44:23 <sandbergja> we should make sure that we loop back at some point before launching antora that we haven't left out any new changes
14:44:34 <sandbergja> I also need to learn how to add content to antora. :-)
14:44:51 <jweston> for the non-committers in the room, shall we continue to send updates/revisions in the usual way and they will be added when and where appropriate?
14:44:54 <dluch> sandbergja: Yes, that's a very good idea
14:45:21 <dluch> jweston: I assume so.  Committers, what say you?
14:45:24 <sandbergja> jweston: I think that's a safe assumption
14:46:04 <jweston> dluch sandbergja++ thanks
14:46:12 <remingtron> jweston: the diretory structure is different under Antora, but individual asciidoc files are basically the same as before
14:47:07 <remingtron> okay, I've pushed my latest to the antora collab branch
14:47:13 <remingtron> working/collab/blake/LP1848524_antora_ize_docs
14:47:24 <jweston> remington: thanks - I'm not even in asciidoc world, yet, but that makes sense to me
14:47:40 <dluch> remingtron++
14:47:56 <jweston> remingtron++
14:49:15 <sandbergja> remington: to check my understanding, if I want to add a new asciidoc file into antora, I add it to the appropriate docs-antora/modules/[NAME OF MODULE]/pages directory, then add  an xref to the appropriate nav.adoc?
14:50:07 <sandbergja> ^add an xref within the appropriate nav.adoc
14:52:23 <abneiman> sandbergja: git is complaining about an untracked file - relevant, or ignorable?
14:52:45 <sandbergja> abneiman: probably ignorable!
14:53:03 <sandbergja> especially if it's not an asciidoc file
14:53:25 <abneiman> sandbergja: no, it appears to be the 3.3.3-3.4.0 upgrade script
14:53:35 <Bmagic> jweston: yes
14:53:36 <sandbergja> oh... hmmm
14:53:49 <jweston> bmagic++
14:53:57 <abneiman> sandbergja:  Open-ILS/src/sql/Pg/version-upgrade/3.3.3-3.4.0-upgrade-db.sql~HEAD
14:54:12 <sandbergja> abneiman: which branch are you on?
14:54:20 <sandbergja> (you can run git status to check)
14:54:27 <abneiman> master
14:54:52 <sandbergja> Is there another version of that file without the ~HEAD business on the end?
14:55:24 <sandbergja> (i.e. is there a file called  Open-ILS/src/sql/Pg/version-upgrade/3.3.3-3.4.0-upgrade-db.sql)
14:56:12 <abneiman> yeah, both that one and ~HEAD are dated 10/21/19
14:56:26 <sandbergja> Okay, great!  It's safe to ignore that.
14:56:35 <abneiman> sandbergja++
14:56:47 <abneiman> thank you once again :)
14:56:52 <sandbergja> And also safe to just delete the file with ~HEAD in the filename, and then git won't complain about it again
14:57:13 <abneiman> sweet, done
14:57:50 <abneiman> I wonder if I managed to pull that in doing my nonstandard commit at hackaway
14:58:00 * abneiman is still obvs a git noob
15:00:13 <remingtron> sandbergja: sorry, stepped away for a minute, reading up now...
15:00:50 <remingtron> sandbergja: sounds like you've got it right (for adding to Antora docs)
15:01:07 <sandbergja> Yay!  I'll give that a try then.
15:01:28 <dluch> Folks, we are at time.  Thanks for all the great work, everyone!  Feel free to keep going!
15:01:31 <dluch> As decided above, the next meeting will be January 9. Same time, same place. Business meeting first then collaboration time.
15:01:40 <dluch> Please continue using the email list for questions and other things that come up in between meetings!
15:01:58 <dluch> Thanks for coming, everyone!
15:02:04 <dluch> #endmeeting