14:00:31 <dluch> #startmeeting 2020-01-09 - Documentation Interest Group Meeting
14:00:31 <pinesol> Meeting started Thu Jan  9 14:00:31 2020 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:31 <pinesol> The meeting name has been set to '2020_01_09___documentation_interest_group_meeting'
14:00:42 <dluch> #topic Agenda
14:01:00 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20200109-agenda
14:01:05 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation.
14:01:12 <dluch> #topic Introductions
14:01:19 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:24 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:01:27 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:29 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:01:32 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin University)
14:03:02 <abneiman> #info abneiman is Andrea Neiman, Equinox
14:03:29 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:03:53 <tkatie217> #info /me is Katie Greenleaf Martin, Blair Co PaILS/SPARK
14:05:11 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:05:18 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:05:26 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:05:35 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:05:47 <dluch> That's all really just so it shows up in the minutes
14:05:55 <dluch> #topic Old and Ongoing Business
14:06:03 <dluch> #info Previous Action Items
14:06:13 <dluch> How are we doing on these?  I'll take them in order...
14:06:25 <dluch> #1, sandbergja: video for proof of concept in the Quick Starts section?
14:06:36 <sandbergja> nope, not yet :-(
14:06:48 <dluch> Want me to leave it as an action item?
14:06:57 <sandbergja> yes, please :-)
14:07:35 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:08:14 <dluch> Also, related to Quick Starts, I discovered that NC Cardinal has a whole bunch of single-page things like that.  May be worth checking with April to see if we can use them
14:08:31 <dluch> sandbergja++
14:08:44 <dluch> #2, abneiman:  Did you have a chance to look into/plan a community crash course on ascii?
14:08:54 <sandbergja> Oh, good to know!
14:09:10 <abneiman> dluch: I have looked into it, but, alynn26 is planning something similar for the conference so I don't want to step on toes
14:09:20 <abneiman> and/or duplicate effort
14:09:30 <dluch> Okay, thanks.  Should I remove it as an action item?
14:09:45 <alynn26> may be we collab at the conference
14:09:53 <abneiman> probably so. +1 to collab alynn26
14:10:19 <dluch> That would be great.  And maybe we could do some version as an online thing for folks who can't be at conference
14:10:36 <abneiman> dluch: that's a good idea
14:10:50 <dluch> abneiman++ alynn26++
14:11:05 <dluch> #3, abneiman: I know you have prodded gmcharlt about the test server. More on that shortly, unless you want to say anything now?
14:11:16 <abneiman> nope nothing from me
14:11:26 <dluch> abneiman++
14:11:36 <dluch> #4, sandbergja, gmcharlt, and/or Dyrcona: how's work on setting up a git repo for ui (and maybe layouts) coming?
14:11:39 <gmcharlt> dluch: still on my plate, but it's stacked high. I'll carve out time to complete by next Friday
14:11:59 <dluch> Thanks, gmcharlt!
14:12:03 <sandbergja> for the git repo, gmcharlt made not one but two!
14:12:10 <dluch> gmcharlt++
14:12:13 <sandbergja> So we are good on #4
14:12:25 <dluch> Awesome!
14:12:38 <dluch> sandbergja++
14:12:50 <dluch> #5, bmagic, remingtron, and players to be named later (?): work on the nav, of which there are approx 192 lines needed.  Is this done or in progress?
14:13:10 <Bmagic> I completed Acq recently
14:13:20 <remingtron> and I'm working on Cataloging chapter as we speak
14:13:45 <remingtron> we're using the LP bug 1848524 to claim one chapter at a time
14:13:47 <pinesol> Launchpad bug 1848524 in Evergreen "wishlist: Antora-ize docs " [Undecided,New] https://launchpad.net/bugs/1848524
14:13:49 <Bmagic> you can see the results http://antora.mobiusconsortium.org/prod/docs/latest/acquisitions/selection_lists_po.html
14:14:04 <dluch> Excellent, thank you!  Should we leave it as an action item?
14:14:26 <remingtron> and my latest comment on the bug includes a list of steps to do for each section in the nav.
14:14:26 <Bmagic> yep, still an action item
14:15:02 <tkatie217> +Bmagic looks nice!
14:15:18 <dluch> #action Bmagic and remingtron will continue working on the nav, as per Launchpad bug 1848524
14:15:21 <pinesol> Launchpad bug 1848524 in Evergreen "wishlist: Antora-ize docs " [Undecided,New] https://launchpad.net/bugs/1848524
14:15:22 <remingtron> Bmagic++ #keeping the demo online and updated
14:15:26 <dluch> bmagic++
14:15:30 <Bmagic> tkatie217: Thank you :)
14:15:34 <dluch> remingtron++
14:15:40 <Bmagic> remingtron++
14:16:04 <dluch> #6, Everyone will test the new Antora server and email the DIG list (or IRC) with problems (or suggestions).  I don't think I've seen many (any?) emails with problems or suggestions. How is testing going?  (Also, more on Antora shortly.)
14:17:03 <dluch> crickets...
14:17:10 <alynn26> It looks great.
14:17:24 <Bmagic> :)
14:17:41 <dluch> I agree, it does look great
14:17:51 <remingtron> there are still little bugs hiding everywhere, so please test!
14:18:12 <dluch> I'll keep that on as an action item, then.  :-)
14:18:24 <Bmagic> yep - lots of hidden "gems" in there
14:18:34 <dluch> #action Everyone will test the Antora server and email the DIG list (or IRC) with problems (or suggestions).
14:18:55 <alynn26> Home icon needs updating. If you click on it it goes to the "it's powered by Antora".
14:19:24 <remingtron> alynn26++ #testing!
14:19:29 <Bmagic> lol
14:19:44 <Bmagic> I threw that page on there in the very very beginning
14:19:50 <dluch> Good find, lol
14:20:02 <Bmagic> probably should hit the "Introduction" page
14:20:22 <alynn26> That would be what I would expect.
14:21:03 <Bmagic> committing to the repo...
14:21:13 <tkatie217> I'm also seeing "Untitled :: Evergreen Documentation " in my browser tab regardless of what page i'm on - would be nice if it had a title, or just stayed with "Evergreen Documentation"
14:21:19 <alynn26> bmagic ++
14:21:51 <remingtron> tkatie217: yes, that gets better when we add labels in the nav.adoc files
14:22:03 <remingtron> (I think)
14:22:19 <dluch> Oh, that's good to know
14:22:22 <tkatie217> +remingtron that would make sense :)
14:22:41 <alynn26> I think it does, if you check out the Glossary it says Glossary.
14:23:06 <sandbergja> alynn26: I think the glossary looks so cool in antora. :-)
14:23:17 <dluch> navlabels++ :-D
14:23:47 <dluch> Okay, everyone keep up the good testing!  Let's move on
14:23:47 <tkatie217> +1 to glossary! gorgeous!
14:24:05 <dluch> +1 The glossary really is awesome
14:24:15 <dluch> #info Update on Documentation server move
14:24:43 <alynn26> I do have an update to the Glossary, With a few additional features. Here is my testing Gist: https://gist.github.com/alynn26/072bcda581fead021eab2f079dd49e82
14:24:55 <dluch> It doesn't look like rsoulliere is here right now...how's this going?
14:25:05 <dluch> gmcharlt: how's this going?
14:25:11 <dluch> alynn26++
14:26:49 <dluch> Okay, I'll leave the docs server move on the agenda for next time, and we'll catch up with it then
14:27:01 <dluch> #info Antora progress
14:27:11 <dluch> bmagic and remingtron?
14:27:21 <dluch> You already kind of updated us...anything else?
14:27:51 <dluch> Also...
14:27:55 <dluch> #info Numbering issue, Antora vs. Current.
14:28:08 <dluch> There are links on the agenda to both.  Who wants to start this discussion (who added it to the agenda)?
14:28:45 <remingtron> all are encouraged to help add labels to the various nav.adoc files. Grab us on email or IRC if you need help getting started.
14:29:16 <dluch> Awesome, thanks.
14:29:19 <remingtron> Bmagic: is the "numbering issue" talking about how the old docs used chapter numbers?
14:29:23 <dluch> remingtron++
14:29:38 <Bmagic> not sure
14:29:46 <Bmagic> who put that on the agenda?
14:29:49 <remingtron> no idea
14:29:54 <Bmagic> lol
14:30:13 <dluch> lol, me either.
14:30:20 <remingtron> okay, skip?
14:30:34 <dluch> Yup.  We can come back to it at another meeting
14:30:40 <dluch> also...
14:31:01 <dluch> #action Everyone, when adding agenda items, please include your name in parenthesis
14:31:17 <dluch> :-)
14:31:32 <dluch> Any other old or ongoing business to discuss?
14:31:32 <abneiman> I think it may have been copied from December?
14:31:40 <abneiman> (numbering issue, that is)
14:31:55 <Bmagic> yeah, I was going through the history for the wiki and it was there from the start
14:31:55 <dluch> abneiman: That's very possible
14:32:20 <dluch> So, I'm probably responsible, LOL
14:32:35 <Bmagic> wiki history to the rescue
14:32:42 <abneiman> and looking at Dec.... Bmagic, looks like you added it. So past-Blake thought it was something to talk about
14:32:50 <dluch> bmagic++
14:32:54 <abneiman> :)
14:32:55 <dluch> haha
14:33:00 <Bmagic> ok, thinking...
14:33:09 <remingtron> abneiman++ #digging through wiki history
14:33:19 <dluch> abneiman++
14:33:24 <dluch> wikihistory++
14:33:50 <dluch> Bmagic: Keep thinking and we'll talk about it at a future meeting.
14:33:52 <abneiman> heh. I was mostly wondering if Past Andrea was responsible for the mystery item, but yes. wikihistory++
14:34:02 <Bmagic> well, all I can come up with is the version of PG and OpenSRF mentioned
14:34:23 <Bmagic> example http://docs.evergreen-ils.org/3.2/_installing_prerequisites.html
14:35:12 <dluch> I was thinking it was more along the lines of page numbers or something, lol
14:35:32 <dluch> Oh, or numbers in the menu?
14:35:34 <Bmagic> it must not be that big of a deal
14:35:45 <Bmagic> The chapters are numbered the old way
14:35:46 <dluch> haha, must not
14:36:08 <dluch> Okay, moving on...
14:36:15 <dluch> #topic New Business
14:36:28 <dluch> #info DIG programs for Conference
14:36:46 <dluch> We have a few different documentation-related programs submitted for conference:
14:36:56 <dluch> alynn26 has "AsciiDoc, let's get started"
14:37:05 <dluch> bmagic is going to submit one on the docs move to Antora
14:37:12 <Bmagic> haha, I am?
14:37:17 <dluch> tkatie217 was thinking about an intro to sources for Evergreen documentation How is that going?
14:37:18 <Bmagic> (just kidding)
14:37:26 <dluch> Very funny, Bmagic
14:37:34 <tkatie217> Alynn++ definitely sending some people to that one!
14:37:53 <tkatie217> * alynn26++, rather
14:38:16 <dluch> tkatie217: are you still thinking about the docs sources one?
14:38:26 <tkatie217> dluch I was out sick part of this week so I haven't given it any thought between when I sent the email and now
14:38:30 <dluch> We often have a lightning-round "Intro to DIG" talk. I'm happy to do it, but I know, lfloyd, you have been doing it for several years now...did you want to again?
14:39:00 <tkatie217> But we can adapt what Angela and I did last year so it would be an easy submission - my plans for April are still somewhat fluid so I would prefer to have a buddy
14:39:11 <alynn26> I can do it again.
14:39:12 <dluch> tkatie217: Okay, no worries.  If it's something you'd still like to pursue, though, go ahead and submit the idea, even if it's not all fleshed out yet
14:39:34 <dluch> alynn26: Great, thanks!
14:39:49 <dluch> Did I miss any?
14:40:06 <dluch> Is anyone else thinking of submitting a docs-related program?
14:40:50 <dluch> Don't forget that tomorrow is the submission deadline for conference proposals!
14:41:05 <dluch> alynn26++ bmagic++ tkatie217++
14:41:36 <dluch> Is there any other new business we need to discuss?
14:41:55 <abneiman> are we doing the usual docs hackfest on preconference day, as well?
14:42:03 <dluch> Oh!  Yes!
14:42:15 <dluch> Thank you, abneiman!
14:43:04 <dluch> And we could use a few DIG folks to volunteer to help out new folks who come and want to learn how to contribute.  Any takers?
14:43:18 <dluch> [for the docs hackfest]
14:43:28 <abneiman> I'm planning to be there & can help new people
14:43:44 <dluch> abneiman++
14:43:58 <alynn26> I'll be there
14:44:16 <dluch> alynn26++
14:44:54 <dluch> I'll be there, too, though I'm not sure how helpful I'll be for new folks, lol
14:45:42 <dluch> Okay, if there's no other new business, we can move on to...
14:45:49 <dluch> #topic Collaboration time
14:46:08 <dluch> There's about 15 minutes left.
14:46:12 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:46:22 <dluch> Or, we can just end the meeting now.
14:46:36 <Bmagic> I committed to the repo just now
14:47:16 <sandbergja> alynn26: are your glossary changes ready for review?
14:48:18 <alynn26> I've got a branch I need to push up with the changes.  in it is also additonal words, and linking in the current docs in the the end matter.
14:48:47 <sandbergja> Oh, excellent!  I'll look forward to that, then
14:49:36 <remingtron> alynn26++
14:50:00 <dluch> Awesome! alynn26++
14:53:24 <dluch> I'm going to start reviewing the older doc needs to see if I already have something that will meet some of them
14:53:36 <dluch> (But not today, lol)
14:55:02 <remingtron> Bmagic: I just pushed my cat changes to collab
14:55:15 <Bmagic> nice! remingtron++
14:55:39 <dluch> remingtron++
14:59:31 <dluch> We are just about at time.  Thanks for all the great work, everyone!  Feel free to keep going!
14:59:41 <dluch> Next meeting will be February 6.  Same time, same place.  It will be primarily collaboration time.
14:59:46 <sandbergja> dluch++
15:00:06 <alynn26> dluch++
15:00:07 <dluch> Thanks for coming, everyone!
15:00:19 <dluch> #endmeeting