#evergreen: 2020-02-04 Developer Meeting

Meeting started by csharp at 15:02:31 US/Eastern (full logs).

Meeting summary

    1. Agenda: https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-02-04 (csharp, 15:03:12)

  1. Roll Call (csharp, 15:03:31)
    1. csharp = Chris Sharp, GPLS (csharp, 15:03:42)
    2. berick Bill Erickson, KCLS (berick, 15:03:58)
    3. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff_, 15:04:05)
    4. jeffdavis = Jeff Davis, Sitka (BC Libraries Coop) (jeffdavis, 15:04:09)
    5. sandbergja = Jane Sandberg, Linn-Benton Community College (sandbergja, 15:04:41)
    6. terranm = Terran McCanna, PINES (terranm, 15:04:52)
    7. remingtron is Remington Steed, Hekman Library (Calvin University) (remingtron, 15:05:16)
    8. dbwells = Dan Wells, Hekman Library (Calvin University) (dbwells, 15:05:22)

  2. Action Items from Last Meeting (csharp, 15:05:42)
    1. gmcharlt will apply various code changes and nudges regarding the remaining webstaffblocker bugs (csharp, 15:05:51)
    2. said bugs: https://bit.ly/2vHWljR (csharp, 15:08:23)

  3. OpenSRF release info (csharp, 15:09:34)
  4. Evergreen release info (csharp, 15:11:03)
    1. we need to address i18n and l10n issues with Angular as fewer and fewer interfaces are available in localized versions (csharp, 15:14:38)
    2. 3.3.6 and 3.4.2 were released 1/29/2020 - first releases of the year (csharp, 15:15:52)
    3. ACTION: berick will follow up on i18n/l10n issues and report back (csharp, 15:16:12)
    4. ACTION: sandbergja will assist berick as needed (csharp, 15:16:29)
    5. alynn26 = Lynn Floyd, Indiana (alynn26, 15:17:56)
    6. about 60 bugs targeted for 3.5-alpha - 41 with pullrequest tags and 8 with signedoff tags (csharp, 15:18:48)
    7. feedback fest scheduled for the week of 2/17 - 2/22 - code reviewers and committers are expected to participate (csharp, 15:20:38)
    8. ACTION: csharp will work with terranm to get at least one sandbox server running master + pullrequest patches (csharp, 15:23:56)
    9. https://bugs.launchpad.net/evergreen/+bug/1842297 (for the logs) (csharp, 15:25:59)
    10. 3.5 roadmap: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.5 (csharp, 15:29:24)
    11. request for attention for Hopeless Holds (https://bugs.launchpad.net/evergreen/+bug/1811710) and Angular admin page filters (https://launchpad.net/bugs/1846042) (csharp, 15:31:16)
    12. there is a need for documentation around bug wrangling guidelines - specifically release/milestone/series targeting (csharp, 15:39:40)
    13. and like a magician, remingtron provided a wiki link: https://wiki.evergreen-ils.org/doku.php?id=dev:bug_wrangler:faq (csharp, 15:40:46)

  5. Hatch (csharp, 15:42:06)
  6. Feedback for New Features Under Development (csharp, 15:46:44)
    1. ACTION: csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server (csharp, 15:52:56)
    2. https://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:angular_staff_catalog (berick, 16:02:11)
    3. ACTION: berick to open LP on showing link to ang staff cat by default in 3.5 (berick, 16:17:25)
    4. ACTION: berick to open LP on showing link to ang staff cat by default in 3.5 (berick, 16:19:57)
    5. IDEA: more cowbell (berick, 16:21:48)


Meeting ended at 16:21:53 US/Eastern (full logs).

Action items

  1. berick will follow up on i18n/l10n issues and report back
  2. sandbergja will assist berick as needed
  3. csharp will work with terranm to get at least one sandbox server running master + pullrequest patches
  4. csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server
  5. berick to open LP on showing link to ang staff cat by default in 3.5
  6. berick to open LP on showing link to ang staff cat by default in 3.5


Action items, by person

  1. berick
    1. berick will follow up on i18n/l10n issues and report back
    2. sandbergja will assist berick as needed
    3. berick to open LP on showing link to ang staff cat by default in 3.5
    4. berick to open LP on showing link to ang staff cat by default in 3.5
  2. csharp
    1. csharp will work with terranm to get at least one sandbox server running master + pullrequest patches
    2. csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server
  3. sandbergja
    1. sandbergja will assist berick as needed
    2. csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server
  4. terranm
    1. csharp will work with terranm to get at least one sandbox server running master + pullrequest patches


People present (lines said)

  1. csharp (78)
  2. berick (59)
  3. sandbergja (35)
  4. terranm (21)
  5. pinesol (15)
  6. jeffdavis (11)
  7. Bmagic (9)
  8. remingtron (8)
  9. jeff (5)
  10. jeff_ (2)
  11. Dyrcona (2)
  12. dbwells (2)
  13. alynn26 (2)
  14. abneiman (1)


Generated by MeetBot 0.1.4.