15:05:21 <csharp> #startmeeting 2020-03-03 - Developer Meeting
15:05:21 <pinesol> Meeting started Tue Mar  3 15:05:21 2020 US/Eastern.  The chair is csharp. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:21 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:21 <pinesol> The meeting name has been set to '2020_03_03___developer_meeting'
15:05:39 <csharp> #info agenda: https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-03-03
15:05:49 <csharp> #topic roll call
15:05:54 <berick> @coffee csharp
15:05:54 * pinesol brews and pours a cup of Esmeralda Especial Best of Panama, and sends it sliding down the bar to csharp
15:05:57 <csharp> #info csharp is Chris Sharp, GPLS
15:06:00 <csharp> berick++
15:06:15 <berick> #info berick Bill Erickson, KCLS
15:06:15 <Dyrcona> #info Dyrcona is Jason Stephenson, CW MARS
15:06:24 <alynn26> #info alynn26 is Lynn Floyd, EI
15:06:28 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
15:06:29 <JBoyer> #info JBoyer, Jason Boyer, EOLI
15:06:43 <miker> #info miker Mike Rylander, EOLI
15:07:36 <csharp> #topic Action Items from Last Meeting
15:07:46 <csharp> #info berick will follow up on i18n/l10n issues and report back
15:07:56 <csharp> berick: you have the floor
15:08:05 <berick> k..
15:08:11 <csharp> (also sandbergja )
15:08:12 <berick> so progress made on bug 1862395
15:08:14 <pinesol> Launchpad bug 1862395 in Evergreen "Update Angular translations for poeditor pre-3.5" [Undecided,New] https://launchpad.net/bugs/1862395 - Assigned to Bill Erickson (berick)
15:08:27 <berick> thanks for the assist sandbergja
15:08:54 <berick> if I'm reading the poeditor site correctly, though, we don't yet have new translactions to pull back into EG
15:08:55 <sandbergja> happy to do it!  thanks for getting it rolling
15:09:09 <berick> due in part to get the strings uploaded late in the game
15:10:18 <csharp> how can others help in keeping that ball rolling?
15:10:19 <berick> i'll put out a call for translators to review the poeditor content
15:10:22 <csharp> ah
15:11:14 <csharp> moving on then...
15:11:20 <csharp> #info csharp will work with terranm to get at least one sandbox server running master + pullrequest patches
15:11:40 <csharp> so yeah, the feedback fest was kind of a crazy good success
15:12:03 <csharp> we now have a good model for future feedback fests and bug squash weeks
15:12:25 <csharp> terranm++ # not in channel, but that was on her initiative
15:12:36 <JBoyer> csharp++
15:12:39 <JBoyer> terranm++
15:12:46 <berick> yeah, terranm++ big time
15:12:51 <JBoyer> That was a good week
15:13:10 <csharp> #info csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server
15:13:11 <pinesol> Launchpad bug 1821094 in Evergreen 3.3 "Item status refresh after editing can get confusingly slow" [Medium,Confirmed]
15:13:22 <csharp> I can tell you right now that we haven't done that yet :-/
15:13:33 <csharp> #action csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server :-)
15:13:42 <sandbergja> thanks, csharp!
15:13:46 <csharp> #info berick to open LP on showing link to ang staff cat by default in 3.5
15:14:13 <berick> i have not opened said LP, but I've given some additional thought to it..
15:14:54 <berick> testing the catalog without full integration is only going to tell us so much
15:15:33 <berick> i'm going to open an LP for promoting the Ang cat to becoming the default for (presumably) 3.6
15:15:49 <berick> if that's too early, we can bump to 3.7
15:16:04 <berick> but in any event, whenever it's merged, i think it needs to be merged very early in the release cycle
15:16:29 <berick> since it's a significant change
15:17:19 <berick> given that, I probably won't open an LP for making it visible by default in 3.5, unless there's a push to do so
15:17:38 * berick is open to suggestion as always
15:18:11 <csharp> no push from my direction, though we have been testing it among GPLS/PINES staff and plan to switch on the 3.4 version in production soon
15:18:35 <berick> csharp: good to hear.  i look forward to the feedback
15:19:28 <csharp> ok, any other residual items from the last meeting (or before) that needs discussion?
15:20:07 <csharp> #topic Release info: OpenSRF
15:20:18 <csharp> anyone have OpenSRF news?
15:20:36 <csharp> I only see a couple of low priority fixes that have been targeted to a new release
15:21:29 <miker> still looking for time to work on param chunking, any extra hands welcome
15:22:00 <miker> that'll get us completely out from under ejabberd stanza size issues
15:22:32 <miker> (think: sending a big batch update for templates, huge marc records, etc)
15:23:32 <csharp> related bug: https://bugs.launchpad.net/opensrf/+bug/1725317
15:23:33 <pinesol> Launchpad bug 1725317 in OpenSRF ""XML stanza is too big" still possible with chunking and bundling" [Undecided,New] - Assigned to Galen Charlton (gmc)
15:23:45 <miker> I have a perl WIP of the context, I think it's on the working repo ... but JS support would be a big win
15:25:01 <csharp> #info miker is calling for assistance with OpenSRF chunking/bundling improvements
15:25:16 <csharp> #topic Release info: Evergreen
15:25:35 <csharp> beta tomorrow!
15:26:05 <csharp> Evergreen build teams will be snapping into action for that
15:26:16 <csharp> berick: anything you want to highlight?
15:27:02 <berick> the feedback fest action was probably biggest highlight
15:27:10 <berick> overall, a fairly calm release
15:27:24 <berick> debit payment payments probably the biggest new feature
15:27:26 <csharp> the DB upgrade script is non-threatening :-)
15:27:35 <berick> indeed, tis a modest sql update
15:28:21 <berick> question...
15:28:39 <berick> should we institute any kind of commit freeze for beta cutting?
15:28:56 <berick> i know we do that sometimes for release cutting to reduce churn and finalize release notes
15:29:38 <Dyrcona> I think it's a good idea.
15:29:42 <csharp> +1
15:30:34 <berick> k, thanks.  so, i'll post a note that we'd like to freeze commits tomorrow, except for those related to release cutting
15:30:57 <alynn26> +1
15:31:02 <berick> another question..
15:31:20 <csharp> #info commit freeze will go into effect 3/4 to allow for cutting the 3.5 release
15:31:40 <berick> are we OK creating the origin/rel_3_5 branch after after the beta is out?
15:31:56 <csharp> I always prefer when we do that, fwiw
15:32:23 <Dyrcona> +1
15:32:50 <berick> great, thanks
15:32:57 <alynn26> +1
15:33:01 * berick will proceed thusly
15:33:38 <csharp> #info we will create a rel_3_5 branch along with the beta
15:34:19 <csharp> ok, moving on
15:34:27 <csharp> #topic Release info: Hatch
15:34:37 <csharp> this is a placeholder, but any updates from anyone?
15:34:45 <berick> I have no new Hatch updates
15:35:22 <csharp> moving on to New Business then
15:35:31 <csharp> #topic Feedback for New Features Under Development
15:35:57 <csharp> not sure who added that, but take it away!
15:36:53 <sandbergja> I'm interested in bug 1627373 under needsdiscussion :-)
15:36:55 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New] https://launchpad.net/bugs/1627373
15:37:42 <sandbergja> csharp: berick: you two probably have the best idea about how to get that bug unstuck
15:37:49 <csharp> right - I just added that tag in the last day or so because I wanted consensus about the best way to implement it
15:38:46 <csharp> back in 2016, berick talked me out of my thoughts in the last paragraph of https://bugs.launchpad.net/evergreen/+bug/1627373/comments/3 and I just kind of walked away from it since PINES acq libs weren't complaining
15:38:47 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New]
15:38:55 <sandbergja> (and it has an annoying cousin, bug 1770202, which causes more trouble for us locally)
15:38:56 <pinesol> Launchpad bug 1770202 in Evergreen "Evergreen only recognizes a few EDI order statuses" [Undecided,New] https://launchpad.net/bugs/1770202
15:40:15 <berick> i can spend some time with bug 1627373.
15:40:16 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New] https://launchpad.net/bugs/1627373
15:40:23 <csharp> I think the original approach I took in https://bugs.launchpad.net/evergreen/+bug/1627373/comments/1 was more what we needed
15:40:29 <csharp> berick++
15:41:09 <sandbergja> berick++
15:42:16 <csharp> maybe this list of needsdiscussion bugs can be addressed as part of bugsquash week coming up?
15:42:38 <csharp> with a shared spreadsheet ala terranm
15:42:47 <alynn26> bugsquash++
15:43:20 <csharp> #action berick will consider approaches to https://launchpad.net/bugs/1627373
15:43:21 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New]
15:43:56 <csharp> #action csharp will organize a spreadsheet of needsdiscussion bugs to be walked through during bugsquash week
15:45:00 <csharp> it does seem that needsdiscussion is an indicator of things kind of mired in the mud
15:45:11 <csharp> #topic QA-related bugs
15:45:30 <csharp> welp, that's an empty result set
15:45:37 <csharp> hooray! we fixed 'em all!
15:45:54 <miker> EVERGREEN IS DONE, EVERYONE! WE DID IT!
15:45:56 <sandbergja> hahahahaha
15:46:18 * csharp highfives room
15:47:05 <csharp> ok, well, the floor is now open for anyone else's comments/questions/discussions
15:48:02 * JBoyer has been on the phone most of the meeting, but as far as the angular opac goes, would it help to swap to an on-by-default setup with an OUS to disable it, or do we want a hard cut "This is the future, welcome to it." date?
15:48:36 <csharp> maybe a "Catalog Classicâ„¢" button?
15:49:01 <JBoyer> csharp++
15:49:04 <csharp> @who moved my iframes?
15:49:04 <pinesol> Guest24783 moved your iframes.
15:49:06 <berick> JBoyer: full integration will require a lot of link rewriting.  making it something that can be toggled is non-trivial
15:49:24 <JBoyer> Ah, now I see. Yeah, that's a hard cut.
15:49:43 <berick> and not just the URL paths, but how the links are handled (angjs routing vs standard href, etc.)
15:49:57 <berick> JBoyer: yeah, I think it has to be a hard-cut
15:50:27 <csharp> #topic next developer meeting
15:50:40 <csharp> The next meeting will be in person in Atlanta!
15:50:51 <csharp> (with IRC simulcast - maybe video too)
15:51:14 <berick> and technicolor!
15:51:29 <csharp> Police Squad! In color!
15:51:43 <alynn26> See yall in Atlanta
15:51:48 <csharp> we'll have more details on when exactly that will be later
15:52:05 <csharp> ok, I think we're done.
15:52:11 <csharp> #endmeeting