14:00:14 <dluch> #startmeeting 2020-03-05 - Documentation Interest Group Meeting
14:00:14 <pinesol> Meeting started Thu Mar  5 14:00:14 2020 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <pinesol> The meeting name has been set to '2020_03_05___documentation_interest_group_meeting'
14:00:24 <dluch> #topic Agenda
14:00:37 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20200305-agenda
14:00:48 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:00:59 <dluch> #topic Introductions
14:01:07 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:14 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:40 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:40 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:01:51 <cmalm_> #info cmalm is Carissa Malmgren, Roanoke Public Library (NTLC)
14:04:07 <dluch> Thank you for coming! We are a small group today, but will be mighty! ;-) If you come in later, feel free to introduce yourself when you arrive.
14:04:22 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:04:32 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:04:41 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:04:54 <dluch> #topic Old and Ongoing Business
14:05:04 <dluch> #info Previous Action Items
14:05:37 <dluch> How are we doing on these?  I think most of the people in them aren't here, but I'll take them in order...
14:05:56 <dluch> #1, sandbergja: video for proof of concept in the Quick Starts section?
14:06:14 <dluch> (I don't see her on IRC right now, so we'll move on)
14:06:30 <dluch> #2, I'm also going to skip this one, since we have more on Antora progress later
14:06:41 <dluch> #3, Everyone will test the Antora server and email the DIG list (or IRC) with problems (or suggestions)
14:06:50 <dluch> I know that sandbergja and some of her people did this, and posted to the Launchpad bug. Anyone else? Do we need to keep this as an action item?
14:07:53 <abneiman> I have not tested Antora, but if you are happy with the test outcomes so far we could probably drop the action item
14:08:37 <alynn26> #info alynn26 is Lynn Floyd Evergreen Indiana
14:08:39 <dluch> I think they've been good. bmagic and remingtron, what do you think?
14:08:57 <dluch> Hi, Lynn!
14:09:26 <dluch> Okay, well... #4, Everyone, when adding agenda items, please include your name in parenthesis
14:09:35 <dluch> No one added any agenda items except me, lol.
14:09:43 <dluch> Let's all just keep this in mind for future meetings, please. :-) I don't think we need to keep it as an action item.
14:09:59 <alynn26> lol
14:10:20 <dluch> So, I'm going to keep the other action items for next time...
14:10:36 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:10:57 <dluch> Ha, I guess that's it.
14:11:08 <alynn26> hi ya'll
14:11:13 <dluch> #info Update on Documentation server move
14:11:28 <dluch> gmcharlt: how's this going?
14:12:09 <gmcharlt> dluch: stalled at present, but I would like to set a time next week with interested parties, possibly via GTM, to get back on track and ensure that credentials are distributed
14:12:46 <gmcharlt> with Wednesday, Thursday, and Friday afternoon ET being generally the best for me
14:13:22 <dluch> Awesome, sounds good. If I remember correctly, that was going to be remingtron and sandbergja, though I'll be happy to participate, too
14:13:42 <alynn26> gmcharlt++
14:13:45 <dluch> gmcharlt++
14:14:06 <gmcharlt> dluch: I'll send a Doodle to the three of you; feel free to forward as desired
14:14:32 <dluch> Sounds great, thank you!  Is there anyone else at the meeting today that would like to be included?
14:14:44 * alynn26 raised hand
14:14:52 <abneiman> me, please
14:15:53 <dluch> Great!  Thanks, alynn26 and abneiman!
14:16:07 <gmcharlt> noted, thanks
14:16:12 <dluch> alynn26++
14:16:16 <dluch> abneiman++
14:16:22 <abneiman> gmcharlt++
14:16:48 <dluch> Okay, moving on...
14:16:57 <dluch> Well, this might not fly, either, lol
14:16:59 <dluch> #info Antora progress
14:17:08 <dluch> bmagic and remingtron: Where are we with Antora nav?
14:17:22 <dluch> (I'm pretty sure bmagic went to lunch)
14:17:54 <dluch> Anyone know... Did we get things done in time to be included in 3.5?
14:18:17 <dluch> (I'm thinking no, but I haven't read the release notes closely...)
14:18:25 <abneiman> dlu
14:18:45 <abneiman> dluch: not that i can tell
14:18:54 <dluch> Okay, thanks
14:19:03 <dluch> What else do we need to be doing for this project going forward? Do we know yet?
14:19:04 <abneiman> there's only one LP item for antora, and it's still open
14:19:17 <dluch> abneiman++
14:19:38 <abneiman> see remingtron's comment here for next steps: https://bugs.launchpad.net/evergreen/+bug/1848524/comments/21
14:19:39 <pinesol> Launchpad bug 1848524 in Evergreen "wishlist: Antora-ize docs " [Undecided,New]
14:21:11 <dluch> #action everyone will review all of the docs on Antora, looking for broken things and other fixes needed and report on Launchpad
14:21:40 <dluch> Any other old or ongoing business to discuss?
14:21:43 <alynn26> I'm thinking that if we do not get them in 3.5, we so a big push at the Conference.
14:21:57 <dluch> alynn26: that's an excellent idea
14:23:18 <dluch> Okay, moving on...
14:23:26 <dluch> #topic New Business
14:23:36 <dluch> #info April and May Meetings
14:23:47 <dluch> Normally, we would have the April meeting on the 2nd and the May meeting on the 7th. April would be a collaboration/working time meeting and May would be a business meeting.  But, DIG will also meet at the Evergreen International Conference later in April, and will have a documentation hackfest on pre-conference day.
14:23:56 <dluch> Should we skip April and/or May?
14:24:17 <dluch> It looks like, in past years, we've often had the April meeting, had the hackfest and meeting at conference, and skipped May, but that's not always the case.
14:24:33 <dluch> I have no real preference, so will go with what the group would like.
14:24:46 <jihpringle> do we want to do anything 3.5 related before 3.5.0 is released?
14:27:03 <dluch> We're aiming for the 3.5 release to be before the conference, right?
14:27:30 <jihpringle> I'm not sure if the release date has changed, but it was slated for April 1st
14:27:56 <alynn26> From what i know it's still slated for April 1st.
14:28:33 * csharp confirms April 1st
14:28:49 <jihpringle> there's a bug squashing week planned for the week of March 16th
14:29:00 <dluch> And if we had the April DIG meeting, it would be on the 2nd. But it would be all collaboration time, and we could work on 3.5 docs then, too...
14:29:08 <dluch> csharp++
14:29:26 <dluch> jihpringle: so we could push on docs during that week?
14:30:10 <jihpringle> possibly???
14:31:06 <abneiman> dluch: jihpringle: IMO no reason to not include docs work as part of Bug Squashing Week, if people are available/willing
14:31:16 <alynn26> Yes
14:31:29 <dluch> Yeah, I think that's a good idea.  jihpringle++
14:31:36 <alynn26> I got a couple of bugs in docs I can push that week.
14:31:50 <dluch> excellent
14:32:21 <dluch> #action DIG will work on 3.5 documentation during Bug Squashing Week, March 16-20
14:32:38 <dluch> So, also have the April meeting?
14:32:39 <jihpringle> I haven't had a chance to look at the release notes in any depth but I think the biggest changes from a docs perspective will be the angular catalogue which I don't think we've included in the 3.4 docs (after a quick skim)
14:33:08 <dluch> jihpringle: I think you're right
14:33:10 <alynn26> yes, to the april meeting, and then most likely not the May meeting.
14:33:13 <abneiman> also there's a lot of angular admin ports, so screen shots might need updating
14:33:31 <dluch> abneiman: Yes, that's true!
14:33:40 <alynn26> screenshots--
14:33:42 <dluch> Thanks, alynn26.  We'll plan on that, then.
14:34:10 <jihpringle> do we need to make a decision about how and when we start including the angular catalogue?
14:35:06 <dluch> Do we wait until it's all done and "standard" or make a special section for the experimental version?
14:35:42 <alynn26> I think we do.  I think a special section for the experimental version with some basic information is needed.
14:35:43 <abneiman> If someone has tuits & the inclination, documenting (at least in part) the experimental version might be a kindness
14:35:57 <abneiman> as long as we're clear that it's still experimental
14:36:12 <abneiman> I can ask CWG next week if they might be able to pitch in on that
14:36:12 <alynn26> I know we are looking at going to 3.4 this spring with the experimental turned on.
14:36:18 <jihpringle> I agree with having a special section to start including it
14:36:47 <alynn26> We will start doing some basic documentation in house on it.
14:36:52 <dluch> Agreed.
14:37:12 <alynn26> CWG++
14:37:31 <jihpringle> we're thinking about having a library or two pilot it when we move 3.5 in May so we also be starting to document it in house
14:37:37 <dluch> abneiman: thanks for asking CWG!
14:37:42 <dluch> CWG++ indeed
14:37:55 <alynn26> If they can do some and get it to us in some form, we will translate.
14:38:09 <dluch> Yep
14:38:36 <dluch> I will probably not have time before bug squashing week, but I do want to play around with it more and can also help contribute some
14:42:14 <dluch> #agree We will begin working on documentation for the experimental catalog now
14:42:31 <dluch> #info Conference plans
14:42:47 <dluch> (I forgot to put this one on the agenda)
14:42:48 <dluch> At the January meeting, we talked about docs related programs that are happening at the conference. Usually, at the hackfest, we also have a couple of people who help to guide new folks on getting started (or folks like me, who always forget, lol).  Do we have a couple of you willing to do that? morning and/or afternoon?
14:43:11 <alynn26> I will be available in the morning
14:43:34 <alynn26> I have the new Dev meeting in the afternoon.
14:43:35 <dluch> alynn++
14:43:41 <dluch> oops
14:43:45 <dluch> alynn26++
14:43:50 <alynn26> :)
14:44:20 <alynn26> that's my alter alter alter ego
14:44:35 <abneiman> I can be available for docs hackfest, probably all of it, though I may sit in on new devs in the afternoon as well
14:44:47 <dluch> :-)
14:44:53 <dluch> abneiman++
14:44:59 <dluch> Anyone else available/willing to mentor folks in the afternoon (or also in the morning)?
14:45:13 <dluch> I'll be there all day, of course. ;-)
14:46:02 <alynn26> So, we will get them started, then you can work with them in the afternoon, I will be on IRC most of the day
14:46:25 <abneiman> yeah, I will likewise be available for IRC pings even if I'm not in the room
14:46:34 <dluch> :-) Sounds good!  Thank you both!!
14:46:44 <dluch> Is there any other new business we need to discuss?
14:47:27 <alynn26> I am sure bmagic and remington will be around also
14:47:43 <dluch> Yes, probably!
14:47:58 <abneiman> I think sandbergja is planning to be at the conference as well
14:48:12 <dluch> excellent
14:48:48 <dluch> #topic Collaboration time
14:49:40 <dluch> We have 12 minutes left. Not much, but we can still work on stuff if you want.  What did everyone planning to work on today?  Let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:50:09 <dluch> (excuse typo above.  sigh)
14:50:41 <abneiman> I have to skedaddle but I'll teport back next week about whether CWG is able to assist with experimental catalog docs
14:50:57 <dluch> abnieman: Thanks!
14:51:15 <abneiman> dluch++ # fearless leader
14:51:32 <dluch> :-)
14:51:33 <alynn26> dluch++
14:51:34 <dluch> If everyone is amenable, I'm happy to end the meeting now...
14:52:39 <dluch> Next meeting will be April 2. Same time, same place.  It will be primarily collaboration time.  Everyone also please work on 3.5 docs during Bug Squashing Week in March!
14:52:53 <dluch> Thanks for coming, everyone!
14:52:58 <alynn26> +1 fore ending
14:52:58 <jihpringle> thanks dluch++
14:53:05 <cmalm> dluch++
14:53:06 <dluch> #endmeeting