14:00:10 <dluch> #startmeeting 2020-04-02 - Documentation Interest Group Meeting
14:00:10 <pinesol> Meeting started Thu Apr  2 14:00:10 2020 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <pinesol> The meeting name has been set to '2020_04_02___documentation_interest_group_meeting'
14:00:27 <dluch> #topic Agenda
14:01:12 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20200402-agenda
14:01:12 <dluch> Welcome everyone!  Today's meeting will be some discussion and updates but hopefully we'll still have lots of time for collaboration and working on documentation.
14:01:24 <dluch> #topic Introductions
14:01:37 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:42 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:01:50 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:02:31 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:42 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:03:55 <dluch> If you're just joining us for the DIG meeting, Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:04:39 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:05:18 <dluch> Thank you all for coming! If you join in later, feel free to introduce yourself when you arrive.
14:05:27 <adurrence> #info adurrence is April Durrence, NC Cardinal
14:05:50 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:05:53 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:06:05 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:06:17 <dluch> We are going to do some quick business items, but let's try to get through them fairly quickly...
14:06:31 <dluch> (Also, dang, this is a lot harder with only one screen, lol!)
14:06:45 <dluch> #topic Business
14:06:59 <dluch> #info Update on Documentation server move
14:07:18 <dluch> gmcharlt: (or anyone) This is done, yes?
14:08:08 <dluch> We had a meeting a couple weeks ago (?) right before everything went wonky, and several of us got logins
14:08:48 <alynn26> I was hoping to attend that meeting, but I had another one at the same time.
14:09:17 <dluch> alynn26: \Yes, I remember now. gmcharlt was also going to get you access
14:09:22 <Bmagic> Server is up and running. Bare bones right now
14:09:38 <Bmagic> eg-docs.georgialibraries.org/prod/
14:09:44 <dluch> Okay, thanks.
14:10:05 <alynn26> what can we do to help flesh it out.
14:11:38 <Bmagic> The antora stuff is on there right now - I'm not sure about any other pieces that need to be hosted there (if any). I think there are some. Perhaps the SQL->HTML generator?
14:11:44 <alynn26> It looks really good.
14:12:04 <dluch> Yes, it does!
14:12:15 <Bmagic> All of the legacy documentation will need to be copied over. Keeping the links the same
14:12:48 <dluch> Yeah, that's what I was remembering, too...we'll need to copy stuff over
14:13:11 <dluch> I'm going to move on, and we can talk about it in more depth next meeting or after business, maybe, in collaboration time.
14:13:20 <dluch> #info Quick update on Antora progress
14:13:33 <dluch> remingtron and bmagic: Where are we with Antora nav progress?
14:14:18 <Bmagic> I made some tweaks to it during the server setup. I think* it's all been addressed
14:14:33 <dluch> Awesome!
14:14:37 <dluch> bmagic++
14:14:46 <alynn26> Bmagic++
14:14:53 <alynn26> Remingtron++
14:15:00 <dluch> So, are you still wanting us to go in and look for more things to tweak?
14:15:05 <dluch> remingtron++
14:15:09 <Bmagic> need click-through's and testing though
14:15:25 <alynn26> I did notice the index was not working.
14:16:01 <dluch> Haha, okay, cool. We have that as an action item from last meeting...everyone go through and test things, so keep doing that!
14:16:17 <Bmagic> I had a thought the other day> If we merge this branch into master, it will delete the current docs stuff (which is fine as long as all of the latest stuff has been forwarded to the antora branch as well) - I was trying to think of a way we could query our git repo to see if there are any non-merged branches that touch /docs/* files?
14:16:36 <abneiman> Bmagic: very good thought
14:16:57 <abneiman> (n.b. I have no idea how to do that, though)
14:17:26 <Bmagic> probably some clever bash tricks for it. Haven't looked into it further than just thinking about it.
14:17:53 <dluch> So, bmagic: you good doing some more exploring/thinking about it?
14:18:04 <Bmagic> yes
14:18:12 <dluch> Sweet
14:18:21 <dluch> Want an action item for it?
14:18:23 <alynn26> Bmagic++ exploring++
14:18:27 <Bmagic> sure
14:19:22 <dluch> #action bmagic will think about and explore how to query our git repo to see if there are any non-merged branches that touch /doc/* files
14:19:46 <dluch> bmagic++
14:19:55 <dluch> #info Quick update on DIG Bug Squashing Week Activity
14:20:09 <dluch> I know here it was totally insane during Bug Squashing Week, so I did nothing. I assume the same for you all. Did anyone get docs worked on at all?
14:20:26 <dluch> With the 3.5 release getting pushed back a bit, we have a little more time, so that's good.
14:20:29 <alynn26> I had plans for Bug Squashing week, then the Governer sent us all home.
14:21:23 <alynn26> I've not even looked at them recently. To many other issues getting staff connected remotely.
14:21:34 <dluch> Yep, me, too (well, not the governor, but our city and county sent us home, lol)
14:21:50 <abneiman> I had good intentions for BSW (even told Bmagic I'd look at docs stuff) but then everything happened
14:22:29 <dluch> Yep. I think we're all in the same boat. Let's not stress too much about it atm, but try working on docs as we can squeeze it in.
14:22:31 <Bmagic> what happend?
14:22:37 <Bmagic> (lol)
14:22:52 <dluch> eyeroll
14:22:59 <abneiman> ha!
14:23:04 <alynn26> Bmagic, have you seen the news? :)
14:23:13 <alynn26> lol
14:23:20 <dluch> Okay, moving on, lol
14:23:23 <dluch> #info Discussion: Ways to promote DIG info and Docs-related sessions without in-person Conference
14:23:40 <dluch> We had several DIG- and docs-related sessions for the conference in Atlanta, which is now cancelled, of course.
14:24:01 <dluch> As you hopefully saw earlier, Outreach Committee is working on organizing a virtual conference
14:24:06 <alynn26> I am planning on doing the AsciiDoc Session if there is an Virtual conference.
14:24:13 <alynn26> or when
14:24:19 <dluch> alynn26++
14:24:25 <adurrence> virtual conference ++
14:24:40 <dluch> definitely
14:24:45 <abneiman> let's say "when" :)
14:24:50 * abneiman crosses fingers
14:24:59 <alynn26> Also, I can do the presentation anytime for anyone.
14:25:02 <dluch> and abneiman++ for spearheading it!
14:25:19 <adurrence> abneiman++
14:25:56 <dluch> I forgot to change up the agenda after we had the outreach meeting yesterday, so I guess really discussion should be on whether other folks are willing/able to do their presentation for virtual conference
14:26:36 <adurrence> I think Benjamin and I will be glad to do ours - depending on timeframe and barring conflicts
14:27:29 <dluch> Excellent! adurrence++ benjamin++ (I don't know what his nick is, lol)
14:27:46 <adurrence> (me neither)
14:27:57 <adurrence> lol
14:28:02 <abneiman> all planned presenters should've received an email from me this morning, asking if they are willing to retool their presentation(s) for a virtual conference - so if you are a presenter please let me know if you want to partake (abneiman@equinoxinitiative.org)
14:28:19 <Bmagic> maybe BAMkubasa
14:28:35 <adurrence> yep, we haven't had a chance to chat about it yet
14:28:37 <abneiman> and if interest groups want virtual space to meet, that's cool too, but similarly let me know
14:28:38 <adurrence> sound right
14:28:53 <dluch> Thanks, abneiman! So, we don't need to hash it out here, jusst let abneiman know!
14:29:41 <dluch> I was thinking that since IGs have dedicated meeting times already set up, we probably didn't need one...but there's something to be said for seeing each other...
14:30:10 <dluch> (also, my s key is only working half the time, lol. Weird!)
14:30:24 <abneiman> yeah, the groups that meet regularly probably don't need to do something special, but groups that only meet at the conference might want to get something together.
14:30:34 <dluch> True
14:31:03 <dluch> I'm going to move on to the next discussion thing, then we should still have good time for collaboration
14:31:05 <dluch> #info May DIG meeting
14:31:24 <dluch> The plan we decided on at the last meeting was to hold this April meeting, then have the in-person hackfest and DIG meeting at conference, and no May meeting. Since there's no conference, I think it would be fine to have the May meeting. But I'm also fine if everyone would like to not do so. Thoughts?
14:32:42 <alynn26> I say lets have the May meeting.  Hopefully, we will have time to do some docuementation between now and then.
14:32:54 <abneiman> +1 to May meeting
14:33:30 <dluch> Great, thanks! May meeting it is!
14:33:45 <dluch> #info We will catch up on other action items at business at the next meeting
14:33:57 <dluch> #info Anything else pressing?
14:34:52 <dluch> Hearing nothing, we will move on to
14:34:54 <dluch> #topic Collaboration time
14:35:11 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:36:29 <Bmagic> The landing page on the antora docs still has a <title>untitled</title>
14:36:55 <Bmagic> <title>Untitled :: Evergreen Documentation</title>
14:39:54 <dluch> Like, should it just be Evergreen Documentation with the Untitled removed?
14:41:13 <dluch> Also, everyone, in my haste hopping back and forth between my meeting outline and here, I forgot to just ask at the beginning...How is everyone doing right now?
14:42:50 <abneiman> dluch: this tweet really summed it up... https://twitter.com/MeredithIreland/status/1245359302300360712
14:43:37 <adurrence> :)
14:43:47 <jihpringle> yup :)
14:44:02 <dluch> LOL, that's perfect
14:44:10 <Dyrcona> abneiman++
14:45:13 <alynn26> https://twitter.com/UnHelpDesk/status/1239915255054155776/photo/1
14:45:50 <dluch> alynn26++
14:45:53 <dluch> also perfect
14:46:07 <dluch> (though I was the vpn person earlier this week, lol)
14:46:21 <abneiman> Bmagic: question - (this may have been previously answered but I can't recall) - will past versions of docs be moved over to Antora? If not, there should be a) an easy to find link to past versions and b) an indication of what versions you're looking at in antora
14:46:36 <abneiman> alynn26++
14:47:10 <abneiman> so maybe that should be in the title, if possible: "3.4 :: Evergreen Documentation"
14:47:19 <alynn26> The other issue is people crashing our Reporter, Wanting ridiculous reports.
14:47:36 <dluch> Good point, abneiman!
14:47:52 <alynn26> I'm thinking title should be Evergreen Documentation :: 3.4.
14:48:04 <dluch> alynn26: lol
14:48:27 <dluch> Hmm. Yes, alynn26, that does seem more logical
14:48:50 <abneiman> alynn26: so, since it shows in the browser tab, I was thinking that having the "narrower term" (so to speak) made sense first. But not a hill to die on.
14:49:31 <alynn26> I see your point their also.
14:49:36 <dluch> Ohhh, I didn't think about that
14:49:42 <alynn26> Either way would work for me.
14:51:15 <dluch> yep
14:59:13 <dluch> We are just about at time.  Thanks for all the great work, everyone!  Feel free to keep going after the meeting!
14:59:25 <dluch> The next meeting will be May 7. Same time, same place. Business meeting first then collaboration time (if there's time).
14:59:46 <dluch> Please continue using the email list and/or Launchpad for questions and other things that come up in between meetings.
15:00:04 <dluch> Thanks for coming!
15:00:08 <dluch> #endmeeting