15:02:54 <Dyrcona> #startmeeting 2020-05-05 - Developer Meeting
15:02:54 <pinesol> Meeting started Tue May  5 15:02:54 2020 US/Eastern.  The chair is Dyrcona. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:54 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:54 <pinesol> The meeting name has been set to '2020_05_05___developer_meeting'
15:03:04 <Dyrcona> #topic Introductions
15:03:08 <Bmagic> #info Bmagic, Blake GH MOBIUS
15:03:20 <csharp> #info csharp = Chris Sharp, GPLS
15:03:44 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:03:56 <miker> mmorgan: yes, exactly. just create an alert for each location (or group) and assign to all copies
15:04:07 <miker> they peel it off as folks open back up
15:04:11 <alynn26> #info alynn26 is Lynn Floyd Evergreen Indiana
15:04:12 <miker> s/they/then
15:04:21 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:04:33 <miker> #info miker = Mike Rylander, EOLI
15:04:41 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:04:45 <Dyrcona> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-05
15:05:14 <JBoyer> Ooh, that new business item has been on my mind before.
15:06:03 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:06:37 <devted> #info devted, Ted Peterson, MOBIUS
15:06:46 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:06:47 <Dyrcona> #topic Action Items from Last Meeting
15:07:44 <Dyrcona> #info csharp will arrange testing for sandbergja's fix to https://launchpad.net/bugs/1821094 on a realistic test server
15:07:46 <pinesol> Launchpad bug 1821094 in Evergreen 3.3 "Item status refresh after editing can get confusingly slow" [Medium,Confirmed]
15:07:48 <csharp> we installed the fix for bug 1821094 on a test server and one of our testers provided a comment on the bug
15:08:07 <csharp> that's kind of where we left it as far as I'm aware
15:08:10 <sandbergja> csharp++
15:08:37 <Dyrcona> So the action item is done. Is any more work required that merits a new action item?
15:09:17 <csharp> I'll check on our end to see if they think the feature is ready
15:09:47 <berick> #info berick Bill Erickson, KCLS
15:10:25 <Dyrcona> #info action item done.
15:10:46 <Dyrcona> #action csharp will check if PINES staff think https://launchpad.net/bugs/1821094  is ready
15:10:46 <pinesol> Launchpad bug 1821094 in Evergreen 3.3 "Item status refresh after editing can get confusingly slow" [Medium,Confirmed]
15:11:15 <Dyrcona> Next item
15:11:22 <Dyrcona> #info berick will consider approaches to https://launchpad.net/bugs/1627373
15:11:23 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New]
15:11:42 <berick> i need to carry that one over for next time
15:12:28 <Dyrcona> #info action item tabled until next meeting
15:12:50 <Dyrcona> #info csharp will organize a spreadsheet of needsdiscussion bugs to be walked through during bugsquash week
15:13:14 <csharp> since bugsquash week was overtaken by covid-19 closures, etc., that didn't happen :-/
15:13:26 <csharp> I can do it before the next one
15:13:48 <Dyrcona> #info action tabled because of pandemic
15:14:11 <Dyrcona> #action csharp will organize a spreadsheet of needsdiscussion bugs to be walked through during next bugsquash week
15:14:32 <Dyrcona> Hmm, guess I should add berick's as another action...
15:14:55 <Dyrcona> #action berick will consider approaches to https://launchpad.net/bugs/1627373
15:14:56 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,New]
15:15:19 <Dyrcona> Any other discussion about the above items?
15:16:16 <Dyrcona> If not, moving on....
15:17:18 <Dyrcona> #topic OpenSRF Release Info
15:17:58 <Dyrcona> I'm not sure that we have any releases planned, but there is 1 bug that I want to mention in relation to a potential future release: https://bugs.launchpad.net/opensrf/+bug/1874510
15:17:59 <pinesol> Launchpad bug 1874510 in OpenSRF 3.1 "Chunked message reassembly leads to premature request timeout" [Medium,Confirmed]
15:18:30 <berick> i'll merge that one shortly unless someone beats me to it
15:18:41 <Dyrcona> I signed off on the path, but thought someone else should have a look. If that goes in, I think it is worthy of a bug release.
15:19:37 <Dyrcona> Who normally does the OpenSRF releases, gmcharlt?
15:19:46 <gmcharlt> Dyrcona: aye
15:20:03 <gmcharlt> I'm in another meeting, but at risk of really opening myself up, am wiling to take action items
15:20:11 <berick> heh
15:20:15 <Dyrcona> Are there any special steps required?
15:20:43 <gmcharlt> Dyrcona: not particularly
15:20:56 <Dyrcona> Well, if it's not any hard than doing an Evergreen release and the steps are documented somewhere or as easy as "make release" then I'd be happy to help out.
15:22:06 <gmcharlt> there are steps on the wik page
15:23:01 <Dyrcona> OK. I'll have a look after the meeting. Not sure this is action-worthy.
15:23:31 <Dyrcona> #info tentative OpenSRF releases to coincide with Evergreen 3.5.0 or RC
15:23:44 <Dyrcona> And that would bring us to.....
15:23:58 <Dyrcona> #topic Evergreen Release Info
15:24:35 <berick> i can summarize some stuff..
15:25:11 <berick> 3.5rc was delayed, of course.  it has not been forgotten!  we're just wrapping up a few issues
15:25:25 <berick> hoping to merge bug 1847800 very soon
15:25:26 <pinesol> Launchpad bug 1847800 in Evergreen "Missing links to secondary admin pages" [High,Confirmed] https://launchpad.net/bugs/1847800
15:25:39 <berick> which was identified by several people as critical
15:26:06 <berick> once that's merged, the plan is to do a 3.4 release first, followed directly by 3.5 rc1
15:26:20 <Dyrcona> berick++
15:26:30 <berick> that way 3.5 can use the latest 3.4 sql as its basis
15:26:46 <berick> specifically to address the complexity introduced by the money aging bug
15:26:57 <csharp> stat: we've committed fixes for 24 of the 32 bugs targeted to 3.5.0
15:27:09 <Dyrcona> us++
15:27:14 <Dyrcona> csharp++
15:27:26 <sandbergja> berick++
15:27:27 <berick> csharp++
15:27:29 <sandbergja> csharp++
15:27:49 <berick> yes, the delay has allowed us to get quite a few more bug merged.  thanks for the parallel attention
15:28:19 <Dyrcona> #info Evergreen 3.5.0RC1 planned after https://launchpad.net/bugs/1847800 fix is committed
15:28:20 <pinesol> Launchpad bug 1847800 in Evergreen "Missing links to secondary admin pages" [High,Confirmed]
15:28:28 <berick> nothing else from me unless there are questions re: 3.5
15:28:34 <Bmagic> I'd like to discuss the docs stuff
15:28:56 <Dyrcona> OK, Bmagic. Go ahead.
15:29:45 <Bmagic> not sure if it needs to run parrallel to an EG release, but the Antora stuff is looking pretty good: eg-docs.georgialibraries.org/prod/
15:30:32 <Bmagic> It's not clear what is required for it to merge - for example: the server-side code that makes the pages that might be server specific should be in the EG repo?
15:31:48 <Dyrcona> What benefit do we get from having the server-side code in Eg proper versus separate?
15:32:18 <Bmagic> The old docs need preserved somehow as well. It was mentioned that they could be "slurped" and linked. Not sure if there should be code for that either?
15:33:02 <Bmagic> Dyrcona: One benefit is, we won't lose it. The code that runs our current docs is sometimes gone or inaccesible...
15:33:13 <Dyrcona> I'm personally a bit unclear on the relationship of antora documentation and the current documentation, etc.
15:34:17 <Dyrcona> So, is antora meant to replace the current docs server? But, right now, it can't?
15:34:19 <Bmagic> the current docs have been modified slightly to be Antora-friendly
15:34:26 <Bmagic> replace - yes
15:35:54 <Bmagic> At the same time - we've a new docs server. It seems to me that the Antora branch could easily be merged with no affect on anything else?
15:36:52 <berick> Bmagic: that would be collab/blake/LP1848524_antora_ize_docs ?
15:37:25 <Bmagic> yes
15:38:23 * Dyrcona senses an action item item coming up....
15:38:28 <berick> ok so it all sits in docs-antora and some changes to docs
15:38:37 <Bmagic> it would need a quick change to make it ready. Change the config to point to "master" - and then for the 3.5 branch, the config changed to "tags/rel_3_5"
15:38:53 <Bmagic> the final nail will be to blow away docs/* and rename docs-antora -> docs
15:39:47 <Dyrcona> Bmagic: Do you think it is ready for the final nail, or would more work be required?
15:40:23 <Bmagic> I think it's ready - with the exception of telling everyone who might have outstanding docs/* changes in working branches - to merge or forever hold your peace
15:40:45 <berick> Bmagic: this would be a master-only commit?
15:41:02 <berick> or do you expect to merge to 3.5 as well?
15:41:37 <Bmagic> Antora is setup internally to deal with git branches for doc versioning - therefore, it can have a master "version" and a 3_5 "version" each with a small change in antora.yml
15:42:16 <Dyrcona> So, if I understand correctly, you're asking to have this in for 3.5, right?
15:42:39 <berick> well for 3.5 i'm a little concerned at such a big doc change at this point might be too disruptive
15:43:23 <Bmagic> I think it would need to hit master before the cut, and it would branch with 3_5 - I'm happy with the group thoughts on the matter. Perhaps it can merge to master between releases..
15:43:32 <miker> yeah, I think this big of a change should be at the beginning of the dev cycle rather than the end
15:43:48 <csharp> I would be more comfortable with a target of 3.6 - yeah - what others are saying :-)
15:43:58 <Bmagic> sounds good
15:44:34 <Dyrcona> #info antora docs branch revisited after 3.5 release for 3.6
15:44:35 <Bmagic> changes to docs/* needs to be "backported" to collab/blake/LP1848524_antora_ize_docs in the meantime
15:44:59 <Dyrcona> Bmagic: you should be able to rebase on master, no?
15:45:32 <Bmagic> I don't think the files are hooked up 1:1
15:46:22 <dbwells> #info dbwells = Dan Wells, Hekman Library, Calvin University (and late)
15:46:56 <Dyrcona> Bmagic: If you want help with that, I'm sure we'll be able to  make it happen.
15:47:27 <Bmagic> cool, thanks for taking the time today to talk about that
15:47:46 <Dyrcona> So, anything else for Evergreen releases?
15:48:21 <csharp> Bmagic: looking forward to testing it out
15:48:58 <Bmagic> csharp: feel free to click through what's there http://eg-docs.georgialibraries.org/prod/
15:49:13 <csharp> oh cool
15:50:02 <Dyrcona> #topic New Business
15:51:43 <Dyrcona> I added the one agenda item under new business partly because of bug 1873286.
15:51:45 <pinesol> Launchpad bug 1873286 in Evergreen 3.4 "jQuery 3.5.0 breaks at least AngularJS interfaces" [Critical,Fix committed] https://launchpad.net/bugs/1873286
15:53:47 <Dyrcona> I think jQuery and jQueryUI could also be used to resolve some date-related bugs in the OPAC such as: bug 1723651 and bug 1814150.
15:53:49 <pinesol> Launchpad bug 1723651 in Evergreen "Use HTML5 Date Element in the OPAC" [Wishlist,New] https://launchpad.net/bugs/1723651
15:53:50 <pinesol> Launchpad bug 1814150 in Evergreen "Self-registration: system accepts wrong DOB format" [Medium,Confirmed] https://launchpad.net/bugs/1814150
15:54:42 <Dyrcona> I also think it could be used to replace the Dojo that is occasionally used int he OPAC, such as for the Overdrive integration.
15:55:08 <JBoyer> Outright requiring it would also make it easier to stamp out those odd situations where JS fails if it's included, like bug 1739666
15:55:09 <pinesol> Launchpad bug 1739666 in Evergreen "Publication Date "Between" option doesn't work if jQuery is enabled in the OAPC." [Medium,Confirmed] https://launchpad.net/bugs/1739666
15:55:31 <Dyrcona> JBoyer, yes, I was about to mention the presence of those bugs.
15:56:03 <csharp> sounds like a solid case for it (not knowing what's involved, really)
15:56:19 <jeffdavis> I've added the "jquery" tag to the 3 bugs I know of where enabling jQuery breaks something in the OPAC
15:56:24 <Dyrcona> So, I guess what I'm really asking is what everyone thinks about going with jQuery in the OPAC, and possibly requiring it?
15:56:43 <csharp> you had me at "replace the Dojo" :-)
15:56:50 <Bmagic> lol
15:56:52 <Dyrcona> jeffdavis++ Yes, that jogged my memory on them.
15:56:53 <Dyrcona> :)
15:57:43 <Dyrcona> Not hearing any outright opposition, I suppose the next step would be to make a Lp bug and start a branch.
15:57:49 <csharp> +1
15:58:05 <jeffdavis> I'm less familiar with jQueryUI
15:58:24 <csharp> https://www.youtube.com/watch?v=PVhTDNlbsSc
15:58:29 <Dyrcona> #action Dyrcona will open a Lp bug about adding jQuery and jQueryUI to the OPAC
15:58:32 <jeffdavis> I wonder if it is less supported/more likely to become unsupported
15:58:48 <jeffdavis> ...than jQuery proper
15:58:57 <Dyrcona> I've not read anything about jQueryUI deprecation.
15:59:33 <jeffdavis> looks like the last stable release was 4 years ago
15:59:38 <Dyrcona> I've experimented with some of the widgets, and the datepicker would be particularly useful since we can't rely on HTML5 because of Safari on Mac OS X.
16:00:36 <jeffdavis> And the last commit was in Dec. But we can discuss that via LP, not important for today's meeting.
16:00:39 <csharp> seems to be actively developed: https://github.com/jquery/jquery-ui
16:00:44 <csharp> yeah
16:01:04 <Dyrcona> Ok, anyone have anything else for new business?
16:02:37 <Dyrcona> Does anyone have anything to bring up about needsdiscussion or qaproject bugs?
16:06:03 <Dyrcona> Not hearing anything, I declare the meeting adjourned!
16:06:08 <Dyrcona> #endmeeting