#evergreen: 2020-08-04 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-08-04

Meeting started by JBoyer at 15:01:10 US/Eastern (full logs).

Meeting summary

  1. Introductions (JBoyer, 15:01:31)
    1. berick Bill Erickson, KCLS (berick, 15:01:45)
    2. JBoyer = Jason Boyer, EOLI (JBoyer, 15:01:46)
    3. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:01:48)
    4. gmcharlt = Galen Charlton, EOLI, part of the 3.6 release team (gmcharlt, 15:01:51)
    5. Bmagic = Blake GH, MOBIUS (Bmagic, 15:01:57)
    6. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:02:04)
    7. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:02:15)
    8. cburton = Chris Burton, Niagara Falls Public Library (nfBurton, 15:02:28)
    9. terran = Terran McCanna, PINES (terran, 15:02:53)

  2. Action Items from Last Meeting (JBoyer, 15:03:13)
    1. mike = Mike Rylander, EOLI (miker, 15:04:59)
    2. alynn26 = Lynn Floyd Evergreen Indiana (alynn26, 15:06:45)
    3. csharp = Chris Sharp, GPLS (csharp, 15:07:54)
    4. _sandbergja is Jane Sandberg, Linn-Benton Community College (_sandbergja, 15:09:35)
    5. ACTION: berick and csharp to consider approaches to lp 1627373 (JBoyer, 15:09:58)
    6. ACTION: JBoyer to file LP bug about replacing Dojo with jQuery (JBoyer, 15:25:10)

  3. OpenSRF Release Info (JBoyer, 15:26:22)
    1. ACTION: gmcharlt will cut OpenSRF 3.2.1 (gmcharlt, 15:28:21)
    2. ACTION: gmcharlt to build an OpenSRF 3.2.1 release during the same timeframe as the Evergreen maintenance releases (JBoyer, 15:28:42)

  4. Evergreen Release Info (JBoyer, 15:30:15)
    1. the next Evergreen Maintenance Release date is August 12th (JBoyer, 15:38:34)
    2. Feedback Fest is August 17 - August 21 (JBoyer, 15:40:42)
    3. Bug Squashing Week is September 21 - September 25 (JBoyer, 15:41:02)

  5. Hatch Release info (JBoyer, 15:42:01)
    1. ACTION: berick to open LP bug re: the removal of Hatch Local Storage in web staff client (JBoyer, 15:45:49)

  6. New Business (JBoyer, 15:46:11)
  7. Feedback for new features (JBoyer, 15:55:07)
    1. ACTION: _sandbergja to do some testing on the Angular staff catalog branch with the aim of merging pre-feedback fest (JBoyer, 16:02:32)

  8. Angular 9 /10 update (JBoyer, 16:03:40)
    1. ACTION: gmcharlt , _sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week. (JBoyer, 16:09:02)

  9. Curbside pickup discussion (JBoyer, 16:10:07)
  10. Angular Acquisitions Search (LP 1850547 ) (JBoyer, 16:15:16)
  11. Patron API (LP 1887196) (JBoyer, 16:19:34)


Meeting ended at 16:30:55 US/Eastern (full logs).

Action items

  1. berick and csharp to consider approaches to lp 1627373
  2. JBoyer to file LP bug about replacing Dojo with jQuery
  3. gmcharlt will cut OpenSRF 3.2.1
  4. gmcharlt to build an OpenSRF 3.2.1 release during the same timeframe as the Evergreen maintenance releases
  5. berick to open LP bug re: the removal of Hatch Local Storage in web staff client
  6. _sandbergja to do some testing on the Angular staff catalog branch with the aim of merging pre-feedback fest
  7. gmcharlt , _sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week.


Action items, by person

  1. _sandbergja
    1. _sandbergja to do some testing on the Angular staff catalog branch with the aim of merging pre-feedback fest
    2. gmcharlt , _sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week.
  2. berick
    1. berick and csharp to consider approaches to lp 1627373
    2. berick to open LP bug re: the removal of Hatch Local Storage in web staff client
    3. gmcharlt , _sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week.
  3. csharp
    1. berick and csharp to consider approaches to lp 1627373
  4. gmcharlt
    1. gmcharlt will cut OpenSRF 3.2.1
    2. gmcharlt to build an OpenSRF 3.2.1 release during the same timeframe as the Evergreen maintenance releases
    3. gmcharlt , _sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week.
  5. JBoyer
    1. JBoyer to file LP bug about replacing Dojo with jQuery


People present (lines said)

  1. JBoyer (98)
  2. gmcharlt (45)
  3. berick (31)
  4. csharp (25)
  5. _sandbergja (20)
  6. pinesol (14)
  7. Dyrcona (11)
  8. jeffdavis (9)
  9. terran (9)
  10. nfBurton34 (9)
  11. Bmagic (7)
  12. miker (5)
  13. mmorgan (5)
  14. nfBurton (2)
  15. alynn26 (2)
  16. rhamby (1)


Generated by MeetBot 0.1.4.