15:02:14 <JBoyer> #startmeeting 2020-09-01 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-09-01
15:02:14 <pinesol> Meeting started Tue Sep  1 15:02:14 2020 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:14 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:14 <pinesol> The meeting name has been set to '2020_09_01___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2020_09_01'
15:02:24 <JBoyer> #topic Introductions
15:02:27 <JBoyer> New meeting, who dis?
15:02:52 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:02:55 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:56 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:02:57 <gmcharlt> #info gmcharlt = Galen Charlton, EOLI
15:03:18 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:23 <abneiman> abneiman = Andrea Neiman, Equinox
15:03:31 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:03:37 <abneiman> #info abneiman = Andrea Neiman, Equinox
15:03:59 <berick> #info berick Bill Erickson, KCLS
15:04:13 <JBoyer> Others can chime in as they arrive, I don't want to keep anyone too long today.
15:04:17 <JBoyer> #topic Action Items from Last Meeting
15:04:43 <JBoyer> First from last meeting was "berick and csharp to consider approaches to lp 1627373"
15:04:44 <pinesol> Launchpad bug 1627373 in Evergreen "Acq: We need to fully implement EDI availability codes" [Wishlist,Confirmed] https://launchpad.net/bugs/1627373
15:04:56 <JBoyer> berick, csharp, any word or ought it be pushed to next meeting?
15:04:59 <alynn26> #info alynn26 = Lynn Floyd, Evergreen Indiana
15:05:22 <berick> JBoyer: pushed to next please.  i'm still planning to participate, though
15:05:29 <JBoyer> berick++
15:05:37 <JBoyer> #action berick and csharp to consider approaches to lp 1627373
15:05:44 <sandbergja> berick++
15:05:46 <JBoyer> next was "JBoyer to file LP bug about replacing Dojo with jQuery (lp 1890342)"
15:05:47 <pinesol> Launchpad bug 1890342 in Evergreen "The OPAC should replace Dojo with jQuery" [Medium,New] https://launchpad.net/bugs/1890342
15:05:47 <sandbergja> csharp++
15:06:03 <JBoyer> I did managed to step over this very low hurdle. No progress as of yet.
15:06:20 <JBoyer> next item, "gmcharlt will cut OpenSRF 3.2.1"
15:06:43 <JBoyer> gmcharlt, at this point, would aligning it with the September 16th releases be better?
15:06:56 <gmcharlt> JBoyer: yeah. please toss in an #action for me
15:07:12 <JBoyer> #action gmcharlt will cut OpenSRF 3.2.1 around Evergreen point release time
15:07:29 <JBoyer> Next was "berick to open LP bug re: the removal of Hatch Local Storage in web staff client"
15:07:29 <terranm> #info terranm = Terran McCanna, PINES
15:07:45 <berick> pullrequest posted
15:07:50 <JBoyer> And indeed, there is a new branch at the existing bug lp 1774008
15:07:51 <pinesol> Launchpad bug 1774008 in Evergreen "Remove data storage options from Hatch" [Wishlist,Confirmed] https://launchpad.net/bugs/1774008
15:07:51 <berick> to an already-opened ticket
15:08:33 <JBoyer> I'll try to take a look, I imagine it won't cause much of a problem since it's just removing a couple targeted chunk.
15:08:59 <JBoyer> The last 2 action items from last meeting: "sandbergja to do some testing on the Angular staff catalog branch with the aim of merging pre-feedback fest", and "gmcharlt , sandbergja , and berick will work to test and merge lp 1864371 to use Angular 10 in the staff client before Feedback Fest week"
15:09:00 <pinesol> Launchpad bug 1864371 in Evergreen "Upgrade to Angular 10" [Wishlist,Fix committed] https://launchpad.net/bugs/1864371
15:09:15 <JBoyer> Success, both were merged. A great feedback fest was had by all.
15:09:26 <berick> woohoo
15:09:44 <JBoyer> Anyone have any discussion re: previous action items before we move on?
15:10:10 <JBoyer> ok, on we go
15:10:12 <JBoyer> #topic OpenSRF Release Info
15:10:24 <JBoyer> #info gmcharlt to cut 3.2.1 release soon
15:10:55 <JBoyer> If there's nothing else to discuss re: OpenSRF we'll move on
15:11:28 <JBoyer> #topic Evergreen Release Info
15:11:37 <JBoyer> First a quick calendar dump:
15:11:43 <JBoyer> #info Feature Slush: Tuesday, September 8
15:11:48 <JBoyer> #info Feature Freeze: Monday, September 14
15:11:56 <JBoyer> #info September Monthly Point Releases: Wednesday, September 16
15:11:59 <JBoyer> #info Bug Squashing Week: September 21 - September 25
15:12:20 <JBoyer> September 8 and 14 are especially important, as they're creeping ever closer.
15:12:46 <JBoyer> Any discussion or news re: Evergreen releases?
15:12:55 * csharp appears
15:13:30 <terranm> There are a lot of new angular interfaces with pullrequests that haven't been tested yet if anyone has a vested interest in getting the into 3.6
15:13:39 <terranm> *them
15:13:46 <gmcharlt> also, just a general call for review of pull requests, particularly those on the wishlists
15:14:15 <terranm> Despite all the testing during FF, there are probably 140 or so open pullrequests
15:14:36 <gmcharlt> s/wishlists/roadmap/
15:14:42 <JBoyer> I would also add that anything on terranm's feedback fest sheet that is still up likely still has any Ready for Testing patches in place if you want an easy test to signoff on.
15:15:16 <terranm> sandbox sheet: https://docs.google.com/spreadsheets/d/11MjEa8V8d7NYxVM3s1Ra1IOdbhZPFExoWiWDOAKEXoE/edit#gid=0
15:15:22 <JBoyer> terranm++
15:15:37 <JBoyer> Any other Evergreen news? if not ...
15:15:53 <JBoyer> #topic Hatch Release Info
15:16:23 <JBoyer> #info JBoyer will try to put berick's branch on lp 1774008 through it's paces
15:16:24 <pinesol> Launchpad bug 1774008 in Evergreen "Remove data storage options from Hatch" [Wishlist,Confirmed] https://launchpad.net/bugs/1774008
15:16:44 <JBoyer> I don't know if there's a lot more to say re: Hatch, but will wait a few seconds just in case.
15:17:14 <berick> nothing from me
15:17:21 <JBoyer> #topic New Business
15:17:34 <JBoyer> #info a request from sandbergja for review of course reserves / course materials in lp 1849212 .
15:17:35 <pinesol> Launchpad bug 1849212 in Evergreen "Course Materials Module" [Wishlist,New] https://launchpad.net/bugs/1849212 - Assigned to Jane Sandberg (sandbej)
15:17:36 <JBoyer> Did I mention feature-winter is coming?
15:17:51 <JBoyer> sandbergja, would you like add anything?
15:18:08 <sandbergja> Sure, I actually got some great feedback on that
15:18:16 <sandbergja> and will be addressing it hopefully today
15:18:35 <sandbergja> so there should be a fresh branch available for review today or tomorrow
15:18:47 <JBoyer> That sounds great.
15:18:57 <JBoyer> sandbergja++
15:19:08 <JBoyer> Any other new business that didn't make it to the agenda?
15:19:11 * Dyrcona has a question about new features.
15:19:27 <Dyrcona> Is there a goal to get curbside into 3.6?
15:19:57 <JBoyer> Ideally, everything on the roadmap, yes, but that one does seem especially timely.
15:20:15 <gmcharlt> Dyrcona: I would like to see it get in, particular as its in production use
15:20:50 * gmcharlt grants that it's possible that by 3.8 it could become moot
15:21:05 * abneiman knocks wood on gmcharlt's behalf
15:21:08 <Dyrcona> OK. Thanks! We're planning to look at it soon, on 3.2
15:21:46 <JBoyer> I could see benefit for the feature in general even after its current need has passed. But the sooner that need passes the better.
15:21:53 <terranm> +1
15:22:19 <Dyrcona> +1
15:22:19 <JBoyer> Any other new business or disucussion?
15:22:24 <jeff> While the implementation of curbside doesn't meet our needs, I wouldn't discount it as being moot at some near point in the future. Several libraries I've spoken with are thinking that curbside may become a permanent continues service offering.
15:23:29 <terranm> Yeah, we're not planning on implementing it anytime soon because our libraries already have their processes in place, but I can see implementing it as an option later.
15:23:56 <mmorgan> One really nice feature of the curbside is the streamlined checkout of held items.
15:25:19 <JBoyer> Sounds reasonable to me, and jeff, if there are minor changes that would help make it meet your needs I'd be happy to see new lps for them.
15:25:42 <JBoyer> If there's no further discussion...
15:26:12 <JBoyer> The next meeting is scheduled for Tuesday, October 6th, I assume there's no reason that need be changed/
15:26:13 <JBoyer> ?
15:26:35 <gmcharlt> I know of no reason to change the date
15:26:41 <JBoyer> #info Next Meeting is Tuesday October 6th at 3pm Eastern
15:27:11 <JBoyer> And with that, I follow up one of the longer meetings with one a much more reasonable length.
15:27:16 <JBoyer> #endmeeting