14:00:08 <dluch> #startmeeting 2020-09-03 - Documentation Interest Group Meeting
14:00:08 <pinesol> Meeting started Thu Sep  3 14:00:08 2020 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:08 <pinesol> The meeting name has been set to '2020_09_03___documentation_interest_group_meeting'
14:00:22 <dluch> #topic Agenda
14:00:42 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20200903-agenda
14:00:46 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:00:58 <dluch> #topic Introductions
14:01:08 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:08 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:11 <gmcharlt> dluch: sorry to barge in, but I do have one update that's relevant but can't otherwise join the meeting - I will be merging the Antora branches definitely, tomorrow
14:01:31 <dluch> Awesome, thank you, gmcharlt!
14:01:50 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:54 <kgmartin> #info kgmartin is Katie Greenleaf Martin, Blair Co Lib Sys in Central PA
14:01:55 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
14:01:59 <rfrasur> gmcharlt++
14:02:11 <abneiman> gmcharlt++ # Antora FTW
14:02:24 <rfrasur> #info rfrasur = Ruth Frasur, Evergreen Indiana et al
14:02:35 <Bmagic> #info Bmagic = Blake GH, MOBIUS
14:04:03 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:04:07 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:04:18 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:04:18 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:04:30 <dluch> #topic Old and Ongoing Business
14:04:47 <dluch> #info Check-in - How is everyone doing?
14:04:47 <dluch> How are things where you are?
14:05:25 <rfrasur> Cray cray, but okay
14:05:27 <dluch> We're still working from home, and our COVID numbers have gone through the roof since the college kids came back to town.
14:05:57 <abneiman> dluch: I'm also in a college town and I am so grateful they opted for all-remote for the fall
14:06:29 <abneiman> as for me, the humidity is revolting here but otherwise we're mostly OK
14:06:49 <dluch> abneiman: that IS good. I haven't paid attention to the news this week, but last week the MU pres. said they weren't going to close because young people get over it quickly. *eyeroll
14:07:30 <rfrasur> Apparently the MU pres never missed two weeks of school and then tried to catch up while also living the "college experience."
14:07:47 <abneiman> "college students will totally responsibly socially distance" - people who have made careers out of working with college students, apparently
14:07:49 <dluch> I hear ya on the humidity. We were originally supposed to get some relief from it this weekend, but now it's been pushed to middle of next week. fingers crossed
14:07:59 <dluch> Lol. Exaclty
14:09:05 <dluch> jihpringle: how are things up where you are? Do you all get affected by all the Pacific coast area fires?
14:10:01 <jihpringle> we've been pretty lucky as far as fires this year, though we did have a thunderstorm with lightning that set off 5 fires on the mountains around me
14:10:19 <dluch> Yikes!
14:10:19 <jihpringle> a couple smokey days but nothing compared to the last few summers
14:10:45 <dluch> That's good. You have had some rough summers, for sure
14:11:01 <jihpringle> most of the fires were very far from any people or buildings so there was a lot of monitoring and waiting for rain to put them out
14:11:31 <dluch> I'm going to move on. But am not at all opposed to continued personal conversations. :-)
14:11:34 <dluch> #info Previous Action Items
14:11:49 <dluch> How are we doing on these? Has anyone had time for anything?
14:11:49 <dluch> I'll take them in order...
14:12:14 <dluch> #1 sandbergja will make a video for proof of concept in the Quick Starts section
14:12:26 <dluch> I don't think sandbergja is here
14:12:29 <dluch> ?
14:12:34 <sandbergja> oh I just got here!
14:12:55 <dluch> Oh, yay! Greetings!
14:13:02 <sandbergja> Can you defer that until next time?
14:13:07 <dluch> Absolutely!
14:13:11 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:13:28 <dluch> #2 Bmagic is writing a script to identify places in Antora docs that need headers raised up a level. DIG will help with making the changes then.
14:13:28 <dluch> Bmagic?
14:14:07 <Bmagic> I'll be honest, though a full 30 days has gone by, I've not done anything for DIG. This line item, however, was done a couple of months ago
14:14:40 <dluch> Okay, cool. So are we at the place for DIG to make changes, or do we need to wait on some more to be done?
14:14:54 <dluch> And thanks! bmagic++
14:15:12 <Bmagic> The dev meeting did mention gmcharlt merging the antora branch. I've not seen that come through
14:15:21 <gmcharlt> Bmagic: scroll up
14:15:26 <Bmagic> :)
14:15:27 <dluch> He said earlier he's doing it tomorrow
14:15:29 <dluch> lol
14:15:35 <Bmagic> ty
14:15:52 <abneiman> and related to said, once Antora is merged, I have several docs commits lined up :)
14:16:02 <dluch> Okay, I'm going to remove that action item, then.
14:16:09 <dluch> abneiman: awesome!!
14:16:15 <dluch> abneiman++
14:16:32 <dluch> #3 dluch will update the style guide to reflect new header stuff
14:16:42 <dluch> I completely forgot about this again. Will keep it.
14:16:55 <dluch> #action dluch will update the style guide to reflect new header stuff
14:17:11 <dluch> #4 We will revisit the topic "#info Should the server-side generation script(s) be in the EG repo?" when scripts are done
14:17:11 <dluch> Are scripts done?
14:17:38 <Bmagic> yep
14:17:46 <Bmagic> that was also completed prior to last meeting
14:18:01 <dluch> Well, last meeting was working, so we didn't cover any of these things
14:18:59 <dluch> Okay, so " Should the server-side generation script(s) be in the EG repo?" Or is that done, too?
14:20:53 <dluch> Bueller?
14:21:36 <Bmagic> yep
14:21:41 <Bmagic> that is done, committed to the branch
14:21:55 <dluch> Awesome. Bmagic++
14:22:04 <dluch> I'll remove that action
14:22:07 <dluch> #5 dluch will start working on an Antora roadmap, with help from Bmagic and remingtron, that we can share with devs and others
14:22:27 <dluch> It seems like this is a moot point now? (And since we never got around to it at all--sorry!)
14:22:52 <abneiman> agreed that it seems moot since gmcharlt is preparing to merge it
14:23:32 <dluch> Great. Will remove the action
14:23:44 <dluch> #6 dluch will send a message to the docs list to ask for video documentation contributions to the community YouTube channel
14:23:53 <dluch> Lol, in my notes I have [SERIOUSLY, DO THIS BEFORE THE NEXT MEETING.]
14:23:59 <dluch> But I didn't
14:24:24 <dluch> #action dluch will send a message to the docs list to ask for video documentation contributions to the community YouTube channel
14:24:46 <dluch> #info Antora progress
14:25:06 <dluch> As noted above, gmcharlt is merging Antora docs tomorrow! Yay!!!
14:25:12 <dluch> gmcharlt++
14:25:39 <Bmagic> gmcharlt++
14:25:46 <dluch> Anything else in Antora-land that we should talk about today? Or just wait until next time when it's all done?
14:26:40 <abneiman> are there any other changes to the style guide or instructions pages that are needed?
14:26:44 <abneiman> w/r/t Antroa
14:26:49 <abneiman> or even Antora
14:27:21 <dluch> Hmm. I don't know. When I update the style guide with the header stuff, I will check
14:28:02 <abneiman> dluch++
14:28:03 <dluch> (It will probably be next week, but I'm putting on my planner this time)
14:28:35 <dluch> #info Launchpad documentation cleanup
14:28:43 <dluch> During our collaboration time during the last meeting, we made a start at doing this. Has anyone had time in-between?
14:28:52 <dluch> abneiman: What is the procedure for these? If we find something, should people notify you? Is there a way to contact the bug wranglers in general? Or is removing tags and stuff something anyone can do?
14:29:30 <abneiman> I think anyone can add/remove tags
14:29:57 <dluch> Excellent
14:30:14 <dluch> abneiman++
14:30:47 <dluch> I know I looked at it a bit after last meeting, and that's the last time I thought about it
14:30:59 <abneiman> and absent a way to ping the Bug Wranglers in general, people can reach out to me if they have questions - either here in IRC or via email
14:31:17 <dluch> abneiman++
14:31:54 <dluch> #info 3.5/Experimental Catalog documentation
14:32:05 <dluch> I know jihpringle and maybe some others were working on these and/or contributing them. Any news?
14:32:56 <jihpringle> I'm plugging away at them in our docs and happy for anyone to take what I've done so far and strip out anything Sitka specific for teh community docs
14:32:58 <jihpringle> http://docs.libraries.coop/sitka/_experimental_catalogue.html
14:33:15 <dluch> Thank you!
14:33:18 <dluch> jihpringle++
14:33:46 <dluch> Any other old or ongoing business to discuss?
14:34:06 <jihpringle> it should be possible to pull the asciidoc files from our repository or I can always email the files to someone if that's easier
14:34:40 <dluch> Awesome, thank you for all your work!
14:34:58 <dluch> Okay, moving on...
14:35:07 <dluch> #topic New Business
14:35:10 <dluch> #info From CWG organizing committee: annual "DIG for Catalogers" training
14:35:22 <dluch> The CWG organizing committee is doing future planning and suggests having an annual "DIG for Catalogers" training like we did this year.
14:35:22 <dluch> Thoughts? Volunteers?
14:35:54 <dluch> jweston couldn't be here today, but says they have no particular date in mind and she's happy to help plan again
14:36:31 <dluch> It went really well this year, and it seems like a good idea
14:37:15 <jihpringle> I think it's a great idea and could possibly help (depending on when it is)
14:37:36 <dluch> Awesome, thanks jihpringle!
14:38:09 <dluch> I also plan to help again
14:39:17 <dluch> Okay, well, I'll let jweston know, and the three of us can figure out a good date/time. It doesn't have to be during the normal CWG meeting, so lots of flexibility
14:39:28 <dluch> jihpringle++
14:39:31 <dluch> jweston++
14:39:34 <jihpringle> sounds good :)
14:39:50 <dluch> Is there any other new business we need to discuss?
14:41:01 <dluch> Okay, we have about 20 minutes left...
14:41:06 <jihpringle> are we planning to have a docs hackaway or something around the release of 3.6?
14:41:29 <jihpringle> It looks like quite a bit of new stuff is going to make it into 3.6
14:41:42 <dluch> I was assuming we would, as part of the onlie hackaway in October
14:42:04 <rfrasur> The EG Hackway (Oct. 26-28)could definitely accommodate a DIG component.
14:42:28 <dluch> rfrasur++
14:42:42 <dluch> Does that work for folks?
14:43:13 <abneiman> jihpringle: confirming that this is your repo? http://git.sitka.bclibraries.ca/gitweb/ if so, I can look at some of the angular catalog docs (during hackaway, probably not before)
14:43:21 <dluch> (It's my first Hackaway, and I'm excited!)
14:43:55 <jihpringle> abneiman: that's our old one
14:43:57 <jihpringle> https://github.com/BCLibCoop/sitka-manual
14:44:06 <rfrasur> As we get further along in the planning for that online event, we may need some more information about what DIG would like to do so we can configure rooms to meet those needs, but it shouldn't be any big deal at all.
14:44:10 <abneiman> jihpringle++ I thought some of those "last change" dates looked a little stale :)
14:44:22 <rhamby> a quick note that docs have traditionally been a part of the hack-a-way and unless there aren't folks doing it will continue to be
14:44:32 <dluch> rfrasur: Sounds good, thanks
14:44:36 <dluch> rhamby++
14:45:12 <dluch> #action DIG will participate in the fall Hackaway and particularly focus on 3.6 docs
14:45:27 <abneiman> dluch et al., noting that re 3.6 features, Equinox stuff will all have accompanying docs merged once I finalize them
14:45:45 <dluch> abneiman++
14:45:56 <jihpringle> abneiman++
14:46:09 <dluch> Any other new business?
14:46:51 <dluch> Okay, we have about 15 minutes left...
14:47:07 <dluch> #topic Collaboration time
14:47:16 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary
14:47:35 <dluch> Also, for the last meeting, I made a list of ideas you can work on (alone or with others) if you don't already have something. I know it can be kind of overwhelming sometimes to know where to start.
14:47:35 <dluch> -your own priority projects
14:47:35 <dluch> -finishing 3.5 docs
14:47:35 <dluch> -experimental catalog docs
14:47:36 <dluch> -cleaning up old docs tickets on Launchpad
14:47:36 <dluch> -finding docs tickets on Launchpad to work on
14:47:38 <dluch> -easy tasks from Documentation Needs List
14:47:40 <dluch> -auditing and removing finished or irrelevant items from the Documentation Needs List and/or adding 3.5 documentation needs
14:47:42 <dluch> -still-relevant items from the Documentation Needs List (be sure to assign yourself to it so we don't duplicate work)
14:47:45 <dluch> -documentation-related short videos for the community YouTube channel
14:47:47 <dluch> -looking through existing docs for things that need updating - text and/or images
14:48:54 <abneiman> belatedly - I did have an item of new biz (apologies) - and it is that Outreach is going to be reviewing wiki pages for outdated info. I know that the DIG stuff is pretty well maintained, so this shouldn't affect its pages, but just as an FYI
14:49:28 <dluch> abneiman++ Thanks
14:49:50 <dluch> Still can't hurt to look through and see what we might no need anymore
14:49:56 <dluch> *not
14:50:09 <abneiman> akilsdonk has signed up to review most of the docs pages
14:50:23 <dluch> Great!
14:50:28 <dluch> akilsdonk++
14:50:50 <dluch> And I'm happy to help if she has any questions or anything
14:51:13 <abneiman> dluch++
14:52:11 <abneiman> sandbergja: I was going to drop a note on LP 1642023 saying that you & I had reviewed it during BSW and that I'm willing to signoff/commit if Lynn is finished with that (I don't see her in channel atm)
14:52:12 <pinesol> Launchpad bug 1642023 in Evergreen "Docs: Web Client Print / Receipt Templates" [Medium,Triaged] https://launchpad.net/bugs/1642023 - Assigned to Lynn Floyd (lfloyd)
14:59:38 <dluch> We are at time.
14:59:38 <dluch> Next meeting will be October 1. Same bat time, same bat channel.  It will be primarily collaboration time.
14:59:52 <dluch> Thanks for coming, everyone!
15:00:03 <rfrasur> dluch++ # lots of progress.  Thanks.
15:00:07 <jihpringle> dluch++
15:00:12 <dluch> #endmeeting