14:01:44 <dluch> #startmeeting 2020-11-05 - Documentation Interest Group Meeting
14:01:44 <pinesol> Meeting started Thu Nov  5 14:01:44 2020 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:44 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:44 <pinesol> The meeting name has been set to '2020_11_05___documentation_interest_group_meeting'
14:01:54 <dluch> #topic Agenda
14:02:12 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20201105-agenda
14:02:15 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:02:26 <dluch> #topic Introductions
14:02:27 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:02:27 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:02:29 <kgmartin> #info kgmartin is Katie Greenleaf Martin, Blair Co/SPARK PA
14:02:36 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
14:02:53 <jweston> #info jweston is Jennifer Weston, Equinox
14:04:57 <alynn26> #info alynn26 = Lynn Floyd,Evergreen Indiana
14:05:13 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:05:18 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:05:18 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:05:18 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:05:27 <rfrasur> #info rfrasur = Ruth Frasur, Evergreen Indiana
14:05:40 <adurrence> #info adurrence=April Durrence, NC Cardinal
14:05:51 <dluch> #topic Old and Ongoing Business
14:05:56 <dluch> #info Check-in - How is everyone doing?
14:05:56 <dluch> How are things where you are?
14:06:02 <alynn26> I am still working on the Survey documentation.
14:06:18 <alynn26> Things are going good. Busy
14:06:33 <dluch> alynn26++
14:06:48 <kgmartin> I am doing well & have a bit of time this afternoon if anyone has a bitesize project idea :)
14:06:56 <abneiman> I took a covid test today since I was a poll worker for three days... my nose still hurts, lol (sorry for the TMI)
14:07:08 <adurrence> ouch!
14:07:13 <dluch> Awesome. kgmartin++
14:07:21 <dluch> Ugh, abneiman, i'm sorry!
14:07:35 <abneiman> eh, better safe than sorry
14:07:44 <jweston> abneiman++ for doing hero work at the polls
14:07:59 <dluch> I actually am still occasionally getting nosebleeds from the second one I had. (but not the other two)
14:08:00 <kgmartin> I was SO not prepared for how weird the brain swab is!
14:08:10 <dluch> abneiman++ for civic duty@
14:08:14 <dluch> !
14:08:23 <abneiman> brain_swab--
14:08:34 <dluch> for sure
14:08:43 <rfrasur> abneiman++
14:08:46 <dluch> How were things at the polls?
14:09:57 <abneiman> fine - busy. Everyone was pretty chill. No shenanigans (phew).
14:10:39 <dluch> That's good! Definitely phew. I didn't hear of anything around here, either, fortunately.
14:10:58 <dluch> Okay, let's keep moving...
14:11:01 <dluch> #info Previous Action Items
14:11:01 <dluch> How are we doing on these? Has anyone had time for anything?
14:11:01 <dluch> I'll take them in order...
14:11:16 <dluch> #1 sandbergja will make a video for proof of concept in the Quick Starts section
14:11:28 <dluch> I don't think sandbergja is on IRC right now...
14:11:47 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:12:06 <dluch> #2 dluch will update the style guide to reflect new header stuff
14:12:09 <dluch> I did not do this. But, abneiman, I think that was part of the wiki updating you did?
14:12:27 <abneiman> yes! I did sweep that up into my wiki updates
14:12:52 <dluch> Awesome, thank you!!
14:12:59 <jihpringle> #info jihpringle = Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:13:09 <dluch> #3 dluch will send a message to the docs list to ask for video documentation contributions to the community YouTube channel
14:13:29 <dluch> I still did not do that. I will during collaboration time, if we have it. Sorry, lol
14:13:50 <dluch> #4 DIG will participate in the fall Hack-a-Way and particularly focus on 3.6 docs
14:13:50 <dluch> I'm going to skip this one, because we have an agenda item next up to talk about the Hack-a-Way
14:14:14 <dluch> #5 abneiman will update the wiki with new Antora info
14:14:19 <dluch> I know that abneiman did this - do you have anything you want to report about?
14:14:50 <abneiman> Style Guide is fully updated with info about header sytax, xref syntax, and a few other goodies
14:14:54 <jweston> abneiman++ nice job
14:15:21 <dluch> abneiman++++++++
14:15:26 <jweston> confirming link to style guide -- correct?  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_style_guide
14:15:35 <abneiman> I put a few fixme tags on this page because some of these steps need to be revised: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation
14:15:48 <abneiman> jweston: that's correct
14:16:03 <dluch> Beat me to it, jweston, lol
14:16:42 <abneiman> and there was one other thing (looking)
14:17:29 <dluch> abneiman, does someone need to volunteer to do the Fixme tags? Or can anyone do them? Is that something someone could work on today?
14:18:12 <dluch> I thought there was one other thing, too, but couldn't find it, lol
14:18:14 <abneiman> dluch: anyone can look at them but I think they would need a Bmagic or sandbergja to verify
14:18:55 <dluch> Okay, cool. Neither of them are here, so maybe we can revisit that next month?
14:18:59 <abneiman> ahhhh! it was this: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:github-workflow
14:19:25 <abneiman> I added a few Antora-y things to that page ^^ as well
14:19:28 <dluch> Yay!
14:19:46 <kgmartin> +abnieman ++ that will be super-helpful!
14:19:57 <abneiman> +1 to revisit next month. I didn't know which edits needed to be made, but I didn't want to leave it as accurate (because I know it isn't) so FIXME it is
14:20:00 <kgmartin> (with apologies for misspelling your last name)
14:20:18 <abneiman> :)
14:20:54 <dluch> #info abneiman added Antora info to these pages: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_style_guide, https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation, https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:github-workflow
14:21:43 <dluch> #action https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:22:01 <dluch> abneiman++ Thank you so much!
14:22:15 <dluch> #info Hack-a-Way follow-up
14:22:31 <dluch> I ended up being out sick for a good part of the Hack-a-Way, so didn't get any 3.6 docs done. But the talk about Antora went well, I think, as did the DIG strategy session!
14:22:50 <dluch> Thank you to abneiman, alynn26, sandbergja, and Bmagic for keeping the DIG fires burning at the Hack-a-Way! (and anyone else I forgot!)
14:23:05 <dluch> abneiman++
14:23:05 <dluch> sandbergja++
14:23:05 <dluch> alynn26++
14:23:06 <dluch> Bmagic++
14:23:20 <abneiman> #info DIG strategy notes doc here: https://docs.google.com/document/d/1w8iJF9RhsZL0XJ1JelQPquZIOMnjE9fOl14TyDl_bMc/edit?usp=sharing
14:23:22 <dluch> (and if you haven't heard, sandbergja saved us all! ;-( ))
14:23:34 <dluch> There were some tasks that came out of the strategy session, agenda/notes for which can be found at https://docs.google.com/document/d/1w8iJF9RhsZL0XJ1JelQPquZIOMnjE9fOl14TyDl_bMc/edit?ts=5f99ce7f
14:23:40 <rfrasur> Thanks to all of you did so much DIGging during the hackaway. This was the most informative one for me (ever) and much appreciated.
14:23:44 <dluch> Oops, lol. What abneiman said
14:24:10 <dluch> I'm going to add a couple of action items from the strategy doc there
14:24:25 <dluch> #action dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it.
14:24:36 <jweston> abneiman++ alynn26++ Bmagic++ rfrasur++ and especially sandbergja++ (for, you know, saving us all) during hack-a-way
14:24:43 <dluch> #action abneiman will find and fix orphan pages and other nav issues
14:25:02 <dluch> #action Bmagic will add “email us about this page” link to all pages
14:25:20 <dluch> There are some other things on the document, but I think those were the main ones assigned to particular people that aren't already done.
14:25:20 <dluch> Did I miss any?
14:25:42 <dluch> rfruasur++ That's great to year!
14:25:57 <dluch> What else would folks like to say about the Hack-a-Way?
14:26:46 <jweston> Having a dedicated DIG session for the whole event was great (even though I didn't get there as often as planned)
14:27:02 <abneiman> I had put this in the agenda under new bix, but technically it's a followup from Hackaway and therefore really Old Biz: JBoyer has enabled the BOOPAC on Equinox's 3.6 public demo server
14:27:08 <abneiman> JBoyer++
14:27:21 <dluch> Yay! JBoyer++
14:27:29 <jihpringle> JBoyer++
14:27:31 <dluch> jweston: I liked that, too!
14:27:38 <rfrasur> It was weird and cool and sandbergja++ is basically amazing.  Her YouTube video about GitHub was super helpful.
14:27:39 <jihpringle> and abneiman++ for asking :)
14:28:05 <rfrasur> JBoyer++
14:28:06 <jweston> JBoyer++ enabling BOOPAC and abneiman++ for BOOPAC name
14:28:10 <rfrasur> BOOPAC++
14:28:18 <kgmartin> hehe
14:28:21 <dluch> rfrasur: Right?! I have that one bookmarked on my browser bar
14:28:31 <abneiman> I mean, I was just following established naming conventions ;-)
14:28:36 <dluch> lol BOOPAC++
14:29:48 <dluch> #info Antora update
14:29:48 <dluch> Other than things in the strategy document, anything else we need to talk about?
14:30:14 <abneiman> I can't think of anything right now, other than what's in the doc
14:30:28 <dluch> That's all I could think of, too
14:30:41 <dluch> Any other old or ongoing business to discuss?
14:31:15 <dluch> Okay, moving on...
14:31:15 <dluch> #topic New Business
14:31:30 <dluch> #info Change in meeting format
14:31:46 <dluch> This came up at the strategy meeting, than maybe we could do a Zoom/Meet/whatever meeting every other month, to have some "in person" discussions. There were votes for both doing business via video and collab time on IRC and vice versa.
14:31:55 <dluch> Discuss.
14:32:22 <abneiman> +1 to having a bimontly (or at least quarterly) F2F DIG meeting
14:32:42 <kgmartin> +1 screen sharing capability is nice for collaborative work as well
14:33:31 <abneiman> I lean slightly towards having collab F2F and kepe busincess on IRC (due to its minutes feature)
14:33:37 <abneiman> ....except without all the typos
14:33:47 <dluch> kgmartin and abneiman: that was kinda my thought, too. Might be easier to work on stuff together
14:34:01 <dluch> Plus Meetbot is the bomb
14:34:31 <jihpringle> I think that makes sense and in the F2F we could do demos/presentations like some of the other interest groups are doing as well as collaboration
14:34:51 <dluch> jihpringle++ that's a great idea!
14:35:06 <abneiman> jihpringle++
14:35:10 <jweston> +1 to all suggestions -- bus meetings on IRC and F2F for planned collaboration & screen sharing meetings (bimonthly or quarterly)
14:35:14 <kgmartin> jihpringle++
14:35:16 <abneiman> love the ideas of doing demos, especially for new diggers
14:35:45 <rfrasur> also +1 to all suggestions
14:35:55 <dluch> Okay, so can we just do this by acclaimation, or does anyone feel the need for a formal vote?
14:35:58 <kgmartin> We have been doing demos and collaborative work sessions for the cataloging group in SPARK and it's quite nice.
14:36:06 <dluch> [I'm all for acclaimation, lol.]
14:36:21 <dluch> kgmartin: Cool!
14:36:26 <abneiman> as long as we document the decision (no pun intended) +1 for acclaimation
14:36:33 <jweston> +1 acclaimation
14:37:05 <jihpringle> and we'd have the options to record the F2F as well (being able to watch the cat working groups ones that I couldn't attend has been great)
14:37:15 <jihpringle> +1 to acclaimation
14:37:18 <alynn26> +1
14:38:19 <dluch> #info DIG decided by acclaimation to moving to having months with collaboration meetings using a F2F/screen sharing platform and business meetings on IRC
14:38:39 <dluch> (I think there's a different tag, but I can't remember it...)
14:38:55 <rfrasur> #results?
14:39:04 <dluch> Oh. #agreed DIG decided by acclaimation to moving to having months with collaboration meetings using a F2F/screen sharing platform and business meetings on IRC
14:39:06 * rfrasur shrugs
14:39:16 <rfrasur> dluch++
14:39:19 <dluch> I think. lol
14:39:42 <dluch> Cool. I have access to both Zoom and Meet. Anyone have a preference?
14:40:07 <abneiman> I can also offer Meet, as well as GoToMeeting
14:40:11 <dluch> Or, we could try one next month, then the other in January
14:40:21 <dluch> I mean, February
14:40:39 <dluch> (Holy $#@#, y'all, it's almost 2021)
14:41:06 <jweston> bright side - that means 2020 is almost over
14:41:12 * rfrasur laughs
14:41:15 <jihpringle> :)
14:41:19 <abneiman> December DIG year-end F2F meeting & social hour?
14:41:21 <dluch> definitely a good thing
14:41:26 <rfrasur> social week?
14:41:31 <dluch> Oooo, abneiman++
14:41:42 <kgmartin> abneiman++
14:41:43 <abneiman> lol rfrasur
14:41:54 <alynn26> +1 for social hour
14:42:04 <adurrence> abneiman++
14:42:04 <jweston> abneiman++ excellent plan
14:42:12 <dluch> Cool! Let's do that.
14:42:31 <dluch> #agreed December DIG meeting will be F2F social hour!
14:42:42 <rfrasur> abneiman++ # you got the best ideas
14:42:51 <dluch> Okay, I'll set something up and send it to the DIG list.
14:42:59 <abneiman> and here I always thought I wasn't a vision person
14:43:17 <dluch> lol
14:44:04 <dluch> #info News Item: JBoyer has enabled the BOOPAC for the 3.6 public demo @ demo.evergreencatalog.com
14:44:22 <dluch> abneiman mentioned this in the hackaway discussion earlier, but here it is with an info tag.
14:44:36 <dluch> abneiman: Anything else we need to know related to this?
14:44:56 <abneiman> dluch: nope
14:45:04 <dluch> Sweet
14:45:19 <dluch> abneiman++ JBoyer++
14:45:22 <dluch> Is there any other new business we need to discuss?
14:46:46 <dluch> #topic Collaboration time
14:46:46 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:46:55 <dluch> We have 15 minutes
14:47:17 <dluch> Here's the I made a list of ideas you can work on (alone or with others) if you don't already have something. I know it can be kind of overwhelming sometimes to know where to start.
14:47:23 <alynn26> I will be sending a survey out about the Hack-a-way.
14:47:38 <dluch> Oops. *Here's the list I made...
14:48:29 <abneiman> I apparently missed a set of docs in my big 3.6 push so I'm going to correct the two missed ones and add them to my to-be-merged pile
14:49:03 <dluch> -your own priority projects
14:49:03 <dluch> -3.6 docs
14:49:03 <dluch> -experimental catalog docs
14:49:03 <dluch> -cleaning up old docs tickets on Launchpad
14:49:03 <dluch> -finding docs tickets on Launchpad to work on
14:49:04 <dluch> -easy tasks from Documentation Needs List
14:49:05 <dluch> -auditing and removing finished or irrelevant items from the Documentation Needs List and/or adding 3.6 documentation needs
14:49:10 <dluch> -still-relevant items from the Documentation Needs List (be sure to assign yourself to it so we don't duplicate work)
14:49:12 <dluch> -documentation-related short videos for the community YouTube channel
14:49:14 <dluch> -looking through existing docs for things that need updating - text and/or images
14:49:23 <dluch> alynn26++
14:49:26 <dluch> abneiman++
14:49:56 <jweston> dluch++ great list -- saving for later :)
14:50:05 <dluch> I am going to go email the docs list about contributing video documentation, lol
14:50:11 <dluch> :-)
14:52:17 <abneiman> ... apparently I managed to get the image files in correctly but I failed to push the revised adoc. Go figure.
14:52:55 <jweston> alynn26 from hack-a-way list of old stuff not asciidoc'd, do you have updated doc for Local Admin --> Surveys?  someone asked me about that recently (don't remember who) but it would be good to add that back
14:54:36 <adurrence> I created 3 circ training modules with short videos, but not sure whether any would be useful to larger community. Anyone is welcome to take a look and leave a comment. Circ module 1: https://360.articulate.com/review/content/ffa35550-08b9-4d2e-b66a-5f1a6bf86583/review
14:54:37 <adurrence> https://360.articulate.com/review/content/ffa35550-08b9-4d2e-b66a-5f1a6bf86583/review
14:55:11 <adurrence> Circ module 2: https://360.articulate.com/review/content/e72a5e39-5c66-4abd-917b-d6bba0f95ffc/review
14:55:20 <jweston> adurrence++ fantastic!
14:55:32 <alynn26> jweston, I am currently working on an updated version of this.  I have it for before it was angularized.
14:55:34 <adurrence> Circ module 3: https://360.articulate.com/review/content/3a9c12a0-118a-46e1-ae2a-fd0ab46d0858/review
14:55:57 <dluch> abneiman: Do you remember (I can't find it ATM in the Outreach Comm. meeting minutes)...if people have documentation videos to submit to the community YouTube channel, how are they supposed to do that? Send 'em to rhamby, or did we decide on a different workflow?
14:56:14 <dluch> adurrence++ awesome!!
14:56:20 <adurrence> Yes, rhamby said dropbox
14:56:28 <adurrence> I save it somewhere, I think :/
14:56:29 <abneiman> yeah, send to rhamby
14:56:44 <abneiman> adurrence++ # yay videos!
14:56:46 <jihpringle> adurrence those look really cool!
14:56:54 <adurrence> Thanks!
14:56:56 <dluch> abneiman: Thanks!
14:57:27 <adurrence> Feel free to share widely, if anyone you know would find useful!
14:58:22 <adurrence> If you think any of the videos would be good for EG YouTube channel or if they need reshoot or edit, let me know feedback good/bad, all okay!
15:00:03 <jihpringle> will do :)
15:00:37 <dluch> We are at time.
15:00:58 <jihpringle> for the experimental catalogue in 3.6 how do we want to handle the docs?  we originally talked about doing a separate section and calling it experimental but it's not anymore in 3.6
15:01:19 <dluch> Next meeting will be December 3. Face to Face!
15:01:48 <dluch> Thanks for coming, everyone! Feel free to continue working together.
15:01:50 <dluch> #endmeeting