15:01:11 <JBoyer> #startmeeting 2020-11-10 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-11-10
15:01:11 <pinesol> Meeting started Tue Nov 10 15:01:11 2020 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:11 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:11 <pinesol> The meeting name has been set to '2020_11_10___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2020_11_10'
15:01:22 <JBoyer> #topic Introductions
15:01:26 <JBoyer> Give me your hashtag-infos
15:01:39 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:01:51 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:52 <berick> #inf berick Bill Erickson, KCLS
15:02:00 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:02:06 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:08 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:02:08 <nfBurton> #info nfBurton = Chris Burton, NFPL
15:03:05 <terranm> #info terranm = Terran McCanna, PINES
15:03:16 <JBoyer> Infinite bericks, I guess Evergreen should be finished next month. :D
15:03:29 <miker> #info miker = Mike Rylander, EOLI
15:03:39 <JBoyer> Ok, feel free to introduce yourself as we move along
15:03:41 <JBoyer> #topic Action Items from Last Meeting
15:03:44 <shulabear> #info shulabear = Shula Link, GCHRL
15:03:48 <JBoyer> #info jeffdavis to gather information re:current Syrup users
15:04:21 <JBoyer> jeffdavis, you around?
15:05:05 <csharp> #info csharp = Chris Sharp, GPLS
15:05:42 <jeffdavis> JBoyer: IIRC NOBLE and Calvin College are the only ones
15:06:08 <JBoyer> That's what I was thinking. (and taking entirely too long to type out_
15:06:45 <JBoyer> So while Course Reserves may not be 100% there yet, "everybody" using it knows we're planning to drop Python support in the future.
15:06:56 <JBoyer> Which can be planned for / around.
15:07:40 <JBoyer> Any other discussion to be had about Syrup?
15:07:46 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:08:06 <JBoyer> ok.
15:08:09 <JBoyer> #topic OpenSRF Release Info
15:08:18 <JBoyer> #info OpenSRF 3.3?: Removing Python & Java
15:08:43 <JBoyer> If memory serves this is Dyrcona's topic?
15:09:01 <Dyrcona> I thought with the imminent removal of Java and Python that we should consider an OpenSRF 3.3 release.
15:09:12 <gmcharlt> agreed
15:09:17 <Dyrcona> This would coincide with adding Ubuntu 20.04 support.
15:09:49 <JBoyer> Reasonable. It would be odd for a point release to be where new OS support happens.
15:10:24 <Dyrcona> Right, or the removal of Python and Java.
15:10:43 <JBoyer> True.
15:10:58 <gmcharlt> nothing in Evergreen requires Java support or python support to my knowledge, so there's nothing stopping us from making osrf 3.3 the minimum required version for _new_ installations, with a note to the effect that 3.2.x won't break 3.6 and earlier
15:11:42 <Dyrcona> That was my thought make OSRF 3.3 and Evergreen 3.7.
15:12:22 <Dyrcona> I'm not sure what "make" is doing in there, but you get the idea, I hope.
15:13:11 <sandbergja> make -f Makefile.install fossa?
15:13:20 <Dyrcona> :)
15:14:27 <Dyrcona> So, I guess the question is when to merge the branches and fork the rel_3_3 and rel_3_7 branches, and maybe we don't need an answer today.
15:14:54 <JBoyer> Looks like some more testing is needed to get those branches in, but that should easily be achievable by the ~3.7 timefram.e
15:15:21 <JBoyer> "Looks like" meaning they're not all signed off yet, but I imagine they'll be no trouble.
15:15:47 <gmcharlt> yeah, and easy enough to get OpenSRF 3.3 out the door sooner than EG 3.7
15:16:23 <JBoyer> #agreed The removal of Python and Java will be a part of the 3.3 OpenSRF and 3.7 Evergreen releases
15:16:33 <Dyrcona> I think it's worth mentioning again that if you test the Focal Fossa branches, you are effectively testing all 3, since the Focal branches depend on the Python and Java branches.
15:16:58 <abowling> #info abowling = Adam Bowling, Emerald Data Networks
15:17:43 <JBoyer> Do all 3 need to be applied manually or does the fossa branch basically include the others?
15:17:59 * JBoyer goes to look after lazygoogling
15:18:08 <Dyrcona> JBoyer: The Fossa branch includes the other two, yes.
15:18:22 <JBoyer> Excellent, ok. So easy to test then.
15:18:38 <berick> good summary http://list.evergreen-ils.org/pipermail/evergreen-dev/2020-October/000053.html
15:19:13 <JBoyer> berick++
15:19:51 <JBoyer> ok, hopefully some Ubuntu VMs will be spun up and those branches taken for a spin. Any further OpenSRF discussion?
15:20:23 <JBoyer> on to Evergreen
15:20:29 <JBoyer> #topic Evergreen Release Info
15:21:05 <csharp> point releases scheduled for next Wednesday = 3.4.5, 3.5.2, & 3.6.1
15:21:16 <csharp> lots of hackaway goodness
15:21:20 <JBoyer> It doesn't look like I was complete off on my recollection of the 3.7 release team volunteers; have you had a chance to get together and discuss timelines?
15:21:38 <JBoyer> csharp++
15:21:47 <berick> no timeline discussion yet on 3.7.  on my mind, though
15:22:15 <JBoyer> berick++
15:22:21 <berick> for release team coordination, ##eg-release a reasonable place for that, to start anyway?
15:23:28 <JBoyer> It certainly can be. whatever method works best for the group should be fine.
15:23:43 <csharp> yeah
15:23:52 <csharp> https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit#gid=0 - spreadsheet for volunteer roles
15:24:06 <berick> k, i'll put feelers out soon for how we want to manage the roles, etc.
15:24:20 <berick> team++
15:24:37 <csharp> @eightball is there an "I" in team?
15:24:37 <pinesol> csharp: No.
15:24:46 <JBoyer> and to make sure csharp's reminder hits the brief minutes
15:25:08 <JBoyer> #info 3.4.5, 3.5.2, & 3.6.1 point releases scheduled for next Wednesday
15:25:46 <JBoyer> If there's no further Evergreen release info I'll move along
15:25:48 <sandbergja> This is the last 3.4 release, right?
15:26:08 <sandbergja> (I haven't been following irc much lately, unfortunately)
15:26:33 <csharp> sandbergja: sounds right - should pretty much be security only now that 3.6 is out
15:26:36 <Dyrcona> It somehow seem appropriate to end it on 3.4.5, but I'm not sure if it really is the last 3.4 release.
15:27:19 <csharp> we're so squishy on release dates - we're really more like Fedora than Ubuntu release-cycle-wise
15:27:22 <JBoyer> I mean, if people would just stop finding security bugs I suppose we could leave it there, heh.
15:27:34 <gmcharlt> per https://wiki.evergreen-ils.org/doku.php?id=dev:release_process:schedule, making 3.4.5 end of life for general bugfixes would be OK
15:27:46 <sandbergja> JBoyer: hahaha
15:27:46 <JBoyer> gmcharlt++
15:27:47 <csharp> gmcharlt++
15:27:48 <gmcharlt> I'm editing that page now to add 3.6
15:28:25 <sandbergja> gmcharlt++
15:28:41 <gmcharlt> and done
15:29:48 <JBoyer> Ok, now we can move on to
15:29:50 <JBoyer> #topic Old Business
15:29:59 <JBoyer> #info PostgreSQL 10+ support - 9.6 EOL is 2021-11-11
15:30:21 <JBoyer> Does anyone have any further information to bring to the table re: Pg10+ ?
15:30:41 <JBoyer> I know there are a couple production upgrades in the planning phases, but haven't heard anything else.
15:31:01 <csharp> we won't be moving to it until late winter/early spring at this point
15:31:26 <Dyrcona> We're sticking with 9.6 for now. I have a test server with 9.6 through 12 installed.
15:31:42 <csharp> Dyrcona++ # pioneering
15:31:47 <Dyrcona> Um, 9.6 through 13, now. I installed 13 last month.
15:32:35 <Dyrcona> I'm not sure how we should go about benchmarking things, but I can say that performance seems to change quite a bit on 12 versus 9.6 and 10.
15:33:45 <JBoyer> odd benchmarking aside, you haven't noticed anything like the changes in Pg10 where things we were doing in 9.6 and below would just blow up anywhere, correct?
15:34:33 <Dyrcona> Not so far. It looks like we've caught those. I haven't seen anything just blow up on 12, either, and I've been using it as my main test db.
15:34:56 <JBoyer> That's promising.
15:36:21 <JBoyer> Ok. If there's no more discussion to be had about Pg10 I feel like we've already covered the Fossa / -Python / -Java discussions, does anyone have any new business that didn't hit the agenda?
15:37:32 <JBoyer> in that case
15:37:38 <JBoyer> #topic Announcements
15:37:42 <JBoyer> #info Next Meeting is 2020-12-01
15:38:30 <JBoyer> What luck, this meeting is ending in a reasonable timeframe, heh.
15:38:37 <JBoyer> Thanks everyone.
15:38:39 <JBoyer> #endmeeting