15:00:32 <JBoyer> #startmeeting 2020-12-01 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2020-12-01
15:00:32 <pinesol> Meeting started Tue Dec  1 15:00:32 2020 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <pinesol> The meeting name has been set to '2020_12_01___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2020_12_01'
15:00:40 <JBoyer> #topic Introductions
15:00:51 <csharp> #info csharp = Chris Sharp, GPLS
15:00:52 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:00:54 <abowling> #info abowling = Adam Bowling, Emerald Data Networks
15:00:57 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:03 <berick> #info berick Bill Erickson, KCLS
15:01:05 <miker> #info mike = Mike Rylander, EOLI
15:01:09 <shulabear> #info shulabear = Shula Link, GCHRL
15:01:11 <miker> #info miker = Mike Rylander, EOLI
15:01:12 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:15 <rhamby> #info rhamby = Rogan Hamby, EOLI
15:01:24 <mantis2> #info mantis = Gina Monti, Bibliomation
15:01:40 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:02:10 <terranm> #info terranm = Terran McCanna, PINES
15:02:20 <JBoyer> With no action items from our last meeting we'll go right to updates
15:02:27 <JBoyer> #topic Evergreen Release Info
15:03:11 <berick> i can offer a bit on the EG side
15:03:16 <JBoyer> Dyrcona has a question about 3.7 beta and release dates, and I think I saw a message about that recently
15:03:27 <JBoyer> berick++
15:03:32 <berick> indeed, proposed schedule emailed
15:03:48 <Dyrcona> berick++
15:03:55 <terranm> berick++
15:03:56 <berick> and related terranm propesed dates for feedback fest and bug squash week
15:04:19 <sandbergja> terranm++
15:04:20 <sandbergja> berick++
15:04:23 <berick> February 8-12  and March 8-12 respectively
15:04:24 <Dyrcona> Those dates also work for me. terranm++
15:05:32 <berick> so i'll update the general EG roadmap page with these dates
15:05:41 <terranm> Cool, I'll put them on the community calendar
15:06:07 <mmorgan> berick++
15:06:11 <mmorgan> terranm++
15:06:12 <JBoyer> #info proposed dates email thread: https://georgialibraries.markmail.org/message/ke4aaxb45g6ec3j6
15:06:28 <JBoyer> Someday I'll look this stuff up before the meeting starts. Not today!
15:07:07 <Dyrcona> :)
15:07:08 <JBoyer> I'm also +1 to the recommended dates.
15:07:29 <Dyrcona> I hit refresh on the agenda as the meeting started.
15:07:56 <JBoyer> I at least get a little more ahead than that so I can write up a command script, heh.
15:08:18 <JBoyer> If there are no more Eg updates or questions about it, we'll move on to Docs
15:08:37 <JBoyer> #topic Documentation Updates
15:09:09 <JBoyer> Who would like to expand on the changes to the DIG meeting format, or have I been punk'd by old data?
15:09:38 * JBoyer looks for hidden camera
15:10:37 <JBoyer> Looks like that means it's time to discuss business of a newer nature.
15:10:46 <JBoyer> #topic New Business
15:11:14 <JBoyer> terranm, would you like to talk about the signed off bugs list?
15:11:23 <terranm> Sure. We have a bit of a backlog in patches that are tested and signed off but not committed. Michele has been highlighting some of the more urgent fixes in email.
15:11:43 <terranm> Would it be reasonable to ask each core committer to commit to checking and committing at least one signed off patch per month? (At least until we're keeping up with them?)
15:12:40 <JBoyer> Seems reasonable to me.
15:12:43 <csharp> +1
15:12:46 <berick> terranm: i like the idea.  maybe a good dev list heads-up / discussion
15:12:53 <mmorgan> +1
15:13:26 <terranm> With great power comes great responsibility
15:13:26 <JBoyer> I also really like the list of 10 that mmorgan is keeping. Don't want to wade through the long list, here's 10 to pick from!
15:13:30 <Dyrcona> It's all right with me. I started looking at some this week in between other things.
15:13:41 <mmorgan> Low hanging fruit!
15:13:46 <csharp> The List of Ten
15:14:06 <terranm> mmorgan++
15:14:12 <berick> yeah, the list is great
15:14:12 <JBoyer> terranm++
15:14:14 <JBoyer> mmorgan++
15:14:49 <JBoyer> was there anything you wanted to add about it mmorgan or just make folks aware, which we now ought be?
15:15:05 <Dyrcona> mmorgan++
15:15:35 <mmorgan> Just wanted to keep folks attention on them :)
15:15:43 <JBoyer> +1
15:16:16 <terranm> Thanks all!
15:16:57 <csharp> might be worth using the bug assignment feature to let other committers know you're working on a bug
15:16:58 <mmorgan> terranm++
15:17:05 <sandbergja> Just a note that we should update this wiki page with the expectation that core committers review one signedoff patch/month (unless we think it will just be a temporary need): https://wiki.evergreen-ils.org/doku.php?id=contributing:core_committer_responsibilities&s[]=committers
15:17:34 <Dyrcona> I don't think it should be  permanent requirement of being a committer.
15:17:35 <sandbergja> (I don't think we'll ever *not* have a backlog of signedoff bugs, but I've been pretty pessimistic lately hahaha)
15:17:38 <terranm> :)
15:17:40 <JBoyer> Also, a big +1 to mentioning both the request to check / commit a minimum of 1 bug per month and updates on the "top 10" on the dev list to remind everyone, especially since it's December.
15:18:01 <csharp> yeah, I think the intention is enough without codifying something
15:18:01 <mmorgan> I agree using the assignment feature is great for keeping track.
15:18:13 <sandbergja> that makes sense
15:18:15 <csharp> meaning I agree with Dyrcona
15:18:23 <JBoyer> I don't know that it should be a requirement but it does seem like something attainable to try to do, which could stand to be mentioned.
15:18:41 <Dyrcona> Also, definitely assign bugs to yourself when looking at them.
15:19:10 <berick> JBoyer: ditto
15:19:11 <terranm> More like a goal than a requirement
15:19:22 <JBoyer> terranm++
15:19:36 <berick> "flight hours"
15:19:52 <csharp> there you go
15:21:38 <JBoyer> Ok, any other items to discuss before announcements are announced?
15:22:13 <JBoyer> #topic Announcements
15:22:20 <JBoyer> #info Next meeting is 2021-01-05
15:22:41 <JBoyer> And that's all I have unless anyone is excited about anything in particular.
15:22:59 <jeffdavis> Sorry, I was afk - there was a question about security releases
15:23:07 <jeffdavis> i.e. whether to do a round of them in Dec
15:23:33 <JBoyer> Oh, right, didn't make the agenda.
15:23:59 <Dyrcona> Yes, there was such a question, but I wasn't sure if we should broach it here, but why not?
15:24:47 <JBoyer> I do think dropping them right before Christmas is a pretty rough time.
15:25:22 <JBoyer> People with an eye to exploiting bugs usually have more free time around the holidays than the people that apply the patches, so to speak.
15:25:44 <Dyrcona> Yeah, and this was my motivation for asking about the 3.7 release.
15:25:59 <csharp> Dyrcona: we can speak in pig latin to obscure what we're aying-say
15:26:29 <Dyrcona> :)
15:26:41 <jeffdavis> I believe there are a few pending security fixes, I'd support a release in Jan esp if that helped get more of the fixes committed
15:26:59 <csharp> sounds reasonable to me
15:27:17 <JBoyer> With the 3.7 timeline I think it would definitley be fine to look at the Jan point release.
15:27:20 <Dyrcona> I agree with security releases in January rather than waiting for March.
15:27:44 <csharp> also, is it safe to assume that January would be the next window for point releases generally?
15:28:13 <Dyrcona> csharp: Thst's OK with me.
15:28:36 <JBoyer> Seems that way, unless a flurry of activity takes place in the next 13-14 days, which would be unusual for December.
15:28:46 <csharp> yeah
15:29:40 <JBoyer> Ok, so skipping December and planning to make January a security release, does that sound like a good plan to everyone present?
15:29:57 <berick> so we have security and the Top Ten Challenge for Jan.
15:30:02 <csharp> yes
15:30:19 <csharp> also the 100 pushup challenge and New Year's resolutions
15:30:27 <Dyrcona> I'm going to assign myself an action to set dates in Lp for the next point releases, and add a 3.4.6 security release.
15:30:29 <JBoyer> csharp++
15:30:51 <csharp> Dyrcona++
15:30:57 <terranm> Dyrcona++
15:31:16 <Dyrcona> #action Dyrcona to assign release dates in Launchpad for 3.6.2, 3.5.3, and 3.4.6 releases.
15:31:36 <Dyrcona> Hmm... Maybe I can't or didn't do it right?
15:31:52 <JBoyer> I don't recall if meetbot is down with that unless you're chair.
15:31:53 <csharp> Dyrcona: that should work I think
15:31:58 <JBoyer> #action Dyrcona to assign release dates in Launchpad for 3.6.2, 3.5.3, and 3.4.6 releases.
15:32:13 <JBoyer> Or it got bored and wondered off...
15:32:26 <csharp> Marvin the Meetbot?
15:32:33 <Dyrcona> Maybe there's no feedback with action?
15:32:47 <JBoyer> oh, that could be.
15:32:48 <csharp> that's my impression
15:33:00 <JBoyer> Now you're double gonna do it, I guess. :)
15:33:04 <Dyrcona> :)
15:33:59 <JBoyer> Ok, We've all got some things we can start looking at and hopefully the next point releases will be packed with good stuff and 3.7 will be another big release.
15:34:06 <JBoyer> Hurrah!
15:34:18 <JBoyer> #endmeeting