15:05:10 <JBoyer> #startmeeting 2021-01-05 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-01-05
15:05:10 <pinesol> Meeting started Tue Jan  5 15:05:10 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:10 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:10 <pinesol> The meeting name has been set to '2021_01_05___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_01_05'
15:05:18 <JBoyer> #topic Introductions
15:05:21 <JBoyer> Hello, hello
15:05:29 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:05:30 <csharp> #info csharp = Chris Sharp, GPLS
15:05:32 <miker> #info miker  = Mike Rylander, EOLI
15:05:48 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:05:48 <mrisher> #info mrisher = Mike Risher, KCLS / Catalyte
15:05:49 <csharp> eeeeoooliolioliooo
15:05:53 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:05:59 <berick> #info berick Bill Erickson, KCLS
15:06:44 <JBoyer> ok, anyone coming in later feel free to info-in then.
15:06:46 <JBoyer> #topic Action Items from Last Meeting
15:06:52 <JBoyer> #info Dyrcona to assign release dates in Launchpad for 3.6.2, 3.5.3, and 3.4.6 releases
15:07:00 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:07:06 <Dyrcona> That's done, btw!
15:07:11 <JBoyer> Dyrcona++
15:07:28 <JBoyer> I thought I remembered seeing that.
15:08:27 <JBoyer> In the interest of time, are there any updates for Evergreen, OpenSRF, or Hatch releases? There's nothing on the agenda so unless someone has a last minute EUREKA I'm going to skip them all
15:08:40 <JBoyer> (or Docs)
15:08:53 <terranm> #info terranm = Terran McCanna, PINES
15:09:26 <berick> just noting we're < 2 months from 3.7 feature freeze
15:09:45 <JBoyer> Alright. I also see that where mmorgan did the thing and updated the agenda, I did not update it with my planned additions. Some people...
15:09:49 <JBoyer> berick++
15:09:55 <JBoyer> So,
15:09:56 <JBoyer> #topic New Business
15:10:18 <JBoyer> #link https://georgialibraries.markmail.org/message/w76isj7krseqvo3i?q=list:org%2Egeorgialibraries%2Elist%2Eopen-ils-dev Michele's latest top 10 bugs
15:10:22 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:10:31 <terranm> mmorgan++
15:10:44 <JBoyer> anything you'd like to call out specifically mmorgan?
15:11:11 <mmorgan> They're all important, just wanted to keep a good supply of low hanging fruit for folks that might have time to do some committing.
15:11:31 <JBoyer> (I do know there's been interest expressed in bug 1857060 also if we want to turn it up to 11)
15:11:32 <pinesol> Launchpad bug 1857060 in Evergreen "A few changes needed to accomodate 979 ISBNs" [Medium,New] https://launchpad.net/bugs/1857060
15:11:35 <JBoyer> Sounds good. mmorgan++
15:12:15 <mmorgan> I could certainly have included more :) but 10 seemed a reasonable number.
15:12:36 <JBoyer> Well, this morning I was messing with LP searches and came up with these:
15:12:48 <JBoyer> #link https://bugs.launchpad.net/evergreen/+bugs?orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.tag=pullrequest+-signedoff+-needsrepatch&field.tags_combinator=ALL LPs with pullrequests ready to test
15:12:58 <JBoyer> and
15:12:59 <JBoyer> #link https://bugs.launchpad.net/evergreen/+bugs?orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.tag=pullrequest+signedoff+-needsrepatch&field.tags_combinator=ALL LPs with signedoff branches ready to look over + push if good
15:13:28 <csharp> holy craznap
15:13:30 <JBoyer> So if 10 bugs isn't enough challenge folks can look through around 130+ there, heh.
15:13:38 <JBoyer> Those are, believe it or not, significantly shorter than they started.
15:13:48 <mmorgan> JBoyer++
15:14:27 <terranm> Yeah, we tested a lot during the last few bugsquash/feedback fests
15:14:50 <JBoyer> Which kind of winds us around to the topic I mentioned briefly in my email reminder this morning.
15:15:16 <JBoyer> #topic How can these meetings be made more effective / beneficial
15:16:31 <JBoyer> I know most of an afternoon is not a lot of time to really give this much thought, especially after the second day back to work for many / most folks, but even if you don't have any thoughts or suggestions today I'd like you all to think about where these may fall flat or how they may be even better than they already are in future.
15:18:08 <sandbergja> These meetings can be particular helpful when we have a thorny (or controversial) issue on the docket to discuss
15:18:17 <sandbergja> Maybe we could schedule some more of those?
15:18:31 <berick> sandbergja: agreed.  having a focus is helpful
15:18:31 <JBoyer> Also bear in mind I'm not staking any claim on running these meetings. If someone has some Big Ideas and wants to take the wheel we can certainly see how that works out. Though I do find that it helps to make some assumptions about who is running things if nothing else so they can have their calendar prod them to prod the rest of us, heh
15:18:33 <sandbergja> Also, I always look forward to these meetings because of JBoyer's jokes
15:18:53 * JBoyer does what he can
15:18:57 <csharp> I think having *something* scheduled is important since we can be a big disorganized blob of a dev community
15:19:17 <csharp> so even if some months it's kind of looking at each other it's better than not doing anything
15:19:49 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin University)
15:20:37 <csharp> also, I think we're more chatty when we're focused on the next bugsquash or other structured dev activity
15:21:02 <JBoyer> sandbergja, I'm not sure I follow what you meant by "Maybe we could schedule some more of those?" More meetings like this, or more specialized discussions at a certain time, something else entirely, etc?
15:21:03 <csharp> for my part, I'm straight off vacation and prepping for next weekend's PINES upgrade
15:21:21 <sandbergja> More specialized discussions
15:21:27 <mmorgan> Maybe each meeting, in addition to other business, we could look at a certain bug that's languishing, or a certain group of related bugs, so there's something on the agenda each month.
15:21:29 <sandbergja> Say, have a topic of the month
15:21:35 <csharp> (going to 3.6.1 in case people are curious)
15:21:37 <terranm> +1
15:21:56 <csharp> new devs offer a model like that
15:22:45 <sandbergja> If we want to have a lot of discussion sometime, we could always have a topic like "Should we move to Github, Gitlab, etc."  :-)
15:22:54 <csharp> or this agenda item: finally settle the self-hosted gitolite vs. other options thing
15:22:57 <csharp> jinx
15:23:15 <sandbergja> Or strategizing on improving test coverage, since that always comes up, but we never really make a plan about it
15:23:31 <JBoyer> Ugh. Yeah. That one only seems to get real traction when discussed in person.
15:24:07 <csharp> moving onto another git platform would offer built-in testing stuff too, which would affect sandbergja's idea there
15:24:08 <JBoyer> There was a rough consensus around GitHub during the hackaway, so that's kind of progress. (*If* we're moving, we know where to. :D )
15:24:55 <terranm> It might be a good idea to have a status update on numbers of commits, new bug reports, etc. each month.
15:25:22 <mmorgan> +1
15:25:54 <terranm> Last month we discussed each core committer having a goal of committing at least one patch per month - maybe that could be in the status update too
15:26:21 <mmorgan> And also stats on open bugs, those with pullrequests and signoffs so we know how much work there is to do and how much gets done.
15:26:32 <terranm> +1
15:26:52 <sandbergja> We also might need some coordination of large projects with tons of lp tickets (I'm thinking getting the bootstrap opac ready for 3.7)
15:27:07 <JBoyer> Lots of good ideas. I might have to re-adjust my calendar reminders at this rate. ;)
15:28:08 <JBoyer> sandbergja, Something like a Bootstrap-themed bug squashing week would be good. (doesn't have to be that specific event but similar in spirit I assume)
15:28:43 <JBoyer> I do think there are several bootstrap bugs in that signedoff LP search link.
15:28:43 <sandbergja> JBoyer: yeah, that sounds good!
15:29:18 <csharp> also, we saw the value of video meetings for the EG conf and Hackaway - maybe every few months could be a hosted Zoom/Google/whatever call that gets recorded for the archives
15:29:28 <mmorgan> Agree about coordination of large projects, we often find ourselves in the position of wanting to use a new feature after an upgrade, but finding there are too many bugs remaining to make it useful/possible to implement.
15:30:39 <csharp> the main reason for IRC meetings is automatic minutes and ultimate transparency, but with good minute taking and a video record, maybe that would spirit would be preserved
15:30:58 <csharp> er.. too many "would"s there
15:31:04 <terranm> +1
15:31:11 <mrisher> It would be great to get more visibility on old pull requests.  I sometimes come across old pull requests I submitted long ago that need a look.
15:31:21 <JBoyer> I can also see people specifically avoiding video meetings, especially if they're recorded. So we shouldn't consider only those, but they would make a nice addition.
15:31:57 <JBoyer> mrisher++
15:32:38 <mrisher> maybe make a special category of untested pull request that are older than a certain length.  (6 months?  3?)
15:33:41 <JBoyer> I feel like ~6 is a good time to call them out. Any branches would almost certainly require a rebase at that point.
15:33:43 * mmorgan likes the idea of curated lists that are not so big that they are overwhelming to look at
15:34:08 <terranm> +1
15:34:13 <JBoyer> True. My links above are maybe a little overwhelming.
15:34:51 <mmorgan> JBoyer: They are comprehensive:)
15:34:52 <JBoyer> So, it sounds like we have a lot of very good ideas. I am but one person who has made some poor choices re: time, does anyone have anything they feel passionately about and want to take an action item?
15:35:29 <JBoyer> Noting that "action item" does not necessarily mean "done by 2021-02-02"
15:35:42 <JBoyer> (though that would be nice also)
15:36:17 <Dyrcona> Should we survey again about good times for these meetings? I"ve noticed a lack of certain names participating lately.
15:36:50 <JBoyer> Probably not a bad idea.
15:37:52 <JBoyer> #action JBoyer will poll the community about possible dev meeting times
15:38:17 <JBoyer> I'll send a couple emails and drop notes in here a couple different times over the next week or two.
15:38:33 <berick> JBoyer++
15:40:16 <sandbergja> What other action items are there?
15:42:11 <JBoyer> Whatever anyone would like to commit to doing. :) Organizing a bootstrap-fest or something like it, mmorgan is handling a top 10 bugs list now and then, does someone want to re-surface specifically old bugs, or some other metric, etc.
15:42:41 <sandbergja> I could make a list of cool old bugs!
15:42:54 <sandbergja> Probably taking a lot of inspiration from mmorgan's lists
15:43:01 <JBoyer> #action sandbergja will put together a list of older bugs that need attention
15:43:04 <mmorgan> sandbergja++
15:43:05 <JBoyer> sandbergja++
15:43:32 * mmorgan will continue with the top ten list, and is open for nominations for said list
15:43:34 <terranm> sandbergja++
15:43:38 <terranm> mmorgan++
15:43:41 <JBoyer> the nice thing about that is if there are any xul-related bugs (other than "strip out the rest of it") they can be marked won't fix, also helping. :)
15:43:46 <mrisher> sandbergja++
15:44:15 <sandbergja> Oh, that's another large topic we should discuss at some point: getting rid of dead code (including xul)
15:44:34 <mmorgan> +1
15:44:56 <terranm> +1
15:45:11 <mmorgan> It's frustrating when digging through code only to realize what you're looking at is not used anymore
15:45:22 <JBoyer> And potential refactoring. Are there perl mods we're no longer using, are there any we're using very little of and can be written-out, etc. Fewer dependencies, fewer bugs we didn't write. ;)
15:45:48 <sandbergja> Very true
15:46:01 <terranm> Next Feedback Fest is Feb 8-12, and my goal is to load as many patches for testing as possible again
15:46:13 <JBoyer> (to a point. Anyone that suggests "roll our own crypto!" gets put in time out.)
15:46:27 <JBoyer> terranm++
15:46:30 <sandbergja> I nominate dead code removal + refactoring desires as a discussion item for the February meeting
15:46:45 <mrisher> terranm++
15:46:53 <sandbergja> as in our wishes related to refactoring
15:49:13 <JBoyer> #info Feedback Fest is February 8-12
15:50:26 <JBoyer> We can also continue to think about ways to improve these meetings.
15:51:26 <JBoyer> Additionally, releases are scheduled for 2021-01-20 I believe, so now's the time to hit those lists good and hard (be they 10 or 100+).
15:51:48 <JBoyer> I know gmcharlt has said that he would be able to help with that some though he's not able to be here today.
15:52:02 <Dyrcona> The releases are going to be security releases, so we'll need some extra coordination.
15:52:10 <csharp> reminder to make sure you "claim" each bug by assigning it to yourself
15:52:20 <JBoyer> Dyrcona++
15:52:22 <JBoyer> csharp++
15:52:34 <Dyrcona> At some point, we'll need to declare a commit moratorium.
15:53:25 <JBoyer> Ah, right. Hadn't thought about that, good point.
15:53:55 <JBoyer> What has the timeframe been like on that in the past, a week, slightly more, slightly less?
15:54:13 <Dyrcona> Nothing drastic, just a day or so around release time.
15:54:40 <JBoyer> Oh, right. It's not like an RC release and all of that..
15:54:42 <Dyrcona> Though, it depends on how long it takes us to get the releases together.
15:55:22 <JBoyer> Maybe to be on the safe side, if we're aiming for a 1/20 release we call a hold on the Thursday prior?
15:55:42 <JBoyer> Eh, that is basically a week.
15:56:14 <Dyrcona> We have been slow getting the last couple of releases out.
15:56:36 <Dyrcona> Granted, the last one happened right before the US Thanksgiving holiday.
15:57:44 <sandbergja> How about 1/18 as the cut-off?
15:57:54 <sandbergja> Then we would have all of 1/19 and 1/20 to work on the release
15:58:23 <Dyrcona> That sounds good for now. I suppose that we could change it if necessary.
15:58:28 <JBoyer> I think that would work for me.
15:59:38 <Dyrcona> Oh! I just realized that 1/18 is a US Holiday, and I'm supposed to do a bunch of O/S upgrades that day.
16:00:00 <JBoyer> And I'm off, and csharp is upgrading, and, and. oops.
16:00:04 <Dyrcona> Moving to Ubuntu 18. It should still be OK for me.
16:00:34 <sandbergja> Hmmm... maybe we should change the date of the release?
16:00:48 <sandbergja> That sounds like a lot, no matter when we have the commit cut-off
16:00:55 <Dyrcona> Maybe. We've been consistently late anyway.
16:02:16 <JBoyer> I think pushing back the release 1 week is no problem, especially since we have to include a 1-2 day commit freeze. I'm still good with a Monday freeze, Wednesday release on 1/27 if that works with everyone else.
16:02:51 <gmcharlt> +1
16:02:53 <Dyrcona> That works for me. I was just about to suggest pushing it back a week.
16:02:59 <sandbergja> +1
16:03:27 <JBoyer> #info January releases pushed back to 2021-01-27
16:03:44 <JBoyer> That much more time to squeeze in those bugs! :)
16:04:14 <JBoyer> I just noticed it's past 4, and I thought this would be a shorter than usual meeting. Anything else to discuss before I shut it down?
16:04:17 <Dyrcona> Yeahp.
16:04:38 <Dyrcona> I updated the dev calendar, and I'll get the milestones in Lp.
16:04:46 <JBoyer> Dyrcona++
16:04:51 <sandbergja> Dyrcona++
16:04:54 <sandbergja> JBoyer++
16:04:58 <JBoyer> #topic Announcements
16:05:03 <Dyrcona> JBoyer++ sandbergja++
16:05:04 <terranm> Dyrcona++ JBoyer++
16:05:14 <gmcharlt> JBoyer++
16:05:15 <csharp> JBoyer++
16:05:19 <JBoyer> (I guess the release change would have been a good announcement, oh well.)
16:05:20 <JBoyer> #info Next Meeting is 2021-02-02
16:05:27 <JBoyer> #endmeeting