15:02:55 <JBoyer> #startmeeting 2020-02-02 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-02-02
15:02:55 <pinesol> Meeting started Tue Feb  2 15:02:55 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:55 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:55 <pinesol> The meeting name has been set to '2020_02_02___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_02_02'
15:03:01 <JBoyer> #topic Introductions
15:03:13 <JBoyer> maek info
15:03:24 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:03:27 <dluch> #info dluch = Debbie Luchenbill, MOBIUS (DIG facilitator)
15:03:28 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:34 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:03:39 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:03:41 <berick> #info berick, Bill Erickson
15:03:42 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:51 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:04:19 <stephengwills> #info stephengwills => Steve Wills, Maine Balsam Library Consortium
15:04:23 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox (partial attentino)
15:04:36 <JBoyer> Others feel free to announce yourself when popping in.
15:04:39 <JBoyer> #topic Action Items from Last Meeting
15:04:44 <terranm> #info terranm = Terran McCanna, PINES
15:04:55 <JBoyer> 1. JBoyer will poll the community about possible dev meeting times
15:05:03 <Dyrcona> #info Dyrcona = Jason Stephenson CW MARS, Inc.
15:05:04 <JBoyer> This was done to varying levels of effectiveness
15:05:09 <JBoyer> Poll is still open at https://forms.gle/ypTx2zqLbW7eVoj99 if you have not yet answered.
15:05:19 <csharp> #info csharp = Chris Sharp, GPLS
15:05:39 <mrisher> #info mrisher = Mike Risher, Catalyte / KCLS
15:06:37 <JBoyer> I should have remembered to make a ~5-10 minute announcement less than 60 minutes out. :) (I am glad to see so many folks make it today)
15:07:38 <berick> a reminder reminder
15:07:41 <JBoyer> The results of the poll are basically that the second week of the month works for everyone, and we'll probably be trying the Second Tuesday at 2pm Eastern for a while
15:08:06 <JBoyer> The Discord person can get off my lawn though.
15:08:10 <JBoyer> (I kid. ;) )
15:08:38 <Dyrcona> It the meetings move to Discord, I won't be there. I'm not kidding.
15:08:39 <abneiman> JBoyer: can someone with the power to do so update the community calendar?
15:09:14 <JBoyer> Dyrcona, I think the suggestion was 50/50 a joke, to make the community more attractive to the youths.
15:09:49 <stephengwills> what’s a yoot?
15:09:59 <sandbergja> meetings now moving to TikTok
15:10:19 <JBoyer> At least reports would be quick, heh.
15:10:20 <terranm> lol
15:10:32 <Dyrcona> :)
15:10:37 <dluch> lol
15:10:42 <berick> 2nd tuesday at 2 is the cataloging working group
15:11:05 <JBoyer> Speaking of the calendar, I think Dyrcona has access, but it would be good to know who all does, and possibly expand that group if need be.
15:11:31 <sandbergja> I think I have access
15:11:44 <terranm> Were there people who didn't want to keep it first Tuesday afternoon?
15:11:46 <Dyrcona> Yeah, I can edit the developer calendar and maybe the community calendar.
15:11:56 <phasefx> we can always make an electron app for EG and have our meetings there :)
15:12:00 <JBoyer> Well, 2pm, 3pm, AND 4pm all had the same number of votes, so we could do 3 instead.
15:12:05 <csharp> phasefx++
15:12:09 <terranm> I think I can add things to the community calendar, but not edit other peoples' events
15:12:20 <phasefx> (says the person who did embed chatzilla into the xul client once)
15:12:26 <Dyrcona> :)
15:13:04 <Dyrcona> Well, I suggested having a poll for new meeting time, because I thought we were getting  a low turn out, particularly among core committers.
15:13:14 <terranm> Ah
15:13:20 <abneiman> noting that 2nd Tuesdays at 2pm is the typical time for Cataloging Working Group
15:13:55 <Dyrcona> So, are we going with second tuesday at 3PM?
15:13:58 <sandbergja> +1 to 3pm on 2nd tuesdays
15:14:17 <JBoyer> I have typed and erased several messages.
15:14:24 <JBoyer> I should just send smaller ones I suppose.
15:15:05 <JBoyer> If there is no conflict with the second Tuesday at 3pm, lets do that. I'd really like to avoid 4 if possible.
15:15:12 <terranm> +1
15:15:23 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:15:25 <gmcharlt> +1
15:15:26 <Dyrcona> +1
15:15:34 <berick> +1
15:15:46 <mmorgan> +1
15:15:57 <JBoyer> #agreed Future meetings will take place on the second Tuesday of the month at 3pm Eastern time.
15:16:10 <JBoyer> hurrah
15:16:33 <JBoyer> So, on to the second action item from the last meeting,
15:16:36 <JBoyer> 2 sandbergja will put together a list of older bugs that need attention
15:16:57 <JBoyer> #link http://list.evergreen-ils.org/pipermail/evergreen-dev/2021-January/000082.html And it was so.
15:17:00 <JBoyer> sandbergja++
15:17:21 <mmorgan> sandbergja++
15:17:35 <terranm> sandbergja++
15:17:46 <Dyrcona> I have updated the calendar. Looks like it updated past meetings, too.
15:17:46 <Bmagic> sandbergja++
15:17:53 <mrisher> Concerning those older bugs
15:18:06 <terranm> I assume we won't be meeting next week tho?
15:18:06 <dluch> sandbergja++
15:18:34 <mrisher> 3 of them are ones that I'd like to follow up on.  I'm going to be switching assignments in a few weeks, and at that point I won't be doing Evergreen work.  I'd like to ask if anyone could please take a look at those 3 while I'm still doing Evergreen work.
15:18:48 <mrisher> Maybe it can happen during feedback fest next week.
15:19:02 <JBoyer> terranm, anyone can chat if they like but I'm not planning to do anything about next week myself.
15:19:04 <terranm> mrisher: I'm so sorry to hear that :(
15:19:13 <sandbergja> mrisher: oh man!  We'll really miss you!
15:19:24 <mmorgan> Indeed!
15:19:26 <JBoyer> mrisher++
15:19:47 <mrisher> I'll miss you too!@
15:19:53 <JBoyer> Feedback fest is a good time.
15:20:15 <mrisher> these are the 3:
15:20:18 <mrisher> Needs discussion https://bugs.launchpad.net/evergreen/+bug/1848579
15:20:19 <pinesol> Launchpad bug 1848579 in Evergreen "Angular grids: interval columns are not filterable" [Medium,Confirmed]
15:20:20 <mrisher> Needs testing https://bugs.launchpad.net/evergreen/+bug/1844169 , https://bugs.launchpad.net/evergreen/+bug/1847519
15:20:21 <pinesol> Launchpad bug 1844169 in Evergreen "Angular: Local Admin Search Filter Groups Port" [Wishlist,Confirmed]
15:20:22 <pinesol> Launchpad bug 1847519 in Evergreen "Angular: Local Admin Circulation Limit Set Port" [Wishlist,Confirmed]
15:20:47 <sandbergja> mrisher++
15:21:04 <JBoyer> In fact... I would suggest that anyone that can put together a test server (or 2) try to make sure that some of mmorgan's interesting / important bugs *and* some of sandbergja's old bugs are included, and mrisher's 3 because more Angular == more better.
15:22:05 <csharp> Oldsquash week?
15:22:10 <JBoyer> Not on every test server, of course, but I imagine there will be a handy worksheet like last time and we should try to make sure those are running *somewhere*
15:22:21 <dluch> lol
15:22:40 <mmorgan> Just a clarification on my list - those all have signoffs, do they need to have a place on a test server?
15:23:06 <JBoyer> They do not! no one bother with mmorgan's list of bugs you don't need to load on a test server! :)
15:23:21 <mmorgan> Just commit them!;-)
15:23:40 <JBoyer> That also counts as feedback fest progress, yes.
15:23:57 <JBoyer> Ok.
15:24:13 <csharp> I do think it's worth the committer's time to test an older signed-off bug, but point taken
15:24:41 <Dyrcona> I generally don't signoff and commit unless I've tested a bug fix.
15:24:52 <csharp> same
15:24:57 <Dyrcona> But, I suppose I could just commit ones that I've already tested. :)
15:25:30 <JBoyer> csharp, certainly, but FF may allow for more in-depth testing, where a committer's testing usually involves knowing that it's already been given the once-over before they looked at it.
15:26:01 <mmorgan> Make sense! I wasn't sure if committers built their own test enviroments for committing purposes.
15:26:07 <Dyrcona> I'll see if I can make time to look at some of the signed off bugs this wek.
15:26:13 <JBoyer> I also assume committers do all of their testing directly rather than asking someone else to poke at things.
15:26:24 <mmorgan> Dyrcona++
15:26:32 <Dyrcona> mmorgan: I think most of us do have our own test systems.
15:26:59 <JBoyer> Moving on, we'll skip OpenSRF updates since there's nothing on the agenda, so up next is
15:27:09 <JBoyer> #topic Evergreen Updates
15:27:58 <JBoyer> Feedback Fest discussion is basically part of this anyway, given the timing. :)
15:28:15 <berick> for 3.7, next milestone is Feature Freeze -- 3 week countdown
15:28:47 <terranm> I'm still in post-upgrade blues, so I'm behind on getting feedback fest testserver lists/info put together
15:30:22 <JBoyer> #info 3.7 Feature Freeze is 2021-02-24
15:31:25 <JBoyer> terranm, any need to reschedule or just a little behind?
15:31:32 <terranm> No, I'm just behind
15:31:44 <terranm> I'll pull it together last minute
15:31:48 <JBoyer> #info Feedback Fest is the week of 2021-02-08
15:31:52 <JBoyer> terranm++
15:32:05 <mmorgan> terranm++
15:32:10 <gmcharlt> terranm++
15:32:11 <JBoyer> #topic Security/point releases for 3.6.2, 3.5.3 and 3.4.6 on Wednesday, February 17, 2021.
15:32:18 <dluch> terranm++
15:32:28 <terranm> Bmagic: Are you willing to host a feedback fest test server next week?
15:32:44 <terranm> We'll have two as well
15:32:45 <Bmagic> sure!
15:32:55 <terranm> Bmagic++
15:32:55 <mmorgan> Bmagic++
15:33:11 <JBoyer> No good way to "undo" with meetbot.
15:33:18 <terranm> Sorry
15:33:38 <sandbergja> terranm++
15:33:39 <JBoyer> Nope, you're fine.
15:33:46 <Dyrcona> There are 3 security patches I want to roll into the point releases. IIRC, two of them are currently private.
15:34:15 <gmcharlt> I can help with tarball creation tomorrow
15:34:40 <Dyrcona> Well, we're not releasing until after feeback fest.
15:34:56 <gmcharlt> ah, then I can help afterwards!
15:35:03 <gmcharlt> (sorry, wasn't kidding about partial attention)
15:35:07 <Dyrcona> At least, that's my suggestion from an email to the developer list.
15:35:34 <Dyrcona> That's all right. I should be more prepared, I was digging out my car until just before the meeting.
15:36:32 <Bmagic> Dyrcona++ combustion_engine_cars--
15:36:34 <JBoyer> Are all 3 already signed-off? I don't recall if a specific list of potential patches has been sent to the security list (I've been meaning to put one together myself and haven't yet.)
15:36:53 <Dyrcona> Anyway, I'm requesting a commit moratorium from Noon EST on Tuesday, 2/16 until noon EST on Thursday 2/18 so that we can coordinate the mostly simultaneous release of the tarballs and announcement, etc.
15:37:03 <gmcharlt> +1
15:37:19 <Dyrcona> JBoyer: I sent a list in December that was ignored. The three that I want to release are all signed off.
15:39:01 <Dyrcona> They have also been targeted in Launchpad, so if you can see private bugs, you should be able to see them there.
15:40:11 <JBoyer> I'll check that out. May have to double check my list settings too.
15:40:22 <JBoyer> And +1 to the commit moratorium timeline.
15:40:51 <Dyrcona> The list in December was a list of all of the security bugs, but I did say that for these three, I thought they were ready to go in.
15:41:32 <JBoyer> Dyrcona++
15:42:19 <JBoyer> Any other point release discussion or questions about Evergreen updates before moving on?
15:43:12 <Dyrcona> Well, I just want that there will be a 3.4.6 security release, and if my math is correct, it has two more months of security life.
15:44:25 <Dyrcona> I also have some things I'd like reviewed during feedback fest, but I think we left that topic. :)
15:45:04 <JBoyer> We don't need to review them today, so long as they're up next week! :D
15:45:32 <JBoyer> But yes, I think you're right about 3.4.6 and the 3.4 timeline.
15:46:07 <JBoyer> (don't need to review them all, that is)
15:46:52 <JBoyer> #topic Documentation
15:46:59 <JBoyer> #info Next DIG meeting this Thursday, Feb. 4, and is on Zoom. Agenda: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20210204-agenda
15:47:26 <JBoyer> dluch, anything you'd like to add?
15:47:51 <dluch> Nope! We didn't have a meeting in January, because just me and jihpringle showed up. :-D
15:48:15 <dluch> Thanks!
15:48:19 <JBoyer> dluch++
15:48:48 <JBoyer> #topic Launchpad Status
15:48:58 <JBoyer> #info Open Bugs - 2527
15:49:06 <JBoyer> #info Pull Requests - 151
15:49:13 <JBoyer> #info Signoffs - 65
15:49:27 * mmorgan thought it would be useful to have a snapshot of the status of Launchpad bugs each meeting, so added that to the agenda.
15:49:28 <JBoyer> Thank you to whoever pulled those together.
15:49:34 <JBoyer> mmorgan++
15:49:38 <terranm> mmorgan++
15:49:41 <JBoyer> I agree!
15:49:49 <mmorgan> Any other Launchpad stats that would be helpful? I'm happy to compile them.
15:49:53 <dluch> mmorgan++
15:51:29 <Dyrcona> mmorgan++
15:51:35 <Dyrcona> I
15:51:58 <terranm> Maybe number of new bugs added since previous meeting?
15:52:00 <Dyrcona> When you're testing the branch on a Lp bug, please assign the bug to yourself.
15:52:28 <mmorgan> terranm: Good idea!
15:52:43 <terranm> Likewise, number of signoffs and pullrequests added since previous meeting?
15:52:52 <mrisher> terranm++
15:53:04 <terranm> And number of commits... you get the idea :D
15:53:15 <terranm> mmorgan++
15:53:32 * mmorgan gets the idea!
15:53:35 <Dyrcona> mmorgan: How are you getting these statistics? Are you tracking them yourself or using the Lp API?
15:53:36 <JBoyer> I think a visual indicator of progress like that would be helpful.
15:53:37 <mmorgan> terranm++
15:54:11 <mmorgan> Dyrcona: For this first snapshot, just using Launchpad search.
15:54:41 <mmorgan> Open bugs are what Launchpad reports on the main screen.
15:55:00 <mmorgan> pullrequest have that tag, but are not signedoff
15:55:14 <mmorgan> signedoff have that tag, but are not committed.
15:56:04 <Dyrcona> OK. I get the idea. :) I might look into using the APIs again for things. Seems like every time I get something working, they change the back end, and I have to start over or upgrade my Ubuntu. :)
15:57:04 <Dyrcona> It looks like we're never leaving Lp at this rate. :)
15:57:25 <jeffdavis> Or we could just close all existing bugs.
15:57:49 <jeffdavis> "moved to new bug tracker, didn't fix"
15:58:28 <terranm> heh
15:59:19 <stephengwills> wait until mmorgan has the workflows for all the new stats debugged first.
15:59:29 <phasefx> we've done that before
15:59:49 <terranm> Or we could just fix all of - 2500 bugs shouldn't be that hard, right?
15:59:52 <phasefx> (RIP Bugzilla)
15:59:53 <jeff> twice now.
16:00:00 <phasefx> (and TRAC)
16:00:10 <terranm> There's probably, like, 10 of them I could fix
16:00:38 * mmorgan bets many of those bugs no longer need to be fixed.
16:00:43 <Dyrcona> terranm: Go for it!
16:01:11 <terranm> I'll leave a few for the rest of you
16:01:37 <mmorgan> :)
16:01:44 <JBoyer> Launchpad janitorial work is still helping out, if anyone has time to look at a small subset of 2500+ bugs and determine that some don't apply anymore.
16:03:21 <alynn26> maybe the new dev group can look at some of the bugs that have been around for a while that checking on.  May be make it a meeting.
16:03:30 <JBoyer> And it seems like discussions about changing bug tracking systems (again) seem to do best in person. But, 20 people answered my poll and 18 said that specific combination of times worked for them, so if anyone wants to throw it on the agenda for March and see what happens, that's an option. ;)
16:04:12 <terranm> alynn26: good idea, I'll put that on this month's agenda
16:04:20 <JBoyer> terranm++
16:04:25 <JBoyer> alynn26++
16:04:35 <dluch> DIG has also talked about (and done some) reviewing of old bugs with the documentation label
16:04:39 <alynn26> I'll get you a list of possible bugs
16:04:46 <Dyrcona> alynn26++ # That sounds like a capital idea!
16:04:55 <terranm> alynn26++
16:04:58 <mmorgan> alynn26++
16:05:01 <dluch> alynn26++
16:05:51 <mrisher> re: "documentation label"
16:05:58 <mrisher> Is there a LP tag "documentation"?
16:06:07 <alynn26> yes
16:06:10 <dluch> yep
16:06:21 <mrisher> I do know of a bug that needs documentation help, so I should tag it appropriately
16:06:40 <dluch> Definitely! Thanks
16:06:44 <mrisher> never knew that was a tag til now
16:07:41 <JBoyer> Any other LP discussion before I move us quickly to new business and talk about LP real quick?
16:08:06 <terranm> mrisher: This list has the 'official' tags and their usage guidelines
16:08:08 <terranm> https://wiki.evergreen-ils.org/doku.php?id=dev:lp_tags
16:08:27 <mrisher> terranm:  that's useful!  thank you
16:08:39 <Dyrcona> You can also start typing in the tag box, and it will suggest existing tags. That works in search, too, I think.
16:08:44 <JBoyer> "official" also having the benefit of auto-completion in LP.
16:09:06 <JBoyer> Ok, going to move on because I
16:09:15 <JBoyer> 've kept people longer than expected
16:09:24 <JBoyer> #info New Business
16:09:30 <JBoyer> #topic New Business
16:09:35 <JBoyer> #info LP 1914116 - Query string cleanup after fixing LP 1687545
16:09:37 <pinesol> Launchpad bug 1914116 in Evergreen "An audit of query parameters is needed" [Critical,New] https://launchpad.net/bugs/1914116
16:09:38 <pinesol> Launchpad bug 1687545 in Evergreen "W3C wants query parameters standardized on ampersands; semicolons are now bad" [Medium,Fix committed] https://launchpad.net/bugs/1687545
16:10:34 <JBoyer> 545 has finally banished the semicolons from our query strings, but now we need to fix mkurl because param&copy_count becomes param(c)_count, which while amusing, does not work.
16:11:14 <JBoyer> So I just wanted to bring that up because point releases (except 3.4.6) will include 545 and should have a fix for 116.
16:12:00 <JBoyer> #topic Announcements
16:12:07 <JBoyer> #info Next Meeting is 2021-03-09 at 3pm Eastern / 12 Pacific
16:12:27 <JBoyer> I believe that's it.
16:12:30 <JBoyer> #endmeeting.