14:00:05 <dluch> #startmeeting 2021-03-04 - Documentation Interest Group Meeting
14:00:05 <pinesol> Meeting started Thu Mar  4 14:00:05 2021 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <pinesol> The meeting name has been set to '2021_03_04___documentation_interest_group_meeting'
14:00:10 <dluch> #topic Agenda
14:00:40 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20210304-agenda
14:00:40 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:00:55 <dluch> #topic Introductions
14:01:03 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:05 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:14 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:01:16 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:46 <jweston> #info jweston is Jennifer Weston, Equinox
14:04:12 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:04:20 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:04:30 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:04:40 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:04:57 <dluch> #topic Old and Ongoing Business
14:05:02 <dluch> #info Check-in - How is everyone doing? How are things where you are?
14:05:30 <jihpringle> the weather seems to have decided that we get spring :)
14:05:38 <dluch> It's gorgous, warm, and sunny here!
14:05:43 <Bmagic> I'm doing awesome over here. I can't complain
14:05:49 <dluch> Haha, here, too, jihpringle!
14:05:54 <jweston> same here -- lots of lovely sunshine
14:06:19 <dluch> Awesome! Nice change from a couple weeks ago!
14:06:21 <jihpringle> lots of piles of dirty snow too, but you just have to look above them at the blue sky
14:06:43 <dluch> Lol
14:07:18 <dluch> #info Previous Action Items
14:07:32 <dluch> How are these coming?
14:07:36 <dluch> I'll take them in order...
14:07:59 <dluch> 1. sandbergja will make a video for proof of concept in the Quick Starts section
14:08:12 <dluch> sandbergja are you around?
14:08:38 <dluch> Doesn't look like it
14:08:48 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:09:11 <dluch> 2. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:09:12 <sandbergja> I'm in two meetings in once
14:09:18 <sandbergja> And totally did not do this
14:09:24 <dluch> I see there are still a couple of Fix Me! tags on that page. This might be a good project for someone(s) during collaboration time. Were there other "Fix Me!"s that got done?
14:09:36 <dluch> Lol, no worries, sandbergja!
14:10:40 <dluch> #action https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:11:00 <dluch> 3. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it.
14:11:10 <dluch> I have not done this at all. I figured we'd go through it together somewhat, jweston, but have you gotten to this on your own at all?
14:11:20 <jweston> nothing from me on that front
14:11:42 <dluch> Okay, let's set up a time to collaborate sometime in the next month
14:12:03 <dluch> #action dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it.
14:12:05 <jweston> dluch sounds great! would be nice to get it reviewed before 3.7 is released
14:12:22 <dluch> Agreed!
14:12:30 <dluch> Then we can do it again for 3.7, lol!
14:12:37 <jweston> dluch Hooray!
14:12:50 <dluch> 4. abneiman will find and fix orphan pages and other nav issues
14:12:58 <dluch> abneiman can't be here today. She did send me a report, though:
14:12:58 <dluch> "...my focus for the next month...is to push docs for any EOLI features that are committed for 3.7. I also have a list of small fixes that I've picked up just from using the new docs interface that I will probably bundle up with those commits."
14:13:48 <dluch> I don't think this really needs another action item, so I'll move on
14:13:52 <dluch> 5. Bmagic will add “email us about this page” link to all pages
14:13:54 <dluch> Bmagic?
14:14:01 <Bmagic> that's me, and no, haven't done it :)
14:14:18 <dluch> Okee-dokee!
14:14:24 <Bmagic> I'll get to it!
14:14:27 <dluch> #action Bmagic will add “email us about this page” link to all pages
14:14:50 <dluch> 6. dluch will make a spreadsheet of all the bugs with documentation tags for people who want to do docs stuff during the Feedback Fest
14:14:53 <dluch> I did this, the first morning of the Fest. Was it helpful for anyone? (I ended up being out sick most of the week.)
14:15:29 <jweston> dluch++ it was a great list!  other working groups followed your lead (of course, I didn't work on docs but it was helpful)
14:15:37 <dluch> It seems like a nice thing to keep up, maybe, for reference.
14:15:41 <dluch> Oh, awesome! :-)
14:15:44 <jweston> agreed
14:16:02 <dluch> 7. dluch will ask sandbergja if she's willing to do a "start to finish" docs editing presentation, as a session, hackfest presentation, or later DIG Zoom meeting.
14:16:13 <dluch> I did this, too, and sandbergja said she was happy to do it! Yay! She's going to submit the idea as a program proposal for the conference.
14:16:31 <jweston> dluch++ sandbergja++ nice!
14:16:52 <jihpringle> sandbergja++ dluch++
14:16:56 <dluch> sandbergja++ :-)
14:17:21 <dluch> #info Feedback Fest...feedback
14:17:32 <dluch> As I mentioned, I ended up being sick most of that week, so didn't get to do much. Loved seeing terranm's daily updates, though. Seems like a very productive week! Anyone have comments? Or work on docs-related bugs?
14:17:42 <dluch> (Is that Terran's nick?)
14:18:50 <jihpringle> I agree, it was a very productive week. I didn't do anything doc related but I had a chance to look at some other stuff
14:18:58 <dluch> Terran++ terranm++ anyway :-D
14:19:06 <dluch> jihpringle++ awesome
14:19:29 <jweston> same impression here - it was a productive week - looking forward to Bug Squashing
14:19:44 <jihpringle> depending on what makes it in in the end I can see the admin interfaces being a big doc piece
14:19:52 <jihpringle> lots of admin interfaces being angularized
14:19:54 <Bmagic> yes!
14:20:10 <dluch> cool!
14:20:17 <jweston> absolutely lots of angularization going on!
14:20:54 <jihpringle> it seems to be mostly replicating the existing functionality, but everything looks a little different
14:21:46 <jweston> I see new screenshots in our future
14:21:55 <jihpringle> indeed :)
14:21:55 <dluch> Indeed
14:22:00 <dluch> :-)
14:22:29 <dluch> #info Online Conference
14:22:42 <dluch> The Evergreen International Online Conference is May 24-27, with the Hackfest on the 28th. For more info, including the registration link, see the conference website: https://evergreen-ils.org/conference/2021-evergreen-international-online-conference/
14:22:57 <dluch> As mentioned in #7, sandbergja is going to do a docs process presentation. Has anyone else submitted--or plans to submit--a docs-/DIG-related session? Are there any ideas folks would like to throw out for possible presentations?
14:24:21 <jweston> there is a DIG hackfest the day after the conference, too, right?
14:24:38 <dluch> Correct
14:25:01 <dluch> Alrighty! No problem. But keep thinking about it. :-)
14:25:18 <jihpringle> we should promote that, I couldn't tell from the registration if DIG was part of the hackaway or not
14:25:44 <dluch> Ah, okay, good catch
14:26:06 <dluch> We're having a conference planning meeting tomorrow, so I'll bring it up then
14:26:33 <dluch> #info Ideas for future Zoom sessions
14:26:41 <dluch> At the February meeting, we talked about some ideas of program topics for future Zoom meetings, in addition to some being just open for all collaboration. Here's what we came up with then:
14:26:41 <dluch> -Doc show & tell
14:26:41 <dluch> -Ask us anything
14:26:41 <dluch> -Have a presenter who knows about something we need to document and can demo/answer questions
14:26:57 <dluch> What other ideas do we have, if any? (and it's okay if not, for now)
14:27:41 <jweston> we could pick a section and to through it together to identify needs as an example (or that docs show & tell?)
14:28:06 <jihpringle> I like that idea - I think it's different than show and tell
14:28:29 <dluch> I was thinking docs show & tell would be more the completed docs and stuff. That's a good idea, jweston
14:28:29 <jihpringle> we could do a session on the style guide
14:28:49 <jweston> so typing is bad today -- but thanks for interpreting
14:28:57 <dluch> Ooo, yes, good idea, jihpringle
14:29:00 <jweston> jihpringle++ excellent idea
14:29:16 <dluch> jweston++ jihpringle++
14:29:21 <jihpringle> I know we have one, but I haven't looked at it in a long time :)
14:30:44 <dluch> Cool, we have some awesome ideas!
14:30:47 <dluch> Thanks!
14:30:57 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:31:25 <jihpringle> I'd be willing to do one of the topics sometime after May
14:31:48 <dluch> Yay! jihpringle++
14:31:55 <dluch> Would you like to choose which?
14:32:37 <jihpringle> sure, I'll look at the list and figure out which one makes the most sense
14:32:56 <dluch> Sounds like a plan. Thanks!
14:33:05 <jihpringle> np :)
14:33:24 <dluch> Okay, moving on...
14:33:35 <dluch> #topic New Business
14:33:44 <dluch> I don't have anything for new business. Does anyone have something they'd like to bring up?
14:35:14 <dluch> #topic Collaboration time
14:35:31 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:36:10 <jweston> dluch I'm starting list of headings from the Needs list so we can split them up to review
14:36:44 <dluch> I can take a look at those FixMe tags, unlesss someone else would like to (and someone else doing it would be TOTALLY fine ;-) )
14:36:47 <jihpringle> I'm also happy to help with the Doc Needs list, we'll be updating our docs for 3.7 over the next two months so I'll be making my own list of docs missing for 3.7 anyways
14:36:51 <dluch> jweston++ sounds good
14:37:24 <dluch> jihpringle++ that would be great!
14:37:58 <jweston> dluch jihpringle great!  I'll share link to list this afternoon
14:38:17 <dluch> Thanks!
14:38:22 <jihpringle> great!
14:40:02 <dluch> Hmm. One of the fixme tags is this question: "is the below statement still accurate? I know the PDF / HTML part is not, but curious about the rebuild timing."
14:40:02 <dluch> "Note: Changes to the official repository are processed into HTML, PDF and ePub daily at 1pm and 11pm. (see http://docs.evergreen-ils.org/)"
14:40:22 <dluch> Does anyone know the answer to this? Bmagic?
14:40:58 <Bmagic> looking
14:41:36 <Bmagic> as far as I know, the only thing that is being generated is the HTML nightly
14:41:59 <dluch> Is it always at the same time nightly?
14:46:24 <dluch> Welp, I'm totally useless for both of the fixme tags, lol. I think the other one,
14:46:24 <dluch> "the test build instructions need to be updated for Antora," is going to need Bmagic or sandbergja or alynn26 (or someone who'd not me, anyway, lol)
14:46:52 <Bmagic> around midnight
14:50:04 <dluch> Okay, thanks
14:54:47 <Bmagic> it runs 1am EST
14:57:33 <jweston> dluch jihpringle I am emailing the needs list outline to you so we can volunteer to review different parts
14:57:55 <dluch> Awesome, thanks!
14:57:56 <jihpringle> perfect, thanks!
14:57:59 <dluch> jweston++
14:59:23 <dluch> We are at time.
14:59:35 <dluch> Next meeting will be April 1, on Zoom (no foolin'). I'll send the link to the list later.  It will be primarily collaboration time. Bring a project to work on and a pet if you have one. :-)
14:59:47 <jweston> dluch++
14:59:54 <jihpringle> dluch++
15:00:02 <dluch> Thanks for being here, y'all!
15:00:14 <dluch> #endmeeting