15:01:08 <JBoyer> #startmeeting 2021-03-09 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-03-09
15:01:08 <pinesol> Meeting started Tue Mar  9 15:01:08 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <pinesol> The meeting name has been set to '2021_03_09___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_03_09'
15:01:16 <JBoyer> #topic Introductions
15:01:20 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:26 <JBoyer> New meeting time, new into time.
15:01:35 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:37 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:01:38 <eeevil> #info miker = Mike Rylander, EOLI
15:01:39 <terranm> #info terranm = Terran McCanna, PINES
15:01:40 <rhamby> #info rhamby = Rogan Hamby, Equinox
15:01:46 <shulabear> #info shulabear = Shula Link, GCHRL
15:01:51 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:03 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College
15:02:53 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Cooperative
15:02:53 <csharp> #info csharp = Chris Sharp, GPLS
15:03:17 <JBoyer> Nice to see some more names in our new time slot. Anyone else coming in later feel free to #info it up.
15:03:28 <JBoyer> With no action items from the last meeting we'll move on to Eg updates.
15:03:32 <JBoyer> #topic Evergreen Release Update
15:03:49 <JBoyer> #info 3.7 Feature Freeze tomorrow
15:04:05 <JBoyer> #link https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.7 3.7 Roadmap
15:04:13 <JBoyer> #info Bug Squashing Week March 15-19
15:04:23 <berick> #info berick Bill Erickson
15:04:41 <terranm> Bug Squashing spreadsheet is started here: https://docs.google.com/spreadsheets/d/1wCOjCAfG82ZLpCQckPmCbrUrpZZuCcZF7ECQJKQgc0c/edit#gid=0
15:04:54 <JBoyer> terranm++
15:05:02 <terranm> I'd like to suggest a BSW cleanup project of the webstaffclient tag. That would involve updating all of the bugs that have it to remove that and make sure they have a more specific tag.
15:05:10 <JBoyer> I know I need to update a couple machines for that.
15:05:41 <JBoyer> That's not a bad idea.
15:05:45 <gmcharlt> I've got several questions, but here's one to start
15:05:46 <mmorgan> terranm++
15:05:59 <gmcharlt> are we comfortable making the switch to Bootstrap as the default OPAC theme for 3.7?
15:06:51 <terranm> We've been running the Bootstrap OPAC with some minor customizations for almost 2 months now and we are happy with it. There are a few things that aren't available yet, like the curbside pickup functionality
15:07:30 <JBoyer> That's coming soon
15:08:09 <gmcharlt> https://bugs.launchpad.net/evergreen/+bugs?field.tag=bootstrap-blocker
15:08:12 <JBoyer> If we want to make *certain* that people give it a shot and report bugs rather than waiting for it to be "finished" making it the default with the option to fall back to the TPAC is probably a good idea
15:08:57 * mmorgan notices bug 1898775 which would be a blocker for us
15:08:58 <pinesol> Launchpad bug 1898775 in Evergreen "Bootstrap OPAC: Add to bucket broken" [Medium,Confirmed] https://launchpad.net/bugs/1898775
15:08:58 <sandbergja> My sense is that it's a bit of a stretch, given how thinly spread local sysadmins are right now.
15:09:25 <gmcharlt> I tend to agree with JBoyer; any strong objections to that approach?
15:09:43 <sandbergja> My preference would be to say all 3.8-targeted dev that touches the OPAC has to work with the bootstrap OPAC; and then set bootstrap as default in 3.8
15:10:11 <sandbergja> but mine is a light objection rather than a strong objection
15:11:06 <terranm> mmorgan: I think we got that working, but I'll have to go back and see what we did. It might have just been the link not getting formed correctly.
15:11:39 <mmorgan> terranm: Thanks, good to know!
15:13:08 <jeffdavis> What does "making Bootstrap the default" actually entail? Is it just a question of changing the default value for OILSWebTemplatePath ?
15:13:10 <JBoyer> I'm basically just suggesting we un-comment the 1-2 lines that currently prevent the bootstrap opac from displaying with an upgrade note detailing how to turn it back off. So long as folks know about it ahead of time it shouldn't be too burdensome, but we could use the feedback from people on the fence if that's enough to nudge them toward using it.
15:13:20 <miker> jeffdavis: aye
15:13:23 <JBoyer> jeffdavis, basically un-commenting 1 or 2 lines
15:13:31 <gmcharlt> I think we should make the switch but hold off on a formal deprecation of TPAC until 3.8, though if we do that, we should decide whether we want to say that new features aren't required to be supportded in TPAC
15:13:33 <Dyrcona> I think we have too many rewrites going on and everything feels half-baked. It should be experimental until its done, then we can have a good 4.0 release in a year or so.
15:15:38 <sandbergja> gmcharlt: holding off on deprecation, but still making bootstrap default seems good to me.
15:16:39 <JBoyer> I don't really anticipate it ever being "finished" if it's just a thing that systems play with on test servers. It would also be hard to tell devs working on opac features they have to focus on the one that's off by default or do everything twice.
15:17:15 <csharp> well, we are running it without major problems in PINES, so it's definitely beyond test server status
15:17:41 <Dyrcona> I don't think I expressed myself as well as I could have, but so be it.
15:18:24 <csharp> Dyrcona: I agree with your point that we're in a half-baked status with a lot of our major UIs: bootstrap, ang OPAC, etc.
15:19:18 <JBoyer> Heh, moving to the bootstrap opac over the course of the next couple major releases is one way to get rid of all of the dojo in the opac. :)
15:19:20 <Dyrcona> So, I'm OK with it, if we focus on dropping AngularJS, Dojo, XUL, tpac, etc.
15:19:54 * csharp watches the waves of hate for dojo emanating from his fingers as he types
15:20:20 <gmcharlt> csharp: there are laws about the handling of hazardous materials, you now ;)
15:20:25 <gmcharlt> *know
15:20:27 <csharp> heh
15:20:50 * csharp hides the chemicals from OSHA inspectors at his house
15:21:08 <JBoyer> Not being a group that's big on motions and whatnot, I would at least like some rough numbers of what people think:
15:21:42 <shulabear> Being in PINES, I can confirm that bootstrap is working well live.
15:21:42 <JBoyer> #startvote Make the Bootstrap OPAC the default in 3.7 with an easy way for systems to revert to the TPAC if desired? yes no abstain
15:21:42 <pinesol> Begin voting on: Make the Bootstrap OPAC the default in 3.7 with an easy way for systems to revert to the TPAC if desired? Valid vote options are yes, no, abstain.
15:21:42 <pinesol> Vote using '#vote OPTION'. Only your last vote counts.
15:21:54 <gmcharlt> #vote yes
15:22:02 <terranm> #vote yes
15:22:02 <shulabear> #vote yes
15:22:02 <csharp> #vote yes
15:22:03 <JBoyer> #vote yes
15:22:06 <Dyrcona> #vote abstain
15:22:09 <mmorgan> #vote yes
15:22:17 <sandbergja> #vote yes
15:22:33 <miker> #vote yes
15:22:35 <rhamby> #vote yes
15:23:06 <JBoyer> #endvote
15:23:06 <pinesol> Voted on "Make the Bootstrap OPAC the default in 3.7 with an easy way for systems to revert to the TPAC if desired?" Results are
15:23:06 <pinesol> yes (9): JBoyer, shulabear, sandbergja, mmorgan, gmcharlt, csharp, terranm, rhamby, miker
15:23:06 <pinesol> abstain (1): Dyrcona
15:24:07 <JBoyer> So it looks like the overall consensus is to aim for that. There are some patches ready or coming soon that I'm sure will help.
15:24:25 <jeffdavis> The good word from the various PINES folks about Bootstrap is encouraging.
15:24:47 <mmorgan> pines++
15:24:53 <gmcharlt> I'd like to ask about some of the roadmap entries as well
15:25:17 <gmcharlt> e.g., berick, the item editor - where do you think it stands w.r.t. the latest round of feedback?
15:25:37 * miker lines up behind gmcharlt
15:26:09 <berick> gmcharlt: i'm under some time constraints so I'm not sure about hitting the 3.7 deadline
15:26:19 <berick> but i have reviewed the feedback and it makes sense
15:26:34 <berick> note leaving the alerts, etc. out was not intentional
15:26:43 <gmcharlt> berick: that was my sense as well (re timing), but I wanted to make sure
15:27:10 <mmorgan> question about the angular editor:
15:27:11 <berick> i will update the LP soon, though, either way
15:27:30 <mmorgan> Once it goes in, there's no fallback to the current editor, true?
15:27:43 <berick> mmorgan: should still be accessible from the Classic catalog
15:27:54 <berick> or Traditional
15:28:06 <mmorgan> Ok, thanks!
15:28:30 <gmcharlt> I think geographic sorting (bug 1863252) is close, but any testers available for today/tomorrow?
15:28:31 <pinesol> Launchpad bug 1863252 in Evergreen "Wish List - Ability to sort holdings in OPAC based on geographic proximity to user specified location" [Wishlist,New] https://launchpad.net/bugs/1863252
15:28:56 <shulabear> I'd be available to test it tomorrow.
15:29:35 <gmcharlt> also noting that we found some testing issues re consolidate patron notes/alerts/message (bug 1846354); I'm personally a bit dubious about it make it in tomorrow, but I do think that we need to get it in as early as possible during the 3.8 cycle
15:29:37 <pinesol> Launchpad bug 1846354 in Evergreen "wishlist: Consolidate patron notes, alerts, and messages" [Wishlist,New] https://launchpad.net/bugs/1846354 - Assigned to Galen Charlton (gmc)
15:29:41 <gmcharlt> shulabear++
15:30:10 <gmcharlt> and a general plea for scale testers of triggered events log rewrite (bug 1207533)
15:30:11 <pinesol> Launchpad bug 1207533 in Evergreen "Triggered event log times out for large-data sites" [Medium,Confirmed] https://launchpad.net/bugs/1207533
15:30:24 <gmcharlt> miker: what did you want to bring up?
15:30:36 <terranm> We tested notes consolidation late last week and didn't find any problems, but I didn't go through all the comments to verify
15:30:42 <miker> terranm: first, thanks for all the lasso testing so far! do you think you'd have a chance to look at the record detail copy table changes on festivus?
15:30:45 <terranm> I was mainly testing conversion
15:30:57 <gmcharlt> terranm: we subsequently found issues related to it re patron merging and purging
15:31:11 <terranm> miker: Yes, I can look tomorrow if that's not too late
15:31:13 <gmcharlt> but it's definitely good that the conversion is looking good to you
15:31:23 <miker> (note, but both tpac and boopac are lasso-adjusted -- they share the relevant code)
15:31:46 <miker> terranm: thanks. as for if that's too late ...
15:31:58 <gmcharlt> csharp: DYM still building on your test system?
15:32:05 <csharp> gmcharlt: yep
15:32:12 <miker> is feature freeze tomorrow EOD or at midnight in 8.5 hours
15:32:14 <csharp> still on "identifier"
15:32:31 <csharp> 7+ days so far
15:32:37 <gmcharlt> miker: tomorrow EOD
15:32:44 <gmcharlt> csharp: just on identifier?
15:33:02 <Dyrcona> releated to miker's question, could we have a refresher what feature freeze means: patches in master, bugs targeted with pullrequest, signedoff, what?
15:33:26 <gmcharlt> Dyrcona: freeze = patches in master; slush = viable pull request
15:33:28 <JBoyer> I don't think it's been 7 days of identifier, but after 7 days it's somewhere in identifier.
15:33:35 <csharp> no - it's done title, author, series, and now on identifier
15:33:45 <gmcharlt> ok
15:33:58 <csharp> still have keyword and subject after that
15:34:07 <Dyrcona> Should we info some of these things for the minutes?
15:34:08 <miker> csharp: ugh ... I won't have time for a side-loader before EOD tomorrow, but I think that'll be necessary
15:34:42 <csharp> haha - the dym.prime.sql file is 9GB :-)
15:34:51 <csharp> didn't think to look at that before
15:36:22 <gmcharlt> I think the last roadmap bug we haven't discussed yet is bug 1901930 (SIP2 mediator)
15:36:23 <pinesol> Launchpad bug 1901930 in Evergreen "Evergreen SIP2Mediator Support" [Wishlist,New] https://launchpad.net/bugs/1901930
15:36:23 <JBoyer> Dyrcona, not a bad idea; I always thought the "feature" part was the significant bit, so no more features after tomorrow (like DYM or geosort) but smaller bugfixes would still be ok.
15:36:44 <gmcharlt> ^ yeah
15:36:54 <csharp> oooh - I keep meaning to test that and keep getting derailed (SIP2Mediator)
15:38:13 <gmcharlt> berick: out of curiosity, are you y'all running that in production (particularly with your sorter?)
15:38:46 <berick> gmcharlt: not yet.  soon, though
15:39:15 <rhamby> I had been wanting to test that so I'm willing to do so tonight / tomorrow.
15:41:20 <csharp> 52,071,071 lines in that file (wc -l took a while)
15:42:53 <gmcharlt> I'm personally a bit dubious about rushing that one in - while it /mostly/ stands off to the side, the new interface for managing SIP2 accounts could very much give the wrong impression if you don't want to jump off SIPServer right away
15:43:41 <gmcharlt> so, are there any other new feature pull requests that anybody wants to strongly advocate for putting in tomorrow?
15:44:10 <csharp> any ECDI stuff that's just sitting there? (kinda looking at terranm )
15:44:23 <terranm> Uh... I think just geosort
15:44:33 <Dyrcona> Yes, bug 1861319
15:44:35 <pinesol> Launchpad bug 1861319 in Evergreen "Allow Item Renewal on Expired Patron Record" [Wishlist,Confirmed] https://launchpad.net/bugs/1861319
15:44:56 * rfrasur is "listening in" (csharp, terranm)
15:45:25 <berick> bug 1885179 and bug 1904788 would be pretty easy to review, i think.  one is signed off.
15:45:27 <pinesol> Launchpad bug 1885179 in Evergreen "Angular staff catalog Add All Search Result to Basket option" [Wishlist,New] https://launchpad.net/bugs/1885179
15:45:28 <pinesol> Launchpad bug 1904788 in Evergreen "Staff catalog browse paging from record list support" [Wishlist,New] https://launchpad.net/bugs/1904788
15:45:46 <gmcharlt> Dyrcona: 1861319 doesn't look too scary; I'll take a look at it
15:47:03 <gmcharlt> berick: and I previwed 1885179 a while back, so I will look at it as well
15:47:21 <berick> gmcharlt++
15:47:28 <Dyrcona> gmcharlt++
15:47:47 <terranm> https://bugs.launchpad.net/evergreen/+bug/1853006 - This one would be good to get in even though it's only done for TPAC
15:47:48 <pinesol> Launchpad bug 1853006 in Evergreen "Add "limit to available" option in OPAC record view" [Wishlist,New]
15:48:08 <csharp> bug 1863252 is geosort FWIW
15:48:08 <pinesol> Launchpad bug 1863252 in Evergreen "Wish List - Ability to sort holdings in OPAC based on geographic proximity to user specified location" [Wishlist,New] https://launchpad.net/bugs/1863252
15:48:10 * mmorgan was just going to mention 1853006 :)
15:49:05 <mmorgan> Already discussed, but we are really hoping for Did you mean...
15:49:35 <csharp> mmorgan: I think miker is gonna rejigger the upgrade
15:49:47 <csharp> so probably not in time
15:49:59 <Dyrcona> I can look at bug 1207533 tomorrow.
15:50:00 <pinesol> Launchpad bug 1207533 in Evergreen "Triggered event log times out for large-data sites" [Medium,Confirmed] https://launchpad.net/bugs/1207533 - Assigned to Jason Stephenson (jstephenson)
15:50:00 <mmorgan> miker++
15:50:02 <rfrasur> also like to see 1853006 go in, and then we can look at bootstrap update to it.
15:50:04 <mmorgan> csharp++
15:51:52 <JBoyer> Looks like there's a lot of good stuff to test out tomorrow, anyone have anything else they want to bring up before we move on?
15:52:16 <JBoyer> tick
15:52:17 <JBoyer> tick
15:52:43 <JBoyer> #topic DIG evaluating outstanding 3.6 documentation and turning to 3.7
15:53:03 <JBoyer> dluch, or other DIG folks, anything to add?
15:54:33 <JBoyer> Well, I'm sure the 3.6 documentation is outstanding; here's hoping it doesn't need too much editing to be made into 3.7. (bah-dum, psh.)
15:55:36 <JBoyer> I'm not going to go into much detail on the LP stats since the hour is nearly up, but thank you to those who gathered them. ( mmorgan, sandbergja ?)
15:55:50 * mmorgan raises hand
15:55:57 <JBoyer> mmorgan++
15:56:09 <Dyrcona> FYI: There are utilities for gathering stats if you run Ubuntu: lp-tools package.
15:56:10 <mmorgan> Just want to keep some running data points on that.
15:56:36 <mmorgan> Dyrcona: Thanks, I'll take a look, that certainly would be helpful.
15:57:02 <JBoyer> Dyrcona, I saw you mentioned trying that out, does it work well with our projects? (I thought there was some issue with it in the past or something like that)
15:57:51 <Dyrcona> My issue in the past seemed to be with limits on number of requests or something like that when doing mass bug updates.
15:58:14 <JBoyer> With the discussion of the default opac in 3.7 there is one other timing / planning thing that would be good to have input on.
15:58:20 <JBoyer> #topic New Business
15:58:33 <JBoyer> #topic Schedule removal of XUL code from Evergreen
15:59:04 <JBoyer> So, probably not happening tomorrow. :) Dyrcona, did you have a timeframe in mind (3.8, etc.) or something else?
15:59:15 <Dyrcona> I did some poking and it looks like some of the Dojo code relies on XUL, so the two should be dropped at the same time.
16:00:07 <JBoyer> Mmm. Dojo can carry a larger target on its back.
16:00:16 <Dyrcona> I was thinking 3.8, but I'm less sure. We'd have to come up with replacements for some of the features that still rely on Dojo.
16:01:02 <csharp> if those can be discretely identified and bug-reported, that would help us know what we're up against (I'm happy to help with that)
16:01:50 <JBoyer> That sounds good.
16:02:27 <Dyrcona> Looking ahead, maybe we could shoot for 4.0 where everything is Angular?
16:02:36 <gmcharlt> hmm, user permission editor being a big one (of actual code under /xul/ still in use)
16:02:49 <JBoyer> Would a couple people like to take on an action item to identify and document the dojo bits so they be can be removed?
16:03:03 <terranm> Is the Reports interface using dojo?
16:03:33 <JBoyer> The only part that could is the folder page, and I don't *think* it does.
16:03:45 <Dyrcona> Since i raised the issue. I'll volunteer to document what still uses dojo and xul.
16:03:52 <terranm> Dyrcona++
16:03:54 <berick> Dyrcona++
16:03:54 <JBoyer> (have not yet checked) Though that page also needs updating
16:04:00 <mmorgan> Dyrcona++
16:04:23 <JBoyer> csharp, were you volunteering to help do that also or help remove some of them later?
16:05:19 <JBoyer> #action Dyrcona to start documenting where Dojo and XUL are still required so they can be completely removed.
16:06:25 <JBoyer> At this point in the day we may well be losing folks to the clock.
16:06:43 <JBoyer> Does anyone else have anything to add before we call it a day?
16:07:02 <terranm> I have enough to do already :)
16:07:15 <JBoyer> #topic Announcements
16:07:18 <JBoyer> #info Next Meeting is April 13, 2021
16:07:22 <JBoyer> #endmeeting