14:00:39 <dluch> #startmeeting 2021-05-06 - Documentation Interest Group Meeting
14:00:39 <pinesol> Meeting started Thu May  6 14:00:39 2021 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <pinesol> The meeting name has been set to '2021_05_06___documentation_interest_group_meeting'
14:00:51 <dluch> #topic Agenda
14:01:08 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20210506-agenda
14:01:14 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time
14:01:26 <dluch> #topic Introductions
14:01:38 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:38 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:02:31 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:02:37 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:03:31 <mantis> #info mantis is Gina Monti, Bibliomation (Connecticut)
14:05:23 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:05:39 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:05:39 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:05:39 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:05:54 <dluch> #topic Old and Ongoing Business
14:06:05 <dluch> #info Check-in - How's everyone doing?
14:06:32 <alynn26> Getting ready for the Conference.
14:06:39 <dluch> Yay!
14:07:13 <dluch> I'm bummed today because the weather keeps going between sunny and cloudy, and I just wish it would pick one or the other. :-P
14:07:24 <jihpringle> we upgrade to 3.7 in less than two weeks, so I'm deep into updating our docs :)
14:07:30 <dluch> (preferably raining, but I think it's going to miss us)
14:07:54 <dluch> Ooo, good luck with everything, jihpringle! Hope it all goes smoothly!
14:07:57 <alynn26> yeam, it's doing that here also
14:08:04 <alynn26> Good luck jihpringle
14:08:22 <jihpringle> thanks!
14:09:28 <mantis> This is my first meeting.  Wanted to see what was going on so I can join after the conference and take a look at beginning projects you all might need help with.
14:09:46 <HomerPublicLibra> First time here! Thankful for all the evergreen documentation that is available out there.
14:10:33 <dluch> Yay, mantis and HomerPublicLibra! Glad you're here!
14:10:43 <alynn26> Welcome one and all.
14:11:02 <dluch> #info Previous Action Items
14:11:16 <dluch> How are these coming?
14:11:16 <dluch> I'll take them in order...
14:11:30 <dluch> 1. sandbergja will make a video for proof of concept in the Quick Starts section
14:12:06 <dluch> I don't think sandbergja is here today...so I'll carry that one over again
14:12:20 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:12:34 <dluch> 2. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:12:45 <dluch> I see there are still a couple of Fix Me! tags on that page. I looked at them a little bit in March, but had too many questions to do any. Have any of the "Fix Me!"s gotten done or new ones added in the last two months?
14:13:41 <dluch> I'm going to take that as a "no", lol...
14:13:42 <alynn26> As for the How to contribute page, Blake and I are working that in to the actual documentation.  Not just on the wiki.
14:14:11 <dluch> #action https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:14:33 <dluch> alynn26: Bmagic mentioned that to me this morning--that's awesome!
14:14:57 <jihpringle> agreed - that's great!
14:15:34 <Bmagic> I just finished my branch for that
14:15:34 <alynn26> With a much easier way to contribute to the GitHub also.
14:15:39 <dluch> I think it'll be really helpful to have the info there, as well as on the wiki--more accessible
14:15:50 <dluch> Woot! I can't wait!
14:15:59 <Bmagic> https://bugs.launchpad.net/evergreen/+bug/1927534
14:16:00 <pinesol> Launchpad bug 1927534 in Evergreen "Docs: Need documentation on how to contribute Documentation" [Undecided,New]
14:16:12 <alynn26> Just looking at it.
14:16:23 <dluch> So, we should all go put heat on it?
14:16:55 <Bmagic> I was going to just tag it "pullrequest" once I heard from alynn26 or anyone else
14:17:04 <dluch> Sounds good
14:18:25 <dluch> #info alynn26 and Bmagic are working in the information on how to contribute documentation into the documentation and have also worked out an easier way for people to contribute to GitHub
14:18:41 <dluch> (just so it's in the minutes :-) )
14:19:04 <dluch> #info https://bugs.launchpad.net/evergreen/+bug/1927534
14:19:05 <pinesol> Launchpad bug 1927534 in Evergreen "Docs: Need documentation on how to contribute Documentation" [Undecided,Confirmed]
14:19:30 <dluch> 3. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it.
14:19:51 <dluch> jweston has done this and created a document which I have not done anything with at all, I'm sorry. jihpringle, did you do any work on it?
14:20:15 <jihpringle> I am have not :(
14:20:38 <dluch> Okay, no worries.
14:20:42 <jihpringle> it's still on my to do list but I won't have time until after the conference
14:20:49 <alynn26> Now we also need to work on 3.7
14:21:19 <jihpringle> we'll have 3.7 docs that can be copied on May 17th
14:21:27 <dluch> #action  dluch and jweston and jihpringle (and anyone else who wants to) will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
14:22:00 <alynn26> jihpringle++
14:22:02 <dluch> Thanks, jihpringle! That will be awesome.
14:22:07 <dluch> jihpringle++
14:22:43 <dluch> 4. Bmagic will add “email us about this page” link to all pages
14:22:43 <dluch> Bmagic?
14:24:10 <dluch> Oh, BTW, that previous action item would be something fairly easy for new folks to help with, mantis and HomerPublicLibra. :-)
14:24:13 <Bmagic> yep
14:24:24 <Bmagic> That is done
14:24:33 <dluch> Bmagic++
14:24:46 <Bmagic> each and every page has that in the footer, AKA: https://docs.evergreen-ils.org/eg/docs/latest/shared/about_this_documentation.html
14:25:01 <dluch> Great, thank you! I'll take that action item off.
14:25:06 <mantis> dluch: The beginner's section of the list looks very achievable thanks for compiling that!
14:25:48 <dluch> mantis++
14:26:17 <dluch> Okay, moving on from previous action items...
14:26:18 <dluch> #info Online Conference
14:26:33 <dluch> The Evergreen International Online Conference is May 24-27, with the Hackfest on the 28th. For more info, including the registration link, see the conference website: https://evergreen-ils.org/conference/2021-evergreen-international-online-conference/
14:26:57 <dluch> sandbergja is going to do a docs process presentation. alynn26 and Bmagic are doing a preconference on Antora. Anything else folks want to talk about for the conference?
14:27:46 <dluch> We are also going to have lightning rounds during the conference, so if anyone has any short docs-related things they want to present, keep that in mind! (Does anyone have any ideas?) Often, we do a DIG plug in lightning rounds. Shall we again? I'm happy to do so, but also happy to let someone else do it. alynn26 often does it...
14:28:07 <dluch> :-D
14:28:46 <Bmagic> dluch for lightning round! Here here
14:29:07 <alynn26> dluch++ for lighting round
14:29:19 <dluch> Alrighty, lol
14:29:37 <dluch> #action dluch will sign up for a lightning round slot to do a DIG plug
14:29:40 <alynn26> If you want my slides from previous ones let me know.
14:29:47 <dluch> alynn26++
14:30:39 <dluch> #info Ideas for future Zoom sessions
14:30:56 <dluch> At the February meeting, we talked about some ideas of program topics for future Zoom meetings, in addition to some being just open for all collaboration. Here's what we came up with then:
14:30:56 <dluch> -Doc show & tell
14:30:56 <dluch> -Ask us anything
14:30:57 <dluch> -Have a presenter who knows about something we need to document and can demo/answer questions
14:31:23 <dluch> We haven't actually scheduled any of these yet.
14:31:27 <dluch> So far, our Zoom DIG meetings have not been well attended. Should we go ahead and try scheduling sone of these things and see if more folks show up? Are people just Zoomed out right now and interested in a break--or a return to collaboration on IRC?
14:31:44 <dluch> I don't necessarily feel comfortable asking someone to do a presentation and then only have one person show up for it. But if we think people aren't showing up because we're not having a "program" other than collaboration time, maybe we should schedule something.
14:32:16 <jihpringle> I think if we had something scheduled for the June meeting that we could talk up at the conference we might get better attendance
14:32:29 <alynn26> i think people do not realize we are having them via Zoom. I think some may think we are only using IRC.
14:33:04 <jihpringle> agree alynn26
14:33:20 <alynn26> I think some more publicity may help.  Also making sure that the Google Calendar is up to date with where we are meeting.
14:33:44 <dluch> jihpringle and alynn26 Good points. We had talked about skipping the June meeting, but if we have something set up we can promote at the conference--sessions, lightning round, hackfest--maybe that would be better
14:34:05 <alynn26> Maybe in the lighting talk, mention we are having meetings in zoom.
14:34:18 <dluch> I can definitely do that
14:35:42 <alynn26> What is one piece of documentations that is needed that we can easily do in an hour but has not been done yet.
14:35:54 <alynn26> Or, something new to 3.7.
14:36:06 <dluch> What about something like a 3.7 docs show & tell for June? jihpringle, would you be willing to help/do something like that, since you will have just finished them? Maybe just highlight a new thing in 3.7?
14:36:49 <alynn26> And we can then push the for inclusion in Master.
14:36:59 <alynn26> s/the/ the docs
14:37:01 <dluch> And anyone else who's worked on 3.7.
14:37:19 <jihpringle> yup, I'd be happy help with that, I just might be a few minutes late for the June call - I have another call right before
14:37:24 <alynn26> I've looked at it. I know Ruth is presenting on it at the conference.
14:37:38 <dluch> jihpringle++
14:38:04 <dluch> We can always start the meeting with introductions and pet show & tell and stuff like that. :-D
14:38:20 <jihpringle> :)
14:38:44 <jihpringle> We could do Hopeless Holds if we want something smallish but new
14:39:39 <dluch> alynn26++ That's true, both Ruth and abneiman are presenting on 3.7 new features so may be willing to help, too
14:40:01 <dluch> Ooo, that would be a good one, jihpringle! Smallish, new, and exciting
14:40:21 <alynn26> I like hopeless holds.
14:40:36 <jihpringle> if you haven't seen it yet we have a 1 minute video on it - https://youtu.be/Sf6DISXuEu0
14:40:46 <dluch> jihpringle++
14:42:00 <dluch> #info DIG will have a June meeting on Zoom focusing on the Hopeless Holds feature in 3.7
14:42:26 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:43:23 <dluch> Okay, moving on...
14:43:25 <dluch> #topic New Business
14:43:48 <dluch> #info Hackfest topics/Projects
14:44:34 <dluch> I think we've done some of this above. However, what are some things we want to tackle during the hackfest on the 28th? People can always come and work on their own thing, but it also usually helps for us to have one or more things we want to focus on. Also, do we want to have any kind of formal DIG orientation, or are the two conference programs enough, do we think?
14:44:51 <dluch> Please discuss. :-)
14:46:02 <jihpringle> I think it would be good to have some kind of short formal orientation - going on the hopeful assumption that we'll have more new people come
14:46:16 <alynn26> I don't think a formal DIG orientation would be necessary. Now, if someone wants we can do the Asciidoc in 5 minutes or less presenation.
14:47:04 <alynn26> I think it will depend on the crowd.
14:47:21 <jihpringle> I'm envisioning something along the lines of welcome to DIG, here's where you can find information, this is when/where we meet etc.
14:47:27 <jihpringle> I agree, it will depend on the crowd
14:48:01 <dluch> Okay, lol, so how about I have a little "intro to DIG" planned in the instance that we have some totally new folks, and if we don't, we can skip it. And, yes, seems like Asciidoc quick tour could also be helpful, based on who comes.
14:48:15 <jihpringle> that sounds good
14:48:37 <dluch> I'm okay with playing it fast and loose, as long as everyone else is. ;-)
14:49:17 <dluch> #info Docs PDFs
14:49:18 <jihpringle> should we have a 3.7 manual set up ahead of the hackaway?  (I'm not entirely clear what we need to do for that)
14:49:30 <alynn26> the hackfest at the conference is usually fast and loose.
14:49:35 <dluch> Sorry, jumped the gun
14:50:31 <dluch> jihpringle: Like, what needs to be documented in 3.7 still? Or something based on what you've done? Not sure what you mean
14:50:44 <abneiman> Sorry, my appointment ran way long - I'll read scroll back & feel free to toss me action kittens
14:50:52 <alynn26> with antora it works a little different.  When the release is cut, the manual is cut also. We will need to backport things to 3.7
14:50:58 <abneiman> Omg items, action items, thanks phone
14:50:59 <jihpringle> https://docs.evergreen-ils.org/
14:51:08 <jihpringle> maybe we just need to be adding a 3.7 link here?
14:51:30 <dluch> abneiman, LOL. I like action kittens
14:51:59 <alynn26> No, what needs to happen is that needs updating.  To say 3.6 Forward or some such.
14:52:29 <dluch> That sounds fairly straightforward
14:52:31 <jihpringle> I can get to a version that says it's 3.7 through the 3.6 doc
14:52:33 <jihpringle> https://docs.evergreen-ils.org/eg/docs/3.7/index.html
14:52:47 <jihpringle> (I assume at this point it's likely identical to 3.6)
14:52:56 <alynn26> Yes, it is.
14:53:12 <dluch> Yep
14:54:19 <jihpringle> but since 3.7 is now released should we have the link to it so that is someone is looking for 3.7 they'll find something?
14:54:20 <abneiman> 3.7 should have the stuff I added for EOLI features - and a handful of minor fixes.
14:54:46 <abneiman> So not totally identical to 3.6
14:55:01 <dluch> Yeah, I like the idea of having the direct link for 3.7
14:55:10 <dluch> abneiman++
14:55:15 <Bmagic> The differences between "latest" and "3.7" today, are pretty much nill
14:55:33 <Bmagic> As master continues to grow away from 3.7, that will change
14:55:50 <jihpringle> who has access to add the link to the website?
14:56:17 <alynn26> We need to make sure we include milestones in the Lauchpad bugs when we add the documentation.
14:56:31 <Bmagic> I'm pretty sure I can edit that page
14:56:43 <abneiman> Yes alynn26 +1 to LP milestones
14:56:47 <jihpringle> also, we'll need to pick a new topic for June Hopeless Holds is already in the 3.7 version - I assume from abneiman
14:58:06 <abneiman> I think that actually went in for 3.6 but yes, it exists 🙂
14:58:17 <dluch> Ah, yes!
14:59:46 <dluch> We are approaching an hour. I don't mind continuing, but I want to be mindful of y'all's time. I know Bmagic has another meeting to get to, and others may, too.
15:00:05 <Bmagic> I vote that we update that page to say "3.6+" and it links to "latest" maye with a note about "you can change the version of the documentation in the bottom left"
15:00:37 <dluch> Some of the other things in new business we can move to the discussion list and/or the conference, if people prefer to end now.
15:01:29 <dluch> Bmagic, a note once they get to the latest docs or on the website page?
15:02:10 <Bmagic> "If you are looking for documentation for 3.6 and any version after that, click here"
15:02:30 <Bmagic> "You can change the version within this modern version of Evergreen documentation"
15:02:47 <jihpringle> in the bottom left corner"
15:03:36 <Bmagic> I'm in another meeting atm, sorry if I'm distracted
15:03:45 <dluch> "In this version of Evergreen documentation, you can change the version in the bottom left corner"
15:03:57 <jihpringle> perfect :)
15:04:02 <csharp> @blame Bmagic's other meeting
15:04:02 <pinesol> csharp: Bmagic's other meeting stole bshum's tux doll!
15:04:18 <dluch> or "In this Evergreen documnetation...."
15:04:28 <alynn26> dluch+=
15:04:28 <dluch> :-)
15:04:32 <alynn26> dluch++
15:05:06 <dluch> csharp lol
15:05:34 <alynn26> I think we need it both places. Because do we really want to continue to remember to update the webpage everytime.
15:05:53 <dluch> Okay, so Bmagic can edit the website with that, unless someone else has edit access and wants to?
15:06:00 <alynn26> We do seem to forget about it.
15:06:06 <HomerPublicLibra> You guys are awesome. Soaking it all in.
15:06:25 <dluch> Aww, thanks, HomerPublicLibra!
15:07:28 <alynn26> I was thinking for the June meeting, How about something that has not been documented, but needs to be.  Maybe something like the Transit List.
15:08:00 <jihpringle> or we could do searching the new staff catalogue - I'm not seeing anything about the catalog preferences, keyword, numeric etc. searches
15:08:24 <jihpringle> Transit List would also be a nice contained feature
15:08:28 <dluch> Both good ideas!
15:09:37 <alynn26> Transit list have been on my to do list.
15:09:52 <dluch> (I think I've done Transit List documentation...wlil have to go look. Maybe I just thought about it, lol.)
15:10:08 <alynn26> I have thought about it a couple of times.
15:10:39 <dluch> Well, that sounds fine to me for June
15:10:45 <jihpringle> we have it but it's never made it back to the community docs - http://docs.libraries.coop/sitka/_transit_list_2.html
15:11:26 <alynn26> That is a good example then, because it shows that we can pull from other documentation into Evergreen
15:12:46 <alynn26> jihpringle, are you still using docbook or did you switch to asciidoc
15:13:04 <dluch> So that also builds on sandbergja's conference presentation about the process of editing/contributing docs start to finish and on alynn26 and Bmagic's preconference
15:13:09 <jihpringle> we code in asciidoc and generate in docbook
15:13:15 <dluch> Which would be cool
15:14:19 <dluch> So...consensus on Transit List then, using jihpringle's existing docs?
15:14:47 <jihpringle> alynn26: I think our github repository is public - https://github.com/BCLibCoop/sitka-manual
15:14:59 <jihpringle> Transit Lists sounds good to me
15:15:18 <alynn26> Forking it now.
15:16:06 <jihpringle> our master branch is currently a mix between 3.5 and 3.7 (depending on which pieces we've updated so far)
15:16:14 <dluch> Oh, I forgot #action Bmagic will edit the docs homepage to say "If you are looking for documentation for 3.6 and any version after that, click here" and the docs to say "In this Evergreen documentation, you can change the version in the bottom left corner"
15:16:53 <jihpringle> we also have a separate repository for our acq manual - https://github.com/BCLibCoop/acq-manual
15:17:15 <alynn26> That is the one I need to read.
15:17:38 <dluch> #info The June DIG meeting instead will focus on documenting Transit List and use jihpringle's documentation to demonstrate pulling other documentation into Evergreen
15:19:44 <dluch> Okay, so we're now at almost 20 after the hour. There are two more items of new business, one of which requires Bmagic, and neither of which are super-time-critical. Shall we continue or save them for another meeting/the conference?
15:21:29 <dluch> Hearing nothing, I'm making the executive decision to table them
15:21:38 <jihpringle> sounds good :)
15:21:54 <dluch> I feel like the pdf one might be a better "in person" discussion for the conference, anyway
15:22:01 <dluch> Alrighty!
15:22:25 <alynn26> I think both of those would be better at the conference. May be part of hackaway discussion.
15:23:03 <HomerPublicLibra> Looking forward to the conference!
15:23:13 <dluch> Thanks for being here, everyone! I look forward to (hopefully) seeing you at the conference and hackfest! Our next non-conference meeting will be on June 3, on Zoom.
15:23:35 <dluch> #endmeeting