15:00:32 <JBoyer> #startmeeting 2021-06-08 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-06-08
15:00:32 <pinesol> Meeting started Tue Jun  8 15:00:32 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <pinesol> The meeting name has been set to '2021_06_08___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_06_08'
15:00:41 <JBoyer> #topic Introductions
15:00:53 <gmcharlt_> #info gmcharlt = Galen Charlton, Equinox
15:00:53 <JBoyer> Old joke, who dis?
15:00:59 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:01:02 <dluch> #info dluch=Debbie Luchenbill, MOBIUS
15:01:02 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:01:22 <rhamby> #info rhamby = Rogan Hamby, Equinox
15:01:24 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:26 <miker> #info miker = Mike Rylander, Equinox
15:01:28 <collum> #info collum = Garry Collum, KCPL
15:01:30 <berick> #info berick = Bill Erickson, KCLS
15:01:30 <terranm> #info terranm = Terran McCanna, PINES
15:01:31 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:34 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:45 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:47 <alynn26> #info alynn26 = Lynn Floyd, Evergreen Indiana
15:02:47 <JBoyer> Ok, anyone else joining later is welcome to info-up then.
15:02:54 <JBoyer> #topic Action Items from Last Meeting
15:02:59 <JBoyer> The careful observer may well be able to guess how this went.
15:03:05 <JBoyer> #action JBoyer will for-really-this-time work with csharp to update mailman settings and make an announcement to the lists ahead of time.
15:03:11 <terranm> :)
15:03:16 <dluch> lol
15:03:37 <JBoyer> That brings us to Eg release things
15:03:38 <JBoyer> #topic Evergreen Release Updates
15:03:45 <JBoyer> sandbergja wanted me to remind everyone that we're hoping to put together 3.6 and 3.7 releases on June 16th. Please fill in spot(s) on the release sheet that you can help with if available.
15:03:50 <JBoyer> And if you want to help but don't know what spreadsheet I'm talking about, ping me directly; I'd rather not share an "anyone with the link can edit" link to a publicly logged channel. :)
15:04:28 <JBoyer> I also believe we're in need of a release manager/team for 3.8.
15:04:55 <JBoyer> Anyone feeling the call?
15:05:27 <gmcharlt_> I am willing to convene a release team, but I am not willing to do it solo
15:06:18 <JBoyer> I believe that's 3 in a row. :-/ Thank you for being willing to do that.
15:06:34 * mmorgan is happy to be on a team, but still don't feel a full grasp of the process
15:06:46 <phasefx> I'm willing to help, but in the same boat
15:07:23 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:07:26 <jeff> I'm interested in assisting but will need to verify some things to avoid overcommitting.
15:08:50 <JBoyer> I'm pulled in a lot of directions but I can also help out.
15:09:21 <Dyrcona> Same here.
15:09:22 <terranm> I'm happy to continue coordinating feedback fest / bug squashing week activities with the next release team
15:09:23 <JBoyer> I can also be bumped if anyone else wants to get some experience.
15:09:37 <JBoyer> terranm++ those are very helpful.
15:10:48 <JBoyer> Ok! We have several people who've expressed at least willingness.
15:11:31 <gmcharlt_> and as a general plea: best way for commiters to help, whether or not they want to be formally on the Release Team (tm) is to review and merge pull requests
15:11:44 <terranm> +1
15:11:52 <JBoyer> In order to nail that down, is everyone ok with a team consisting of gmcharlt_ , mmorgan , phasefx , and myself? With possible assistance from jeff and or Dyrcona depending on other commitments?
15:12:05 <dluch> ReleaseTeam (tm)++
15:12:26 <JBoyer> And yes, everyone that can commit can help: test, commit, push, you've helped put the release together. :)
15:12:52 <Dyrcona> That release team works for me.
15:12:59 <rhamby> +1
15:13:05 <csharp> #info csharp = Chris Sharp, GPLS
15:13:15 * miker will do more PR merging, but not sure he should commit to joining the official team for this round
15:13:56 <JBoyer> jeff and Dyrcona, did you want to check into availability or just help push signed off branches when possible? (which is still great)
15:14:11 <JBoyer> (which would leave us with a team of 4)
15:15:11 <jeff> if you're happy with a team of four, I'm happy to help from the sidelines. I just didn't want to leave gmcharlt hanging there. :-)
15:15:22 <Dyrcona> I've often been around for releases to build a tarball or such when others have commitments.
15:15:39 <Dyrcona> Or do the bugmaster duties.
15:16:41 <csharp> happy to help with building duties too
15:16:59 <JBoyer> In the interest of having a set list today we'll go with the group of 4. gmcharlt_ , mmorgan , phasefx , everyone happy with this team while having plenty of outside help?
15:17:01 <csharp> can't commit to much with the Sharp fam off the rails right now
15:17:20 <terranm> +1 to that release team!
15:17:21 <JBoyer> csharp++
15:17:28 <gmcharlt_> +1
15:17:33 <Dyrcona> +1
15:17:42 <mmorgan> +1
15:17:59 <csharp> +1
15:18:22 <JBoyer> #agreed The 3.8 Release team is gmcharlt_ , phasefx , mmorgan , and JBoyer
15:18:33 <jeff> +1
15:18:54 <JBoyer> Anything else Evergreen release related to discuss?
15:19:19 <JBoyer> #topic Documentation
15:19:25 <JBoyer> #info June DIG was cancelled, July 8 will be a business meeting … somewhere.
15:19:41 <dluch> :-)
15:19:51 <JBoyer> dluch, I thought you could add a little more flavor to the other point than my just copypasta-ing it.
15:21:20 <dluch> Well, we had several new people come to the hackfest and learn how to/contribute new documentation. 3.7 docs are in-progress, the August Zoom meeting is going to be focused on how to submit already-created docs
15:21:33 <terranm> dluch++
15:21:49 <JBoyer> dluch++
15:22:00 <JBoyer> That does sound like a good hackfest.
15:22:15 <dluch> It was!
15:23:07 <JBoyer> If there are no questions or further discussion about docs I'll throw down the LP stats soon
15:23:32 <JBoyer> #topic Launchpad Status
15:23:37 <JBoyer> #info Total Open Bugs - 2533
15:23:41 <JBoyer> #info Total Pullrequests - 116
15:23:44 <JBoyer> #info Total Signedoff - 47
15:23:49 <JBoyer> #info New Bugs Added - 50
15:23:53 <JBoyer> #info New Pullrequest tag Added - 24
15:23:57 <JBoyer> #info New Signedoff tag Added - 9
15:24:00 <JBoyer> #info New Fix Committed - 38
15:24:08 <JBoyer> Things are moving!
15:24:14 <terranm> Nice
15:24:25 <mmorgan> committers++
15:25:00 <JBoyer> I know it would get me in trouble with rate limits, but I do wish my client would split messages with newlines rather than CP-ing each line. :D
15:25:10 <JBoyer> Ok, the main event
15:25:16 <JBoyer> #topic New Business
15:25:22 <JBoyer> #topic Results of jeffdavis's IRC poll sent to the mailing lists
15:25:25 <JBoyer> #info Should Evergreen leave Freenode for another IRC network: 25 yes, 0 no, 7 no preference
15:25:30 <JBoyer> #info Which non-Freenode IRC network do you prefer: 18 Libera, 6 OFTC, 7 no preference, 1 Discord
15:25:38 <JBoyer> We'll be Very Official and have a vote shortly but before that does anyone have any concerns, questions, etc. re: IRC and The Future?
15:25:53 <JBoyer> jeffdavis++ for putting that together
15:26:02 <mmorgan> jeffdavis++
15:26:12 <Dyrcona> jeffdavis++
15:26:14 <gmcharlt_> jeffdavis++
15:26:23 <dluch> jeffdavis++
15:26:25 <terranm> jeffdavis++
15:26:52 <miker> jeffdavis++
15:27:35 <JBoyer> Ok, hearing no concerns,
15:27:38 <JBoyer> #startvote Should the official Evergreen Community IRC leave Freenode? yes, no, abstain
15:27:38 <pinesol> Begin voting on: Should the official Evergreen Community IRC leave Freenode? Valid vote options are yes, no, abstain.
15:27:38 <pinesol> Vote using '#vote OPTION'. Only your last vote counts.
15:27:46 <gmcharlt_> #vote yes
15:27:48 <JBoyer> #vote yes
15:27:59 <Dyrcona> #vote yes
15:27:59 <jeff> #vote yes
15:28:01 <collum> #vote yes
15:28:01 <alynn26> #vote yes
15:28:02 <berick> #vote yes
15:28:04 <phasefx> #vote yes
15:28:04 <csharp> #vote yes
15:28:07 <mmorgan> #vote yes
15:28:14 <rhamby> #vote yes
15:28:17 <abneiman> #vote yes
15:28:30 <dluch> #vote yes
15:28:36 <miker> #vote yes
15:29:06 <JBoyer> #endvote
15:29:06 <pinesol> Voted on "Should the official Evergreen Community IRC leave Freenode?" Results are
15:29:06 <pinesol> yes (14): gmcharlt_, JBoyer, abneiman, jeff, phasefx, berick, collum, miker, Dyrcona, mmorgan, csharp, dluch, rhamby, alynn26
15:29:28 <JBoyer> So then, we'll need a place to go
15:29:39 <JBoyer> #startvote Which network should host the official Evergreen Community IRC channel? libera, oftc, other
15:29:39 <pinesol> Begin voting on: Which network should host the official Evergreen Community IRC channel? Valid vote options are libera, oftc, other.
15:29:39 <pinesol> Vote using '#vote OPTION'. Only your last vote counts.
15:29:49 <JBoyer> #vote libera
15:29:54 <csharp> #vote libera
15:29:54 <collum> #vote libera
15:29:55 <jeff> #vote libera
15:29:58 <miker> #vote libera
15:30:00 <abneiman> #vote libera
15:30:01 <gmcharlt_> #vote libera
15:30:02 <rhamby> #vote libera
15:30:03 <phasefx> #vote libera
15:30:10 <JBoyer> if there's enough other happening we can hash that out, but the voting mechanism isn't terribly flexible.
15:30:16 <JBoyer> Uh, not that it matters I guess. :)
15:30:17 <dluch> #vote libera
15:30:20 <berick> #vote libera
15:30:25 <Dyrcona> #vote libera
15:30:46 <alynn26> #vote libera
15:31:14 <Dyrcona> Looks like we've acquiesced to the poll results.
15:31:16 <JBoyer> #endvote
15:31:16 <pinesol> Voted on "Which network should host the official Evergreen Community IRC channel?" Results are
15:31:16 <pinesol> libera (13): gmcharlt_, JBoyer, abneiman, jeff, berick, phasefx, collum, Dyrcona, csharp, dluch, alynn26, rhamby, miker
15:32:13 <gmcharlt_> I love the smell of unanimity in the afternoon
15:32:20 <dluch> LOL
15:32:31 <Dyrcona> :)
15:32:37 <JBoyer> Ok then, so now folks can go register their nicks. libera has a nice page on how to do that if it's been too long.
15:32:52 <gmcharlt_> so, I thnk we have various implementation steps to consider
15:33:04 <gmcharlt_> 1. officially registering Evergreen as a project with Libera
15:33:09 <gmcharlt_> 2. repointing the IRC bot
15:33:13 <jeff> (s)
15:33:32 <csharp> I think a board member should probably do the registering, no?
15:33:36 <gmcharlt_> 3. somebody with op changing the FreeNode chanel topic to something that's a safe pointer
15:33:50 <gmcharlt_> yeah, I can take care of the registration (and giving the TEP board an official heads-up)
15:33:55 <JBoyer> I may have misunderstood during the conference, I thought we were already registered or we wouldn't have the single-# namespace?
15:33:56 <gmcharlt_> 4. updating the website
15:33:58 <csharp> gmcharlt_++
15:34:11 <devted> #info devted = Ted Peterson, MOBIUS
15:34:21 <dluch> gmcharlt_++
15:34:27 <gmcharlt_> JBoyer: not sure that they police that on the spot, but if we have been already registered, so much the easier for me!
15:34:37 <gmcharlt_> 5. sending a note to the mailing lists
15:34:43 <JBoyer> True, I'm sure it won't be difficult to find out.
15:34:51 <gmcharlt_> 6. (maybe) conducting a community IRC training session
15:34:56 <abneiman> gmcharlt_: does repointing the bot include logging, or is that a separate thing?
15:35:06 <devted> gmcharlt_++
15:35:07 <JBoyer> abneiman, separate bot
15:35:08 <jeff> JBoyer: nothing prevents using a single-# channel, you just have no/less claim to it if/when a project with that name comes along.
15:35:08 <dluch> training session +1
15:35:13 <gmcharlt_> abneiman: yeah, the logging bot would also need to be moved
15:35:23 <JBoyer> jeff, ah, ok.
15:35:36 <mmorgan> What handles indexing?
15:35:53 <Dyrcona> So, bshum or I should be able to point the bots.
15:35:57 <JBoyer> Though "owning" it does mean we can claim #evergreen-*, so the release channel could be official if we're interested in that.
15:36:08 <csharp> pinesol, serflog, egbuilder, pastebot
15:36:10 <pinesol> csharp: Sorry, that command is only available to Evergreen Premiumâ„¢ Subscribers. Please upgrade your subscription ASAP!
15:36:11 <gmcharlt_> yeah, we may as well move the release channel as well
15:36:23 <jeff> as can i, including ensuring that indexing is working again. we should also take a look at Google again... note-to-self.
15:36:36 <JBoyer> Oh, it's going, I just meant it could be #evergreen-release if we wanted. :)
15:36:44 <jeff> another thing to consider is renaming some of the #eg- channels to #evergreen-, or asking about multiple namespaces.
15:36:47 <gmcharlt_> ah, right
15:36:55 <Dyrcona> jeff: FYI, I'm pretty sure bshum moved them to the new VM.
15:36:55 <mmorgan> jeff++ # Such good info in the chat logs!
15:36:57 * csharp mutters something about migrating to the eg-bots server we set up a long time ago
15:36:58 <jeff> probably the rename is better than the dual-prefix
15:37:13 <gmcharlt_> csharp: such a great opportunity to do it now!
15:37:19 <csharp> gmcharlt_: agreed
15:37:30 <gmcharlt_> jeff: yeah, I tend to agree about having a single prefix
15:37:32 <JBoyer> jeff, and possibly letting some of us know what the eg- channels are, I only know of 1.
15:38:21 <jeff> JBoyer: ah, one other i was mistaken about the prefix. not #eg-
15:38:46 <JBoyer> Anyway, I'm dragging things off course. As gmcharlt_ rightly points out there are multiple steps beyond everyone reading this just doing their thing. That means action items!
15:39:10 <JBoyer> Who would like to #act out?
15:39:48 <jeff> i can cut over logging bot and check on indexing, and handle channel maintenance on this end with regard to moderating / topic / etc.
15:39:56 <gmcharlt_> #action gmcharlt will register #evergreen with Libera and inform the TEP board
15:39:57 <jeff> (those are likely different action items)
15:39:59 <Dyrcona> I could take registering and pointing the bots a libera.
15:40:08 <abneiman> I can do the website update once all the pieces are in place
15:40:33 <JBoyer> #action jeff will make sure #evergreen is logged as expected
15:40:35 <abneiman> (also there are probs some wiki pages that will need to be looked at along with the website; I can take that too)
15:40:53 <JBoyer> #action Dyrcona will look at registering / pointing the other bots at #evergreen
15:40:54 <Dyrcona> #action Dyrcona will register the bots and point them at Libera.
15:41:07 <Dyrcona> Dang! Now, I have to do it twice! :)
15:41:19 <JBoyer> #action abneiman will update the website with the new connection details
15:42:43 <JBoyer> jeff, did you want to go ahead and take the ops duties also? (I specifically left off the second half of your comment since it is indeed separate from bot maintenance.)
15:43:06 <JBoyer> Well, you did say that, my mistake there.
15:43:17 <dluch> abneiman I can help with the wiki, if you need/want it!
15:43:31 <JBoyer> #action jeff will handle freenode #evergreen orderly shutdown once the time comes
15:43:40 <jeff> yep, that works.
15:43:50 <jeff> you decided on wording before i did. :-)
15:44:19 <abneiman> dluch++ we will coordinate on that
15:44:36 <JBoyer> That leaves the mailing lists, which I can do.
15:44:57 <JBoyer> #action JBoyer will let all of the Evergreen / OpenSRF mailing lists know about the move
15:45:10 <JBoyer> The next bit is the order of operations.
15:46:49 <JBoyer> I'm thinking something like this, slightly reordered from gmcharlt_ 's points:
15:47:01 <JBoyer> 1. officially registering Evergreen as a project with Libera
15:47:01 <JBoyer> 2.1. updating the website
15:47:01 <JBoyer> 2.2. sending a note to the mailing lists
15:47:01 <JBoyer> 2.3. repointing the IRC bot
15:47:01 <JBoyer> 3. somebody with op changing the FreeNode chanel topic to something that's a safe pointer
15:47:02 <JBoyer> 4. (maybe) conducting a community IRC training session
15:47:20 <gmcharlt_> the registeration of the channel is independent of anything else; if there were another Evergreen open source project that wanted #evergreen, we presumably would have known of them by now
15:47:21 <JBoyer> Ah, it does work, just warns me that I could be banned. How... something.
15:48:52 <JBoyer> gmcharlt_, true. Then I suppose there's very little that has to be done serially other than step 3.
15:49:17 <Dyrcona> I think the bots can be pointed at multiple channels/networks, so the timing on that may be less sensitive, also.
15:49:20 <JBoyer> Though the bot/web/email steps are ideally close to each other in time.
15:50:03 <JBoyer> Dyrcona, that would be great. Or if there is a new place for them to live that they have just never been moved to there could be 2 separate sets, depending on how the bot wranglers want to deal with that.
15:50:12 <JBoyer> (temporarily)
15:50:51 <JBoyer> Alright, it sounds like we have a plan in place.
15:50:53 <Dyrcona> I recall bshum saying that he moved the bots to their new home after the confernece.
15:51:05 <JBoyer> Ah, so much for that option. :)
15:51:28 <JBoyer> jeff++ Dyrcona++ abneiman++ gmcharlt_++ dluch++
15:51:47 <JBoyer> One last thing before we adjourn
15:51:54 <JBoyer> #topic Interest in an officially bridged side-channel?
15:52:02 <JBoyer> This is obviously not the place to make a final decision on this topic, but I would like to hear some thoughts on there being a "semi-official" Evergreen discord or slack channel, etc. that would be bridged to the IRC channel such that messages go both ways.
15:52:07 <JBoyer> As an example see #code4lib on libera. (Though they have more of these than I would be interested in.) This would allow people to use the client / service they're most comfortable with while not dividing community discussion.
15:52:10 <gmcharlt_> to suggest a D-Day: 6/14?
15:52:16 <JBoyer> My assumption would be that ultimately choosing one of these would be settled over the mailing lists because the folks comfortable with IRC are already here. :)
15:52:42 <JBoyer> gmcharlt_, That seems reasonable given the split in duties.
15:53:00 <Dyrcona> I'm not opposed to a bridged side channel.
15:53:12 <JBoyer> Now that I've clouded up the discussion with more copy pastawater can everyone do their thing this week?
15:53:14 <gmcharlt_> I would be -1 to a Slack bridge; Slack, as a tool that ultimately assumes that an HR department exists as the Moderator of Record, does not provide much in the way of community or self-moderation tools
15:53:35 <Dyrcona> I was thinking of 6/15 for the date, but...
15:54:12 <jeff> in my experience when seeing groups bridge IRC and Slack, it tends to kill the IRC channel. Also, seconding Slack's unsuitability for communities.
15:54:12 <JBoyer> Slack also wants to be a whole "network" and we don't want channels splitting off and getting lost.
15:54:14 <gmcharlt_> I've no objection to 6/15
15:55:30 <JBoyer> Are there any Discord users here? I don't know if it's like Slack or more single-channel.
15:55:44 <JBoyer> (It also seems to be the only one that keeps coming up)
15:55:46 <dluch> So, Discord? From a personal and DIG perspective, I definitely would support a side channel
15:55:48 <Dyrcona> I've no objection to 6/14, either. I was just thinking 1 week from today.
15:56:11 <gmcharlt_> @coinflip Monday or Tuesday
15:56:11 <pinesol> gmcharlt_: https://i.imgur.com/m8EySrW.gifv
15:56:13 <dluch> I use Discord for personal stuff, but it's been recent, so I don't know that much about it, lol
15:56:27 <gmcharlt_> unhelpful cat is unhelpful
15:56:29 <csharp> it's where the youngs live
15:56:35 <dluch> Yep
15:56:38 <jeff> JBoyer: yes, Discord has the same issue of multiple channels silo'ing off
15:56:44 * csharp is one of the olds :-)
15:56:45 <JBoyer> Mmm. :-/
15:57:01 <JBoyer> So does Matrix, really. (my preference for not-slack slack)
15:57:08 <Dyrcona> I thought Discord was for gamers.... :)
15:57:12 <rhamby> I've used discord and it's a perfectly feasible chat forum with extra stuff
15:57:13 <csharp> as in, my kids are always on Discord
15:57:35 * csharp shakes fist at kids on his lawn
15:57:36 <rhamby> the culture of discord reminds me of theh old fido net BBS days with so many specialized boards
15:57:44 <jeff> Dyrcona: that is their original and arguably still-primary focus, though they are trying to get away from it after their acquisition by Microsoft fell through.
15:57:47 <JBoyer> Anyway, that's for the email list, I really only wanted to make sure there wouldn't be wailing and gnashing of teeth at the idea today.
15:58:12 <gmcharlt_> yeah, I think there's a broader question of considering a chat platform with less of a barrier to entry than IRC... but possibly ultimately as a replacement for IRC, not a side-channel for all of the community-splitting reasons
15:59:01 <JBoyer> I'll put together a poll for that too.
15:59:12 <Dyrcona> I don't understand this barrier to entry for IRC that everyone talks about? You can type? You can use IRC. It's no really any different from any other chat thingy.
15:59:46 <JBoyer> #action JBoyer will ask the email lists about possible side channels and interest therein
15:59:54 <csharp> Dyrcona: I just had the exact same thought, but obviously there's *something* that makes people uncomfortable :-)
16:00:01 <gmcharlt_> but if you want a bouncer... you're on your own
16:00:10 <gmcharlt_> which I think is one of the main usability problems
16:00:31 <gmcharlt_> also, network effects are real, so to speak
16:00:39 <jeff> I'd like to avoid bridging in general if we can, with the possible exception of Matrix users using the Libera matrix bridge.
16:01:22 <devted> Mattermost (another open source Slack competitor that can be customized)? or Clickup?  (the Chat View with paid plan)
16:01:51 <JBoyer> Yeah, I use ZNC to keep me current on all of my channels just like I want IMAP-like email, everywhere. I can see the appeal of an app just having all of that.
16:02:36 <JBoyer> jeff, would that require an evergreen matrix room
16:02:37 <JBoyer> ?
16:02:47 <rhamby> if we're looking at ease of use and access then I think anything that we have to explain how it's an open source competitor and if you just go find a certain client you can configure it ..... probably isn't what we want
16:02:50 <JBoyer> (I haven't been following that stuff that closely)
16:03:08 <Dyrcona> If it isn't OpenSource. I'm not there.
16:03:19 <rhamby> if we want ease of use it needs to be "go to your phone's app store click install and put in this server name and you're done"
16:03:34 <Dyrcona> cf. What I said before the meeting about using Google, et. al.
16:03:35 <jeff> JBoyer: it's one of the only bridging options I've seen that doesn't present everyone on the far side of the bridge as a single nickname/client on irc.
16:03:37 <JBoyer> Matrix does have that benefit, along with the OSS.
16:03:52 <jeff> JBoyer: other than that, I don't know enough about Matrix yet to speak to your question.
16:03:58 <JBoyer> jeff++
16:04:16 <jeff> rhamby: that seems like a gross oversimplification.
16:04:42 <rhamby> jeff: in what way?
16:04:45 <jeff> rhamby: unless you're advocating that we publish our own chat app which uses Google/Apple auth, at which point I have objections. :-)
16:04:56 <JBoyer> Ok, lots of communicating to do. We don't have to decide if / what *else* to do today, because like I said, the primary audience for that discussion isn't in here anyway. ;p
16:05:05 <gmcharlt_> indeed
16:05:23 <gmcharlt_> also, we might want to have some discussion about desiderata before putting out a poll
16:05:50 <rhamby> no, I'm saying the barrier to entry needs to be low and existing apps with large user bases are probably going to be more useful than most other options
16:05:55 <jeff> the other angle to this is that instead of replacing the IRC channels we might replace the mailing lists.
16:06:15 <gmcharlt_> jeff: i.e., the Discourse approach?
16:06:25 <JBoyer> Yes, and it's not something that needs to be done in the same timeframe either. We're definitely moving to Libera this week, other things will happen later out of necessity.
16:06:44 <jeff> but I'm not sure how we measure benefit from an option like a web forum if our audience is "people for whom the mailing lists work" and "people for whom IRC works" :-)
16:07:41 <jeff> nor how we prove the existence of portions of the community who would benefit from and contribute to meaningful communications via a not-yet-in-existence community channel. :-)
16:08:22 <jeff> it's a non-unique non-trivial issue, and I have no clear suggestions or answers.
16:08:52 <Bmagic> Discord is great IMO. IRC is also great. And coming from an IT support perspective, seeing users use computers, I can say that IRC has a "techy" feel to it, which pushes many away. Humans want "easy to see" "easy to look at" interfaces with zero barriers (like memorizing commands, etc)
16:09:48 <rhamby> we've heard from a large segment of the evergreen community for years that irc isn't comfortable for them, hence why many meetings have moved off it
16:09:56 <Bmagic> Discord / Slack has the "all in one" brand. IRC is "use whatever client" - confusing the matter
16:10:17 <gmcharlt_> so, other meeting topics to discuss?
16:10:20 <JBoyer> For now we'll focus on moving this channel, then we'll discuss possible other things. I really just wanted people to start thinking about things today. (And the discussion can continue right after this!
16:10:24 <miker> the web client libera has looks very discord/slack-y, fwiw
16:10:31 <JBoyer> #topic Announcements
16:10:35 <Dyrcona> Discord/Slack has vendor/network lockin. It's as bad as Facebook.
16:10:35 <JBoyer> #info Next meeting is July 13th, 2021
16:11:02 <JBoyer> Barring any urgent dev stuff, I now return your to your discussion already in progress. :D
16:11:04 <JBoyer> #endmeeting