14:00:11 <dluch> #startmeeting 2021-07-08 - Documentation Interest Group Meeting
14:00:11 <pinesol> Meeting started Thu Jul  8 14:00:11 2021 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <pinesol> The meeting name has been set to '2021_07_08___documentation_interest_group_meeting'
14:00:21 <dluch> #topic Agenda
14:00:46 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20210708-agenda
14:00:54 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:01:01 <dluch> #topic Introductions
14:01:10 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:01:11 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:20 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:34 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:02:04 <mantis> #info gmonti is Gina Monti, Bibliomation
14:02:45 <dluch> jihpringle let me know that she wasn't going to be able to make it today
14:03:22 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:03:38 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:03:38 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:03:38 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:03:50 <dluch> #topic Old and Ongoing Business
14:03:50 <dluch> #info Check-in - How's everyone doing?
14:04:22 <mantis> Pretty good! I started contributing to the small projects finally
14:04:38 <abneiman> I'm OK, but my cats are mad that we're under Kitty Tropical Storm Protocol, which means everyone is inside and this is a Grave Injustice.
14:04:42 <abneiman> mantis++
14:04:44 <dluch> mantis++
14:04:47 <alynn26> Good. back in office full time
14:05:12 <dluch> abneiman: Oh, my! Grave Injustice, indeed. lol
14:05:29 <mantis> alynn26++ for giving me great advice on using the GitHub
14:06:07 <alynn26> mantis, anytime.
14:06:15 <dluch> mantis: I realized that you had emailed me a very long time ago and I was in the middle of a big project and completely forgot to get back to you. I'm sorry!
14:06:28 <mantis> dluch not a problem!
14:06:57 <alynn26> mantis++ for making contributions.
14:07:11 <dluch> I'm back in the office 2 days a week now, usually. Still weird.
14:09:15 <dluch> #info Previous Action Items
14:09:28 <dluch> How are these coming?
14:09:28 <dluch> I'll take them in order...
14:09:46 <dluch> 1. sandbergja will make a video for proof of concept in the Quick Starts section
14:09:46 <dluch> sandbergja isn't here, I don't think, so I'll keep carrying that over
14:09:58 <dluch> #action sandbergja will make a video for proof of concept in the Quick Starts section
14:10:15 <alynn26> there are some videos that were added to the youtube channel
14:10:19 <dluch> 2. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:how-to-contribute-documentation has fixme tags that need to be addressed
14:10:44 <dluch> There were two left, as of Tuesday.
14:11:14 <dluch> I meant to ask Bmagic to update the one about build instructions for Antora, but forgot.
14:11:53 <dluch> Anyone else interested in taking those on? (If not, I'll voluntell Bmagic to do them.)
14:12:36 <dluch> alynn26 none of the added videos were about that Quick Starts section thing, though, were they?
14:12:55 <alynn26> I would have to go look.
14:12:57 <dluch> But ++++ for all the video contributors!
14:13:11 <dluch> 3. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
14:13:18 <dluch> I have still done nothing with the document jweston created or met with her. I'm sorry! Will add this to my priority list for this month.
14:13:37 <dluch> #action dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
14:13:53 <dluch> 4. dluch will sign up for a lightning round slot to do a DIG plug.
14:14:00 <dluch> I did this! Thanks to alynn26 for sending me the slides she'd used before so I had a starting place!
14:14:10 <dluch> alynn26++
14:14:46 <dluch> #info Online Conference--Docs Recap
14:15:01 <dluch> The Evergreen International Online Conference was May 24-27, with the Hackfest on the 28th.
14:15:09 <dluch> You can find links to the session recordings and slides on the conference website, at https://evergreen-ils.org/conference/2021-evergreen-international-online-conference/2021-schedule/2021-program-descriptions/
14:15:25 <alynn26> I just looked at Youtube.  There are several quick start videos loaded.
14:15:25 <dluch> Thanks to sandbergja, alynn26, and Bmagic for doing doc-related sessions! We also had a great hackfest, with several new people dropping in and working on documentation. Yay!
14:15:32 <alynn26> https://www.youtube.com/watch?v=9E6qIzVCDe0
14:15:33 <dluch> Anything else folks want to talk about related to the conference?
14:15:40 <dluch> Thanks, alynn26!
14:17:15 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:17:36 <dluch> Okay, moving on...
14:17:38 <dluch> #topic New Business
14:17:48 <dluch> #info Docs PDFs
14:18:01 <dluch> This was a topic we didn't get to at the May meeting. There's been a question about where our pdfs are for the newer docs.
14:18:12 <dluch> At our August 2020 meeting, that topic came up, and Bmagic noted that having a pdf option native in Antora was on the roadmap: https://docs.antora.org/antora/2.1/project/roadmap/
14:18:23 <dluch> However, it doesn't seem like much has been done since then: https://gitlab.com/antora/antora/-/issues/349.
14:18:35 <dluch> Does anyone have other information or ideas related to the pdfs? Is it something we maybe want to have Evergreeners tackle for the Antora community?
14:19:51 <dluch> Or, we can discuss at a future meeting
14:20:18 <abneiman> I know there's been some community request for PFDing, but does anyone have a sense of the needed lift to make this happen for Antora?
14:20:47 <abneiman> I mean, I think it would be a great thing if someone among us could contribute this to Antora, but I have no sense of the needed scope
14:21:10 <dluch> I don't. Bmagic might, but appears to be at lunch, presently
14:21:39 <dluch> Okay, let's hold off on this discussion, then, for now
14:21:41 <alynn26> abneiman, there is some information in the issue information.
14:22:08 * abneiman did not read the entire issue thread
14:22:25 <alynn26> I scanned most of it.
14:23:04 <dluch> It's been almost 2 months now, since I looked at it, so remember basically nothing.
14:23:06 <abneiman> so what's your sense, alynn26? feasible for an Evergreener?
14:25:13 <dluch> I'm going to go ahead and add for next time
14:25:13 <dluch> #action DIG will investigate Antora's pdf roadmap and its feasability for Evergreeners to do, and/or other ideas about pdfs
14:25:39 <alynn26> I will do some additional research. to see.
14:25:51 <alynn26> In another meeting also.
14:26:08 <dluch> alynn26++
14:26:08 <dluch> #info Show and Tell Topic for October
14:26:20 <dluch> At the October Zoom meeting, we'll be having a demonstration on how to contribute documentation you've already created for something else (aka, your home library/consortium/district), from jihpringle and alynn26.  Do you all have anything you want to add? :-)
14:27:03 <dluch> Oops, lol, jihpringle isn't here. She said she is still willing to do it, though :-)
14:27:20 <dluch> I'm excited!
14:27:38 <alynn26> We have not even talked about so, no comments currently.
14:27:51 <alynn26> Thanks for the reminder.
14:27:57 <dluch> Okee-dokee
14:28:06 <dluch> #info Updating directory of IRC usernames: https://wiki.evergreen-ils.org/doku.php?id=community:irc_channel
14:28:13 <dluch> Gina?
14:28:23 <dluch> mantis
14:28:27 <dluch> (sorry)
14:28:36 <mantis> I was talking to someone off list and realized that this is pretty outdated
14:28:51 <mantis> Just wanted to bring that up; not sure what the best way to propose gathering info
14:29:30 <dluch> Cool. DIG does not maintain the wiki pages, though it does need updating. The Outreach Committee has been working on wiki page updates. abneiman, is that a page that has been looked at yet?
14:29:40 <abneiman> not AFAIK
14:29:48 <abneiman> but gosh is it outdated
14:29:59 <mantis> I could bring this up during Outreach if that's preferable
14:30:10 <abneiman> at the very least we might want to split the table between current/active and former users
14:30:11 <alynn26> That works for me.
14:30:21 <dluch> And we can all help out and go make sure ours are correct, however. :-)
14:30:32 <dluch> abneiman, yeah good idea
14:30:40 <alynn26> Mine is.  Yeah.
14:31:00 <mantis> Alrighty I'll bring this to the outreach meeting but thanks for taking time to look at it
14:31:04 <abneiman> I think otherwise, maybe reminding newer community members that that page is a(n optional) thing, if they want to add themselves?
14:31:21 <dluch> mantis++
14:31:36 <dluch> abneiman sounds reasonable
14:32:02 <dluch> (also, abneiman sounds reasonable. lol)
14:32:12 <abneiman> hahahaha
14:32:27 <alynn26> ++
14:32:36 <dluch> Is there any other new business for the good of the order?
14:32:55 <abneiman> yes - apologies for not adding to the agenda
14:33:05 <dluch> abneiman: go ahead
14:33:10 <abneiman> (and this may pivot into collab time nicely, anyway)
14:33:33 <abneiman> but two things I've noticed - one is that the index page is not generating: https://docs.evergreen-ils.org/eg/docs/latest/shared/index.html
14:33:37 <abneiman> (and hasn't for a while)
14:34:05 <abneiman> and two, is that anything that is a heading 4 ==== or lower is not rendering properly in Antora
14:34:34 <abneiman> (or rather, is not formatting in any special way)
14:34:39 <alynn26> if I remember correctly there is an issue with the index generation with Antora.  I am trying to remember what it is.
14:35:15 <alynn26> Can you give me an example for heading 4.
14:35:54 <abneiman> see for example on the 2nd issue, this page: https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record and the subheading "Sort By Geographic Proximity" which doesn't have heading formatting or a link in the right-hand (or top-of-page) TOC
14:37:15 <abneiman> (not a great example becaues really, that page should probably be split into a couple pages, but it's the one I had handy)
14:37:39 <dluch> Hmm. Yes, I see
14:37:58 <abneiman> anyway, I don't know how to fix either, but I wanted to bring them to the attention of the group
14:38:19 <dluch> abneiman++
14:38:26 <alynn26> for the right side, I think it is an antora setting that does that.  As for the actual display, I think it mostlikely is something not set up in the CSS.
14:38:53 <dluch> I can make another generic action item so we don't forget, if that seems useful
14:39:19 <alynn26> I think an action item would be good. for both issues. Headings 4 and The index.
14:39:54 <abneiman> +1 to action item(s)
14:40:00 <dluch> #action DIG will investigate the index page not generating: https://docs.evergreen-ils.org/eg/docs/latest/shared/index.html
14:41:04 <dluch> #action DIG will investigate why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:41:52 <dluch> Anything else?
14:43:04 <dluch> Alrighty, then...
14:43:09 <dluch> #topic Collaboration time
14:43:22 <dluch> What is everyone planning to work on today?  Please let us know here, and feel free to talk and work with each other.  If you'd like extra accountability, I can make an action item to show up in the minutes, but it's not necessary.
14:44:44 <dluch> I just discovered that I have gel soap under one of my fingernails, because I  stuck it in my mouth. I am going to go rinse it off real quick. *facepalm*
14:45:21 <abneiman> I found a couple more orphan pages that I'm going to give homes to.
14:45:57 <dluch> abnieman++
14:46:12 <abneiman> Oh, and last week I updated the LSE table to include jump-to links, because I was reading a lot in that table and the lack of said links were irritating me: https://docs.evergreen-ils.org/eg/docs/latest/admin/librarysettings.html#settings_overview
14:46:51 <alynn26> cool, that was a feature I was wanting to add to it.
14:46:51 <abneiman> I only backported it to 3.7 thought since the commit was foolishly bundled with some 3.7+ stuff /facepalm
14:46:52 <dluch> Oh, very nice!!
14:47:21 <mantis> I was eyeing this TLD one https://bugs.launchpad.net/evergreen/+bug/1837753
14:47:21 <pinesol> Launchpad bug 1837753 in Evergreen "Docs use acronym TLD without defining it" [Undecided,New]
14:47:31 <dluch> mantis++
14:47:50 <mantis> But I'm unsure what the goal is unless it's a very simple "This means this" addition
14:48:30 <dluch> Yep, I think that's it.
14:48:41 <abneiman> mantis: maybe change the first instance to read "top-level domain (TLD)", and also add it to the glossary?
14:49:01 <dluch> Lol. I was just about to say the same thing!
14:49:07 <mantis> there was a suggestion to add some explanation of this but I was just unsure what to say unless what is provided as one of the comments is appropriate
14:49:37 <alynn26> I think I actually have done this, but it's not commited yet.
14:51:30 <dluch> I don't know about defining it on the page, since the references are in code blocks. But maybe in the glossary
14:52:03 <mantis> I'll work on it and if it's a duplicate edit, you can just delete my pull request
14:52:18 <dluch> ++
14:52:22 <jeff> I'd suggest that "Multiple TLDs for Branch 1" be changed to "Multiple hostnames for Branch 1" and "Branches 2 and 3 don't have alternate TLDs" to "Branches 2 and 3 don't have alternate hostnames"
14:53:00 <abneiman> jeff
14:53:04 <abneiman> jeff++
14:53:10 <dluch> jeff++
14:53:25 <dluch> eliminates the problem completely, lol
14:53:38 <alynn26> jeff++ , that actually makes more since.
14:54:05 <alynn26> I cannot find it in my branches anyway.
14:55:00 <mantis> jeff++
14:55:06 <mantis> Does anyone know the file path for this page?
14:57:54 <abneiman> mantis: looking, sec
14:59:28 <abneiman> mantis: docs/modules/admin/pages/apache_rewrite_tricks.adoc
15:00:28 <abneiman> here's the Antora page: https://docs.evergreen-ils.org/eg/docs/latest/admin/apache_rewrite_tricks.html
15:00:38 <mantis> thanks so much
15:00:46 <dluch> We are at time. But feel free to continue working and collaborating! :-)
15:00:56 <dluch> Our next meeting will be on August 5, on Zoom. I'll post the link on the agenda about a week prior to the meeting.
15:01:04 <dluch> Thanks for being here, everyone!
15:01:13 <dluch> #endmeeting