#evergreen: 2021-09-02 - Documentation Interest Group Meeting

Meeting started by dluch at 14:00:42 US/Eastern (full logs).

Meeting summary

  1. Agenda (dluch, 14:00:52)
    1. The agenda can be found here: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20210902-agenda (dluch, 14:01:13)

  2. Introductions (dluch, 14:01:26)
    1. dluch is Debbie Luchenbill, MOBIUS (dluch, 14:01:26)
    2. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 14:01:45)
    3. jihpringle is Jennifer Pringle, BC Libraries Cooperative (jihpringle, 14:01:52)
    4. alynn26 is Lynn Floyd, Evergreen Indiana. (alynn26, 14:01:53)

  3. Helpful Information: Documentation contributions and collaboration (dluch, 14:03:12)
    1. You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs (dluch, 14:03:12)
    2. DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants (dluch, 14:03:12)

  4. Old and Ongoing Business (dluch, 14:03:22)
    1. Check-in - How's everyone doing? (dluch, 14:03:38)
    2. jweston is Jennifer Weston, Equinox (jweston, 14:04:22)
    3. mantis = Gina Monti, Bibliomation (mantis1, 14:05:43)
    4. Previous Action Items (dluch, 14:06:37)
    5. Bmagic = Blake GH, MOBIUS (Bmagic, 14:07:29)
    6. ACTION: dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7. (dluch, 14:09:39)
    7. https://docs.antora.org/antora/2.1/project/roadmap/ (alynn26, 14:11:09)
    8. https://docs.antora.org/antora/3.0/whats-new/#antora-3-0-0-alpha-8 (alynn26, 14:16:05)
    9. ACTION: alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site (dluch, 14:26:00)
    10. asciidoc extension examples under antora-pdf here: https://gitlab.com/djencks/antora-extension-examples (dluch, 14:27:02)
    11. several work arounds here: https://gitlab.com/antora/antora/-/issues/349 (dluch, 14:27:14)
    12. ACTION: alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record (dluch, 14:33:31)
    13. abneiman filed an LP about the index page not generating: https://bugs.launchpad.net/evergreen/+bug/1941917 (dluch, 14:38:11)

  5. New Business (dluch, 14:38:39)
    1. Show and Tell Topic for October: Same as August (dluch, 14:38:48)
    2. Docs organization: Review and Re-organize (dluch, 14:41:02)
    3. ACTION: jweston will ask for assistance on docs review from the interest groups for review and recruitment (dluch, 14:46:34)
    4. ACTION: jihpringle will set up a spreadsheet for tracking documentation review (dluch, 14:48:02)
    5. https://docs.google.com/spreadsheets/d/1nPD0_blC51wVcYJsdQqGYFoRrlcGmbmqbZlrlosaHgE/edit?usp=sharing (jihpringle, 14:48:02)
    6. jihpringle has already created the spreadsheet :-D (dluch, 14:48:40)
    7. Link Bmagic and alynn26's conference presentation to the "How to Contribute" documentation (dluch, 14:53:46)
    8. Maybe other relevant videos, too, like Chris's reports one, etc. (dluch, 14:54:00)
    9. How should documentation be in the navigation of the new website design? (dluch, 14:56:29)
    10. if any DIGgers have suggestions for a top-level menu name that encompasses All The Learning Things ... please share with Outreach (me, jweston, dluch, et al.) (dluch, 15:09:13)
    11. if any DIGgers have suggestions for a top-level menu name that encompasses All The Learning Things ... please share with Outreach (abneiman, jweston, dluch, et al.) (dluch, 15:09:36)
    12. DIGgers present at the meeting like "Learning Library" (dluch, 15:12:07)
    13. http://www.technicaloverload.com/compare-two-files-using-notepad/ (abneiman_web, 15:14:38)
    14. abneiman discovered that There's a "compare" plugin available so just in case you need to compare two 1000+ line adoc files... it gives you a easy-to-understand visual diff between the two http://www.technicaloverload.com/compare-two-files-using-notepad/ (dluch, 15:15:01)


Meeting ended at 15:16:12 US/Eastern (full logs).

Action items

  1. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
  2. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
  3. alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
  4. jweston will ask for assistance on docs review from the interest groups for review and recruitment
  5. jihpringle will set up a spreadsheet for tracking documentation review


Action items, by person

  1. alynn26
    1. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
    2. alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
  2. Bmagic
    1. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
  3. dluch
    1. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
  4. jihpringle
    1. jihpringle will set up a spreadsheet for tracking documentation review
  5. jweston
    1. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
    2. jweston will ask for assistance on docs review from the interest groups for review and recruitment


People present (lines said)

  1. dluch (130)
  2. alynn26 (37)
  3. jihpringle (25)
  4. abneiman_web (21)
  5. jweston (20)
  6. abneiman (16)
  7. jweston6 (7)
  8. pinesol (6)
  9. Bmagic (2)
  10. rhamby_ (1)
  11. mantis1 (1)


Generated by MeetBot 0.1.4.