15:02:26 <JBoyer> #startmeeting 2021-09-14 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-09-14
15:02:26 <pinesol> Meeting started Tue Sep 14 15:02:26 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:26 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:26 <pinesol> The meeting name has been set to '2021_09_14___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_09_14'
15:02:36 <JBoyer> #topic Introductions
15:02:44 <JBoyer> new meeting, who dis?
15:02:58 <terranm> #info terranm is Terran McCanna, PINES
15:02:59 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:03:01 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:03:15 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:16 <shulabear> #info shulabear is Shula Link, GCHRL/PINES
15:03:17 <gmcharlt> #info gmcharlt = Galen Charton
15:03:50 <rfrasur> #info rfrasur = Ruth Frasur, Evergreen Indiana/ECDI
15:03:51 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:03:55 <berick> #info berick = Bill Erickson, KCLS
15:04:06 <jeff> #info jeff = Jeff Godin, Traverse Area District Libra│······
15:04:09 <jeff> ry (TADL)
15:04:12 <jeff> hah!
15:04:24 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:04:56 <JBoyer> Ok, anyone joining later feel free to throw an #info out.
15:05:02 <JBoyer> #topic Action Items from Last Meeting
15:05:20 <JBoyer> JBoyer will exercise the staff client in a current release of Edge, and JBoyer will look at adding Edge on Windows support to the Hatch installer
15:05:25 <JBoyer> Edge testing not being especially high on my list I have not made time to properly put it through its paces.
15:05:32 <JBoyer> berick has shown though that it can be done without much trouble, so hatch installer changes shouldn't be too bad.
15:05:37 <JBoyer> If anyone else would like to look into this please let me know, lest I action again.
15:06:02 <JBoyer> (or rather, #act yourself.)
15:06:17 <csharp_> #info csharp = Chris Sharp
15:06:48 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:07:06 <JBoyer> That "It" I was referring to above was adding Edge support to the Hatch installer, even with a prepared script that came out weirdly.
15:07:29 * JBoyer kicks a can down the road
15:07:31 <JBoyer> #action JBoyer will exercise the staff client in a current release of Edge
15:07:36 <JBoyer> #action JBoyer will look at adding Edge on Windows support to the Hatch installer
15:08:05 <JBoyer> Ok, seeing no OpenSRF topics on the agenda we move on to
15:08:08 <JBoyer> #topic Evergreen Release Updates
15:08:35 <JBoyer> An adjusted 3.8 release schedule has been sent to the dev lists, does anyone have anything they'd like to add?
15:09:06 <jeff> Were there some specific features in mind with the "In order to allow a little more time to get some features in" part of the update?
15:09:28 <jeff> Or just a general "more time = more features make it"?
15:10:16 <gmcharlt> jeff: some specific ones are bug 1207533
15:10:16 <pinesol> Launchpad bug 1207533 in Evergreen "Triggered event log times out for large-data sites" [Medium,Confirmed] https://launchpad.net/bugs/1207533
15:10:17 <gmcharlt> bug 1905028
15:10:17 <pinesol> Launchpad bug 1905028 in Evergreen "Wishlist: Option to have lost items be charged the Acquisitions Cost" [Wishlist,Confirmed] https://launchpad.net/bugs/1905028
15:10:21 <JBoyer> A little of both, though I'd like to specifically get the mmpbt bug closed.
15:10:39 <gmcharlt> bug 1904593
15:10:39 <gmcharlt> Edit
15:10:39 <gmcharlt> Course materials
15:10:39 <pinesol> Launchpad bug 1904593 in Evergreen "yaous for my account url" [Wishlist,Confirmed] https://launchpad.net/bugs/1904593 - Assigned to Rogan Hamby (rogan-hamby)
15:10:58 <csharp_> gmcharlt: we'll be testing bug 1207533 on a PINES-ish server next week if I can get it done
15:11:16 <csharp_> also notes re-do
15:11:22 <abneiman> csharp_++
15:12:23 <terranm> I think the pullrequest had been removed from the notes consolidation - that would be nice if it is ready to test and we can test it next week though
15:12:29 <JBoyer> To give a minor teaser for those not looking at the agenda, the more of the 60 signed off bugs we can get committed the better. :)
15:12:41 <terranm> +1
15:12:46 <mmorgan> +1
15:12:53 <shulabear> +1
15:13:40 <JBoyer> Any other Evergreen release discussion before moving on?
15:13:40 <abneiman> I added Patron Notes to the agenda for later discussion since it's a little big & invasive. With the longer timeline we should be able to have that rebased & re-pullrequested though.
15:13:53 <terranm> A lot of the remaining open pullrequests are things that can't be easily tested and require sys admins and/or developers to look more deeply
15:14:08 <abneiman> yes, what terranm said :)
15:14:14 <terranm> abneiman++
15:15:07 <JBoyer> Yeah, there are a number of things that are likely not terribly difficult to test, but they are backend things. The "don't specifically require the opensrf user" is certainly one of those.
15:15:11 <terranm> Note also that Bill has been working on redoing the patron interfaces, so a number of things like notes consolidation will need to have updates done to his new branch at some point too
15:15:34 <JBoyer> (being quite difficult to test during a bug squashing week)
15:18:22 <JBoyer> SO, If you're able to put in some time next week with a local test server, please check out the SysAdmin and Developer Review sections of Terran's bug squashing week spreadsheet.
15:18:41 <JBoyer> moving on
15:18:48 <JBoyer> #topic Documentation Updates
15:18:53 <JBoyer> DIG is preparing to do a comprehensive docs review to catch out of date or missing docs and fill in the blanks.
15:19:06 <dluch> Yep, and we need help!
15:19:07 <JBoyer> They'd like volunteers from the various interest groups, including developers. If you have any questions or would like to volunteer please reach out to the documentation list. Anything you'd like to add, jweston or abneiman?
15:19:27 <JBoyer> or dluch, or whoever, that's about all I have handy about it. :D
15:19:51 <dluch> Well, I can add that, for developers, all the sysadmin and setup instructions would be an excellent place to start
15:20:20 <dluch> Thanks in advance! :-)
15:20:45 <abneiman> agreed with dluch. A super-easy way to inform DIG about out-of-date pages is to use the "report feedback" link at the bottom of each docs page, because that will automatically include which page you're on
15:21:30 <dluch> Also, the next DIG meeting is October 7, 2 pm ET, on Zoom where we'll have a presentation from alynn26 and jihpringle on how to contribute already-created documentation
15:21:49 <dluch> Agenda here: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20211007-agenda
15:22:28 <JBoyer> dluch++
15:22:30 <JBoyer> abneiman++
15:22:36 <abneiman> oh! and two bugs that would help DIG & need dev eyes are bug 1930099 and bug 1903476
15:22:36 <pinesol> Launchpad bug 1930099 in Evergreen "generate_docs.pl should be able to run on Windows" [Medium,Confirmed] https://launchpad.net/bugs/1930099
15:22:37 <pinesol> Launchpad bug 1903476 in Evergreen "Generate previews of documentation when documenters open a pull request on Github" [Wishlist,Confirmed] https://launchpad.net/bugs/1903476
15:24:28 <terranm> Here's the link to the bug squashing week spreadsheet for next week: https://docs.google.com/spreadsheets/d/1SE5AG1MgrXq2zHBY6qYcHNGVuIdzsihpfL2ZIIrE45s/edit - see the Open Pull Requests tab for things that need to be tested on local systems by sysadmins/developers
15:24:37 <JBoyer> terranm++
15:24:44 <mmorgan> terranm++
15:25:06 <terranm> "Test Group" categorizations are my own and some may involve additional groups
15:25:23 <dluch> terranm++
15:25:39 <JBoyer> Hopefully some time can be carved out for those two DIG bugs abneiman mentioned next week also, they look very helpful.
15:25:49 <JBoyer> ... Next up is
15:25:54 <JBoyer> #topic Launchpad Status as of 2021-09-14T12:00:00-ish
15:25:59 <JBoyer> Shapshot numbers: 2594 open bugs, 95 PR, and 60 signedoff
15:26:05 <JBoyer> Since the last meeting: 59 new bugs, 22 new PRs, 45 new signoffs, and 47 fixes committed.
15:26:11 <csharp_> Thu, Sep 9, 4:21 AM (5 days ago)
15:26:16 * Dyrcona added a pullrequest since.
15:26:18 <csharp_> oops!
15:27:02 <JBoyer> Dyrcona++ (literally!)
15:27:20 <Dyrcona> pullrequest++
15:27:26 <JBoyer> This month we have several pieces of
15:27:31 <JBoyer> #topic New Business
15:27:48 <JBoyer> Review / discussion of Consolidated Patron Notes (lp 1846354) from abneiman
15:27:48 <pinesol> Launchpad bug 1846354 in Evergreen "wishlist: Consolidate patron notes, alerts, and messages" [Wishlist,New] https://launchpad.net/bugs/1846354 - Assigned to Jason Etheridge (phasefx)
15:28:48 <abneiman> yes - phasefx can't be at this meeting, but I wanted to get a sense of where the community is on that one. It's a little big & hairy and I know berick is working in a similar space.
15:29:15 <abneiman> but it has also languished for a while, so, are there specific things that it needs? just more testing and review?
15:29:39 <abneiman> (gmcharlt please feel free to add anything I've forgotten)
15:30:49 <terranm> I think the last time we tested the conversion went well but there was some code cleanup needed
15:30:53 <abneiman> anyway, since it's a big staff-facing change, I just wanted to see what else we can do to get this one over the hump
15:31:02 <gmcharlt> yeah, echoing abneiman
15:31:02 <terranm> +1
15:31:06 <berick> is there a reason it's not tagged as a pullrequest?
15:31:13 <berick> i what terranm said..
15:31:14 <JBoyer> The last couple of comments from Jason on that bug looks like he's still working on it and the latest one removed the PR, so I'm not sure what's up with that.
15:31:44 <gmcharlt> yeah, current roadblock is ironing some bits about the offline internface
15:31:55 <abneiman> berick: it's awaitng a rebase and the noted cleanups
15:32:07 <berick> abneiman: *nod*
15:32:35 <terranm> I would really love to get that one into 3.8
15:32:43 <mmorgan> +1
15:33:49 <abneiman> ok, if it's just the rebase and a few small wrinkles, I'm pretty confident that can be PR'd in time to test next week
15:33:57 <terranm> abneiman++\
15:34:04 <abneiman> because I, too, would love to get this into 3.8 :)
15:34:04 <terranm> oops abneiman++
15:34:19 <JBoyer> terranm, csharp_ do you think that's soon enough to also throw at a PINES-sized test system?
15:34:36 <JBoyer> Because it works *pretty* well on concerto. ;)
15:35:03 <abneiman> yes, scale testing is key here
15:35:19 <JBoyer> Anyone else with a large-ish test system that is able to try it out would also be extremely welcome.
15:35:41 <mmorgan> Are there concerns other than migration with a large data set?
15:36:08 <terranm> (I defer to csharp_ on that)
15:36:40 <abneiman> mmorgan: part of it is the way larger systems might leverage some of the features like notes-scoping in more complex ways
15:36:42 <terranm> Migration was the biggie, but that seemed to be resolved pretty well
15:36:46 <abneiman> but yes, def migration
15:37:11 * mmorgan nods.
15:37:33 <terranm> PINES is *not* doing anything fancy with scoping as we want everyone to see all the notes
15:38:16 <mmorgan> NOBLE has tried to do some notes/messages scoping, but it's unweildy with the current way it works.
15:38:37 <terranm> I think the new interface will make that much easier to manage
15:38:44 <mmorgan> Indeed.
15:39:02 <mmorgan> We might have some data that we could try and migrate.
15:39:07 <abneiman> mmorgan++
15:39:10 <terranm> mmorgan++
15:39:12 <JBoyer> mmorgan++
15:40:03 <JBoyer> Any further discussion re: patron note / alert consolidation?
15:40:15 <abneiman> thanks, everyone
15:40:20 <JBoyer> abneiman++
15:40:35 <JBoyer> Thoughts on lp 1942467 (identifier field mapping and search), mmorgan?
15:40:35 <pinesol> Launchpad bug 1942467 in Evergreen "Search: Identifier Field Virtual Index Mappings not working" [Undecided,New] https://launchpad.net/bugs/1942467
15:41:03 <mmorgan> I was just hoping to get some input on this and if it's as much of an issue for other sites as ours.
15:41:34 <mmorgan> The 10/13 isbn searchability specifically is a big problem for us.
15:41:39 <JBoyer> Is one of the symptoms of this searching for a 13 digit ISBN and not finding the records that only have the 10, and vice-versa?
15:41:48 <JBoyer> ah, apparently so. :)
15:41:50 <mmorgan> JBoyer: Yes
15:41:58 <mmorgan> :)
15:42:21 <miker> I should be able to look at that early next week, mmorgan
15:42:31 <mmorgan> miker++
15:42:39 <mmorgan> That would be awesome!
15:42:39 <JBoyer> miker++
15:42:44 <terranm> miker++
15:42:50 <gmcharlt> miker++
15:43:25 * mmorgan had donned hipwaders and tried to slog through the code, but the waders aren't high enough:)
15:43:36 <JBoyer> That brings us to another issue raised by mmorgan,
15:43:40 <JBoyer> Approaches to address lp 1883171 (asset.latest_inventory duplicate copies)
15:43:40 <pinesol> Launchpad bug 1883171 in Evergreen "duplicate entries for a copy in asset.latest_inventory table" [Undecided,Confirmed] https://launchpad.net/bugs/1883171
15:43:55 <dluch> mmorgan++
15:44:35 <mmorgan> So this has made the inventory function not useful for us
15:45:15 <mmorgan> Does this look like a parallel requests issue?
15:45:50 <JBoyer> Everyone's favorite issue, a 1:1 table that is actually 1:M
15:46:21 <rfrasur> hah
15:46:26 <mmorgan> "There wasn't an entry already there when I came in!"
15:46:27 <jeff> one concept for inventory was storing all of the inventory dates and giving a view that would output only the most recent.
15:46:29 <JBoyer> I would have thought so from the description, but I'm really confused how you get 2 entries months apart but only 1 id separate.
15:47:12 <jeff> mmorgan: can you explain why the duplicate entries make the feature not useful? is it because the UI displays "any" date and not the most recent, or something else?
15:47:14 <mmorgan> JBoyer: So the two entries are created at the same time, and later one of them gets updated when an inventory is performed
15:47:26 <jeff> (or are you reporting on "all" of the dates?)
15:47:52 <JBoyer> Hah, yeah, that would be the obvious explanation.
15:48:15 * JBoyer needs to be more creative in how to break things.
15:48:15 <mmorgan> jeff: It's a combination of this issue with the the one where other libraries can set inventory dates on my items.
15:49:01 <mmorgan> JBoyer: Having a big, active system and logs helps to see the breakage :)
15:49:34 <mmorgan> bug 1940663 is the other problematic one
15:49:34 <pinesol> Launchpad bug 1940663 in Evergreen "Inventory: Staff users can update inventory dates on non-owned items" [Undecided,Confirmed] https://launchpad.net/bugs/1940663
15:49:50 <jeff> mmorgan: what impact does the duplicate rows bug have for you?
15:50:33 <mmorgan> A few we've noticed - in the client, it's not always the most recent row in the inventory table that displays for an item.
15:51:26 <mmorgan> It's difficult to get accurate reports between this and the non-owned items bug
15:52:18 <JBoyer> Since I'm guessing the code doesn't specify any ordering (because *latest*) I can see postgres sometimes throwing you 1 row and sometimes the other.
15:52:51 <mmorgan> A library can be doing a careful inventory where date is important, but the item is checked in at another library that is using the checkin modifier, and the owning library's date is lost.
15:54:12 <mmorgan> So does an approach come to mind to solve the duplicate issue?
15:54:24 <JBoyer> While jeff has a good point about some workflows saving all inventory-type scans I'd say that doesn't make sense with a table named latest_anything and it should be a simple matter of duplicate removal and a proper constraint being put in. That should be relatively simple.
15:54:43 <terranm> I guess we haven't encountered that problem because we're mainly doing inventories to identify lost items, so we're basing our reports on items with null inventory dates or last inventory dates prior to the current inventory scanning period
15:55:37 <jeff> terranm: depending on your logic, that second one could run into this.
15:56:04 <terranm> Not for our purposes, because if it was checked in somewhere else, it means it's not missing
15:56:17 <Dyrcona> Might as well just add the columns to asset.copy and drop the table.
15:56:43 <mmorgan> We had some libraries doing lots of inventory activities when they were closed, when items started moving around again, we became aware of the non-owned issue because some libraries have chosen to have the checkin modifier on all the time.
15:56:49 <jeff> sorry, i should have been more specific. "second one" meaning "last inventory dates prior to the current inventory scanning period" :-)
15:58:11 <mmorgan> There was lots of discussion of where to store the data back in the original Launchpad ticket.
15:59:03 <mmorgan> bug 1777675
15:59:03 <pinesol> Launchpad bug 1777675 in Evergreen "Support for inventory date" [Wishlist,Fix released] https://launchpad.net/bugs/1777675
15:59:10 <JBoyer> I can see not wanting it on the item if you don't want a large amount of auditor churn for just scanning inventory.
15:59:50 <jeff> I can take a look at the bugs in the next week or two if you're looking for ideas.
15:59:54 <JBoyer> I would have expected the unique constraint to have been added in the beginning.
16:00:14 <mmorgan> jeff++
16:00:19 <JBoyer> jeff++
16:00:29 <mmorgan> JBoyer: Yes, I wondered about that.
16:00:36 * mmorgan encourages folks to weigh in on Launchpad for these bugs.
16:01:07 <Dyrcona> If you're going to add a unique contraint on copy, then might as well move the two inventory fields to asset.copy and drop the table.
16:01:48 <JBoyer> One of these changes is small and one of these changes is (potentially) very, very large.
16:02:10 <JBoyer> Also, if / when inventory is fleshed out asset.latest_inventory will likely be a useful view
16:02:46 <mmorgan> The small one being to add the uniqueness constraint, I assume?
16:02:51 <JBoyer> you bet
16:03:12 * miker will weigh in on LP...
16:03:13 <Dyrcona> The big change would be better in the long run.
16:03:57 <Dyrcona> Seems to me, though, that there is also some utility in having multiple entries.
16:03:58 <JBoyer> only if inventory never gains any more features and asset.latest_inventory is the only inventory-related table ever used.
16:04:58 <JBoyer> but yes, there is utility in a table that lists all inventory scans for an item. "This item was scanned in 2021, 2022, and 2023, but not 2024 or 2025, and now it's back in 2026?"
16:06:14 <JBoyer> But there isn't currently any use in this table backed by this code having multiple entries.
16:06:45 <Dyrcona> I'll stop. I think the rest should go on Lp.
16:07:02 <JBoyer> discussion++
16:07:04 <JBoyer> lp+-
16:07:05 <JBoyer> heh
16:07:24 <JBoyer> Thanks for bringing those up abneiman and mmorgan
16:07:25 <mmorgan> discussion++
16:07:28 <JBoyer> abneiman++
16:07:30 <JBoyer> mmorgan++
16:07:50 <JBoyer> only a few minutes over the hour we come to
16:07:52 <JBoyer> #topic Announcements
16:07:57 <JBoyer> Next Meeting is October 12, 2021
16:08:07 <JBoyer> Anything else to share before I tell the bot to ignore us/
16:08:30 <JBoyer> bye, bot!
16:08:31 <JBoyer> #endmeeting