15:02:33 <JBoyer> #startmeeting 2021-10-12 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-10-12
15:02:33 <pinesol> Meeting started Tue Oct 12 15:02:33 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:33 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:33 <pinesol> The meeting name has been set to '2021_10_12___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_10_12'
15:02:41 <JBoyer> #topic Introductions
15:02:47 <JBoyer> Hello! have we met?
15:02:57 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:02:57 <terranm> #info terranm = Terran McCanna, PINES
15:03:08 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:03:09 <rfrasur> #info rfrasur = Ruth Frasur, EI/ECDI
15:03:12 <abneiman> I don't know any of you weirdos
15:03:14 <shulabear> #info shulabear = Shula Link, PINES/GCHRL
15:03:15 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:03:21 <gmcharlt> #info gmcharlt = Galen Charlton, EOLI
15:03:23 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:03:28 <JBoyer> abneiman++
15:04:52 <JBoyer> Folks joining later are welcome to #info up upon said arrivals.
15:05:07 <JBoyer> It's time for everyone's favorite game:
15:05:08 <JBoyer> #topic Action Items from Last Meeting
15:05:20 <JBoyer> #info JBoyer will exercise the staff client in a current release of Edge
15:05:22 <terranm> It's fun when they're not my action items
15:05:26 <JBoyer> #info JBoyer will look at adding Edge on Windows support to the Hatch installer
15:05:31 <JBoyer> To be honest with myself as much as the rest of you, this just isn't happening until November at the earliest, and I don't have the highest hopes for that either.
15:05:35 <JBoyer> I can promise you that it will be an uneventful thing to test if anyone else would like to volunteer to experiment with the staff client in Edge.
15:06:24 <JBoyer> Are there any volunteers interested in downloading Microsoft Chrome and making sure it Does The Thing?
15:06:38 <sandbergja> #info sandbergja = Jane Sandberg, Linn-Benton Community College, coming in late
15:07:27 <shulabear> I can poke at it some in Edge.
15:07:38 <JBoyer> shulabear++
15:09:21 <JBoyer> I don't expect any surprises since I do use it at home to work with Evergreen, but I use a pretty limited subset of the client. If you could go through and poke at most interfaces side by side with Chrome and note any differences that would go a long way towards answering the question of how hard it would be to support.
15:10:00 <shulabear> Got it.
15:10:00 <JBoyer> #action shulabear will test out the staff client in Microsoft Edge
15:10:33 <terranm> Speaking of which, has anybody done any extensive testing with ChromeOS? I know there are lots of printing headaches with ChromeOS, but not sure about any other potential problems
15:11:09 <JBoyer> I mean, it literally is Chrome, even moreso than Edge, so I would hope it works, printing (and Hatch) aside.
15:11:24 <terranm89> Love it when I ask a question and IRC immediately kicks me off
15:11:24 <JBoyer> Gotta turn down my Shatner filter
15:11:38 <csharp_> # info csharp = Chris Sharp
15:11:44 <csharp_> er...
15:11:51 <csharp_> #info csharp = Chris Sharp
15:11:56 <csharp_> there we go
15:12:07 <JBoyer> terranm89, all you missed was me making a word salad: "I mean, it literally is Chrome, even moreso than Edge, so I would hope it works, printing (and Hatch) aside."
15:12:15 <terranm89> JBoyer++
15:12:39 * csharp_ hears everything JBoyer types in Shatnervoice now
15:12:52 <JBoyer> Just wait until my album comes out.
15:12:58 <csharp_> JBoyer++
15:13:04 <JBoyer> As for the Hatch installer, I'm kind of on the fence about just removing all of the auto-install code and having links to the store pages in the client to install the extensions; anyone have thoughts on that?
15:13:05 <shulabear> I'm hearing Walken more than Shatner.
15:13:17 <rfrasur> shulabear - same.  For whatever reason.
15:13:28 <csharp_> JBoyer: makes sense to me
15:13:54 <terranm89> Few people know that JBoyer sings like Shatner AND dances like Walken
15:14:21 <JBoyer> More people know it than may want to, hey-o!
15:14:25 <Dyrcona> Walken can actually dance, so...
15:14:56 <rfrasur> omg, the mental images. And so much cowbell.
15:15:30 <JBoyer> My thinking with the Hatch links would be that they're only visible if the extension is missing and only the link you need to avoid confusion. If that was in place I'd be happy to have the registry shenanigans removed from the installer so long as berick doesn't object.
15:15:37 <Dyrcona> For later: https://www.youtube.com/watch?v=wCDIYvFmgW8
15:16:09 <terranm89> I was just looking for that link
15:16:22 <Dyrcona> Well, I don't like registry shenanigans either.
15:16:27 <JBoyer> I think I know what it is, and will verify later.
15:17:01 <JBoyer> If there are no more tangentially Edge related thoughts we can move on to the exciting release update.
15:17:22 <JBoyer> #topic Evergreen Release Updates
15:17:40 <Dyrcona> gmcharlt++
15:17:47 <JBoyer> New beta just dropped, gmcharlt++
15:17:55 <gmcharlt> #info Evergreen 3.8-beta is avaialble
15:17:56 <terranm89> gmcharlt++ releaseteam++
15:17:59 <rfrasur> gmcharlt++
15:18:15 <gmcharlt> some comments:
15:18:31 <abneiman> gmcharlt++
15:18:32 <gmcharlt> 1. we should also do an OpenSRF release, but that would mostly be about noting the Debian support changes
15:19:11 <gmcharlt> 2. For the release notes, I used 'asciidoctor' rather than 'asciidoc' to generate the HTML version. Main reason: asciidoctor supports the number of headings levels we're currently using, asciidoc does not
15:19:37 <gmcharlt> 3. testers welcome and needed
15:19:50 <gmcharlt> so I'm wondering if anybody can make commitments to test this week or early next week
15:20:22 <gmcharlt> assuming successful testing, I think the RC period could be truncated or potentially even dropped
15:21:01 <JBoyer> Note if anyone is on the fence that some of the bugsquash servers could be updated to have the 3.8 beta if you're concerned about not being able to install it locally.
15:22:05 <rfrasur> Are we just testing what's in the release notes?
15:22:13 <rfrasur> (sorry, I know this is a dumb question)
15:22:19 <abneiman> I can test against an updated bugsquash (need to finalize some docs things anyway)
15:22:30 <JBoyer> Making sure that nothing existing was broken would also be good.
15:22:37 <gmcharlt> rfrasur: that would be a started point, but the broader testing that we collectively do, the more regressions that get identified
15:22:54 <rfrasur> So, release notes and generalized "everything" testing?
15:23:02 <gmcharlt> yeah
15:23:32 <JBoyer> I'll just plan to load up pattypan and festivus with 3.8b. pattypan will be a fresh db, festivus an upgrade from 3.7.1
15:23:34 <rfrasur> If there's a server, I can commit some time.
15:23:50 <JBoyer> Those 2 will be done today
15:23:53 <terranm89> I can't promise anything, but if it's on one of the bugsquash servers then I can try to poke at it between other things
15:25:00 <rfrasur> JBoyer, whenever they're ready... I'll have a little more availability on the weekend though.
15:25:42 <JBoyer> later today basically means plan to look at them whenever you have time tomorrow or later; I'm not working on them this particular moment. ;)
15:25:54 <rfrasur> lol, slacker
15:26:08 <JBoyer> Only one keyboard on this machine.
15:26:49 <JBoyer> So, if no one has anything else to add re: testing 3.8b we have our LP updates coming up.
15:27:10 <terranm89> Do these LP tag changes sound okay to everyone? Any red flags or other tag suggestions? https://docs.google.com/document/d/1rB11V4Lla_c5Sw_CuytvQRbDBaa6RsIgGA6ZswaaUhs/edit#
15:27:30 <terranm89> Sorry, did I jump ahead?
15:27:47 <JBoyer> Technically, but that's LP too. :)
15:27:53 <terranm89> I saw LP and panicked
15:28:18 <JBoyer> I'll just copy / paste a few lines while people take the time to look that over.
15:28:28 <JBoyer> #topic Launchpad Status (as of noon Eastern)
15:28:38 <JBoyer> Snapshot
15:28:38 <JBoyer> Open Bugs - 2617
15:28:50 <JBoyer> Pullrequests - 71
15:28:52 <JBoyer> Signedoff - 42
15:28:56 <JBoyer> Updates Since Last Meeting
15:29:00 <JBoyer> Bugs Added - 40
15:29:09 <JBoyer> Pullrequest tag Added - 19
15:29:10 <JBoyer> Signedoff tag Added - 45
15:29:14 <JBoyer> Fix Committed - 52
15:29:21 <JBoyer> #topic New Business
15:29:46 <JBoyer> #info terranm89 would like some feedback on her LP tag proposal. :)
15:30:16 <gmcharlt> I've added a couple bits of feedback in the doc, but I'm overall +1 to the idea
15:30:32 <terranm89> I've spoken with the CAT IG and with Acq  folks and they are all excited about easier tagging.
15:30:33 <terranm89> There's not a way to batch-change LP tags is there? (I don't see any way with my permission level anyhoo.)
15:30:40 <terranm89> gmcharlt++ thanks for the feedback
15:30:41 <Dyrcona> I have a question about the Lp tags changes: Why differentiate between needsrebase and needsrepatch?
15:31:06 <JBoyer> There would definitely be a difference in the amount of expected effort.
15:31:31 <terranm89> In my head, needsrebase would be easier / require less actual code fixing
15:31:49 <Dyrcona> I don't necessarily think so, unless by needsrepatch we mean it doesn't work as advertised.
15:31:59 <terranm89> That's how I was interpreting needsrepatch
15:32:24 <JBoyer> And I think there are a couple instances where that's the case.
15:32:41 <terranm89> This is the description in the official tags list: 	testing revealed that the submitted code needs more work
15:32:52 <terranm89> Of course, we could just change that description, too
15:33:19 <Dyrcona> I'm not sure that I like the two tags being so similar, but guess I'll have to live with it.
15:33:41 <Dyrcona> Also, I agree with gmcharlt regarding the deprecation tag.
15:34:15 <terranm89> Whatabout "needsrebase" and "needswork" ?
15:35:51 <terranm89> I've removed "deprecation" from the list of things to be deprecated :)
15:36:12 <JBoyer> You see, now we're talking about recursion...
15:36:46 <terranm89> heh
15:37:00 <Dyrcona> needswork seems better. I don't want to get too hung up on terminology though. Tags are mainly useful for searching, and I pretty much only look for signedoff with Fix Committed unchecked. :)
15:37:08 <jeff> "outdated" and "broken"? :-)
15:37:16 <JBoyer> jeff++
15:37:20 <terranm89> jeff++ lol
15:37:25 <csharp_> "bustedyoufixit"
15:37:33 <terranm89> heh
15:39:42 <JBoyer> Given how many characters match between needsrebase and needsrepatch I do kind of like changing repatch to needswork.
15:39:51 <JBoyer> Easier to tell the difference at a glance.
15:40:52 <Dyrcona> Actually, "broken" might be better. It's shorter.
15:41:22 <Dyrcona> I guess needswork is more polite.
15:42:33 <JBoyer> swingandamiss
15:42:34 <terranm89> I kind of like having the needswork and needsrebase because they are alphabetically grouped with needstest and needsdiscussion - all things that are asking for some specific type of action
15:42:53 <Dyrcona> Yeah. I concur.
15:42:57 <shulabear> terranm89++
15:43:05 <Dyrcona> terranm89++
15:43:06 <abneiman> terranm89++
15:43:10 <JBoyer> terranm89++
15:43:11 <abneiman> indeed, great list terranm89
15:43:17 <Bmagic> #info Bmagic = Blake GH, MOBIUS, super late
15:43:21 <terranm89> (and needsreleasenote)
15:43:26 <gmcharlt> terranm89++
15:44:33 <terranm89> Okay, thanks everyone! I don't suppose there's a way to batch change any of these in LP?
15:44:52 <terranm89> If not I'll recruit some folks from the interest groups to help
15:45:40 <csharp_> terranm89's need put R.E.M.'s Pop Song '89 in my head :-)
15:45:57 <Bmagic> renaming them doesn't bring all the bugs with it?
15:45:59 <csharp_> terranm89: no batching that I'm aware of
15:46:01 <Dyrcona> terranm89: There's some Python libraries that could be used, but I haven't messed with them for a while.
15:46:22 <Dyrcona> Seems to me there was a limit to how many things you could manipulate at once, too.
15:46:24 <csharp_> Dyrcona: last time I looked at those they mostly didn't work as far as I could tell
15:46:31 <abneiman> terranm89: I'm happy to help, just not til next week
15:46:39 <csharp_> probably not updated to python3 too
15:46:54 <Dyrcona> csharp_: There's a newer one on Ubuntu 20.04 that seems to work, even has a shell mode.
15:47:08 <csharp_> Dyrcona: oh cool - I haven't looked in a while
15:47:08 <JBoyer> Bmagic, it doesn't look like you can rename them, just add new and hide the old.
15:47:17 <terranm89> yes, was just typing that
15:47:41 <terranm89> No worries - it's not a bad idea for people to review them and add additional tags at the same time anyway
15:48:01 <JBoyer> But it's possible those python libs might be able to help since the API may be able to do things we can't. Or at least it won't get bored doing it the same way we would. :)
15:48:14 <Bmagic> JBoyer: wow, that'll be "fun"
15:48:59 <Dyrcona> csharp_: lptools and python3-launchpadlib
15:49:01 <terranm89> It's something I can do while I'm stuck in conference sessions all next week
15:50:27 <JBoyer> If there are no more LP comments I'll move along
15:50:40 <csharp_> Dyrcona: thanks, I'll take a look
15:51:37 <JBoyer> csharp_, Dyrcona , if either of you two come up with something that does the job it might be good to throw something about it on the wiki.
15:51:53 <JBoyer> #topic Announcements
15:51:59 <JBoyer> #info Next Meeting is November 09, 2021
15:52:04 <JBoyer> And we're out.
15:52:07 <JBoyer> #endmeeting