14:01:28 <dluch> #startmeeting 2021-11-04 - Documentation Interest Group Meeting
14:01:28 <pinesol> Meeting started Thu Nov  4 14:01:28 2021 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:28 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:28 <pinesol> The meeting name has been set to '2021_11_04___documentation_interest_group_meeting'
14:01:38 <dluch> #topic Agenda
14:01:49 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20211104-agenda
14:01:55 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:02:06 <dluch> #topic Introductions
14:02:06 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:02:06 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:02:21 <alynn26> #info alynn26 is Lynn Floyd, Evergreen Indiana
14:03:50 <jweston> #info jweston is Jennifer Weston, Equinox
14:05:00 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:05:48 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:06:01 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:06:01 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:06:01 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:06:11 <dluch> #topic Old and Ongoing Business
14:06:27 <dluch> #info Check-in - How's everyone doing?
14:06:49 <jweston> unsettled that it is November but loving the fall weather
14:07:08 <alynn26> Getting ready for our Thanksgiving Upgrade.
14:07:12 <dluch> (Also, I keep looking at Ongoing and thinking it's spelled wrong. It's not, right?)
14:07:17 <abneiman> I wanted more of pleasant fall and less of this cold, rainy fall
14:07:34 <abneiman> ongoing is spelled the way I know to spell it :)
14:07:39 <dluch> jweston and abneiman: same here!
14:07:48 <jweston> +1 to ongoing spelling
14:08:08 <abneiman> like, I feel like we got two weeks of mild, cool weather and now it's like "hahaha freeze warning"
14:08:14 <dluch> Good. Just one of those weird times when words look wrong, I guess. LOL
14:08:54 <dluch> Yes, exactly the same here. I didn't expect to be wearing my winter coat quite this early in November
14:09:17 <dluch> Good luck with your upgrade, alynn26!
14:09:47 <jweston> oh, yes -- good luck alynn26
14:10:00 <dluch> #info Previous Action Items
14:10:03 <dluch> How are these coming?
14:10:03 <dluch> I'll take them in order...
14:10:19 <dluch> 1. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.6 context. Also, go through 3.6 and see what other documentation is missing from it. And also 3.7.
14:10:25 <dluch> I have still done nothing, but quite a bit was done in/around the Hack-a-Way, I think?
14:11:22 <jweston> I did a tiny little bit on the doc needs list -- on bitesize bugs on lp and removed any that had been completed (but that was many weeks ago so specifics are fuzzy)
14:11:40 <dluch> jweston++
14:11:44 <dluch> Should we change up the action item?
14:12:24 <dluch> Maybe for 3.7 and 3.8 instead of 3.6? Or do we still need to add 3.6 stuff, too?
14:13:24 <jweston> could we break into two different action items -- 1) reviewing what's there to get rid of the old stuff and 2) look at the newest releases
14:13:43 <dluch> That's a good idea!
14:14:27 <dluch> #action dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.8 context.
14:15:20 <dluch> #action dluch and jweston (and whoever else wants to) will see what documentation is missing from the Documentation Needs List for newest releases.
14:15:53 <jweston> +1 to wording on action item "newest releases" works!
14:16:13 <dluch> 2. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
14:16:25 <dluch> Have you all had a chance to do this?
14:18:44 <dluch> I'm going to assume no...
14:19:01 <alynn26> No, we have not.
14:19:03 <dluch> (I'm pretty sure Bmagic hasn't, anyway)
14:19:14 <dluch> #action alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
14:19:28 <dluch> 3. alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:20:04 <dluch> I wonder if alynn26 maybe had to pop out of the meeting...
14:20:27 <dluch> #action alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:20:41 <dluch> And if this is done, I'll just remove it from next time's agenda, lol
14:20:57 <dluch> 4. jweston will ask for assistance on docs review from the interest groups for review and recruitment
14:21:06 <dluch> I know you did this--jweston do you have any updates?
14:21:08 <jweston> done -- all interest groups have been contacted
14:21:22 <dluch> Awesome!
14:21:24 <jweston> they are awaiting further instruction from us and how best to join in the fun
14:21:29 <dluch> jweston++
14:21:53 <abneiman> jweston++
14:22:01 <dluch> So that will tie into our later discussion on the reorg/review, right?
14:22:23 <jweston> Yes -- when we talk about the review spreadsheet, I think it would be good to put together an introduction and a "here's how you can help" messae
14:22:31 <jweston> *message
14:22:39 <dluch> Great
14:22:50 <dluch> And speaking of the spreadsheet...
14:23:00 <dluch> 5. jihpringle will set up a spreadsheet for tracking documentation review
14:23:00 <dluch> She did this before the September meeting was even over, lol, so we can remove it.
14:23:06 <dluch> jihpringle++
14:23:10 <dluch> It got some use at the Hack-a-Way, yes?
14:23:43 <dluch> (or we can table that untilthe  later discussion)
14:24:16 <jweston> sorry I missed the hack-a-way (I had good intentions)
14:24:29 <abneiman> I'm not sure if it got used at hackaway (I wasn't able to spend as much time there as I wanted) but jihpringle++ for the beautiful spreadsheet anyway :)
14:24:39 <jweston> yes, jihpringle++
14:24:46 <dluch> No worries, anyone!
14:24:53 <dluch> #info October Zoom Meeting--Recap and Decisions
14:25:20 <dluch> We had a great presentation from alynn26 and jihpringle on how to contribute to the community documentation you've already created elsewhere. I completely forgot about getting the recording processed and up, so I'll work on that next week.
14:25:25 <dluch> jihpringle++ alynn26++
14:25:48 <dluch> #action dluch will get the October recording processed and posted
14:25:57 <dluch> Anyone else want to add anything?
14:26:18 <jweston> It was great!  thanks again to jihpringle++ and alynn26++
14:26:25 <dluch> And, for anyone reading the logs later...
14:27:02 <alynn26> Sorry duel focused right now.   Yea, not looked into the CSS yet. but will.
14:27:24 <dluch> Also, we officially decided that we would use "and" instead of "&" in documentation unless the "&" is specifically in Evergreen. jihpringle updated the style guide with this new information.
14:27:24 <dluch> jihpringle++
14:27:36 <dluch> We talked about looking at the patch for this bug: https://bugs.launchpad.net/evergreen/+bug/1944205 and commenting and/or signing off on it. We were excited to have better authority control documentation on its way!
14:27:36 <dluch> Bmagic++
14:27:36 <pinesol> Launchpad bug 1944205 in Evergreen "Docs: Authority needs more advanced documentation" [Undecided,New]
14:27:37 <dluch> Looks like that can still use some commenting, so
14:27:38 <dluch> #action DIG (and anyone else) will review, comment on, and/or sign off on the patch for https://bugs.launchpad.net/evergreen/+bug/1944205
14:27:56 <dluch> No problem, alynn26!
14:28:10 <dluch> #info Hack-a-Way Recap
14:28:44 <dluch> Unfortunately, I ended up having to deal with a bunch of MOBIUS stuff during the event this year (plus headset issues), so didn't get to participate much. Sounds like that was kind of the case with most of us here today, lol.
14:29:12 <dluch> alynn26, do you have a recap or anything?
14:29:24 <abneiman> one big docs thing that did happen at hackaway was a discussion about how to do release notes, and ways to automate that in the future
14:29:42 <jweston> abneiman++ that sounds promising
14:29:59 <dluch> abneiman++
14:30:04 <abneiman> but yes I was in the same boat as Debbie w/r/t having to focus on other things during that time :-\
14:30:30 <abneiman> yes, right now release notes are a lot of manual effort (though not difficult) and streamlining that would be helpful
14:30:41 <dluch> That would be awesome, yes
14:30:42 <alynn26> There was a good doc discussion on Wednesday afternoon about something. not don't recall it right now.
14:31:27 <dluch> Lol. That I was at. With half of my attention, anyway. And I did not take notes.
14:32:10 <dluch> Well, maybe we can bring it up again at our next meeting :-)
14:32:15 <dluch> #info Docs organization: Review and Re-organize
14:32:16 <abneiman> yes, we talked about what to document in 3.8 (among other things); how to generate the 3.8 web page (I can do this, I think!), and where screenshots needed to be updated
14:32:25 <Bmagic> #info Bmagic arrives
14:32:36 <dluch> That's right! abneiman++
14:32:43 <abneiman> mantis had a spreadsheet for the last item
14:33:10 <abneiman> #info spreadsheet for image updates: https://docs.google.com/spreadsheets/d/1Byvvxe8vax8RY7TvoOLcyB-GqDH9GgRbeNqPV9yQyP8/edit?usp=sharing
14:33:23 <dluch> And it was a really helpful spreadsheet! mantis++
14:33:31 <dluch> Thanks!
14:33:33 <abneiman> mantis++
14:33:58 <abneiman> we also talked about putting images in new folders
14:34:15 <abneiman> and I think that was also added to DIG Style Guide thanks to jihpringle
14:34:43 <dluch> It was!
14:35:43 <dluch> jihpringle++ for being the style guide guru lately!
14:35:44 <abneiman> anyway, that's all I remember though there were probably other things
14:36:15 <alynn26> better memory then mine.
14:36:18 <dluch> abneiman++ for taking notes and/or remembering the discussion!
14:36:30 <alynn26> abneiman++
14:36:59 <dluch> So...docs reorg
14:37:25 <dluch> Some of our previous action items were related to this topic. But what else are our next steps?
14:37:45 <dluch> Making a guide for other groups to help?
14:38:04 <jweston> +1 to guide
14:38:16 <abneiman> yeah lowering barriers, etc.
14:38:43 <dluch> Probably that and getting the docs needs page cleaned up would be the easiest for barrier-lowering?
14:38:59 <jweston> agreed
14:39:25 <abneiman> +1
14:40:03 <dluch> We already have the latter as an action above--is there anyone excited (or at least willing) to give the guide a shot?
14:40:13 <alynn26> +1 maybe retire that page, and start fresh
14:41:04 <jweston> I can ping jihpringle about the spreadsheet and drafting a guide for how people can contribute
14:41:17 <jweston> ^ and work with her on that (in Dec)
14:41:22 <dluch> jweston++
14:41:37 <alynn26> jweston++
14:41:57 <dluch> I was just thinking, too, if it would be helpful, you could create a Google doc or something and send it out to all of us
14:42:11 <jweston> +1 to Google doc approach
14:42:41 <jweston> also, we can look at how to incorporate mantis spreadsheet for images into re-org docs
14:43:18 <abneiman> +1 to spreadsheet consolodation
14:44:12 <dluch> #action jweston will talk to jihpringle and mantis about the documentation and images review spreadsheets, create a Google doc for drafting a contribution guide, and send the link to the docs mailing list for everyone to help.
14:44:22 <dluch> Is that okay?
14:44:32 <jweston> dulch++ looks good to me
14:44:40 <alynn26> +1
14:44:53 <dluch> Cool. jweston++
14:45:03 <abneiman> jweston++
14:45:27 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:46:34 <dluch> #topic New Business
14:46:46 <dluch> #info December 2 meeting on Zoom
14:47:14 <dluch> Do we want to have a show and tell topic for that meeting or more of a winter holidays party like we did last year? (I would like to talk about the reorg stuff, regardless)
14:48:21 <dluch> (I'd probably prefer partying, but will go with the majority!)
14:48:39 <alynn26> +1
14:48:42 <jweston> +1
14:49:05 * abneiman dons party hat
14:49:18 <dluch> :-D
14:49:23 <abneiman> but I also have another item of new biz for today
14:49:45 <dluch> #agreed The December meeting will be a party, after a discussion of the docs reorganization stuff
14:49:57 <dluch> abneiman: Go for it!
14:51:32 <abneiman> so, I know Jane has had to step back a bit and I'm definitely slacking on the pace of docs PR review. So is there anyone else who would be interested in being a docs committer with me?
14:51:59 <abneiman> (I will ask this again in Dec if needed)
14:52:53 <dluch> Good thoughts...
14:53:01 <abneiman> **crickets** LOL
14:53:05 <dluch> maybe do bring it up in Dec. and we can think about it?
14:53:10 <abneiman> +1 will do
14:53:27 <alynn26> I think about it, but then I think about it again.
14:53:28 <dluch> abneiman++
14:53:37 <dluch> lol
14:53:58 <abneiman> alynn26++
14:54:14 <abneiman> alynn26: if I can do it, I know you can; you're about 1000x more technical than I am
14:54:30 <dluch> abneiman you want an action item or just added to the Dec. agenda?
14:55:27 <dluch> *add it
14:55:31 <abneiman> just an agenda item is fine
14:55:39 <dluch> Okay, will do!
14:55:40 <abneiman> I may privately nag one or two others in the meantime :)
14:55:47 <dluch> Thanks!
14:55:52 <dluch> Lol, excellent
14:56:03 <dluch> Is there any other new business we need to discuss?
14:56:52 <dluch> We are very close to time, so I'm going to call it. But feel free to collaborate! :-)
14:57:03 <dluch> #info Our next meeting will be on December 4, on Zoom. I'll post the link on the agenda about a week prior to the meeting.
14:57:10 <dluch> Thanks for being here, everyone!
14:57:18 <dluch> #endmeeting