15:02:00 <JBoyer> #startmeeting 2021-11-09 - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2021-11-09
15:02:00 <pinesol> Meeting started Tue Nov  9 15:02:00 2021 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:00 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:00 <pinesol> The meeting name has been set to '2021_11_09___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2021_11_09'
15:02:06 <JBoyer> #topic Introductions
15:02:17 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:02:26 <terranm> #info terranm = Terran McCanna, PINES
15:02:31 <JBoyer> And you, and you, and you?
15:02:34 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:37 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:02:51 <gmcharlt> #info gmcharlt = Galen Charlton, EOLI
15:02:56 <csharp_> #info csharp = Chris Sharp, GPLS
15:03:05 <alynn26> #info alynn26 = Lynn Floyd, Evergreen Indiana
15:03:17 <berick> #info berick = Bill Erickson, KCLS
15:03:35 <sandbergja> #info sandbergja = Jane Sandberg, LBCC
15:04:02 <JBoyer> Feel free to #info up if you're joining us later.
15:04:05 <JBoyer> #topic Action Items from Last Meeting
15:04:12 <JBoyer> #info shulabear will test out the staff client in Microsoft Edge
15:04:16 <JBoyer> Any luck in this testing pursuit shulabear?
15:04:38 <JBoyer> Who I just noticed didn't say anything above, so may not be available...
15:05:12 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:05:26 <JBoyer> We can come back to this if shulabear is available later.
15:05:31 <JBoyer> Release talk!
15:05:32 <JBoyer> #topic OpenSRF Release Updates
15:05:38 <JBoyer> OpenSRF 3.2.2 has been released!
15:05:40 <JBoyer> gmcharlt++
15:05:44 <JBoyer> Any other words you'd like to share, gmcharlt?
15:05:46 <terranm> gmcharlt++
15:05:47 <berick> gmcharlt++
15:05:58 <gmcharlt> just that I've started a rel_3_3 series
15:06:00 <mmorgan> gmcharlt++
15:06:13 <JBoyer> I'd like to remind everyone that there are also some signed off OpenSRF patches that could be poked at, etc.
15:06:28 <gmcharlt> if nothing else, the Java & Python deprecation would warrant a new major release stream
15:07:54 <JBoyer> Speaking of,
15:07:57 <JBoyer> #topic Evergreen Release Updates
15:08:01 <JBoyer> Evergreen 3.8.0 has also been released!
15:08:23 <sandbergja> release_team++
15:08:25 <Dyrcona> gmcharlt++
15:08:29 <JBoyer> I don't have much to add, anyone else on the release team want to add anything?
15:08:33 <JBoyer> gmcharlt++ # again
15:08:38 <terranm> release_team++
15:08:42 <sandbergja> gmcharlt++
15:10:19 <JBoyer> In that case we can move on to a quick LP update
15:10:22 <JBoyer> #topic Launchpad Snapshot as of noon-ish Eastern
15:10:28 * JBoyer #info Open Bugs - 2512
15:10:33 <JBoyer> #info Pull Requests - 78
15:10:38 <JBoyer> #info Signed-off Bugs - 39
15:10:47 <JBoyer> Huh. Not sure how I /me'd that one ...
15:10:53 <JBoyer> v
15:10:54 <JBoyer> #topic Launchpad Changes Since Last Meeting
15:10:58 <JBoyer> #info Bugs Added - 49
15:11:02 <JBoyer> #info Pull Requests Added - 15
15:11:05 <JBoyer> v
15:11:06 <JBoyer> #info Sign-offs Added - 3
15:11:11 <JBoyer> #info Fixes Committed - 9
15:11:27 <shulabear> #info shulabear = Shula Link, GPLS/GCHR
15:11:28 <JBoyer> I need to find a client that will allow me to paste multiple lines....
15:11:50 <Dyrcona> JBoyer: Pidgin
15:12:12 <JBoyer> Dyrcona, I'll check it out.
15:12:41 <JBoyer> shulabear, any word on staff client functionality in MS Edge?
15:13:23 <shulabear> Everything I tested - which was, admittedly, mainly circ and OPAC functions - worked fine in Edge
15:13:39 <JBoyer> shulabear++
15:13:48 <terranm> shulabear++
15:13:53 <JBoyer> Those are things that see a lot of use
15:14:25 <shulabear> The LocalAdmin panel seemed in order, too.
15:14:40 <gmcharlt> shulabear++
15:15:02 <mmorgan> shulabear++
15:15:41 <Dyrcona> shulabear++
15:15:55 <JBoyer> We may revisit the topic of Edge support later since we have several larger new business items today.
15:16:06 <JBoyer> #topic New Business
15:16:23 <JBoyer> #info Updating Evergreen for Newer PostgreSQL Versions ( lp 1937294 )
15:16:23 <pinesol> Launchpad bug 1937294 in Evergreen "Updating Evergreen for Newer PostgreSQL Versions" [Undecided,New] https://launchpad.net/bugs/1937294 - Assigned to Jason Stephenson (jstephenson)
15:16:25 <JBoyer> At a guess, Dyrcona ?
15:16:38 <JBoyer> Hey, the agenda has been updated. :D
15:16:43 <Dyrcona> :)
15:17:07 <JBoyer> (and I sure did miss those 2 point release announcements. :-/ )
15:17:37 <Dyrcona> Yeah, so I know that JBoyer had mentioned wanting to have a look at some of the tests. I just wanted to see if anyone else is interested in having a look. If not, I will.
15:18:29 <Dyrcona> It's important that we get moving on more recent PostgreSQL support in Evergreen because 9.6 is EOL on Thursday, and 10 is EOL in about a year.
15:18:50 <JBoyer> I think the one I was kind of poking at during my last few hours at the hackaway may have been updated already. I'd like to have a look at more of them, but that's probably a couple weeks off.
15:19:34 <csharp_> upgrading to 10 over the next month or so
15:19:37 <Dyrcona> JBoyer: OK. I can revisit the tests with more recent master and update the bug.
15:19:51 <Dyrcona> We're running 10 in production, FWIW.
15:19:58 <csharp_> Dyrcona++
15:20:05 <JBoyer> Dyrcona++
15:20:39 <Dyrcona> In testing newer Pg releases, I've noticed performance gains in some areas and performance degradation in some others.
15:21:36 <Dyrcona> I'm inclined at the moment to add support for newer releases in 3.9 regardless of whether or not all of the performance issues have been addressed. We can sort that out later.
15:21:47 <JBoyer> +1
15:22:12 <Dyrcona> Maybe we can get a more comprehensive test suite along the way?
15:22:47 <JBoyer> What did you have in mind, pgtap, live db, something else?
15:23:34 <JBoyer> (Aside from "some of everything" because that would be great, but... ;) )
15:24:28 <Dyrcona> I'd like to figure out a way to combine pgtap with plprofiler. However, I got no output with plprofiler on Pg 14, but haven't had time to investigate.
15:25:11 <Dyrcona> Testing performance can be tricky because some issues don't crop up until you have thousands or millions of records.
15:26:09 <alynn26> There is work on a large dataset for testing for Evergreen.
15:26:14 <Dyrcona> I'm going to info the link to the Google drive folder where I've been making notes about what I've done so far.
15:26:24 <JBoyer> Yeah, a performance testing suite might be something that has to be put together and expected to run on live-ish data, not so much for concerto. That would still be a useful thing. (and wouldn't necessarily need to be tied to any particular verison)
15:26:53 <Dyrcona> #info Dyrcona's notes on PostgreSQL testing: https://drive.google.com/drive/folders/1sRZ8P1RHCOcZx42DxUehvOpoNkJJnfqn
15:28:37 <Dyrcona> So, in the meantime, I'll look at fixing the tests on newer Pg versions. It looks like the breakage is identical for Pg 12 through Pg 14.
15:30:39 <JBoyer> I know the version numbering change is somewhat symbolic, but it does feel like they're a lot more comfortable breaking things lately. We've hit issues with 10 in the past and now 12+ in just the last couple of years.
15:31:54 <Dyrcona> Eleven also has issues with Evergreen, just not as many.
15:32:21 <JBoyer> I assume the next topic is closely related even though it's coming at things from a slightly different angle.
15:32:42 <Dyrcona> Yeah, might as well move on.
15:32:49 <JBoyer> #info array_accum Aggregate and PostgreSQL 14 ( lp 1947595 )
15:32:49 <pinesol> Launchpad bug 1947595 in Evergreen "array_accum Aggregate and PostgreSQL 14" [Undecided,New] https://launchpad.net/bugs/1947595
15:33:45 <Dyrcona> This one is more concrete. There's a branch on that bug that replaces our custom array_accum function with array_agg from Pg. If someone would like to look at it, that would be great!
15:35:40 <JBoyer> It does seem pretty straightforward, does anyone want to volunteer to put a test system together to make sure that 2-3 calls of array_accum work the way we think they do? (which they almost certainly do)
15:35:57 <JBoyer> I can get to it in a week or two if not.
15:37:41 <JBoyer> I'd like to add that *anywhere* we have a func that largely duplicates (or because of age, exactly duplicates) an internal function we do whatever we can to remove it. I keep giving evergreen.upper and .lower sideeye but I know it's something to do with consistency in the face of multiple potential Unicode implementations, etc.
15:38:22 <JBoyer> #action JBoyer will test out the branch in lp 1947595
15:38:22 <pinesol> Launchpad bug 1947595 in Evergreen "array_accum Aggregate and PostgreSQL 14" [Undecided,New] https://launchpad.net/bugs/1947595
15:38:42 <JBoyer> Moving on with less than 20 before I vanish,
15:38:49 <JBoyer> #info Hackaway followup: Automating point release notes (abneiman)
15:38:52 <JBoyer> abneiman ?
15:39:31 <JBoyer> (And I am going to just push any further Edge support discussion to December at this point)
15:40:21 <abneiman> nothing to report, just wanted to make sure those not at Hackaway knew that this was a conversation point - since apparently release-notes-gathering was a factor in delaying 3.7.2/3.6.5 - so if anyone in the dev community has thoughts or tuits around that, please share :)
15:40:45 <JBoyer> abneiman++
15:40:46 <abneiman> the gist being "yes! we should automate point release notes more, in some manner"
15:41:08 <csharp_> yes - we developers need to be adding release notes documentation as we fix bugs as well as add features
15:41:45 <csharp_> a big question was where those would live and how to rejigger the building process for point releases to deal with them
15:43:58 <csharp_> but the current process of documenters who may not have deep tech knowledge were having to reverse engineer release notes based on reading git commit messages
15:44:11 <csharp_> ...is not optimal
15:44:31 <csharp_> (sorry, finished that sentence without remembering how I started it :-) )
15:44:36 <JBoyer> Is there an LP for this? That doesn't exactly lend it more urgency but does make it harder to forget if it's a high priority or similar.
15:44:52 <csharp_> not that I'm aware of
15:44:55 <csharp_> I can open one
15:44:58 <abneiman> I don't think there's an LP but i can make one
15:45:01 <abneiman> jinx csharp_
15:45:14 <csharp_> abneiman: be my guest
15:45:16 <Dyrcona> What csharp_ and abneiman said. :)
15:45:16 <JBoyer> Rock, paper, scissors, we need a pinesol plugin
15:45:30 <csharp_> @decide csharp_ or abneiman
15:45:30 <pinesol> csharp_: That's a tough one...
15:45:30 <abneiman> :) will do
15:45:40 <JBoyer> abneiman++
15:45:42 <JBoyer> csharp_++
15:45:43 <csharp_> abneiman++
15:45:48 <terranm> There is a "needsreleasenotes" tag that bug wranglers and testers can start using more, too
15:45:58 <mmorgan> bug 1948674
15:45:58 <pinesol> Launchpad bug 1948674 in Evergreen "Improve release building automation" [Undecided,New] https://launchpad.net/bugs/1948674
15:46:22 <csharp_> heh - *my* bug, even
15:46:29 <mmorgan> csharp_ is fast!
15:46:45 <csharp_> time travel is definitely real guyz
15:46:48 <abneiman> terranm++ yes, that too
15:46:52 <JBoyer> terranm, as I (possibly mis-)understand it this is more about massaging all of the existing release notes so it's easier to build releases, it's less about getting devs to write the notes.
15:47:11 <JBoyer> (which they should be doing, yes!)
15:47:20 <JBoyer> mmorgan++
15:48:08 <abneiman> it's a little of both - for point releases, where only a short sentence is really called for, a dev should write a short "release note: words here" message .... and then hopefully that can be additionally automated in the future, but the first step is helpful to those manuallly assembling point release notes
15:49:14 <csharp_> #info Launchpad bug 1948674 in Evergreen "Improve release building automation" [Undecided,New] https://launchpad.net/bugs/1948674
15:49:14 <pinesol> Launchpad bug 1948674 in Evergreen "Improve release building automation" [Undecided,New]
15:49:19 <terranm> Yes, the content has to be there in order for automation to work, so both
15:49:31 <JBoyer> So if anyone is interested in helping out review the wiki pages about releases or release notes to see what's being done today. (One or both may be labeled 2.something. That's still the current stuff for now...)
15:49:47 <csharp_> use Developer::Mind::Reading;
15:50:08 <abneiman> csharp_++
15:50:25 <JBoyer> Any last minute urgent and short topics before I reveal the surprising announcement that awaits us?
15:50:50 <JBoyer> too late!
15:50:51 <JBoyer> #topic Announcements
15:50:56 <JBoyer> #info next meeting is December 14th, 2021
15:51:04 <JBoyer> Thanks everyone
15:51:07 <JBoyer> #endmeeting