15:02:33 <JBoyer> #startmeeting 2021-X-Y - Developer Meeting, Agenda Available at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-01-11
15:02:33 <pinesol> Meeting started Tue Jan 11 15:02:33 2022 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:33 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:33 <pinesol> The meeting name has been set to '2021_x_y___developer_meeting__agenda_available_at_https___wiki_evergreen_ils_org_doku_php_id_dev_meetings_2022_01_11'
15:02:44 <JBoyer> #topic Introductions
15:02:47 <abowling> #info abowling = Adam Bowling, Emerald Data Networks
15:02:57 <csharp_> #info csharp = Chris Sharp, GPLS
15:02:58 <rhamby> #info rhamby = Rogan, EOLI
15:03:02 <terranm> #info terranm = Terran McCanna, GPLS
15:03:04 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:04 <alynn26> #info alynn26 = Lynn Floyd, Evergreen indiana
15:03:06 <JBoyer> #info JBoyer = Jason, Boyer, EOLI
15:03:12 <shulabear> #info shulabear = Shula Link, GCHRL in PINES
15:03:18 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:03:24 <berick> #info berick = Bill Erickson, KCLS
15:03:31 <collum> #info collum = Garry Collum, Kenton County Public Library
15:03:40 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:04:13 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:04:45 <JBoyer> Oh, good. Just noticed the typo in the startmeeting command.
15:05:08 <terranm> heh
15:05:13 <JBoyer> New year, new script, maybe.
15:05:22 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:05:33 <mmorgan> You mean it's not X/Y/2021?
15:05:44 <abowling> JBoyer: I rebuke any of your attempts to keep us in 2021
15:05:54 <JBoyer> Ok, folks joining later feel free to #info-rm us of who's who, as pertains to you.
15:05:54 <terranm> It sure FEELS like it's X/Y/2021
15:06:06 <JBoyer> agreed!
15:06:13 <JBoyer> Anyway
15:06:15 <JBoyer> #topic Action Items from Last Meeting
15:06:19 <JBoyer> #info Dyrcona will finish up the branch for newer PostgreSQL versions ( lp 1937294 )
15:06:21 <pinesol> Launchpad bug 1937294 in Evergreen "Updating Evergreen for Newer PostgreSQL Versions" [Undecided,In progress] https://launchpad.net/bugs/1937294 - Assigned to Jason Stephenson (jstephenson)
15:06:25 <Dyrcona> #info Done!
15:06:35 <JBoyer> :party_emoji:
15:06:38 <csharp_> "solve for X and Y"
15:06:48 <abowling> Dyrcona++
15:06:51 <JBoyer> csharp_++
15:06:54 <JBoyer> Dyrcona ++
15:07:21 <alynn26> Dyrcona ++
15:07:41 <terranm> Dyrcona++
15:07:43 <shulabear> Dyrcona++
15:07:52 <gmcharlt> Dyrcona++
15:07:58 <mmorgan> Dyrcona++
15:08:24 <JBoyer> Dyrcona, Is there a branch in another bug or am I missing something (i.e. is this the bug we should be looking at?)
15:08:29 <Dyrcona> I guess I haven't updated the launchpad bug..
15:08:32 <Dyrcona> :)
15:08:43 <JBoyer> Ah
15:09:41 <JBoyer> In that case there should some good news in our email later I suppose. In short, you've got concerto and friends loading deterministically?
15:09:50 <JBoyer> (again, that is)
15:10:57 <Dyrcona> Yes. Test results are consistent.
15:11:22 <JBoyer> Dyrcona++
15:11:25 <Dyrcona> And all pass, at least, the last few times that I tried.
15:11:50 <JBoyer> Ok, I'm planning to skip release info updates for lack of non-placeholder-ness unless someone prefers that be changed.
15:12:01 <JBoyer> So speak now or hold your peace a few weeks
15:12:17 <JBoyer> #topic Launchpad Updates
15:12:21 <JBoyer> #info Snapshot
15:12:26 <JBoyer> #info Open Bugs - 2606
15:12:29 <JBoyer> #info Pullrequests - 97
15:12:33 <JBoyer> #info Signedoff - 43
15:12:37 <JBoyer> #info Updates since last meeting
15:12:40 <JBoyer> #info Bugs Added - 42
15:12:44 <JBoyer> #info Pullrequest tag Added - 19
15:12:49 <JBoyer> #info Signedoff tag Added - 10
15:12:53 <JBoyer> #info Fix Committed - 2
15:15:13 <JBoyer> Hopefully there's time for committers to take a look at those 43 signed off bugs. And it looks like there are a little over 50 PRs with no signoffs that can be poked at. And don't be shy about removing the PR tag if there's an issue.
15:15:34 <JBoyer> On we move
15:15:36 <JBoyer> #topic New Business
15:15:42 <JBoyer> #topic Github actions to build docs bug 1903476
15:15:43 <pinesol> Launchpad bug 1903476 in Evergreen "Generate previews of documentation when documenters open a pull request on Github" [Wishlist,Confirmed] https://launchpad.net/bugs/1903476
15:17:03 <JBoyer> Would sandbergja or anyone else like to comment?
15:17:16 <sandbergja> Yes! I can comment
15:17:34 <sandbergja> We have great docs people who are contributing docs, often from Windows machines
15:17:43 <sandbergja> the current docs build process doesn't work on Windows
15:18:04 <sandbergja> so this is a way to have Github build it for them, so they can check their work
15:18:16 <sandbergja> and have a shared point of reference with docs reviewers
15:18:56 <sandbergja> My main question for this group is: are we okay using Github Actions (which is free, only means adding a smol YAML file to the repo, no additional sign-up steps necessary)
15:19:20 <sandbergja> Or would that be too much commitment to Github given our current conversation of where best to host our code?
15:19:52 <sandbergja> And I'd of course be happy to have some reviewers for my PR if the general idea of using Github Actions is agreeable :-)
15:21:51 <gmcharlt> I've no objection
15:22:04 <csharp_> same here
15:22:26 <JBoyer> I don't really have a problem with the .github bit, but if the official source stays at git.evergreen-ils.org then we either have a confusing split situation where docs work is happening primarily on GH and code work primarily "elsewhere"
15:22:39 <gmcharlt> JBoyer: that's the status qwuo
15:23:02 <JBoyer> I suppose so.
15:24:32 <JBoyer> No objection from me since it is so minor and does help docs.
15:26:32 <JBoyer> Tangentially, I keep thinking this would be an easier conversation to have in person but the world says "lol, no." *Is* there still an active conversation about the canonical location of the repository? (Not looking to necessarily continue it today, but it may be worth setting up a working group or something if there's sufficient interest)
15:27:51 <berick> i think the conversation is open, but maybe not so active at the moment
15:27:59 <csharp_> @who will convene the Git Synod of 2022?
15:27:59 <pinesol> abneiman will convene the Git Synod of 2022.
15:29:41 <JBoyer> Definitely not very active of late, it's true. Like I said, probably not something for today; should probably have more advanced notice.
15:30:49 <csharp_> even if we stay on gitolite, we're going to need to migrate to the newer server sometime soon, but yeah, it is not this day
15:30:54 <JBoyer> Back to the topic though, sandbergja ++ great work getting this together. I'm hoping to also put together some how-to steps to get things working on Windows, but the more options the more submissions, hopefully.
15:31:51 <JBoyer> #action JBoyer will check out sandbergja 's GH Actions branch
15:31:55 <JBoyer> #topic Eyes on bug 1955079 (mmorgan)
15:31:56 <pinesol> Launchpad bug 1955079 in Evergreen "Emailing Bib Records from the catalog (staff and OPAC) reports success, but fails to send email" [High,Confirmed] https://launchpad.net/bugs/1955079
15:31:59 <sandbergja> JBoyer++
15:32:31 <mmorgan> We recently became aware of this issue. Not sure when it broke.
15:32:42 <mmorgan> Also not sure why it's not more widely reported.
15:32:54 <csharp_> we can confirm
15:33:03 <terranm> I was flabbergasted that we've been on 3.6 for a year and nobody reported to us that it wasn't working
15:33:20 <JBoyer> Sometimes the lack of signal is itself a signal.
15:33:31 <csharp_> it creates a preview A/T event, but I don't see where it actually enters the code to create a non-preview event
15:33:53 <mmorgan> csharp_: I observed the same thing.
15:33:56 <abowling> I dug around on it this afternoon. Per mmorgan's message in launchpad, the error seems to be occurring due to an improperly lengthed array relative to the offset and length values in splice
15:33:58 <miker> I was looking at that this morning, but nothing stood out in a static analysis. does anyone have a log chunk of an attempt they could share?
15:34:19 <miker> I'm going to gather some, but would like more to compare
15:34:28 * mmorgan hasn't been successful finding log entries.
15:35:21 <mmorgan> Also, not sure how this factors in, but as terranm noted on the bug, the enhanced email isn't in the angular catalog yet.
15:36:20 <miker> ah! I hadn't seen that new comment, thanks for pointing it out abowling
15:36:31 <mmorgan> The console errors came from the angular catalog. I've seen no such console errors from tpac
15:36:56 <abowling> miker: sure thing. i was also going to attempt to create the error to see what logs might reveal
15:37:03 <mmorgan> abowling++
15:37:19 <JBoyer> format_biblio_record_entry is doing a lot more with @_ and splice than seems preferable.
15:38:14 <miker> looks like a new-perl issue...
15:38:33 <miker> I'll poke more in a bit
15:38:44 <csharp_> @blame new perl
15:38:44 <pinesol> csharp_: new perl was monkeying around too much on the prod servers!
15:38:57 <csharp_> @blame new anything
15:38:57 <pinesol> csharp_: It really IS new anything's fault!
15:38:58 <JBoyer> That would explain why it can be hard to notice, if it hits buster but not stretch and focal but not xenail.
15:39:30 <JBoyer> mmorgan++
15:39:53 <JBoyer> I can safely say more eyes have been laid upon the bug. :) Sounds like it shouldn't be too far off now.
15:40:38 <JBoyer> Anything more to say about these two bugs or any other new business to raise ?
15:40:41 <mmorgan> Here's hoping! We want to avoid changing the catalog to say your email has NOT been queued for delivery!
15:40:52 <csharp_> bug 1956626 is causing us some trouble in PINES
15:40:53 <pinesol> Launchpad bug 1956626 in Evergreen "Shelving locations in holdings editor only workstation library" [High,New] https://launchpad.net/bugs/1956626
15:40:59 <JBoyer> But a template change is so simple! ;p
15:41:42 <terranm> mmorgan: Yeah, we are removing all of those email links in the OPAC for the time being.
15:41:44 <csharp_> we're upgrading to 3.8 this weekend and the fact that the new volcopy editor doesn't load system-level copy locations means we may need to revert that (or hack the routing back to AngJS)
15:43:38 <terranm> This bug seems to be related to that one as well: https://bugs.launchpad.net/evergreen/+bug/1956627
15:43:39 <pinesol> Launchpad bug 1956627 in Evergreen "System level workstation displays only consortia owned shelving locations" [Undecided,New]
15:45:28 <berick> csharp_: i'll look at 1956626
15:45:38 <terranm> berick++
15:45:45 <JBoyer> berick++
15:46:11 <terranm> This is another new holding template bug that is causing us grief: https://bugs.launchpad.net/evergreen/+bug/1956790
15:46:12 <pinesol> Launchpad bug 1956790 in Evergreen "Holding template with item alert breaks save" [High,New]
15:46:12 * JBoyer was lost looking for the Angular item editor for a bit.
15:46:33 <csharp_> berick++
15:46:48 <JBoyer> And I couldn't find it because this repo had the wrong branch checked out... Works fine in 3.7.2! >_>
15:47:06 <terranm> (Note that we had to install the fix at https://bugs.launchpad.net/evergreen/+bug/1951162 in order for the new holdings editor to work in 3.8 as well.)
15:47:06 <pinesol> Launchpad bug 1951162 in Evergreen "Angular Holdings Maintenance does not successfully retrieve AngularJS item templates" [Critical,Confirmed]
15:47:55 <mmorgan> Ouch! Folks are very attached to their templates.
15:48:12 <berick> that one should prob. be merged.  the last few comments are related to what will be a new bug
15:48:14 <csharp_> mmorgan: yes
15:49:35 <terranm> berick: I wasn't sure if we should go ahead and sign off on it or not because of those other comments
15:49:49 <JBoyer> I'll note that there's no need to stop discussing bugs just because the meeting has ended, anything anyone wants to bring up to get in the minutes and whatnot or should we look at turning  meetbot off and whoever can having a short working session?
15:49:58 <berick> terranm: the patch is good to go.  i'll open a separate LP for the trailing comments.
15:50:09 <terranm> Okay, I'll mark it signed off
15:51:06 <JBoyer> ok,
15:51:12 <JBoyer> #Announcements
15:51:14 <JBoyer> #info Next meeting is February 8th, 2022
15:51:17 <JBoyer> #endmeeting