14:00:33 <dluch> #startmeeting 2022-03-03 - Documentation Interest Group Meeting
14:00:33 <pinesol> Meeting started Thu Mar  3 14:00:33 2022 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 <pinesol> The meeting name has been set to '2022_03_03___documentation_interest_group_meeting'
14:00:40 <dluch> #topic Agenda
14:00:50 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20220303-agenda
14:00:50 <dluch> #info The agenda and minutes from the February meeting can be found here: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20220203-agenda
14:00:59 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:01:10 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:01:10 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:01:10 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:01:20 <alynn_26> #info alynn_26 is Lynn Floyd
14:01:32 <dluch> #topic Introductions
14:01:32 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:32 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:02:02 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative
14:02:09 <mantis> #info mantis is Gina Monti, Bibliomation
14:02:41 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:03:12 <mantis> alynn_26: nice to see ya!
14:03:22 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:03:26 <dluch> #topic Old and Ongoing Business
14:03:26 <dluch> #info Check-in - How's everyone doing?
14:03:45 <mantis> Doing alright.  I think most of the OPAC docs are done.  One of my branches got merged.
14:03:49 <alynn_26> I'm looking for work, anyone got any?:)
14:04:00 <dluch> mantis: Woot!
14:04:08 <alynn_26> mantis++
14:04:12 <abneiman> I saw my first daffodil today <3
14:04:26 <dluch> mantis++
14:04:36 <dluch> abneiman: So cool!!
14:04:48 <Dyrcona> abneiman++ # We got snow this morning.
14:05:32 <abneiman> Dyrcona: that's a bummer - we still may see snow, but it's getting less and less likely
14:05:37 <dluch> It was 81 (27) yesterday but I haven't seen any flowers. And it's going to snow next week.
14:06:41 <jihpringle> we got snow on Monday but the sun is now out and the snow is melting fast
14:06:50 <jihpringle> I'm ready for spring :)
14:06:55 <dluch> :-)
14:06:57 <alynn_26> It going to be a pretty weekend here, but then back to the 40'S for us in Indiana
14:07:28 <dluch> #info Previous Action Items
14:07:42 <dluch> How are these coming?
14:07:42 <dluch> I'll take them in order...
14:08:03 <dluch> How are these coming?
14:08:03 <dluch> I'll take them in order...
14:08:15 <dluch> 1. dluch and jweston will look at the wiki's Documentation Needs List (linked at the beginning) to ensure that undocumented features listed are still relevant in the 3.8 context.
14:08:27 <dluch> I'm sorry, y'all, I still haven't done anything with this. jweston?
14:08:37 <dluch> Does this kind of fall into the reorg project?
14:09:07 <jihpringle> I think the reorg project replaces this
14:09:29 <abneiman> yeah, agreed
14:09:32 <dluch> That was kinda what I was thinking, too. I'm going to remove this action
14:09:44 <jihpringle> maybe what needs to be done is making sure any undocumented things are on the reorg spreadsheet
14:09:51 <dluch> And also, probably, this one?
14:09:51 <jihpringle> and retiring the wiki page
14:09:52 <dluch> 2. dluch and jweston (and whoever else wants to) will see what documentation is missing from the Documentation Needs List for newest releases.
14:10:11 <dluch> jihpringle++
14:10:27 <alynn_26> I would think that this is part of the reorg project also.
14:10:39 <jihpringle> agreed
14:10:42 <dluch> Cool. Getting rid of them!
14:10:55 <dluch> 3. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
14:10:57 <dluch> Any news on this one?
14:11:19 <alynn_26> No. I have time now, I will investigate this further.
14:11:33 <dluch> Great, thank you!
14:11:55 <alynn26> Also the next one.
14:12:02 <dluch> #action alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
14:12:16 <dluch> #action alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:12:21 <dluch> alynn26++
14:12:37 <dluch> 5. dluch will get the October recording processed and posted--unless she already did.
14:12:46 <abneiman> alynn26++
14:12:56 <dluch> She did not. But will get to it this afternoon. Same for February.
14:13:34 <dluch> #action dluch will get the October and February meeting recordings processed and posted
14:13:59 <dluch> 6. jweston will talk to jihpringle and mantis about the documentation and images review spreadsheets, create a Google doc for drafting a contribution guide, and send the link to the docs mailing list for everyone to help.
14:14:03 <dluch> This was done, yes?
14:14:19 <jihpringle> yes, I think so
14:14:31 <mantis> yeah I don't think we need the image review spreadsheet anymore
14:14:40 <mantis> since it's more or less consolidated with the master spreadsheet we have
14:14:40 <jihpringle> we added it to the existing spreadsheet
14:14:47 <dluch> Sweet
14:14:59 <abneiman> one spreadsheet to rule them all
14:15:05 <dluch> jihpringle++ mantis++ jweston++
14:15:21 <dluch> theonespreadsheet++
14:15:40 <dluch> dbs will see if it's possible to trigger a rebuild using something like a particular branch name, like docs-build or something hacky
14:15:44 <dluch> 7.
14:15:54 <dluch> dbs had this done right after the January meeting and the answer is yes. "My #action is done, the answer is "yes" (no hacks needed, other than to wait for the mirror to happen): https://docs.gitlab.com/ee/ci/ci_cd_for_external_repos/"
14:16:02 <dluch> dbs++
14:16:31 <dluch> Next...
14:16:32 <alynn26> dbs++
14:16:40 <dluch> #info February Zoom Meeting--Recap, Decisions, and Follow-up
14:17:07 <dluch> Take a look at the link at the beginning for the February agenda and notes. We did have a few action items from that meeting. (and feel free to correct my notes if I missed anything!)
14:17:27 <dluch> We talked about picking some completed documentation at the meeting today to send to General for review. jihpringle volunteered to blurb it and send it out. We can maybe table that until New Business, if everyone's okay with that?
14:17:49 <dluch> jihpringle also was going to talk to rhamby about setting up a DIG playlist on our YouTube channel.
14:17:55 <jihpringle> I completely forgot about the blurb
14:18:00 <mantis> +1 new business
14:18:04 <dluch> jihpringle: did you have time to get to that yet?
14:18:26 <dluch> jihpringle: no worries! Are you still okay doing that?
14:18:57 <rhamby> she did touch base with me about who/how it can be done and I replied but if she replied since I missed it
14:19:04 <jihpringle> yes, I'm still good to do the blurb
14:19:12 <rhamby> bascially I just need to know what videos in what order you want and what the play list is to be called
14:19:23 <dluch> jihpringle++
14:19:23 <jihpringle> rhamby you did not miss a follow up, it's on my list :)
14:19:56 <jihpringle> dluch: once the October video is available we should have everything for the playlist for now
14:20:08 <dluch> #action jihpringle will blurb some completed documentation and send it out to General for review
14:20:15 <dluch> Thanks, rhamby!
14:20:23 <dluch> jihpringle++
14:21:04 <dluch> We also decided that DIG needed more docs committers, since abneiman is the only one left. More on that in New Business, too.
14:21:16 <dluch> Anyone else who was there want to add anything?
14:22:10 <abneiman> ♫ one is the lonliest number ♫
14:22:17 <dluch> lol
14:22:33 <dluch> #info Docs organization: Progress
14:22:41 <dluch> How are things going?
14:23:19 <mantis> uh
14:23:41 <mantis> there was one comment about how the admin pages were organized in a somewhat weird way during the new dev meeting
14:24:00 <mantis> After rummaging through, I start to understand why it's like this but I would be open to other opinions on it
14:24:05 <abneiman> mantis: the admin pages themselves, or the docs about said?
14:24:16 <alynn26> I actually have a commit redoing them. out there
14:24:25 <alynn26> I think it is in github.
14:24:39 <dluch> oh, great!
14:25:00 <dluch> alynn26++
14:25:34 <mantis> alynn26++ thank you!
14:25:45 <dluch> abneiman: the docs, I'm pretty sure
14:25:55 <mantis> Docs yes
14:26:17 <dluch> mantis++
14:26:20 <abneiman> I mean, in context that makes sense, but also I just hate that the admin pages are alphabetized instead of classified
14:26:29 <abneiman> mantis++ alynn26++
14:26:33 <mantis> I agree with that
14:26:46 * abneiman secretly hoped that alynn26's patch was to reorder the admin pages in the interface :)
14:27:01 <mantis> in any case i'm glad the work on the docs are addressing this
14:27:04 <mantis> that's a big help!
14:27:05 <dluch> abneiman++ :-D
14:27:22 <dluch> #info April Show & Tell
14:27:33 <dluch> April's Meeting, on Zoom, will be a presentation from abneiman and mantis on GitLab stuff (or GitHub? I couldn't remember, lol)
14:27:44 <dluch> abneiman and/or mantis: either of you want to say more?
14:28:23 <abneiman> uh, I hope it's github
14:28:35 <abneiman> because as little as I know about github I know less about gitlab :)
14:28:42 <dluch> abneiman++
14:28:57 <csharp_> abneiman: they are more similar than different, UI-wise
14:29:05 <dluch> April's Meeting, on Zoom, will be a presentation from abneiman and mantis on GitHub stuff
14:29:07 <dluch> :-)
14:29:12 <Dyrcona> We should pick one and migrate.
14:29:23 <abneiman> csharp_++ # let's keep my presentation to one semi-familiar interface at a time tho
14:29:35 <csharp_> abneiman++
14:29:43 <abneiman> Dyrcona: you're not wrong. That's been a conversation for a while.
14:29:49 <mantis> github++
14:29:58 <dluch> Yep
14:30:08 <mantis> I still need the credentials though so I can stumble my way through it
14:30:21 <dluch> Well, I am excited about your presentation!
14:30:21 <mantis> I mean smoothly venture over the high seas
14:30:24 <dluch> mantis++
14:30:30 <dluch> Yes, will get to that asap
14:30:50 <abneiman> mantis and I will stumble gracefully through the high seas
14:30:52 <abneiman> or something
14:31:01 <dluch> Excellent!
14:31:04 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:32:18 <dluch> #topic New Business
14:32:28 <dluch> #info New documentation committers!!
14:32:44 <dluch> Congratulations to mantis, Bmagic, and alynn26, who we chosen by consensus and agreed to become our newest docs committers!!
14:32:50 <dluch> /me waves Kermit arms
14:32:58 <mantis> lol
14:33:09 <jihpringle> mantis++ Bmagic++ alynn26++
14:33:09 <dluch> lol, I did that wrong
14:33:16 <alynn26> Thanks.
14:33:29 <alynn26> Now to figure out how to do that.
14:33:33 <dluch> I still need to get in touch with the core committers group to get them set up with permissions for this role. I'm sorry I haven't done that yet. (Any core committers here? :-) )
14:33:46 <abneiman> mantis++ Bmagic++ alynn26++
14:34:02 <dluch> mantis++ Bmagic++ alynn26++
14:34:19 <mantis> Bmagic++ alyn266++
14:34:36 <alynn26> mantiss++ Bmagic++
14:34:53 <dluch> #action dluch will get in touch with the core committers group to get mantis, Bmagic, and alynn26 set up as documentation committers
14:35:29 <dluch> #info Committing docs pushes--during meeting?
14:35:46 <csharp_> dluch: email gitadmin@evergreen-ils.org
14:35:53 <dluch> I admit that I wrote down very little that made sense in my notes about this...
14:35:58 <dluch> csharp_++
14:36:10 <mantis> lol
14:36:15 <mantis> I was going to ask for some clarification
14:36:15 <dluch> One other thing we talked about in February was whether or not it would be helpful for abneiman to take time during the DIG meetings to do committs? Would that be helpful since you're already here, or would that be too much going on at once? abneiman, we talked about this before you came in February. New docs committers, if you have thoughts about the idea, feel free to comment, too.
14:36:40 <csharp_> if those three aren't already keyed they will need to provide SSH public keys to gitadmin
14:36:50 <csharp_> but I think they are already
14:36:54 <abneiman> in general, calendaring things is a way to ensure they get done, yes
14:36:59 <mantis> abneiman: I don't know how committing works with your procedure.  Is there enough time during a meeting to make it happen?
14:37:14 <abneiman> yes, if I'm prepared, LOL (I am not prepared today)
14:37:33 <abneiman> the process I followed is from Jane & I think it's documented though
14:37:36 <mantis> should we reply to announcement emails with branches ready to go prior to the meeting?
14:37:45 <dluch> csharp, thanks!
14:38:28 <abneiman> well, I thought we were going to try to pivot to github commits (I do git command line right now) so we can take advantage of the new build-testing plugin
14:38:48 <abneiman> that's what I'm supposed to teach myself this month before I talk to y'all about it in April :)
14:38:52 <dluch> Correct (I think)
14:38:57 <dluch> :-)
14:39:10 <mantis> I see
14:39:39 <alynn26> abneiman++
14:40:26 <dluch> abneiman++
14:40:27 <abneiman> anyway I"m rusty, I haven't actually pushed anything since 3.8 and / or the last set of point release notes
14:40:36 * Dyrcona can add the docs committers right now.
14:40:44 <mantis> Dyrcona++
14:40:46 <abneiman> Dyrcona++
14:41:00 <Dyrcona> alynn26: Do you use lfloyd in the Evergreen working repository?
14:41:15 <alynn26> yes, I do.
14:41:34 <Dyrcona> Do you still have access to that ssh key or do you need to send a new one?
14:41:48 <alynn26> I still have access.
14:41:54 <dluch> Dyrcona++
14:42:29 <alynn26> Dyrcona++
14:42:37 <Dyrcona> So, I'm adding Bmagic (blake), mantis (gmonti), and alynn26 (lfloyd). Anyone else?
14:42:50 <dluch> Dyrcona: That's it!
14:43:04 <dluch> Thank you!!
14:43:23 <mantis> my github account is gmontimantis if that hellps
14:44:29 <Dyrcona> mantis: No. I have to use the "name" associated with your key on git.evergreen-ils.org.
14:44:39 <mantis> cool thank you!
14:45:09 <Dyrcona> I'm double-checking for typos before I make it official.
14:46:19 <Dyrcona> OK. It's official.
14:46:26 <Bmagic> Dyrcona++
14:46:33 <dluch> Dyrcona++
14:46:38 <dluch> Woohoo!!
14:46:38 <mantis> Dyrcona++
14:46:42 <jihpringle> Dyrcona++
14:47:12 <dluch> #info Show and Tell Topic for June or just Conference?
14:47:27 <dluch> Do we want to have a Zoom meeting in early June? If so, what do want to cover? Any volunteers?
14:47:41 <dluch> :-)
14:47:50 <mantis> I say just conference
14:48:02 <dluch> We will have a DIG meeting during the Hackfest
14:48:10 <abneiman> +1 to just conference
14:48:47 <dluch> Excellent. I was hoping you'd say that! lol
14:49:02 <dluch> Speaking of...
14:49:04 <dluch> #info Conference
14:49:06 <jihpringle> also +1 to just conference, but we may want to talk in May about any DIG recruiting we want to do in conjunction with the conference
14:49:21 <dluch> jihpringle: good idea!
14:49:30 <mantis> jihpringle++
14:49:40 <dluch> jihpringle++
14:49:45 <dluch> The Evergreen International Online Conference will be June 13-16. Call for proposals has gone out. Anyone submitting a docs-related thing? Or have an idea for one?
14:49:53 <abneiman> good call jihpringle
14:50:37 <dluch> I can do the lightning talk again this year
14:50:50 <mantis> One of my goals for the conference or Hackfest is to try to talk to devs in helping out with a few of the docs
14:50:53 <alynn26> dluch++
14:51:03 <alynn26> mantis++
14:51:04 <dluch> mantis++
14:51:04 <mantis> I don't know where that would fit in there but that's my thought
14:51:18 <dluch> Probably Hackfest?
14:51:29 <mantis> +1 hackfest
14:51:31 <alynn26> I can do by basic of ASCIIDOC again, or do we want to do one about the DOc Reorg
14:51:32 <jihpringle> would it be useful to do a session to talk about docs, the review, and what community members can do to help?
14:51:54 <alynn26> jihpringle, that was my thoughts
14:51:57 <dluch> Yes, to both of those
14:52:00 <mantis> +1 Asciidoc and also the doc reorg
14:52:18 <mantis> can jihpringle do her cool presentation on GitHub desktop?
14:52:37 <mantis> I can't stress enough that it made it so much easier for me to submit after seeing that
14:52:39 <jihpringle> definitely willing to if it would be helpful :)
14:52:51 <mantis> jihpringle++
14:52:52 <alynn26> +1
14:52:56 <dluch> +1
14:53:17 <dluch> alynn26++ jihpringle++
14:53:53 <dluch> DIG rules the world! Er...conference! ;-)
14:54:15 <jihpringle> I could frame it as an easy to submit docs session, and start with how people can contribute without needing to touch git and then finish with the demo
14:54:33 <jihpringle> for those who are adventurous
14:54:50 <dluch> +1 that sounds like a great plan
14:54:51 <jihpringle> try to draw more people in without having them feel like they don't have the technical skills to help
14:54:54 * alynn26 lol
14:55:15 <alynn26> I will get my presentation submitted.
14:55:26 <jihpringle> I'll write up a proposal :)
14:55:36 <dluch> Thanks!
14:56:12 <dluch> #info Documentation to send for review
14:56:41 <dluch> We're getting close to time, so if we need to table this, it's okay. But...
14:56:43 <dluch> What completed documentation is a good candidate for this new procedure we're going to try out?
14:56:56 <dluch> IIRC, it was going to be completed docs that didn't already have a pull request. Is that right?
14:57:31 <mantis> Does it need to be an entire page?
14:57:51 <mantis> Oh is this for the new commit procedure with Git Hub?
14:59:11 <abneiman> so with a whole new page, you need to also show a new menu entry. With an edited page you don't. And I'd recommend using something with screenshots so that can be covered as well.
14:59:19 <alynn26> How about this one.  I do have a pull request for it.  https://github.com/evergreen-library-system/Evergreen/pull/142/files
14:59:30 <abneiman> show new menu entry = show how to add a menu entry
15:00:05 <dluch> mantis: for the idea of sending out completed documentation quarterly to General to ask people to review (?)
15:00:12 <mantis> Oh I see
15:00:36 <abneiman> oh I also misunderstood, lol
15:00:50 <abneiman> yes, +1 to sending completed docs for review
15:00:58 <abneiman> if they're in adoc even better
15:01:04 <abneiman> but they don't need to be
15:01:05 <dluch> I have to admit I'm fuzzy on my recollection of what the discussion around this was
15:01:23 <dluch> Okay, cool
15:01:25 <mantis> +1
15:01:33 <jihpringle> I think I need to watch the video from February :)
15:01:36 <mantis> I also did a lot of changes to the OPAC version that could work
15:01:43 <abneiman> hahaha same jihpringle
15:01:48 <mantis> If you want something more recent
15:01:58 <alynn26> +1 on that
15:02:02 <jihpringle> I know I was part of the conversation but I'm also fuzzy about it
15:02:07 <dluch> Me, too, lol. Let's just wait on this one. We can talk about it on the discussion list, maybe?
15:02:16 <abneiman> +1
15:02:16 <mantis> +1 discussion list
15:02:20 <jihpringle> +1
15:02:21 <alynn26> +1
15:02:42 <dluch> Alright, then...
15:02:45 <dluch> #info Our next meeting will be on April 7, on Zoom. I'll post the link on the agenda about a week prior to the meeting.
15:03:06 <dluch> Unless anyone has pressing new business, I'll close us out
15:04:02 <dluch> Thanks for being here, everyone!
15:04:04 <dluch> #endmeeting