15:01:38 <JBoyer> #startmeeting 2022-04-12 - Developer Meeting
15:01:38 <pinesol> Meeting started Tue Apr 12 15:01:38 2022 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:38 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:38 <pinesol> The meeting name has been set to '2022_04_12___developer_meeting'
15:01:42 <JBoyer> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-04-12
15:01:48 <JBoyer> #topic Introductions
15:01:53 <abowling> #info abowling=Adam Bowling, Emerald Data Networks
15:01:55 <JBoyer> Make it known!
15:02:02 <terranm> #info terranm is Terran McCanna, PINES
15:02:08 <berick> #info berick Bill Erickson, KCLS
15:02:09 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:02:14 <shulabear> #info shulabear is Shula Link, GCHRL in PINES
15:02:20 <mmorgan> #info: mmorgan = Michele Morgan, NOBLE
15:02:21 <csharp_> #info csharp = Chris Sharp, GPLS
15:02:35 <miker> #info miker = Mike Rylander, EOLI
15:03:16 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:03:22 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:55 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:04:03 <JBoyer> Others feel free to drop an info as you arrive.
15:04:04 <jeffdavis> #info jeffdavis is Jeff Davis, BC Libraries Cooperative (Sitka)
15:04:58 <JBoyer> The agenda is looking sparse. Before I just scoot down to Launchpad updates and New Business, anything to report from the Evergreen Release Team?
15:06:03 <miker> sorry, looked away for a second
15:06:34 <JBoyer> I'll take that as a maybe and drop this:
15:06:35 <JBoyer> #topic Evergreen Release Updates
15:06:43 <miker> not really ... I have a beta tarball (and there's a branch pushed) but I still need to get it onto the server for download
15:07:05 <miker> RC1 is next Wednesday
15:07:46 <miker> if anyone could confirm that the beta tarball looks correct (once I get it up for download), I'd appreciate it
15:08:14 <JBoyer> Ah, haven't made that particular hotkey mistake in a little while. :/
15:08:24 <JBoyer> miker++
15:08:24 <miker> mainly to make sure I've built it properly, so I don't make a broken RC and .0
15:08:42 <jamin> #info jamin = Jeremiah Miller, LINN
15:09:42 <miker> and thanks to all that had time to participate in bug squashing week!
15:10:14 <terranm> yes, bugsquashers++
15:10:27 <miker> and, especially
15:10:30 <miker> terranm++
15:10:35 <terranm> :)
15:10:42 <mmorgan> terranm++
15:10:47 <shulabear> terranm++
15:10:53 <JBoyer> terranm++
15:10:58 <jeffdavis> yay terranm!
15:11:09 <JBoyer> Ok, moving along
15:11:14 <JBoyer> #topic Launchpad Status
15:11:18 <JBoyer> #info Snapshot
15:11:23 <JBoyer> #info Open Bugs - 2727
15:11:27 <JBoyer> #info Pullrequests - 74
15:11:30 <JBoyer> '#info Signedoff - 38
15:11:33 <JBoyer> #info Updates Since Last Meeting
15:11:36 <JBoyer> #info Bugs Added - 58
15:11:39 <JBoyer> #info Pullrequest tag Added - 31
15:11:44 <JBoyer> #info Signedoff tag Added - 46
15:11:51 <JBoyer> #info Fix Committed - 58
15:11:57 <JBoyer> #topic New Business
15:12:06 <JBoyer> #info Bug 1955079 - Any hope for patrons?
15:12:06 <pinesol> Launchpad bug 1955079 in Evergreen "Emailing Bib Records from the catalog (staff and OPAC) reports success, but fails to send email" [High,Confirmed] https://launchpad.net/bugs/1955079
15:12:09 <JBoyer> Take it away, mmorgan
15:12:20 <mmorgan> Just wanted to keep this on the radar.
15:12:27 <mmorgan> We're really missing this feature!
15:12:42 <terranm> FYI, I noticed during this BSW that we're running low on bug fixes that can really be tested from the client side. Many of the remaining patches need review from the developers
15:13:05 <terranm> mmorgan++ we had to hide the buttons in our opac, too
15:13:28 <JBoyer> (Kind of) a good problem to have.
15:14:17 <mmorgan> miker's patch works for the staff catalog, but doesn't help opac users :-(
15:15:50 <JBoyer> Does anyone have time to take a look at bug 1955079, possibly using miker's staff fix as a template as to how to address the opac?
15:15:50 <pinesol> Launchpad bug 1955079 in Evergreen "Emailing Bib Records from the catalog (staff and OPAC) reports success, but fails to send email" [High,Confirmed] https://launchpad.net/bugs/1955079
15:16:18 <JBoyer> The #action command has not seen a lot of use of late.
15:16:52 <miker> I can put it on my list to definitely look at pre-RC, but I can't promise a fix :(
15:17:36 <JBoyer> #action miker will look into 1955079
15:17:41 <JBoyer> miker++
15:17:42 <miker> "I have no memory of this place" ... so will have to refresh my brain on the client code
15:17:49 <mmorgan> miker++
15:18:08 <csharp_> miker: when in doubt, follow your nose
15:18:24 <miker> it does smell less foul down there, yes
15:18:40 <JBoyer> and mmorgan++
15:19:03 <JBoyer> Any other last-minute new business or other questions / comments?
15:19:08 <shulabear> miker++ mmorgan++
15:19:45 <JBoyer> #topic Announcements
15:19:49 <JBoyer> #info Next Meeting is May 1, 2022
15:19:54 <JBoyer> #endmeeting