14:00:09 <dluch> #startmeeting 2022-05-05 - Documentation Interest Group Meeting
14:00:09 <pinesol> Meeting started Thu May  5 14:00:09 2022 US/Eastern.  The chair is dluch. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <pinesol> The meeting name has been set to '2022_05_05___documentation_interest_group_meeting'
14:00:18 <dluch> #topic Agenda
14:00:30 <dluch> #info The agenda can be found here:  https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20220505-agenda
14:00:40 <dluch> #info The agenda and minutes from the March meeting can be found here: https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20220203-agenda
14:00:48 <dluch> Welcome everyone!  Today's meeting will be business, followed by collaboration and working on documentation, if there's time.
14:01:00 <dluch> #topic Helpful Information: Documentation contributions and collaboration
14:01:00 <dluch> #info You can find the Documentation Needs List at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs
14:01:00 <dluch> #info DIG Roles can be found at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:digparticipants
14:01:08 <dluch> #topic Introductions
14:01:17 <dluch> Please paste "#info <username> is <name>, <affiliation>" to identify who you are and what organization, if any, you represent.
14:01:30 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:01:34 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative
14:02:50 <dluch> I'm going to give folks another minute or so, but if it's just you and me, jihpringle, I don't think we need to meet, lol (unless you want to)
14:03:17 <mantis> #info mantis is Gina Monti, Bibliomation (will somewhat be around for this meeting)
14:03:33 <jweston> #info jweston is Jennifer Weston, Equinox
14:04:35 <dluch> Thank you all for coming! If you come in later, feel free to introduce yourself when you arrive.
14:04:39 <dluch> #topic Old and Ongoing Business
14:04:50 <dluch> #info Check-in - How's everyone doing?
14:05:13 <mantis> Doing pretty good with conference planning
14:05:16 <jihpringle> we may finally be done with winter, so pretty good!
14:05:17 <dluch> We have been having lots of rain and I definitely didn't expect to have my furnace on at the beginning of May
14:05:18 <jweston> more crazy days! and weather wise -- summer is here in NC
14:05:33 <dluch> mantis: awesome!
14:06:28 <dluch> I think wild weather is going to be the norm now
14:06:53 <dluch> #info Previous Action Items
14:07:09 <dluch> I think these will probably be quick.
14:07:09 <dluch> I'll take them in order...
14:07:21 <dluch> 1. alynn26 and Bmagic will investigate some possible options for adding pdf generating to our documentation site
14:07:33 <dluch> Bmagic is off today, so I'll carry this one again.
14:07:46 <dluch> #action Bmagic will investigate some possible options for adding pdf generating to our documentation site.
14:08:07 <dluch> 2. alynn26 will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:08:17 <dluch> I think that, probably, someone else needs to take on this action item. Any volunteers?
14:08:49 <jweston> dluch: I'll take it
14:08:57 <dluch> jweston++
14:09:14 <dluch> #action jweston will look into Evergreen's Antora CSS to see why anything that is a heading 4 ==== or lower is not rendering properly formatted in Antora. Example: "Sort By Geographic Proximity" at https://docs.evergreen-ils.org/eg/docs/latest/opac/using_the_public_access_catalog.html#_viewing_a_record
14:09:25 <dluch> 3. dluch will get the October and February recordings processed and posted.
14:09:39 <dluch> Ugh, I did not get to this after the last meeting, after all. I should finally be able to after I have next week off.
14:09:53 <dluch> #action dluch will get the October and February recordings processed and posted.
14:10:20 <dluch> 4. jihpringle will blurb some completed documentation and send it out to General for review
14:10:34 <jihpringle> have not done this yet
14:10:36 <dluch> jihpringle? I don't think she's had time to do this yet?
14:10:50 <jihpringle> when we talked about it I was super clear about what we wanted to do, and now less so
14:10:57 <jihpringle> I think I need to watch the recording :)
14:11:12 <dluch> jihpringle++ should we carry it or try and redefine after I get the recordings done?
14:11:16 <dluch> :-)
14:11:37 <jihpringle> lets re-visit it after the recordings are done
14:11:43 <dluch> Sounds good!
14:11:52 <dluch> 5. dluch will get in touch with the core committers group to get mantis, Bmagic, and alynn26 set up as documentation committers
14:12:02 <dluch> This was done before the end of the last meeting! Thanks, Dyrcona!
14:12:02 <dluch> Dyrcona++
14:12:08 <mantis> Dyrcona++
14:12:21 <jweston> Dyrcona++
14:12:40 <jihpringle> Dyrcona++
14:12:40 <dluch> #info Docs organization: Progress
14:13:03 <dluch> How are things going? Things have been nuts here so I haven't done anything.
14:13:36 <jweston> same here -- suggestion to have a call sometime before con to prioritize what we want to work on during hackaway
14:13:39 <dluch> Seems like things have been pretty busy for everyone?
14:13:59 <jihpringle> yes, I'm not sure what happened to April :)
14:14:05 <dluch> jweston: good idea
14:14:12 <dluch> jihpringle: Right?!?!
14:14:18 <jihpringle> yes, +1 to jweston's suggestion
14:14:37 <jweston> April lasted approximately 3 days and now it's May
14:14:54 <dluch> #action DIG will have a call prior to the conference to talk about the hackfest priorities
14:15:14 <dluch> LOL, so true, jweston!
14:15:23 <jihpringle> can we pick a date today or soon?  My calendar is already filling up between now and the conference
14:15:51 <dluch> So, we weren't going to have a June Zoom meeting because of the conference. Do we want to use that day?
14:15:54 <dluch> June 2
14:16:12 <jweston> +1 to June 2
14:16:24 <jihpringle> +1 to June 2
14:16:35 <jihpringle> (I still have it blocked off for the original DIG meeting)
14:17:10 <dluch> Cool, let's plan on then, then. :-) I'll get something scheduled and sent out later today
14:18:05 <dluch> #info DIG call will be on June 2 at 1 p.m. CT / 2 p.m. ET
14:18:16 <dluch> And that leads into...
14:18:19 <dluch> #info Conference docs-related presentation(s)
14:18:29 <dluch> There's been a lot of action here in the last couple of months. Several docs presentations have been combined into a pre-conference. Presenters, want to talk about anything?
14:19:16 <mantis> Originally we wanted to do separate presentations but with the need of pre-conference ideas, we decided to make one big one for the pre-conference
14:19:33 <mantis> I think we're going over an intro to DIG, what contributing looks like, and how to contribute
14:19:41 <mantis> Just off the top of my head
14:19:55 <jihpringle> yes, and talk about the doc re-org as well
14:19:59 <dluch> mantis++
14:20:00 <jihpringle> I think we're at the stage of needing to have a call among the presenters and figure out who is going to do what
14:20:07 <dluch> jihpringle++
14:20:56 <jihpringle> if there's anything DIG related anyone wants us to cover, let us know
14:21:08 <jweston> I'm not part of the presentation group -- and you're all marvelous! (if there is anything I can contribute, just let me know)
14:21:14 <dluch> Do you want me to plan that call or will one of you?
14:21:30 <mantis> I think we can pick a date and time among ourselves
14:21:31 <dluch> +1 jweston!
14:21:46 <mantis> We're already discussing via the email chain anyway
14:21:50 <mantis> Unless anyone feels differently
14:21:50 <dluch> Okay, cool
14:22:04 <jihpringle> agreed
14:23:20 <jihpringle> I think the presentation is part here's how DIG works, here's the cool things we're doing, and now that you know these things come join us :)
14:23:47 <jweston> jihpringle++ great description
14:23:49 <dluch> Also conferencey, for any new folks reading this later, the documentation Hackfest is at the same time as the developer Hackfest, and you can go between. Most of it will be very casual, but we will have some documentation priorities, as mentioned above, and experienced folks there to help answer questions.
14:23:54 <dluch> jihpring++
14:24:02 <dluch> Also jihpringle++
14:24:20 <dluch> That's all I have for old or ongoing business to discuss. Anything I missed that someone would like to talk about?
14:24:38 <jihpringle> will people still be able to sign up for the hackfest on the Monday of the conference?
14:24:46 <mantis> yes
14:25:01 <jihpringle> awesome, than we can plug that as part of the session as well
14:25:01 <jweston> also for future folks reading this, the Hackfest is free
14:25:18 <dluch> Yes!
14:25:43 <jihpringle> maybe we should be sending an email out to the list in the next few weeks
14:25:56 <dluch> That's a good idea
14:25:59 <jihpringle> reminding people that the hackfest includes docs and is free
14:26:03 <jweston> +1 to email promo
14:26:32 <jihpringle> I can commit to doing that
14:26:41 <dluch> Thanks!
14:26:44 <dluch> jihpringle++
14:27:07 <jihpringle> might make sense to wait until the schedule is released and then plug the pre-conference session and the hackfest in one go
14:27:25 <dluch> Sounds reasonable to me
14:27:45 <jihpringle> I'll keep an eye out and then send out the plug
14:28:24 <jweston> jihpringle++
14:28:35 <dluch> #topic New Business
14:28:44 <dluch> #info Documentation to send for review
14:28:56 <dluch> I'm thinking that perhaps this is a good topic for discussion during the Hackfest. Sound okay?
14:29:17 <jihpringle> works for me
14:30:09 <dluch> Is there any other new business we need to discuss?
14:31:23 <jihpringle> is there anything we want to talk about with 3.9 being released?
14:32:03 <jihpringle> we don't have a test server yet so I haven't had a chance to look at it, but based on the release notes there's at least a few changes that affect docs
14:32:17 <jihpringle> like action triggers now being in angular
14:32:59 <dluch> I also have not had a chance to look at it yet. Good point, though. Definitely some things that will require changes and new screenshots
14:33:01 <jihpringle> might just be that we need to update the re-org spreadsheet with the doc needs from 3.9
14:33:14 <jweston> good stuff! until we've had a chance to test it post-release, should we delay this topic to June call?
14:33:35 <dluch> jihpringle: That's probably the best way
14:33:46 <jihpringle> do we want to plan to make this a discussion topic for the hackaway?
14:33:57 <jweston> +1 to hackaway topic
14:34:02 <dluch> +2
14:34:05 <dluch> oops, lol
14:34:08 <dluch> +1
14:34:27 <jihpringle> and maybe we use the 3.9 changes for our pre-conference session demos
14:34:33 <dluch> I'll add that to the agenda
14:34:48 <mantis> +1
14:34:56 <dluch> +1
14:35:03 <mantis> I was considering just being in the room and doing some of the update projects
14:35:17 <dluch> That works
14:35:36 <mantis> Especially since I'll be committing some stuff for the first few times
14:35:49 <jweston> mantis++ committing stuff
14:35:55 <dluch> mantis++
14:35:59 <jihpringle> mantis++
14:36:28 <mantis> power courses through me
14:36:28 <dluch> Any other new business?
14:36:33 <dluch> LOL
14:37:29 <dluch> Hearing none, and knowing we're all super-busy, I'm going to call the meeting. (Feel free to stick around and collaborate, though!)
14:37:32 <dluch> #info Our next meeting will be June 2 on Zoom, then the Hackfest. And then July 7, on IRC.
14:37:45 <dluch> Thanks for being here, everyone!
14:37:59 <jweston> dluch++ thanks for leading
14:38:04 <jihpringle> dluch++
14:38:04 <dluch> jihpringle++
14:38:09 <dluch> mantis++
14:38:11 <dluch> jweston++
14:38:17 <dluch> #endmeeting