15:00:19 <JBoyer> #startmeeting 2022-05-10 - Developer Meeting
15:00:19 <pinesol> Meeting started Tue May 10 15:00:19 2022 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <pinesol> The meeting name has been set to '2022_05_10___developer_meeting'
15:00:27 <JBoyer> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-05-10
15:00:33 <JBoyer> #topic Introductions
15:00:41 <JBoyer> Give deets.
15:00:43 <terranm> #info terranm = Terran McCanna, PINES
15:00:51 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:00:56 <shulabear> #info shulabear = Shula Link, GCHRL in PINES
15:00:59 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:12 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:22 <collum> #info collum = Garry Collum, KCPL
15:01:48 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:01:49 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:03:04 <JBoyer> Ok, anyone joining later feel free to #info-out on your way in
15:03:12 <JBoyer> #topic Action Items from Last Meeting
15:03:28 <JBoyer> The only previous action item involved miker who isn't available, so we'll carry that over
15:03:33 <JBoyer> #action miker will may have looked into bug 1955079
15:03:33 <pinesol> Launchpad bug 1955079 in Evergreen "Emailing Bib Records from the catalog (staff and OPAC) reports success, but fails to send email" [High,Confirmed] https://launchpad.net/bugs/1955079
15:03:50 <JBoyer> And he left a release update above that should be in the minutes
15:03:54 <JBoyer> #topic Evergreen Release Updates
15:04:01 <JBoyer> #info From miker earlier today: "we cut 3.9.0 on April 27 and then I was promptly out of the office for travel and not-work until basically today. I did get the tarball and friends up on the downloads site last week, but we had a suspected broken-build issue, which thankfully turned out to be a false alarm, but delayed the release announcement. so, I still owe the world an email to say "come and get it," but you can, indeed, come and
15:04:01 <JBoyer> get it. quietest release yet? MAYBE SO"
15:04:09 <JBoyer> So,
15:04:10 <JBoyer> #action miker will ring the dinnerbell re: Evergreen 3.9.0 on the lists
15:04:25 <mmorgan> Actually, re bug 1955079, sandbergja has provide a patch
15:04:34 <mmorgan> sandbergja++
15:04:42 <shulabear> sandbergja++
15:04:45 <JBoyer> ooh, sandbergja++
15:05:19 <terranm> sandbergja++
15:05:23 <sandbergja> heya!  hope it works :-)
15:06:02 <JBoyer> He or others can test it now and see how things shake out instead of worrying about how to solve it. :D
15:06:08 <sandbergja> and that branch also includes miker's patch for the staff side
15:07:53 <JBoyer> Do we have any volunteers to handle the point releases? I believe there should be a 3.7.3 as a final sendoff to the 3.7 series to go along with 3.8.1
15:09:13 <Dyrcona> I think our biggest sticking point is release notes for the bug fixes and contributors. The longer we go between releases, the wore work it ends up involving.
15:10:12 <abneiman> if that's a sticking point, I can put some time into release notes later this week
15:10:27 <JBoyer> I don't remember if someone is working on release note simplification or if there's something to look over to make it more automatic sitting somewhere.
15:10:43 * mmorgan can also help with release notes.
15:10:58 <sandbergja> I have a script that prints out some draft release notes to stdout
15:11:06 <Dyrcona> I have some ideas to try to automate release note generation or at least commit message summarization, but no time to really work on it.
15:11:07 <sandbergja> somewhere...
15:11:18 <JBoyer> That may be what I'm thinking of, sandbergja.
15:11:38 <sandbergja> bug 1948674
15:11:38 <pinesol> Launchpad bug 1948674 in Evergreen "Improve release building automation" [Undecided,New] https://launchpad.net/bugs/1948674
15:11:55 <sandbergja> also: abneiman++
15:11:58 <sandbergja> mmorgan++
15:12:57 <Dyrcona> sandbergja: That looks interesting.
15:13:04 <sandbergja> if it would help, I'd be happy to run that script and send you the output as a starting place
15:13:30 <abneiman> sandbergja++
15:13:34 <abneiman> that would be a great start, thanks
15:13:51 <mmorgan> sandbergja++
15:13:58 <Dyrcona> I have a script that I used at MVLC to come up with summaries of changes for the directors. It can does a git cherry to get the commits since the previous release and then dumps those commit messages into a LibreOffice document.
15:14:10 <shulabear> sandbergja++
15:14:28 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:14:36 <sandbergja> Dyrcona: cool!
15:14:38 <shulabear> abneiman++ mmorgan++ dyrcona++
15:14:41 <JBoyer> I'd like to find time to check that out and see how many of the params can be guessed automagically by the script but I can't promise much at the moment.
15:14:52 <JBoyer> But it sounds like an action item
15:15:28 <JBoyer> #action sandbergja will prep auto-drafted release notes for abneiman and mmorgan to review for 3.7.3 and 3.8.1
15:15:36 <Dyrcona> I've been looking at how some other projects do releases, and many have abandoned tarballs.
15:15:39 <JBoyer> sandbergja++ abneiman++ mmorgan++
15:15:59 <Dyrcona> sandbergja++ abneiman++ mmorgan++
15:16:19 <JBoyer> Dyrcona, and moved to .db / .rpm or what do you mean?
15:16:41 <JBoyer> .deb, that is.
15:16:42 <Dyrcona> They just tag releases in their git repos, and they let others worry about packaging.
15:17:07 <Dyrcona> Some (mplayer2?) have even abandoned version numbers.
15:18:28 <JBoyer> Not sure how well that would play out. I don't think an ILS would fit well on the "The only version you need is the latest one" like a media player or browser.
15:19:05 <JBoyer> Missed some words in there. Treadmill was one I believe.
15:19:37 <Dyrcona> Sure, but we can tag releases. I came across some of this while looking into XMPP issues with OpenSRF on Ubuntu 22.04.
15:19:47 <phasefx> JBoyer: addendum for the meeting, live tester
15:20:01 <JBoyer> phasefx++ will add it to new business
15:21:28 <JBoyer> Dyrcona, do you think you have time to gather what some other projects do re: releases and put together some possibilities for consideration?
15:21:47 <Dyrcona> But, it would be nice if we cleaned up our build process so that we could just type 'make release' and have the tarball built for us by autotools.
15:22:23 <Dyrcona> JBoyer: I might have some time for that. I'll see what I can do.
15:22:26 <JBoyer> That would simplify a lot of things, yes.
15:22:29 <JBoyer> Dyrcona++
15:23:22 <JBoyer> #action Dyrcona will try to collect data on release processes across some open source projects for consideration
15:23:48 <JBoyer> Before moving on to new business I'll drop in the LP update real quick
15:24:02 <JBoyer> #topic Launchpad Status
15:24:03 <JBoyer> #info Snapshot
15:24:10 <JBoyer> #info Open Bugs - 2711
15:24:11 <JBoyer> #info Pullrequests - 84
15:24:14 <shulabear> Dyrcona++
15:24:17 <JBoyer> #info Signedoff - 32
15:24:17 <JBoyer> #info Updates Since Last Meeting
15:24:20 <mmorgan> Dyrcona++
15:24:21 <JBoyer> #info Bugs Added - 31
15:24:27 <JBoyer> #info Pullrequest tag Added - 15
15:24:27 * JBoyer #info Signedoff tag Added - 3
15:24:37 <JBoyer> #info Signedoff tag Added - 3
15:24:39 <JBoyer> #info Fix Committed - 8
15:24:47 <JBoyer> mmorgan++
15:24:59 <JBoyer> Ok, new stuff
15:25:01 <JBoyer> #topic New Business
15:25:07 <JBoyer> #info timeline for deprecating TPAC and the traditional staff catalogue
15:25:11 <JBoyer> Take it away, jeffdavis
15:25:27 <jeffdavis> So, uh, we should decide on a timeline for deprecating those tings.
15:25:34 <jeffdavis> Is 3.10 reasonable?
15:25:52 <terranm> +1
15:26:00 <Dyrcona> They're deprecated already, aren't they?
15:26:15 <Dyrcona> Well, I mean TPAC is no longer the default.
15:26:36 <JBoyer> Since that doesn't mean "remove" I don't see why not. And I'm kind of like Dyrcona, I thought the staff catalog basically was though I don't know that it has actually been spelled out.
15:28:06 * mmorgan would want to see more angular catalog bugs fixed before it's the only option.
15:28:10 <JBoyer> I wouldn't necessarily say that tpac has already been deprecated just because it's not the default; to me that would mean it gets nothing but security changes from now on. (Officially, as opposed to just not seeing any improvements)
15:28:20 <terranm> I think it's valuable to be clear that no bug fixes will be done on the old versions.
15:28:25 <Dyrcona> It would be nice to have a timeline for removal in addition to just deprecation. I can think of an example of something that was deprecated in 2004 and wasn't removed from Ejabberd until 2021. :)
15:28:42 <jeffdavis> *cough*xul*cough*
15:29:00 <JBoyer> Yup, and that.
15:29:16 <terranm> We've been solely on the Angular staff catalog and BooPAC since January 2021.
15:29:23 <Dyrcona> I think XUL was supposed to have been removed by now.
15:30:20 <jeffdavis> mmorgan: for me, part of the point of deprecation would be setting a clear target for resolving any major bugs still blocking use of the angular catalogue.
15:30:28 <JBoyer> Because of the way the "traditional" staff catalog works it will be easiest to remove both together. (not *required*, but significantly simpler.)
15:31:33 <JBoyer> And it sends a message to users still using the old interfaces that if they have an issue that's not present in the bootstrap opac or Angular catalog that those are their options for remedy, not an LP bug.
15:32:47 <mmorgan> jeffdavis: Makes sense. Essentially applies a deadline to getting those resolved.
15:32:52 <terranm> +1
15:33:01 <JBoyer> And with the improvements to both coming in 3.9+ I think 3.10 is a manageable target for deprecation. Might be trickier to try to determine a drop-dead date today, though. Feeling up for a vote?
15:34:00 <jeffdavis> I vote in favor of voting on deprecation
15:34:05 <mmorgan> If the deprecation target is set, and the major bugs don't get resolved, does deprecation still happen?
15:34:30 <JBoyer> mmorgan, major bugs in AngCat and BPAC or the older two?
15:34:45 <mmorgan> AngCat and BPAC
15:35:07 <jeffdavis> When we moved to the web-based client we had a "webstaffblocker" tag in Launchpad and did not release 3.0 until all bugs with that tag were resolved, IIRC. That's what I would want us to do for this too.
15:35:51 <JBoyer> Putting a flag in the ground may help get some traction for those bugs now while there's time. And jeffdavis's tag plan would likely also help with that.
15:36:38 <JBoyer> And that's still not removal, just "stick these in amber, they're done."
15:36:57 <abneiman> I could've sworn there was an "angcatblocker" tag in LP but I'm not finding it - there is 'boostrap-blocker' https://bugs.launchpad.net/evergreen/+bugs?field.tag=bootstrap-blocker
15:36:58 <terranm> IIRC there was a similar tag for moving to BooPAC, but the blockers were all resolved ages ago
15:37:22 <abneiman> I have no idea why I cannot be consistent with my usage of quotes, lol
15:37:38 <terranm> Oh, my apologies, there are a couple still flagged as blockers
15:37:49 <Dyrcona> abneiman: It's IRC don't sweat it. :)
15:38:02 <phasefx> :')
15:38:29 <shulabear> abneiman: just looks like my early JS cod :)
15:38:40 <terranm> One of those is only a blocker if using the old staff catalog
15:39:29 <terranm> And I don't think the third is a blocker either
15:40:17 <abneiman> shulabear:  :-D
15:40:26 <JBoyer> Not if you have a local workaround (which you do), though it would be convenient to do something genericizable.
15:40:55 <JBoyer> OK! Keeping in mind that deprecation is not removal:
15:41:39 <JBoyer> #startvote Shall the TPAC and Traditional Staff Catalog(ue) be officially deprecated when 3.10 is released? yes, no, abstain
15:41:39 <pinesol> Begin voting on: Shall the TPAC and Traditional Staff Catalog(ue) be officially deprecated when 3.10 is released? Valid vote options are yes, no, abstain.
15:41:39 <pinesol> Vote using '#vote OPTION'. Only your last vote counts.
15:42:01 <sandbergja> #vote yes
15:42:02 <JBoyer> #vote yes
15:42:02 <terranm> #vote yes
15:42:06 <collum> #vote yes
15:42:09 <abneiman> #vote yes
15:42:11 <Dyrcona> #vote yes
15:42:12 <jeffdavis> #vote yes
15:42:13 <phasefx> #vote yes
15:42:31 <mmorgan> #vote yes
15:43:08 <mmorgan> +1 to an 'angcatblocker' tag
15:43:21 <JBoyer> #endvote
15:43:21 <pinesol> Voted on "Shall the TPAC and Traditional Staff Catalog(ue) be officially deprecated when 3.10 is released?" Results are
15:43:21 <pinesol> yes (9): mmorgan, JBoyer, sandbergja, phasefx, collum, Dyrcona, jeffdavis, terranm, abneiman
15:43:23 <terranm> There are 82 staff catalog bugs, so I propose - staffcatalogblocker
15:44:00 <abneiman> +1 to staffcatalogblocker
15:44:05 <mmorgan> +1
15:44:13 <terranm> I'll add it
15:44:20 <JBoyer> terranm++
15:44:23 <mmorgan> terranm++
15:44:24 <jeffdavis> terranm++
15:44:41 <shulabear> terranm++
15:44:58 <JBoyer> Thanks for bringing that up jeffdavis
15:45:01 <JBoyer> jeffdavis++
15:45:09 <mmorgan> jeffdavis++
15:45:12 <abneiman> jeffdavis++ terranm++
15:45:27 <Dyrcona> jeffdavis++
15:45:40 <JBoyer> Ok, and an update from phasefx
15:45:42 <JBoyer> #info Live tester update
15:45:48 <phasefx> ha, so speaking of blockers
15:45:57 <phasefx> we should probably start treating the live tester as a blocker
15:46:14 <phasefx> but I disabled it in April for fear that people would become inured to the daily error messages
15:46:27 <phasefx> I confess I haven't had any tuits since then to actually look at what the problem is
15:46:36 <phasefx> http://testing.evergreen-ils.org/~live/archive/2022-04/2022-04-25_16:00:04/test.49.html
15:46:50 <sandbergja> phasefx++ # thanks for bringing that up
15:47:08 <shulabear> phasefx++
15:47:19 <Dyrcona> phasefx: I think the failing test has to do with missing directories and autogen.sh. It should be resolved now.
15:47:22 <JBoyer> And I've seen that same test work on a local testing rig, though not one that's rebuilt from scratch like the live tester is, which is annoying.
15:47:24 <phasefx> so any love that can be put toward it would be much appreciated; I'm about to go on vacation, but will re-enable it; it picks up from a public repo that any commiter should have access to
15:48:11 <sandbergja> which repo is it, phasefx?
15:48:29 <phasefx> https://git.evergreen-ils.org/?p=working/random.git;a=shortlog;h=refs/heads/collab/phasefx/eg_live_tests
15:48:46 <sandbergja> phasefx++
15:49:48 <phasefx> EOLI hosts the machine (the test instigator) and the test vm, but in the past we've let community folks into it.  I'm sure such can be done again if needed
15:50:02 <JBoyer> And to Dyrcona's point above, I believe the autogen patch (and a followup) were already in master and it was still failing.
15:50:46 <Dyrcona> I think I used to have access to the old tester. I wouldn't mind looking into it.
15:51:54 <JBoyer> I'd also like to find time to redo the entire testing setup, but time to do so has not made itself available to me.
15:53:26 <JBoyer> It looks like Dyrcona and jeff have both had access in the past and still should (though that machine is not where the testing is actually done, just where the data is gathered) but let me know if you have time to look around and need any help
15:55:06 <JBoyer> Ok, any other new business before we wrap up?
15:55:21 <Dyrcona> JBoyer: I'll wager it
15:55:28 <Dyrcona> s my old key.
15:55:41 <terranm> Is there really going to be a June meeting at the same time since that is the EG Conf week?
15:56:51 <JBoyer> Ah, I hadn't looked into that. There's no point conflicting with anything in the same timeslot.
15:57:12 <terranm> Maybe just make the meeting part of the Friday Hackfest?
15:57:20 <jeffdavis> There is usually a dev meetup at the conference.
15:57:32 <Dyrcona> Yeahp.
15:57:33 * JBoyer furiously scrolls the conf schedule
15:57:48 <collum> During the hackfest?
15:59:05 <JBoyer> Yeah, the hackfest seems the best place for it; I don't want to try to take away from csharp_'s sys admin discussion or anything like that.
16:00:21 <JBoyer> Is everyone good with 3:00p on June 17th then?
16:00:26 <Dyrcona> We've usually had them during time when nothing else is going on, so I concur with during the hackfest.
16:01:18 <JBoyer> Not hearing any issues,
16:01:22 <JBoyer> #topic Announcements
16:01:26 <JBoyer> #info Next Meeting is June 17th at 3pm Eastern / 12 Pacific during the Conference Hackfest
16:01:31 <JBoyer> #endmeeting