15:00:35 <JBoyer> #startmeeting 2022-09-13 - Developer Meeting
15:00:35 <pinesol> Meeting started Tue Sep 13 15:00:35 2022 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <pinesol> The meeting name has been set to '2022_09_13___developer_meeting'
15:00:39 <JBoyer> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-09-13
15:00:46 <JBoyer> #topic Introductions
15:00:59 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:00:59 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:16 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:01:22 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka)
15:01:30 <sandbergja> #info sandbergja = Jane Sandberg, Evergreen enthusiast
15:01:33 <shulabear> #info shulabear = Shula Link, GCHR in PINES
15:01:34 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:41 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:53 <rhamby> #info rhamby = Rogan Hamby, Equinox
15:02:15 <collum> #info collum = Garry Collum, KCPL
15:02:21 <terranm> #info terranm = Terran McCanna, PINES
15:02:40 <stephengwills> #info stephengwills Maine Balsam Libraries
15:03:05 <JBoyer> Others feel free to #info up as you filter in.
15:03:08 <JBoyer> #topic Action Items from Last Meeting
15:03:13 <JBoyer> #info Dyrcona will take a look at LP 1979357
15:03:13 <pinesol> Launchpad bug 1979357 in Evergreen "fixes for qatester failures" [Undecided,New] https://launchpad.net/bugs/1979357 - Assigned to Jason Stephenson (jstephenson)
15:03:33 <JBoyer> I should probably have signed off on that already, I've already tested and verified most of it anyway.
15:04:04 <jeffdavis> just as long as some Jason looks at it
15:04:06 <Dyrcona> I have not had time to really look at it, so maybe I should remove myself from the bug?
15:04:09 <JBoyer> Dyrcona, do you have time to investigate or should I grab that one
15:04:24 <JBoyer> I'll take it then.
15:04:26 <JBoyer> Dyrcona++
15:04:36 <Dyrcona> JBoyer++
15:04:39 <JBoyer> #action JBoyer will take a look at LP 1979357
15:04:39 <pinesol> Launchpad bug 1979357 in Evergreen "fixes for qatester failures" [Undecided,New] https://launchpad.net/bugs/1979357 - Assigned to Jason Stephenson (jstephenson)
15:04:43 <shulabear> JBoyer++
15:05:00 <JBoyer> The other thing from last time,
15:05:01 <JBoyer> #info JBoyer will propose LP users to trim from Drivers / Wranglers / etc. lists.
15:05:06 <JBoyer> I did that, and Dyrcona cleaned them up. Hurrah.
15:05:09 <JBoyer> Dyrcona++
15:05:23 <JBoyer> Unless someone has pressing updates that did not hit the agenda ( o.O ) we'll move on to LP stats
15:05:26 <miker> #info miker = Mike Rylander, EOLI, belated
15:05:35 <gmcharlt> JBoyer: one moment
15:05:46 <JBoyer> sure thing
15:05:47 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:06:11 * Dyrcona thinks we still have some Lp groups to clean up.
15:06:15 <gmcharlt> re 3.8 and 3.9 releases, I would like to declare a merge freeze for bugfixes by end of day tomorrow
15:06:32 <gmcharlt> for finalization (at long last) of the branches for maintenance releases on Thursday
15:07:10 <Dyrcona> gmcharlt++ and +1 even.
15:07:11 <JBoyer> +1
15:07:32 <JBoyer> gmcharlt++
15:07:32 <sandbergja> gmcharlt++
15:07:39 * miker slowly backs away from the commit button
15:07:43 <miker> gmcharlt++
15:07:45 <shulabear> gmcharlt++
15:07:54 <Bmagic> gmcharlt++
15:08:00 <Dyrcona> Should we have a formal vote or just say, "hearing no objections...." :)
15:08:02 <gmcharlt> miker: no, sorry, you will have to wait until Friday to commit Evergreen/COBOL
15:08:04 <terranm> gmcharlt++
15:08:14 <JBoyer> miker, It's like a yellow light when you drive like a Hoosier, it means speed up, not slow down! ;)
15:08:20 <mmorgan> gmcharlt++
15:08:25 <miker> I'll have Evergreen/FORTRAN in by EOB today, though
15:08:39 <gmcharlt> miker++
15:09:14 <JBoyer> Dyrcona, given the timeline and pace of recent commits I'm fine with "hearing no objections."
15:10:59 <Dyrcona> Ok.
15:11:24 <abneiman> is there a plan for release notes?
15:12:14 <JBoyer> #info A merge freeze will be in effect EOB 9/14 so releases can be cut this week
15:12:23 <gmcharlt> an initial draft will be posted this evening; I'm not anticipate a great many additional patches between now and Wednesday evening
15:13:13 <JBoyer> abneiman++
15:13:15 <JBoyer> gmcharlt++
15:13:22 <sandbergja> release_notes++
15:13:56 <shulabear> release_notes++
15:14:20 <JBoyer> ok, we'll move on then if there are no other release updates
15:14:32 <JBoyer> #topic Launchpad Status
15:14:35 <JBoyer> #info Snapshot
15:14:39 <JBoyer> #info Open Bugs - 2844
15:14:42 <JBoyer> #info Pullrequests - 95
15:14:44 <JBoyer> #info Signedoff - 62
15:14:49 <JBoyer> #info Updates Since Last Meeting
15:14:53 <JBoyer> #info Bugs Added - 52
15:14:58 <JBoyer> #info Pullrequest tag Added - 28
15:15:02 <JBoyer> #info Signedoff tag Added - 7
15:15:05 <JBoyer> #info Fix Committed - 6
15:15:11 <JBoyer> mmorgan++
15:15:26 <JBoyer> That brings us to the new
15:15:27 <JBoyer> #topic New Business
15:15:35 <JBoyer> #topic 3.10 release manager / team / etc. Volunteer, Voluntell, or Voluntold; your choice!
15:16:11 <JBoyer> Who would like to bend 3.10 to their will?
15:16:24 <sandbergja> I'd be happy to be part of a release team
15:16:32 <JBoyer> sandbergja++
15:16:39 <JBoyer> That's great
15:16:39 <Bmagic> sandbergja++
15:16:39 <mmorgan> sandbergja++
15:16:50 <gmcharlt> sandbergja++
15:16:57 <abneiman> sandbergja++
15:17:05 <collum> sandbergja++
15:17:15 <shulabear> sandbergja++
15:17:55 <mmorgan> I feel like I've been hogging a seat, but I'd be happy to help also.
15:18:13 <gmcharlt> mmorgan++
15:18:19 <terranm> I'm happy to continue organizing the BSW/FFs
15:18:22 <sandbergja> mmorgan++
15:18:25 <sandbergja> terranm++
15:18:28 <gmcharlt> terranm++
15:18:33 <mmorgan> terranm++
15:18:37 <JBoyer> Much like a conference call for programs, I don't think the applications are overflowing mmorgan. :)
15:18:39 <JBoyer> mmorgan++
15:18:42 <JBoyer> terranm++
15:18:45 <gmcharlt> and unofficially, there are some build things I can help codify and get out of my head for this release
15:18:52 <Bmagic> mmorgan++
15:18:56 <shulabear> mmorgan++
15:19:00 <shulabear> terranm++
15:19:05 <JBoyer> gmcharlt++
15:19:20 <sandbergja> gmcharlt++
15:19:24 <collum> mmorgan++ terranm++
15:19:24 <JBoyer> I've also meant to update a couple of the translation wiki pages for a while.
15:19:36 <collum> gmcharlt++
15:20:00 <gmcharlt> so, sounds like a release team of sandbergja, mmorgan, terranm and me as a shadow
15:20:58 <abneiman> mmorgan++ terranm++ gmcharlt++
15:21:28 <mmorgan> gmcharlt++
15:22:08 <gmcharlt> with respect to 3.10, I've got a question
15:22:32 <gmcharlt> the two biggest pieces I'm aware that are pending are the Angular patron/circ app and the Angular acquisitions blob
15:22:42 <gmcharlt> (yes, that's right, Acquisitions Blob is the new official title)
15:22:55 <mmorgan> :)
15:23:05 <gmcharlt> I'm curious (terranm? berick?) how testing of the patron/circ app is going
15:23:32 <terranm> There were a lot of small issues found during BSW that were tracked on a big ole spreadsheet. I'm not sure if any of those have been addressed yet.
15:23:46 <gmcharlt> (and where I'm leading up to is the question about whether Angular patron/circ is a 3.10 thing, 3.10 "experimental" thing, or a 3.11 thing)
15:24:14 <gmcharlt> (I'm partial, but I'm feeling generally pretty comfortable about Angular Acq Blob being suitable for 3.10)
15:24:15 <terranm> IMO it could be experimental now, but it's not ready for prime time
15:24:52 <Bmagic> Those interfaces get used a lot*. IMO the old and the new should be available for some number of releases
15:25:13 <terranm> FYI: https://docs.google.com/spreadsheets/d/1PL04fcjom0l2xuum_Do-w04asn-ifAEHwuBY6yWIESQ/edit#gid=0
15:26:09 <Bmagic> nicew
15:26:10 <mmorgan> +1 to having both available for a transition period
15:26:20 <sandbergja> Was there a previous discussion of a longer release schedule for 3.10, so that the patron screens are totally ready?
15:26:30 <JBoyer> I feel like a significant overlap has been brought up before and wasn't seen as desirable. Unfortunately I think berick had the most to say about it but appears to be unavailable.
15:26:43 <gmcharlt> sandbergja: yeah, I recall there was a discussion a few meetings back
15:27:46 <gmcharlt> FWIW, I'm in the camp that some sort of overlap period is going to be a necessary evil, but I have significant concerns if such a period is allowed to go on too long
15:29:43 <mrussell> I think it would be best if we had an overlap period so that people can test functionality/ workflow and give feedback on what features work best
15:29:45 <JBoyer> I wonder how many of us are reading the last meeting's notes... :D
15:30:12 <gmcharlt> so to spin a tale: maor testing in 3.10, possibly a non-default alt mode available in 3.10 (although I think I remember from berick that he doesn't think it would be easy to do that/)
15:30:41 <gmcharlt> 3.11 - fully relased; new interface is default but can switch back as needed
15:30:55 <gmcharlt> 3.12 - new interface only, the old one is actively removed
15:31:09 <gmcharlt> (and I acknowledge that that is probably an  aggressive timeline)
15:31:17 <terranm> I seem to recall him saying that the code could be in there so that certain new elements could be available to other interfaces without the new patron interfaces being visible
15:31:20 <Bmagic> That sounds pretty good to me
15:31:30 <JBoyer> The first step proposed last time was non-ui stuff first since so many components have been updated, that could be 3.10 even if the alt-mode isn't available yet
15:32:07 <gmcharlt> yeah, letting core component improvements in as early as possible would be good
15:32:14 <terranm> +1 to that plan
15:32:16 <mmorgan> +1
15:32:58 <gmcharlt> (and of course, calling out that Every. Last. One. Of. Us. would have to revamp circ desk training, directly or indirectly)
15:33:55 <terranm> Yup
15:34:39 <Dyrcona> +1 to the proposed timeline
15:34:45 <terranm> Although, IMO the interfaces / workflows aren't all that different. I don't think they're as different as going from the embedded OPAC to the current staff client.
15:34:57 <JBoyer> +1
15:35:03 <shulabear> terranm++
15:35:13 <gmcharlt> terranm: true, but the little differences can really catch folks, I suspect
15:35:26 <mmorgan> gmcharlt++
15:35:28 <terranm> true
15:35:40 <terranm> (And in the ways we least expect.)
15:35:58 <JBoyer> terranm, yeah, the threat is that The Way Things are Done may be different enough between AngJS and Ang that this or that feature may not be 100% the same day one, even if present.
15:36:00 <mmorgan> Practically everybody that works in a library will touch those screens, which is not necessarily true of other functions.
15:36:27 <gmcharlt> and breaking people's muscle memory is a real concern
15:37:34 <mrussell> As a cataloger I can attest that even the smallest change can completely throw us off our rhythm
15:37:36 <shulabear> gmcharlt++
15:37:47 <mmorgan> mrussell++
15:37:52 <mrussell> gmcharlt ++
15:38:04 <JBoyer> I don't have a feel for how many frontline staff participate in BSW / FF, but maybe an extra callout to them would be a good idea
15:38:17 <terranm> +1
15:38:19 <gmcharlt> hmm, and I just realized that Angular circ/app interesections with the next agenda item: standalone offline circ client
15:38:59 <JBoyer> Depending on how that's handled it can be entirely separate and not intersect the client until the offline client is removed.
15:39:20 <gmcharlt> i.e., either that the Angular patron/circ app needs to be taught how to work offline, else we're never getting rid of the AngularJS circ app, or we run with the standalone clinet idea
15:39:49 <JBoyer> Oh, that angle, ok.
15:40:04 <shulabear> I always try to get frontline staff in on BSW/FF, but depending on how busy they are impacts the feedback.
15:40:43 <terranm> I'm in favor of whichever option allows us to download our blocked patrons list again. (No matter how limited we've tried to make it since moving to the web client, we've never been able to download it because it's too large.)
15:41:06 <shulabear> terranm: That, yes.
15:41:51 <JBoyer> Well, since we're discussing it,
15:41:56 <JBoyer> #topic Should there be a standalone offline client? (see e.g. LP#1943486)
15:42:07 <JBoyer> I'm basically landing at "Yes"
15:42:20 <JBoyer> (unsurprisingly, given my comment)
15:42:53 <JBoyer> hm, bot's on break.
15:42:58 <JBoyer> LP1943486
15:43:01 <terranm> https://bugs.launchpad.net/evergreen/+bug/1943486
15:43:01 <pinesol> Launchpad bug 1943486 in Evergreen "Offline Circulation interface may not load under certain circumstances" [Undecided,Confirmed]
15:43:27 <mmorgan> +1 to standalone, reliable client or app
15:44:34 <terranm> See also: https://bugs.launchpad.net/evergreen/+bug/1727557
15:44:34 <pinesol> Launchpad bug 1727557 in Evergreen "Web Client: Download Block List causes unresponsive page with large file" [High,Confirmed]
15:44:53 <mmorgan> Hmm. Also bug 1981841
15:44:53 <pinesol> Launchpad bug 1981841 in Evergreen "Offline Circulation Non-functional after Clearing Cache" [Undecided,Confirmed] https://launchpad.net/bugs/1981841
15:45:00 <jeffdavis> +1 to standalone here too. Current offline doesn't work for us in many scenarios - we didn't even point our libraries at it during our last upgrade.
15:45:26 <Bmagic> berick had an interface somewhere
15:45:27 <JBoyer> The question (quickly) becomes "Who has time to do this?" It's entirely possible that big chunks of the existing app can be dropped into an Electron container to get something started and the extra abilities it enables means that lovefield would be no longer necessary, but it's still a new thing for someone to build.
15:46:06 <Bmagic> was it an extension of Hatch? IIRC
15:46:17 <JBoyer> (The same could be said of a lot of things around here, but this seems fairly large.)
15:47:05 <Dyrcona> I'm pretty sure berick's interface is its own thing, not related to Hatch.
15:47:14 <miker> (I have to run away for a few minutes, bah!)
15:47:14 <gmcharlt> does anybody have any experience with React Native? Asking because it might also address a potential need for a mobile-focused offline client
15:49:05 <jeffdavis> If Bill or someone has the beginnings of something that's great, but even just agreeing as a community that we want to go in that direction would make it easier to arrange dev resources.
15:50:07 <Bmagic> It seems like a desktop/native OS app (as opposed to a web app) is the clear way to go, as the web seems to still have some road blocks for offline (block list)
15:50:18 <JBoyer> Sigh, haven't hit that key combo in a while...
15:51:53 <Dyrcona> Bmagic: I'm not so sure that a desktop application solves the blocklist download issue, but I'd have to take a closer look.
15:52:20 <Bmagic> I thought it was a shortcoming of the lovefield local browser database capacity?
15:52:44 <Dyrcona> #info berick's offline proof of concept: https://github.com/berick/eg-offline-jfx
15:52:48 <terranm> We didn't used to have any problems downloading the blocklist in the old XUL offline client. I think it was just downloading it to a file back then?
15:53:19 <Dyrcona> Bmagic: Could be. I haven't looked at the bug in a while.
15:53:34 <Bmagic> me either :)
15:53:38 <Dyrcona> terranm: Yes, that's correct.
15:53:42 <gmcharlt> yeah, I would think that anything that can spin up a thread or background process to fetch what is just a text file, though sometimes a large one, should be OK
15:54:27 <terranm> And not having it be subject to the vagaries of browser caching would be nice.
15:55:32 * Dyrcona imagined a user service that would run in the background and grab the offline block list automatically.
15:55:43 <terranm> +1
15:56:04 <terranm> Getting library staff to remember to click the Download button back in the day was always a bit of a challenge.
15:56:12 <JBoyer> To jeffdavis' point above before I screwed up my client again, it sounds like there is interest in this direction from the community.
15:56:27 <Bmagic> we already have Hatch, whats another thing eh? My thinking was, why not piggy back on Hatch? Thereby preventing users from having to install two* things?
15:56:46 <JBoyer> Which means we don't have to hash all of this out right now.
15:57:14 <gmcharlt> Bmagic: a potential opportunity to try something that can remove the need to care about JVMs
15:57:29 <gmcharlt> shall we move on to eslint?
15:57:43 <Bmagic> sure
15:57:49 <JBoyer> Does anyone have time to survey the landscape and report back next meeting?
15:57:49 <Bmagic> (move on I mean)
15:58:15 <JBoyer> If not we can always continue the discussion over email.
15:58:19 <JBoyer> #topic Migrating away from the deprecated Angular linter (see LP#1959048)
15:58:23 <JBoyer> (Requesting a review, and how to coordinate this with the large outstanding angular PRs?)
15:58:32 <sandbergja> gmcharlt, thanks for your review!
15:59:03 <sandbergja> it's the sort of branch that will go out of date quickly, so if anybody has the tuits for merging it, I would appreciate it
15:59:28 <gmcharlt> yeah, from my POV it's ready to be merged; I don't anticipate much trouble adapting the angular acq branch to it
15:59:46 <sandbergja> gmcharlt++ #that's good to hear!
15:59:54 <JBoyer> sandbergja++ gmcharlt++
15:59:58 <gmcharlt> my only real question is whether we want to be brave and also backport it to 3.9 (though I don't think we want to be brave, honestly)
16:00:12 <sandbergja> I was curious about the patron pieces (and other outstanding angular branches)
16:00:30 <sandbergja> it feels kind of mean to change the goal post of how picky the linter is
16:00:45 <sandbergja> after folks have put up a pullrequest
16:01:10 <sandbergja> gmcharlt: I know that I'm not that brave :-)
16:01:20 <gmcharlt> I think berick would be the main person not here who would be largely affected
16:02:09 <Dyrcona> Given that berick is not here to comment, I'd say at a minimum we don't backport it.
16:02:16 <JBoyer> Backporting to 3.9 may be unappealing, but there's not a good way to avoid existing PRs from being effected. I'm not sure it's run as often as it ought be anyway for many PRs.
16:02:36 <gmcharlt> Dyrcona: yeah, I think the real question is timing of merging to the master branch
16:03:17 <gmcharlt> (I raised the possibly of a backport mostly just in case somebody turned up who needed it; I'm not advocating for it)
16:03:27 <Dyrcona> Perhaps the decision should be postponed until we can get feedback from berick?
16:04:10 <sandbergja> I'm okay with that
16:06:12 <JBoyer> sandbergja, would you like to stretch your new release team muscles and followup with berick about this either directly or via the dev list?
16:06:33 <sandbergja> haha sure!
16:06:37 <JBoyer> sandbergja++
16:07:07 <mmorgan> sandbergja++
16:07:29 <JBoyer> #action sandbergja will followup with berick about timing re: merging the new linter
16:08:00 <JBoyer> ok, any further agenda lint lying around?
16:08:18 <sandbergja> JBoyer: I see what you did there
16:08:26 <mmorgan> :)
16:08:32 * JBoyer winks, does finger guns
16:09:17 <JBoyer> We're already a little over time, so
16:09:19 <JBoyer> #topic Announcements
16:09:22 <JBoyer> #info Next Meeting is October 11, 2022
16:09:25 <JBoyer> #endmeeting