#evergreen: 2022-11-15 - Developer Meeting

Meeting started by JBoyer at 15:01:13 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2022-11-15 (JBoyer, 15:01:20)

  1. Introductions (JBoyer, 15:01:27)
    1. phasefx = Jason Etheridge, EOLI (phasefx, 15:01:38)
    2. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:01:44)
    3. JBoyer = Jason Boyer, Equinox (JBoyer, 15:01:45)
    4. berick Bill Erickson, KCLS (berick, 15:01:50)
    5. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:53)
    6. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:01:59)
    7. dmoore = Dan Moore, KCLS (dmoore, 15:02:58)
    8. miker = Mike Rylander, EOLI (miker, 15:03:29)
    9. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:04:07)

  2. Action Items from Last Meeting (JBoyer, 15:04:55)
    1. sandbegja and others are looking into AngularJS node module security updates (JBoyer, 15:05:00)
    2. https://bugs.launchpad.net/evergreen/+bug/1992529 (JBoyer, 15:05:06)

  3. Evergreen Release Updates (JBoyer, 15:07:14)
  4. Launchpad Status (JBoyer, 15:12:36)
    1. Snapshot (JBoyer, 15:12:47)
    2. Open Bugs - 2795 (JBoyer, 15:12:48)
    3. Pullrequests - 72 (JBoyer, 15:12:52)
    4. Signedoff - 43 (JBoyer, 15:12:55)
    5. Updates Since Last Meeting (JBoyer, 15:13:00)
    6. Bugs Added - 56 (JBoyer, 15:13:04)
    7. Pullrequest tag Added - 29 (JBoyer, 15:13:07)
    8. Signedoff tag Added - 25 (JBoyer, 15:13:11)
    9. Fix Committed - 67 (JBoyer, 15:13:17)

  5. New Business (JBoyer, 15:13:36)
  6. Improving QA - there are some issues that commonly recur with new patches, e.g. selectors not being scoped. Should there be a checklist to help devs/committers check for these problems? Other processes? (JBoyer, 15:13:52)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:19:41)
    2. ACTION: jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting (jeffdavis, 15:34:17)

  7. Community Calendar Access - Does every community calendar have at least 2 (active) admins? Do any of them need to have old accounts removed? Do any calendars need to be retired? (I'm aware of Communications, Community, Developers, and the Oversight board, though there may be others.) (JBoyer, 15:43:20)
  8. Looking ahead to Angular 14 / Bootstrap 5 for EG 3.11 (JBoyer, 16:00:40)
    1. https://bugs.launchpad.net/evergreen/+bug/1948693 (JBoyer, 16:00:48)

  9. Announcements (JBoyer, 16:10:37)
    1. Next Meeting is December 13th, 2022 at noon Pacific / 3 pm Eastern (JBoyer, 16:10:38)


Meeting ended at 16:10:44 US/Eastern (full logs).

Action items

  1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting


Action items, by person

  1. jeffdavis
    1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting


People present (lines said)

  1. JBoyer (68)
  2. gmcharlt (28)
  3. berick (19)
  4. jeffdavis (13)
  5. mmorgan (8)
  6. jeff (7)
  7. Bmagic (6)
  8. pinesol (6)
  9. sleary (5)
  10. shulabear (4)
  11. miker (1)
  12. phasefx (1)
  13. shulabear54 (1)
  14. dmoore (1)
  15. scottangel (1)


Generated by MeetBot 0.1.4.