15:02:08 <Dyrcona> #startmeeting 2022-12-13 Developer Meeting
15:02:08 <pinesol> Meeting started Tue Dec 13 15:02:08 2022 US/Eastern.  The chair is Dyrcona. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:08 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:08 <pinesol> The meeting name has been set to '2022_12_13_developer_meeting'
15:02:16 <Dyrcona> #topic Introductions
15:02:31 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:02:40 <rhamby> #info rhamby = Rogan Hamby, EOLI
15:02:45 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:46 <Dyrcona> #info Dyrcona = Jason Stephenson CW MARS
15:03:09 <sleary> #info sleary = Stephanie Leary, EOLI
15:03:12 <shulabear> #info shulabear = Shula Link, GCHRL in PINES
15:03:51 <collum> #info collum = Garry Collum, KCPL
15:03:58 <Stompro> #info stompro = Josh Stompro, LARL
15:04:23 <Dyrcona> So, feel free to continue introducing yourselves as the meeting progresses.
15:04:37 <Dyrcona> #topic Action Items from Last Meeting
15:04:49 <Dyrcona> #info jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting
15:05:03 <Dyrcona> Is jeffdavis around?
15:06:38 <Dyrcona> Ok, not hearing anything from jeffdavis, we'll punt that item to the next meeting in January.
15:06:54 <Dyrcona> #action jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting
15:07:12 <Dyrcona> #topic OpenSRF Release Updates
15:07:30 <Dyrcona> #info gmcharlt isn't able to be here today but said that the OpenSRF release is still on and should drop next week
15:08:02 <Dyrcona> Does anyone have anything to add about next week's OpenSRF release?
15:09:08 <Dyrcona> #topic Evergreen Release Updates
15:09:29 <Dyrcona> #info Contribution of LibraryIQ export code. Github? Contrib repo? It will be similar to collectionHQ, which is inside of a contrib repo. (Bmagic)
15:09:51 <Bmagic> oh hey, that's me
15:09:56 <Dyrcona> Bmagic: I assume you're looking for suggestions on how to share the code with the community?
15:10:43 <Bmagic> Right. It seems we all have little side projects here and there. This one seems like it could be useful for anyone subscribing to LibraryIQ's service
15:11:18 <Dyrcona> How generic is the export? Would it require a lot of customization to make it work for different sites?
15:11:50 <Bmagic> We've utilized similar code (collectionHQ) from the community. This is the same thing, different channel
15:12:36 <rhamby> I'd say it should probably be in a contrib repo though we should have a wiki page tracking these things if we don't already
15:12:41 <Bmagic> I'm writing it with the community in mind. The end result should be: edit a config, setup cron, eat a sandwich
15:14:18 <Dyrcona> OK. A crontrib repo requires some intervention on the part of the gitadmins, which means gmcharlt or myself. Wold a working branch aslo work?
15:15:02 <Bmagic> a working branch could work, but that would be against the Evergreen repo? I'm not sure it belongs in Evergreen proper
15:15:18 <Dyrcona> I guess long term, it might be useful to add things like this to the main Evergreen repo, perhaps in a contrib directory or possibly right in support-scripts.
15:15:54 <Bmagic> I've got a branch for another project that made a sub-folder in support-scripts
15:16:26 <Bmagic> I could keep doing it like that. Everyone here think that Evergreen exports to vendors might be useful enough to just be in Evergreen?
15:16:56 <Dyrcona> Well, if you think it warrants a separate repo, we could set up a crontrib repor or it could go on github. I was also thinking of exposure/advertising for these kinds of tools by adding them into a contrib/ hierarchy.
15:17:29 <Bmagic> It's certainly not "big" enough to be a whole repo... maybe a repo for "all things export" ?
15:17:44 <Dyrcona> I think they could be. As it is, the exports that exist can be hard to locate, and there are different versions of each.
15:18:04 <Bmagic> That's why I thought it might be a good topic for today
15:18:46 <Dyrcona> Well, there's the random repo which functions as a kind of contrib repo already.
15:19:28 <Dyrcona> I don't think it is named very well, and as one of the gitadmins I would (selfishly) like to avoid a proliferation of repositories.
15:20:33 <Bmagic> I want to do the right thing. If it's random repo, that's fine. A wiki page with links to all the places to find things like this would be awesome too. So random repo?
15:21:18 <Dyrcona> Well, I'm not sure what the right thing is, really. I think it would be useful if we could come up with a place to pool a lot of the various tools.
15:21:36 <jeffdavis> Bundling these kinds of tools in some way makes sense to me, but I don't have any specific ideas on the best way to do it
15:22:12 <Dyrcona> Maybe we should move this discussion to the development mailing list since there are not many people here today?
15:22:21 <Bmagic> yeah, I was about to say the same
15:22:29 <Bmagic> I'll put out an email
15:22:51 <Dyrcona> OK. I was going to volunteer but Bmagic++ beat me to it.
15:23:15 <Bmagic> Thanks for your time, we can move on
15:23:20 <Dyrcona> #action Bmagic to email the development list about a way to share common Evergreen tools with the community.
15:23:40 <Dyrcona> Bmagic, you're also up next.
15:23:42 <Dyrcona> #info Enhanced Concerto dataset. LP 1901932 (Bmagic)
15:23:42 <pinesol> Launchpad bug 1901932 in Evergreen "Wish List - Enhanced Concerto dataset" [Wishlist,New] https://launchpad.net/bugs/1901932
15:23:54 <Bmagic> And, I'm back
15:24:18 <Bmagic> I just wanted to bring this up to let everyone know that the enhanced concerto dataset is in a working branch
15:24:59 <Dyrcona> Is it ready to go and should anyone in particular look at it?
15:25:17 <Bmagic> It "works for me" using the standard perl Open-ILS/src/support-scripts/eg_db_config ..... --load-concerto-enhanced
15:26:14 <Bmagic> Though, I'm not ready to pullrequest it yet. I'm going to loop back to it and enhance the code such that it can upgrade itself to match the database structure through upgrades
15:26:15 <mmorgan> Any reason not to tag it with a pullrequest?
15:26:28 <mmorgan> :)
15:27:15 <Dyrcona> I think you could add the pullrequest tag. Upgrading could be a different bug. You could also wait and attempt it all at once.
15:27:35 <Dyrcona> How useful do we think upgrading concerto data is?
15:27:48 <Bmagic> It would be interesting to hear back on my approach. Essentially, it generates the SQL files based upon a live DB. It needs a "schema only" database and another DB containing the enhanced dataset. The code gathers up each table and removes the "stock" stuff that appears in the 950-seed-data
15:28:49 <Bmagic> the result is a perfect dataset that will load itself onto a database that matches where it came from. If Evergreen receives new columns/tables over time, this dataset could still work but it could also break
15:29:56 <Bmagic> So, the next step in my plan is to automate that upgrade with one command. Sort of a "from" .. "to" git commit check, which could be dropped into the make build procedure for releases
15:29:56 <Dyrcona> Hmm. I thought this would just be extra data, or are you talking about upgrades in that previous comment?
15:30:54 <Bmagic> it's extra data for sure. So much extra that the ID's need to come over to make it all coherent
15:31:13 <Dyrcona> I'll have a look at it in my practically non-existent free time.
15:31:42 <Dyrcona> #action Dyrcona to review Lp 1901932
15:31:42 <pinesol> Launchpad bug 1901932 in Evergreen "Wish List - Enhanced Concerto dataset" [Wishlist,New] https://launchpad.net/bugs/1901932
15:31:46 <Bmagic> haha, well, that's more detail than I wanted to get into for this meeting. The take away is: try it out and see what you think
15:32:27 <Dyrcona> Ok, before we move on, jeffdavis we tabled your QA action item earlier. Do you want to pick it up now or wait for next meeting?
15:33:37 <jeffdavis> I don't have anything to add, so yes, let's table it please. (Sorry for missing thestart of the meeting)
15:34:49 <Dyrcona> OK.
15:35:00 <Dyrcona> #topic Documentation Updates
15:35:20 <Dyrcona> #info Where's our technical documentation? For a newbie: how to use $e (editor), what is $ctx, etc.I know there's docs/TechRef but I don't know if it is included in the online antora docs or if it's been updated any time recently.
15:35:43 <Dyrcona> I'm not sure who added this one. I haven't looked at the agenda edit history, but it's a big one, too.
15:36:09 <scottangel> This one is mine. I'm new.
15:37:23 <jeffdavis> There's some additional technical documentation on the wiki (https://wiki.evergreen-ils.org) but it's very incomplete and dispersed.
15:38:16 <jeffdavis> It might make a good hackfest project to assemble some better technical documentation for onboarding new devs?
15:38:31 <Dyrcona> Yes, I was going to repeat what jeffdavis said. I also have some lintks to some older things that got me started as well.
15:38:46 <jeffdavis> Similar to the "Evergreen in Action" doc that was assembled a while ago (and which also ought to be resurrected)
15:39:03 <scottangel> I can use all the help I can get.
15:39:19 <Dyrcona> I was just thinking that we could start a development documentation project, possibly in the mainline docs.
15:40:33 <Bmagic> This one looks "full" https://docs.evergreen-ils.org/eg/docs/latest/development/intro_opensrf.html
15:40:43 <Dyrcona> I think we should save specific resources for after the meeting, but it seems to me there's an action item lurking here.
15:41:54 <Bmagic> This is similar to the "where's the code for that" discussion above. There's a need for a jumping-off page for folks to use
15:42:28 <Dyrcona> Something like that, yes. I think a development section of the documentation would be useful.
15:42:48 <Dyrcona> There used to be one, but it was rather sparse. I haven't checked if it is still there.
15:43:42 <shulabear> That might be something for terranm and the new developer group to work on, if that's still a thing?
15:43:42 <mmorgan> seems like a lot of good documentation is in people's brains. :)
15:44:07 <Bmagic> mmorgan: lol
15:44:44 <Dyrcona> shulabear: That is a good idea. Do you know how to get that onto their agenda?
15:45:08 <shulabear> I do not! But I could shoot Terran an email about it.
15:45:43 <Dyrcona> Awesome sauce. I won't assign you an action item unless you really want one. :)
15:46:19 <mmorgan> New Devs wiki page: https://wiki.evergreen-ils.org/doku.php?id=newdevs:start
15:46:40 <shulabear> Assign me nothing, not this close to the holidays. I think there might already be something Terran made that can act as a starting point.
15:46:47 <shulabear> Like that. mmorgan++
15:47:15 <Dyrcona> shulabear++ mmorgan++
15:47:40 <Dyrcona> #info New Devs wiki page: https://wiki.evergreen-ils.org/doku.php?id=newdevs:start
15:47:41 <mmorgan> terranm is masterful at organizing the group and often asks for input on topics. Emailing her is a good start.
15:48:32 <Dyrcona> scottangel: I'll share a link or two after the meeting, but we'll see how things work out with the new devs group.
15:49:02 <Dyrcona> Moving on....
15:50:13 <shulabear> Terran emailed.
15:50:22 <Dyrcona> #topic Launchpad Status
15:50:22 <Dyrcona> #info Snapshot
15:50:22 <Dyrcona> #info Open Bugs - 2847
15:50:22 <Dyrcona> #info Pullrequests - 91
15:50:22 <Dyrcona> #info Signedoff - 38
15:50:22 <Dyrcona> #info Updates Since Last Meeting
15:50:22 <Dyrcona> #info Bugs Added - 53
15:50:23 <Dyrcona> #info Pullrequest tag Added - 25
15:50:23 <Dyrcona> #info Signedoff tag Added - 4
15:50:24 <Dyrcona> #info Fix Committed - 8
15:50:52 <Dyrcona> Not much to add to the raw numbers there.
15:51:13 <Dyrcona> #topic New Busines
15:51:47 <Dyrcona> #info Recommended PostgreSQL version now that Pg 10 is out of support.
15:52:10 <Dyrcona> This one is me, and I'm not sure that the most interested parties are here to discuss it.
15:52:27 <Bmagic> fork PG into Evergreen
15:52:39 <Dyrcona> No. :)
15:52:47 <Bmagic> :)
15:53:00 <jeffdavis> I need to sign off, but any reason not to go with PG11 until that bug with 12+ is resolved?
15:53:13 <Dyrcona> I want to give a shout out to csharp_ and miker for working on some search performance issues with PG 12+
15:53:24 <Dyrcona> jeffdavis: Pg 11 looks safe.
15:54:23 <Bmagic> done, PG 11 :)
15:54:47 <Dyrcona> #info Open bugs related to newer PostgreSQL versions: Lp 1999274 and Lp 1997098.
15:54:47 <pinesol> Launchpad bug 1999274 in Evergreen 3.10 "Performance of Search on PostgreSQL Versions 12+" [Medium,Confirmed] https://launchpad.net/bugs/1999274
15:54:48 <pinesol> Launchpad bug 1997098 in Evergreen "Add Support for PostgreSQL 15" [Medium,Confirmed] https://launchpad.net/bugs/1997098
15:55:16 <Dyrcona> I'd much rather be able to recommend Pg 15, but anyway.... :)
15:55:34 <Dyrcona> Let's move on.
15:55:49 <Dyrcona> #topic Announcements
15:56:03 <Dyrcona> Does anyone have anything that they would like to announce?
15:56:24 <Bmagic> Happy new year?
15:57:46 <mmorgan> s/?/!!
15:58:17 <Dyrcona> Given recent occurrences, I think the question mark is warranted. :P
15:58:19 <Bmagic> mmorgan++ # loving the enthusiasm
15:58:40 * mmorgan is hopeful.
15:58:59 <Bmagic> the question mark was more slanted towards the context of "anything you want to announce" - wasn't sure if it's an announcement
15:59:11 <Dyrcona> :)
15:59:21 <Dyrcona> OK. I guess we can adjourn.
15:59:32 <Dyrcona> #info Next Meeting is January 10th, 2023
15:59:37 <Dyrcona> #endmeeting