#evergreen: 2023-01-10 - Developer Meeting

Meeting started by JBoyer at 15:02:43 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-01-10 (JBoyer, 15:02:48)

  1. Introductions (JBoyer, 15:02:55)
    1. JBoyer = Jason Boyer, EOLI (JBoyer, 15:03:03)
    2. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:03:05)
    3. terranm = Terran McCanna, PINES (terranm, 15:03:09)
    4. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:03:16)
    5. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:03:18)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:03:19)
    7. collum = Garry Collum, KCPL (collum, 15:03:19)
    8. jvwoolf= Jessica Woolford, Bibliomation (jvwoolf, 15:03:26)
    9. miker = Mike Rylander, EOLI (miker, 15:03:28)
    10. csharp = Chris Sharp, GPLS (csharp_, 15:03:28)
    11. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:03:28)
    12. berick Bill Erickson, KCLS (berick, 15:03:30)
    13. rfrasur = Ruth Frasur, Evergreen Indiana (rfrasur, 15:03:31)
    14. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:03:32)
    15. sandbergja = Jane Sandberg (sandbergja, 15:03:42)
    16. dmoore = Dan Moore, KCLS (dmoore, 15:04:12)
    17. GavinKCLS = Gavin Smith, KCLS (GavinKCLS, 15:04:31)
    18. sleary = Stephanie Leary, EOLI (sleary, 15:04:43)
    19. gmcharlt = Galen Charlton, EOLI (gmcharlt, 15:05:15)

  2. Action Items from Last Meeting (JBoyer, 15:05:36)
    1. jeffdavis will gather more specific examples of recurring QA problems to present for discussion at the next dev meeting (JBoyer, 15:05:42)
    2. https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:common_qa_problems (JBoyer, 15:05:47)
    3. tlittle = Tiffany Little, PINES (tlittle, 15:15:08)
    4. Bmagic to email the development list about a way to share common Evergreen tools with the community. (JBoyer, 15:35:54)
    5. ACTION: Bmagic to email the development list about a way to share common Evergreen tools with the community. (JBoyer, 15:36:41)
    6. Dyrcona to review Lp 1901932 (JBoyer, 15:36:53)
    7. ACTION: Dyrcona to review Lp 1901932 (JBoyer, 15:38:40)

  3. Evergreen Release Updates (JBoyer, 15:40:24)
    1. I've built a 3.8.2 release to end the 3.8 line now that 3.10 is out, if you can help test it's at https://evergreen-ils.org/downloads/Evergreen-ILS-3.8.2.tar.gz (Note, I'm going to have to make a docs change before it's final-final, but no code changes.) (JBoyer, 15:40:32)

  4. Launchpad Status (JBoyer, 15:44:22)
    1. Snapshot (JBoyer, 15:44:26)
    2. Open Bugs - 2881 (JBoyer, 15:44:30)
    3. Pullrequests - 106 (JBoyer, 15:44:34)
    4. Signedoff - 41 (JBoyer, 15:44:37)
    5. Updates Since Last Meeting (JBoyer, 15:44:41)
    6. Bugs Added - 41 (JBoyer, 15:44:47)
    7. Pullrequest tag Added - 29 (JBoyer, 15:44:51)
    8. Signedoff tag Added - 7 (JBoyer, 15:44:55)
    9. Fix Committed - 11 (JBoyer, 15:44:59)

  5. New Business (JBoyer, 15:45:09)
    1. Bugs tagged with cat-holdingseditor (mmorgan) (JBoyer, 15:45:17)
    2. https://bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscribe (JBoyer, 15:45:29)
    3. Thoughts on sharing work on 2000482 (berick) (JBoyer, 15:53:59)
    4. https://bugs.launchpad.net/evergreen/+bug/2000482 (JBoyer, 15:54:05)

  6. Announcements (JBoyer, 16:01:44)
    1. Next Meeting is February 14th, 2023 (JBoyer, 16:01:48)


Meeting ended at 16:01:54 US/Eastern (full logs).

Action items

  1. Bmagic to email the development list about a way to share common Evergreen tools with the community.
  2. Dyrcona to review Lp 1901932


Action items, by person

  1. Dyrcona
    1. Dyrcona to review Lp 1901932


People present (lines said)

  1. JBoyer (68)
  2. berick (26)
  3. mmorgan (22)
  4. Dyrcona (16)
  5. sandbergja (13)
  6. jeffdavis (10)
  7. csharp_ (8)
  8. rfrasur (7)
  9. jvwoolf (7)
  10. terranm (7)
  11. sleary (6)
  12. pinesol (6)
  13. shulabear (6)
  14. tlittle (5)
  15. gmcharlt (5)
  16. abneiman (5)
  17. dmoore (4)
  18. jeff (2)
  19. collum (2)
  20. miker (1)
  21. GavinKCLS (1)


Generated by MeetBot 0.1.4.