#evergreen: 2023-02-14 - Developer Meeting

Meeting started by JBoyer at 15:02:07 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-02-14 (JBoyer, 15:02:10)

  1. Introductions (JBoyer, 15:02:16)
    1. JBoyer = Jason Boyer, EOLI (JBoyer, 15:02:26)
    2. terranm = Terran McCanna, PINES (terranm, 15:02:30)
    3. rhamby = Rogan Hamby, EOLI (rhamby, 15:02:38)
    4. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:02:43)
    5. tlittle = Tiffany Little, PINES (tlittle, 15:02:44)
    6. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:50)
    7. berick Bill Erickson, KCLS (berick, 15:02:53)
    8. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:03:30)
    9. mantis1 = Gina Monti, Bibliomation (mantis2, 15:03:54)
    10. collum - Garry Collum, KCPL (collum, 15:04:17)
    11. jvwoolf = Jessica Woolford, Bibliomation (jvwoolf, 15:04:31)

  2. Action Items from Last Meeting (JBoyer, 15:05:23)
    1. Bmagic to email the development list about a way to share common Evergreen tools with the community. (JBoyer, 15:05:29)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:10:46)
    3. Dyrcona to review Lp 1901932 (JBoyer, 15:11:15)

  3. New Business (JBoyer, 15:11:51)
    1. scottangel: Request for testers / feedback: LP1977554 - Add Password visibility toggle on login screens (JBoyer, 15:11:57)
    2. mantis/gmonti: Procedure for updating terminology in Evergreen (JBoyer, 15:12:51)
    3. JBoyer: It may be possible to completely remove Evergreen server PCI exposure by moving to client-side Authorize.net and PayPal (and dropping PayFlowPro). (JBoyer, 15:17:47)
    4. ACTION: terranm will look at the Stripe license agreement for this (JBoyer, 15:29:59)
    5. ACTION: JBoyer will look over Authorize.net and PayPal license agreements. (JBoyer, 15:30:16)
    6. ACTION: jvwoolf will take authorize.net rather than JBoyer (JBoyer, 15:30:54)
    7. https://stripe.com/legal/ssa might have the relevant docs for stripe (rhamby, 15:31:34)

  4. Launchpad Status (JBoyer, 15:32:53)
    1. Snapshot (JBoyer, 15:32:57)
    2. Open Bugs - 2937 (JBoyer, 15:33:01)
    3. Pullrequests - 119 (JBoyer, 15:33:13)
    4. Signedoff - 28 (JBoyer, 15:33:13)
    5. Updates Since Last Meeting (JBoyer, 15:33:16)
    6. Bugs Added - 69 (JBoyer, 15:33:20)
    7. Pullrequest tag Added - 26 (JBoyer, 15:33:25)
    8. Signedoff tag Added - 9 (JBoyer, 15:33:29)
    9. Fix Committed - 21 (JBoyer, 15:33:33)
    10. JBoyer: Who wants to build Evergreen 3.11 for Workgroups? (JBoyer, 15:34:15)
    11. https://winworldpc.com/screenshot/e280a1c2-a175-4bc5-a0c3-bf11c3a4c2ac/42015082-eae8-11e7-a562-fa163e9022f0 (JBoyer, 15:35:59)
    12. As of now the 3.11 release team is JBoyer, Bmagic, and mmorgan (JBoyer, 15:42:05)
    13. ACTION: JBoyer will send a "Hey, Listen!" email to the dev list about interest in the 3.11 release team. (JBoyer, 15:42:41)
    14. Bmagic: Enhanced Concerto Dataset: LP1901932 (JBoyer, 15:43:42)
    15. https://wiki.evergreen-ils.org/doku.php?id=newdevs:start (terranm, 15:56:35)
    16. terranm: New Devs Update - adding code explanations and samples to https://wiki.evergreen-ils.org/doku.php?id=newdevs:start (JBoyer, 15:56:46)

  5. Announcements (JBoyer, 15:58:11)
    1. Next Meeting is March 14, 2023 at 3pm Eastern (JBoyer, 15:58:15)


Meeting ended at 15:58:19 US/Eastern (full logs).

Action items

  1. terranm will look at the Stripe license agreement for this
  2. JBoyer will look over Authorize.net and PayPal license agreements.
  3. jvwoolf will take authorize.net rather than JBoyer
  4. JBoyer will send a "Hey, Listen!" email to the dev list about interest in the 3.11 release team.


Action items, by person

  1. JBoyer
    1. JBoyer will look over Authorize.net and PayPal license agreements.
    2. jvwoolf will take authorize.net rather than JBoyer
    3. JBoyer will send a "Hey, Listen!" email to the dev list about interest in the 3.11 release team.
  2. jvwoolf
    1. jvwoolf will take authorize.net rather than JBoyer
  3. terranm
    1. terranm will look at the Stripe license agreement for this


People present (lines said)

  1. JBoyer (97)
  2. Bmagic (37)
  3. terranm (16)
  4. mmorgan (11)
  5. mantis2 (8)
  6. rhamby (8)
  7. jvwoolf (7)
  8. pinesol (6)
  9. berick (4)
  10. scottangel (3)
  11. tlittle (2)
  12. jeff (2)
  13. abneiman (1)
  14. collum (1)


Generated by MeetBot 0.1.4.