15:01:09 <JBoyer> #startmeeting 2023-05-09 - Developer Meeting
15:01:09 <pinesol> Meeting started Tue May  9 15:01:09 2023 US/Eastern.  The chair is JBoyer. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:09 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:09 <pinesol> The meeting name has been set to '2023_05_09___developer_meeting'
15:01:14 <JBoyer> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-05-09
15:01:19 <JBoyer> #topic Introductions
15:01:29 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:30 <JBoyer> #JBoyer = Jason Boyer, EOLI
15:01:37 <JBoyer> Hmm, nope.
15:01:40 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:01:43 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:01:50 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:01:55 <Stompro> #info Stompro = Josh Stompro, LARL
15:01:56 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:05 <berick> #info berick Bill Erickson, KCLS (here for 1st half of mtg)
15:02:10 <sleary> #info sleary = Stephanie Leary, EOLI
15:02:11 <collum> #info collum = Garry Collum, KCPL
15:02:27 <terranm> #info terranm = Terran McCanna, PINES
15:02:33 <tlittle> #info tlittle = Tiffany Little, PINES
15:02:46 <shulabear> #info shulabear = Shula Link, PINES/GCHRL
15:03:34 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:05:38 <JBoyer> Ok, anyone else coming in feel free to #info in if joining later.
15:05:45 <JBoyer> #topic Action Items from Last Meeting
15:05:49 <JBoyer> #info None.
15:06:01 <JBoyer> #topic OpenSRF Release Updates
15:06:05 <JBoyer> #info OpenSRF 3.2.3 has been released to fix some memory leaks and most importantly allow building on recent Debian / Ubuntu releases.
15:06:11 <JBoyer> Though I will note that we're pretty close to a 3.3.0, given that there are some additional fixes in git. I don't have a specific plan for that at the moment but let this be a reminder that OpenSRF does have it's own LP and there are some pullrequest tagged things to check out there.
15:06:15 <JBoyer> And eventually, of course, an OpenSRF-on-Redis release will easily be a 4.0.0.
15:07:36 <JBoyer> If there are no questions (me copy/pasting can make it hard to get a word in edgewise. :) ) we'll move on to Evergreen release updates
15:08:03 <JBoyer> #topic Evergreen Release Updates
15:08:30 <JBoyer> #info Feedback Fest going on now, progress looks good
15:08:31 <Dyrcona> I have a late-breaking update for this topic.
15:08:31 <JBoyer> #info Evergreen 3.11 Beta 1 coming Monday
15:08:43 <JBoyer> Dyrcona, excellent, go for it
15:09:17 <Dyrcona> #info Evergreen 3.10.1a tarball released today (2022-05-09) to add a missing upgrade script.
15:09:28 <JBoyer> And Dyrcona++ for that.
15:09:45 <terranm> Dyrcona++
15:09:48 <JBoyer> Thanks!
15:09:51 <shulabear> Dyrcona++
15:10:04 <dluch> Dyrcona++
15:10:23 <mmorgan> Dyrcona++
15:10:35 <tlittle> Dyrcona++
15:11:09 <Dyrcona> I will share the karma with Linda Jansova. I don't know if she has an IRC handle.
15:12:08 <JBoyer> Same. Possibly, but people can offer thanks
15:12:24 <JBoyer> by helping with translations, if they're able. :D
15:12:27 <JBoyer> And Re: Feedback Fest, I have had basically no time to participate beyond putting a single machine up, but I've been noticing the progress and it looks really good.
15:12:47 <terranm> bugsquashers++
15:12:55 <JBoyer> Anything to add Bmagic or mmorgan ?
15:13:09 <Bmagic> whoops
15:13:17 <mmorgan> Just that there's been a lot of progress since the conference!
15:13:20 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:13:26 <JBoyer> Works for me!
15:13:30 <mmorgan> feedbackfesters++
15:13:35 <JBoyer> Bmagic++ mmorgan++ bugsquashers++
15:13:47 <JBoyer> #topic Documentation Updates
15:13:51 <Bmagic> I've been busy merging patches onto our test machine. I love it! Lots of activity
15:14:00 <JBoyer> #info Documentation hackfest: Lots of new folks in the morning! Got them started with our reorg spreadsheet, a live demo from Andrea, talked about 3.11 some, and other general docs conversations
15:14:07 <JBoyer> #info No May meeting last week, next meeting on June 1
15:14:10 <JBoyer> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20230601-agenda
15:14:24 <JBoyer> Anything to add dluch ? (or other DIG members?)
15:14:41 <dluch> Nope! That covers everything I have!
15:14:46 <JBoyer> dluch++
15:14:55 <terranm> dluch++ abneiman++
15:14:55 <JBoyer> #topic Launchpad Status
15:14:59 <JBoyer> #info Snapshot
15:15:02 <JBoyer> #info Open Bugs - 2963
15:15:06 <JBoyer> #info Pullrequests - 74
15:15:09 <JBoyer> #info Signedoff - 16
15:15:14 <JBoyer> #info Updates Since Last Meeting
15:15:17 <JBoyer> #info Bugs Added - 80
15:15:20 <JBoyer> #info Pullrequest tag Added - 42
15:15:25 <JBoyer> #info Signedoff tag Added - 27
15:15:29 <JBoyer> #info Fix Committed - 60
15:15:48 <JBoyer> Love that Fix Committed number!
15:15:57 <mmorgan> Indeed!
15:15:57 <terranm> Awesome!
15:16:03 <Dyrcona> Yes.
15:16:03 <shulabear> committers++
15:16:27 <dluch> Sweet!
15:16:28 <JBoyer> onward, then
15:16:29 <JBoyer> #topic New Business
15:16:33 <JBoyer> #topic Git server move and branch renaming from master to main
15:16:36 <JBoyer> Lead on, Dyrcona
15:17:27 <Dyrcona> The project has evolved from just renaming branches from master to main. We (the system admin and git admin groups) decided to upgrade our git infrastructure at the same time. This means ....
15:17:35 <Dyrcona> #info SSH access to git.evergreen-ils.org repositories will be disabled on June 1, 2023 at 13:00 UTC (9:00 AM EDT).
15:17:50 <Dyrcona> #info Git repositories will be moved to a new host and "master" branches renamed to "main."
15:18:31 <Dyrcona> I expect everything to take less than 1 hour since we'll have much of the hard stuff done and ready to go before the date.
15:18:59 <JBoyer> That's great, especially the host move, which I know has been in the cards for a bit.
15:19:02 <JBoyer> Dyrcona++
15:19:04 <terranm> Dyrcona++
15:19:08 <mmorgan> Dyrcona++
15:19:13 <collum> Dyrcona++
15:19:15 <rfrasur> #info rfrasur = Ruth Frasur, Evergreen Indiana / ECDI
15:19:21 <Bmagic> Dyrcona++
15:19:25 <dluch> Dyrcona++
15:19:38 <Dyrcona> I'm also going to throw an action out there so there's something for the next meeting. :)
15:19:42 <shulabear> Dyrcona++
15:19:49 <Dyrcona> #action Dyrcona will communicate what our git users need to do as a result of these changes via email and blog posts.
15:20:50 <JBoyer> Ah, yes. I suspect this will be stuff that's not overly complicated, but people definitely do not do often.
15:21:08 <jeff> Are you planning to change hostnames or host keys during the transition?
15:21:25 <Dyrcona> Yeahp: clearing ssh host keys, and a couple of git steps.
15:22:20 <JBoyer> jeff, was your question about dealing with ssh client side or moving the existing keys from the old server to the new?
15:22:22 <Dyrcona> jeff: Host keys will change. The goal is for the old host name to still work, especially for the gitweb.
15:22:43 <jeff> JBoyer: yes. :-)
15:22:54 <JBoyer> Hah. jeff++
15:23:03 <jeff> I was asking if the intent was to rotate the keys or copy the keys. Sounds like the former.
15:23:37 <JBoyer> Though I do think ssh-key migration is a valid thing to do, though depending on the size of the OS upgrade additional ones may need to be generated.
15:23:58 * jeff nods
15:24:37 <JBoyer> But I'm not volunteering to jump into that decision making process, so I'll wait and see what happens unless there's interest in discussing that now.
15:24:38 <Dyrcona> The new host already has keys, so we're not planning to add more. Plus, the keys on the current server are 10+ years old.
15:25:36 <JBoyer> Works for me.
15:26:19 <Dyrcona> I plan to include steps for updating hosts keys with OpenSSH. If someone wants to volunteer steps for other SSH environments, let me know.
15:27:02 <JBoyer> Dyrcona++ that should get pretty good coverage, I think that's what even git on Windows uses these days.
15:27:29 <JBoyer> Any other git discussion?
15:27:51 <Dyrcona> If anyone has additional questions, feel free to ping me.
15:28:15 <JBoyer> alrighty then
15:28:17 <JBoyer> #topic The business of running these things
15:28:21 <JBoyer> That would be me.
15:28:27 <JBoyer> In the past I've made reference to the fact that anyone who is interested in taking over meeting-running duties is welcome to take a turn.
15:28:33 <JBoyer> But now, especially after some reflection spurred by a couple sessions at the recent conference, I'm actively asking for someone else to take this over.
15:28:37 <JBoyer> To mangle a mental health metaphor, I seem to be starting each day with fewer and fewer spoons and it seems that what few there are are bent to begin with.
15:29:06 <Bmagic> :)
15:29:23 <JBoyer> I have not had the bandwidth to really dedicate more to this than 'start meeting', 'topic', 'topic', 'endmeeting' which is not nothing, but it's not a lot more.
15:30:06 <Bmagic> We'll miss the cadence of your meetings!
15:30:10 <JBoyer> I'm happy to take this request to the lists, but I assume that those currently here are the most engaged at the moment and would like to give you first shot.
15:31:04 <Bmagic> ok, I'll do it
15:31:09 <Dyrcona> Would be OK to have a rotating chair?
15:31:17 <Dyrcona> Bmagic++
15:31:27 <shulabear> JBoyer++ Bmagic++
15:31:33 <dluch> JBoyer++
15:31:36 <JBoyer> Bmagic++
15:31:38 <mmorgan> Bmagic++
15:31:39 <Bmagic> JBoyer++
15:31:39 <dluch> Bmagic++
15:31:43 <mmorgan> JBoyer++
15:31:46 <collum> Bmagic++
15:31:49 <collum> JBoyer++
15:32:12 <JBoyer> And there's certainly no reason it can't rotate, just so long as the next meeting running (or two, ideally) are known before the current one ends.
15:32:31 <tlittle> Bmagic++
15:32:39 <tlittle> JBoyer++
15:33:06 <JBoyer> Additionally, it's not like this is some rigid thing, so there's no reason to adhere strictly to the past agenda format, though maybe don't change too much all at once. :D
15:33:08 <Dyrcona> I can definitely stand in if needed, though I've missed a few meetings lately.
15:33:45 <JBoyer> And I can certainly help stand in too, and it's not like I'm not going to still be here, slowly typing at a non-copy-paste pace. :)
15:33:59 <Dyrcona> :)
15:34:10 <Bmagic> :)
15:34:41 <JBoyer> That was a very double-negative reassurance. To be more clear, I'll still be here, I just want to see the community get the effort it deserves to keep moving things forward.
15:34:48 <Dyrcona> JBoyer: You're giving away the tricks. (I did that with my info and action items today.)
15:35:36 <Bmagic> I can't guarantee error-free spelling :)
15:36:00 <Bmagic> English hard, code good
15:36:06 <JBoyer> Bmagic++ You've got a few weeks to figure it out. ;)
15:36:08 <JBoyer> Speaking of.
15:36:10 <Dyrcona> JBoyer++ English--
15:36:14 <JBoyer> #topic Announcements
15:36:18 <JBoyer> #info Next Meeting is June 13, 2023
15:36:24 <JBoyer> #endmeeting