15:00:02 <Bmagic> #startmeeting 2023-06-13 - Developer Meeting
15:00:02 <pinesol> Meeting started Tue Jun 13 15:00:02 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:02 <pinesol> The meeting name has been set to '2023_06_13___developer_meeting'
15:00:10 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-06-13
15:00:19 <Bmagic> #topic Introductions
15:00:43 <terranm> #info terranm is Terran McCanna, PINES
15:00:46 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:01:14 <shulabear> #info shulabear is Shula Link, PINES
15:01:15 <Stompro> #info Stompro = Josh Stompro, LARL
15:01:17 <sleary> #info sleary = Stephanie Leary, Equinox
15:01:25 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:01:27 <JBoyer> #info JBoyer = Jason Boyer, Equinox
15:01:31 <collum> #info collum = Garry Collum, KCPL
15:01:38 <jeffdavis> #info jeffdavis = Jeff Davis, Sitka
15:02:06 <Bmagic> feel free to info yourself as you arrive
15:02:07 <tslittle> #info tslittle = Tiffany Little, PINES
15:02:27 <Bmagic> #topic Action Items from Last Meeting
15:02:33 <Bmagic> #info Dyrcona will communicate what our git users need to do as a result of these changes via email and blog posts.
15:02:41 <Dyrcona> #info Done!
15:02:51 <Bmagic> lol, nice
15:02:53 <terranm> Dyrcona++
15:03:03 <Bmagic> Dyrcona++ # indeed
15:03:04 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:05 <tslittle> Dyrcona++
15:03:05 <shulabear> Dyrcona++ was very smooth process
15:03:06 <Dyrcona> I didn't get any questions, so I assume everyone has made the transition.
15:03:22 <sleary> Dyrcona++ it was very easy!
15:03:34 <Dyrcona> gmcharlt++ csharp_++
15:03:48 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:03:51 <Dyrcona> They both did some important steps.
15:04:37 <shulabear> gmcharlt++ csharp_++
15:04:38 <Bmagic> great work!
15:04:59 <berick> #info berick Bill Erickson, KCLS
15:05:07 <Bmagic> I think we can move on, though I don't see berick, nvm
15:05:14 <Bmagic> #topic OpenSRF
15:05:14 <berick> Dyrcona++
15:05:25 <Bmagic> #info RUST timeline
15:05:51 <Bmagic> berick: I threw this on the agenda because it was bare. Feel free to tell me to move on
15:06:11 <berick> well...
15:06:35 <berick> not much so say on the Rust side at this point.  kind of waiting/hoping others will get interested and join the momentum
15:06:48 <berick> i did at this https://github.com/kcls/evergreen-universe-rs/blob/main/PRIMER.md
15:06:51 <berick> tiny primer
15:07:13 <berick> i think the bigger question now is more about the Redis stuff, which has been decoupled from Rust now
15:07:18 <berick> and is ready for wider testing
15:07:33 <Dyrcona> berick++
15:07:37 <Bmagic> oh! berick++
15:07:40 <Dyrcona> I'll take a look.
15:08:11 <Dyrcona> It's time I pick up another programming language. Last year was lua.
15:08:22 <shulabear> I'm interested, but I'm also still learning Rust
15:08:25 <shulabear> berick++
15:08:26 <Bmagic> so, to be clear, you've coded some OpenSRF to use Redis without* Rust?
15:08:40 <berick> right, the Redis branches now fully function without Rust.
15:08:47 <berick> we're treateing them as 2 separate projects
15:09:00 <Bmagic> berick++
15:09:13 <berick> since there was (understandably) concern about rushing into Rust
15:10:10 <Bmagic> yes, it seems we could be causing us some undo treadmill work adopting Rust. Some good points were made over the email discussion
15:10:11 <Dyrcona> I think we should replace the back end C and Perl with Rust eventually, by that I mean the services.
15:11:26 <berick> well get learnin! :)
15:11:44 <Bmagic> I think some good takeaways were that if we were to adopt Rust, we should use it more widely, which, of course, can be a monster project
15:12:18 <berick> exactly, if adding dependencies, make it worth it
15:13:06 <Bmagic> it's "cool" but other than that, the supporting reasons were: {help me fill in the blank here}
15:13:28 <JBoyer> To explain one of the points of concern; Debian won't have a packaged Rust until I think Bookworm; so, just last week, and only 1 supported version. Otherwise you're basically running rust-current, so to speak.
15:14:26 <JBoyer> It's nice to have some idea of what versions people are using rather than finding out that 1.14.3 works but 1.15.7 doesn't, etc.
15:15:51 <jeffdavis> It would be good to have ways of trying out/adopting Rust for EG stuff without making it an EG dependency yet.
15:16:05 <jeffdavis> egsh looks cool, thanks for sharing that
15:16:07 <berick> jeffdavis: you can
15:16:13 <berick> yeah, that ;)
15:16:25 <berick> but of course it depends on the Redis branches
15:16:37 <berick> so, it's a long game
15:17:43 <jeffdavis> kind of works as a roadmap though - there's some time to get up to speed on Rust while Redis dev continues, then ramp up with Rust once the Redis stuff is in main?
15:18:10 <berick> jeffdavis: yeah, pretty much
15:18:34 <Bmagic> I'm sure more discussions will be had, we can table it. Good to know that berick has Redis up for testing sans Rust!
15:18:43 <Bmagic> berick++ # for good measure
15:18:56 <jeffdavis> yeah, really excited for Redis and hoping the Rust interest takes off
15:18:59 <JBoyer> berick++
15:19:12 <Bmagic> #topic Evergreen
15:19:15 <Bmagic> #info Post 3.11.0 release feedback
15:19:46 <Bmagic> Anything anyone want to talk about here? Thanks gmcharlt for posting the fixed tarball!
15:20:46 <Bmagic> gmcharlt++
15:20:55 <terranm> gmcharlt++
15:21:12 <Bmagic> moving on
15:21:15 <Bmagic> #topic Documentation
15:21:19 <Bmagic> #info Recent change to the docs server build wrapper script (JBoyer / Bmagic)
15:21:37 <Bmagic> Again, the agenda was bare and I thought of this. Thanks JBoyer!
15:22:41 <Bmagic> Recap: it was possible for the nightly docs build to destroy the website if certain pieces weren't perfect. JBoyer introduced a change that mitigates the problem
15:23:30 <Bmagic> moving on
15:23:36 <Bmagic> #topic New Business
15:23:46 <Bmagic> #info New devs onboarding
15:23:50 <Bmagic> #info http://list.evergreen-ils.org/pipermail/evergreen-dev/2023-June/000573.html
15:24:19 <Bmagic> sleary: I agree with all of your points
15:24:44 <sleary> Thanks to everyone who offered feedback to my email!
15:25:46 <Bmagic> the floor is open
15:25:55 <jeffdavis> I can't formally commit to anything, but we're onboarding a new dev next month at Sitka and I'm hoping we can contribute to community documentation for new devs as part of that
15:26:09 <terranm> jeffdavis++
15:26:19 <tslittle> jeffdavis++
15:26:33 <JBoyer> jeffdavis++ Any efforts are appreciated.
15:26:42 <sleary> jeffdavis++ and congrats on the additional hands!
15:26:55 <Bmagic> jeffdavis++
15:26:56 <jeffdavis> The existing new devs stuff is SUPER helpful even in its WIP state!
15:26:58 <terranm> we're at 2nd interview phase for our open position and I'm hoping to have them work on documentation as part of their learning process as well
15:27:18 <jeffdavis> nice :)
15:27:35 <sleary> terranm++
15:27:51 <shulabear> terranm++
15:27:55 <JBoyer> terranm++
15:28:26 <Bmagic> the evergreen-release channel was created on a whim and it seemed at the time that it might have just been created to solve one issue, but then, we kept using it. That's how I remember it
15:28:53 <sleary> I think it's fine to have a separate channel; there just needs to be a way for people to find out about it.
15:29:12 <sleary> I initially assumed I couldn't see it because I was using the web client while fighting with Quassel/Windows 11
15:29:27 <Bmagic> And now that it exists, I do seem to think that it's better that all of that chatter is off this channel
15:29:27 <sleary> but I got that working and I still don't see it in the channel list
15:29:55 <abneiman> +1 to One Channel to Rule Them All
15:30:14 <berick> I also favor a single channel.
15:30:23 <tslittle> +1
15:30:25 <berick> best for learning
15:30:50 <jeff> is there a reason or a concern with public logs of the release channel? is part of the idea that there's not-public links/etc flying around during release time?
15:31:49 <jeff> i've no strong opinion either way on one-channel or many-channels, but support having a list of "official" project channels and making logs more readily available for those channels.
15:32:02 <Bmagic> hmmm, it's public as far as I know. The security stuff wouldn't be there (correct me if I'm wrong releaseers)
15:33:05 <Dyrcona> It's public, but it is not logged by the bots.
15:33:07 <jeff> sleary: I think the reason you can't see the channel in your IRC client is the same reason you wouldn't be able to see this channel if you weren't already in it: the channels are +s ("secret") to avoid being listed in the commands that spam bots use, etc. Something we did long ago, and could test removing if folk think +s is causing more trouble than its worth.
15:33:14 <Bmagic> I mean, the chatter is public
15:34:00 <jeff> I mention the above because I'm happy to be the one to set up logging / join the bots / list the channels on the wiki or web page / toggle channel modes as needed / etc.
15:34:21 <Bmagic> so, shall we remove it?
15:35:32 <abneiman> since it's not logged, is there a need / process to preserve its historic data?
15:35:50 <jeffdavis> I'm not against removing +s but I'm not sure it solves the underlying problem, which is that release discussion is siloed in an underadvertised channel?
15:36:09 <Bmagic> I mean reamove the whole channel
15:36:17 <jeffdavis> ah
15:36:25 <jeffdavis> well I'm ok with that :)
15:36:30 <Dyrcona> Is release discussion really generally useful?
15:36:44 <mmorgan> Since it's not logged, is there historic data to preserve?
15:36:50 <jeff> I mean, the channel is currently listed on the IRC page on the website. I don't know if that's a recent addition.
15:37:19 <Dyrcona> Individual users would have their logs of the channel conversation, but that's it.
15:37:22 <Bmagic> I didn't realize we put it on our website. That makes me sway back to keeping it
15:37:26 <jeff> The only historical data would exist in individual users logs. I don't know if that's worth pursuing.
15:37:39 <JBoyer> I suppose release chatter in here can show where some rough edges may be even if people don't otherwise make note of them.
15:38:15 <JBoyer> I think the mention on the site is less than a month old, so not a strong indicator of usefulness or need.
15:38:24 <jeff> (but that page contradicts itself at present, since it claims that "everything on IRC is public and logged"
15:38:27 <jeff> )
15:38:33 <Bmagic> It might be worth a broader email to the community?
15:39:33 <jeff> I think it's up to the folk making use of the channel: if you're a release team participant, do you need the channel as a useful tool to help you do your work? If so, keep, and plan to log unless there's a reason not to.
15:40:50 <JBoyer> I don't expect a lot of strong opinions from people not involved in releases. I have used it some, but would have just pinged people in here if not.
15:40:52 <jeff> The agenda item is about findability/discoverability of channels, I think. Deciding to stop using a channel is I suppose one creative way of solving the issue... :-)
15:40:59 <Bmagic> It gets noisy in short bursts. I really don't know what the answer is. Just keep it and move on?
15:41:12 <sleary> I don't think we need to resolve this today, and I know the board will be discussing Slack and other options as part of this week's agenda item on funding community tools
15:41:31 <shulabear> sleary++
15:41:35 <mmorgan> JBoyer brings up a point. Would removing the release channel just lead to more private conversation on IRC?
15:41:48 <mmorgan> Which would not be public, for sure.
15:41:52 <Bmagic> sounds good, leaving it alone for now
15:41:55 <sleary> Thank you to whoever added the other channels to the web page
15:42:20 <Bmagic> sleary: did you want to touch on any of those sub points?
15:43:12 <sleary> Not at present, but if anyone would like to claim to-do items, I will be happy to help with any of them after the ALA conference.
15:43:46 <terranm> Maybe keep that list on the agenda for the next few months to touch base on?
15:43:56 <mmorgan> +1
15:43:56 <Bmagic> yep
15:44:08 <sleary> +1
15:44:17 <jeffdavis> terranm++
15:44:40 <Bmagic> #topic Announcements
15:44:47 <Bmagic> #info Next meeting is July 18, 2023 (open for discussion)
15:45:08 * mmorgan added a last minute agenda item...
15:45:11 <sleary> Bmagic did mmorgan want to discuss Launchpad stats?
15:45:24 <Bmagic> oops, sorry, I didn't refresh
15:45:33 <mmorgan> :)
15:45:44 <mmorgan> I've been compiling Launchpad stats since 2021, happy to continue if they're useful.
15:45:50 <Bmagic> well, I guess it's just going to end up under Announcements
15:45:59 <Bmagic> #info Launchpad Stats - useful? (mmorgan)
15:46:12 <mmorgan> I've entered the stats up til now into this sheet:
15:46:22 <mmorgan> https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing
15:46:33 <Bmagic> #info https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing
15:46:39 <mmorgan> Also was playing with some charts, I'm happy to continue if this is useful info.
15:47:24 <Bmagic> I think it's great! mmorgan++
15:47:25 <shulabear> mmorgan++
15:47:35 <terranm> mmorgan++
15:47:45 <collum> mmorgan++
15:48:38 <Bmagic> I wonder if we can get some version of this up on the community site somewhere?
15:49:04 <mmorgan> Ok! Hoping this will show some trends and yield useful info as we move along.
15:49:21 <Bmagic> Maybe automated? For all I know, this has been done before and there is a project somewhere on github....
15:49:40 <jeff> mmorgan++ I think it's good to track metrics. We should consider if there are any others that we would like to track, and please speak up if you'd like help automating the task or otherwise lightening your burden. :-)
15:49:43 <mmorgan> I'm all for getting it on the communit site, and automating!
15:49:51 <sleary> Bmagic certainly. I have some WordPress charts and graphs plugins stashed... somewhere. I'll put it on the website fixer-upper to-do list
15:50:14 <mmorgan> jeff++
15:50:18 <mmorgan> read my mind!
15:50:32 <Bmagic> very cool, yes! I'm for seeing this data easily. It can only help us
15:50:37 <terranm> +1
15:51:08 <shulabear> +1
15:51:31 <Bmagic> do we have an action item here?
15:51:42 <mmorgan> #action mmorgan will explore moving LP stats to community site and automating same
15:51:52 <Bmagic> ty
15:52:20 <Bmagic> Looping back to the next meeting date. Everyone OK with moving to the following week from our normal in July?
15:52:51 <Bmagic> July 18th
15:52:58 <Dyrcona> Bmagic: Anyw particular reason?
15:53:08 <Bmagic> I'm on vacation that week
15:53:16 <Dyrcona> :)
15:53:55 <Bmagic> we're down to a couple minutes
15:53:59 <Dyrcona> I'm OK with moving the date of the meeting.
15:54:06 <sleary> +1
15:54:07 <jeffdavis> date change works for me
15:54:15 <collum> +1
15:54:16 <mmorgan> no objection from me
15:54:20 <Bmagic> #topic Feedback for New Features Under Development
15:54:25 <Bmagic> #info Enhanced concerto improvements (date carry) Lp 1901932
15:54:25 <pinesol> Launchpad bug 1901932 in Evergreen "Wish List - Enhanced Concerto dataset" [Wishlist,Fix released] https://launchpad.net/bugs/1901932
15:55:01 <Bmagic> not sure if it's worth soaking up the time, but I did update that branch to deal with the dates
15:55:18 <terranm> Bmagic++
15:55:26 <jeffdavis> I wonder if it would be worth opening a new bug for the updates? easy to miss otherwise
15:55:26 <Bmagic> Anyone want to plug their patch with these last 5 minutes?
15:55:27 <berick> isn't it already merged?
15:56:03 <Bmagic> berick: see comment #8
15:56:27 <Bmagic> for tracking reasons, I wasn't sure. Yes, I can make another LP bug
15:56:37 <berick> +1 to new bug
15:56:48 <mmorgan> +1
15:56:52 <gmcharlt> yeah, falls in the general rule that comments in fix released bugs can easily be missed
15:56:54 <Bmagic> #action Bmagic will create a new LP bug for the Enhanced concerto code updates
15:57:08 <gmcharlt> (e.g., most of my committer workflow is tied to LP queries that ignore fixed-relesaed bugs
15:57:13 <Bmagic> any other patches to throw in here?
15:57:23 <Bmagic> gmcharlt: makes sense
15:57:58 <terranm> No patches, but I just rolled out our first HTML action trigger notification and it makes me happy!
15:58:08 <Bmagic> awesome!
15:58:09 <mmorgan> terranm++
15:58:13 <Bmagic> terranm++
15:58:14 <shulabear> terranm++ It looks great!
15:58:18 <sleary> terranm++ \o/
15:58:35 <terranm> These are the mockups of what they will all look like when I'm done - https://pines.georgialibraries.org/notices/
15:59:07 <collum> terranm++
15:59:10 <mmorgan> Oooh! Really nice!
15:59:12 <Bmagic> Thanks everyone, calling it
15:59:15 <Bmagic> #endmeeting