15:06:58 <Bmagic> #startmeeting 2023-07-18 - Developer Meeting
15:06:58 <pinesol> Meeting started Tue Jul 18 15:06:58 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:58 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:58 <pinesol> The meeting name has been set to '2023_07_18___developer_meeting'
15:07:04 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-07-18
15:07:12 <Bmagic> #topic Introductions
15:07:16 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:07:18 <terranm> #info terranm = Terran McCanna, PINES
15:07:32 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:07:35 <berick> #info berick Bill Erickson, KCLS
15:07:36 <sandbergja> #info sandbergja = Jane Sandberg, Princeton University Library
15:07:37 <sleary> #info sleary = Stephanie Leary, Equinox
15:07:50 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:07:54 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:08:12 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:08:29 <Bmagic> Feel free to introduce yourself throughout
15:08:38 <Bmagic> #topic Action Items from Last Meeting
15:08:53 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:08:59 <Bmagic> Go ahead mmorgan
15:09:02 * mmorgan would like to defer to next meeting :)
15:09:25 <Bmagic> alright :)
15:09:36 <Bmagic> #action mmorgan will explore moving LP stats to community site and automating same
15:09:46 <Bmagic> #info Bmagic will create a new LP bug for the Enhanced concerto code updates
15:09:58 <Bmagic> This is done: https://bugs.launchpad.net/evergreen/+bug/2023690
15:09:58 <pinesol> Launchpad bug 2023690 in Evergreen "Enhanced Concerto dataset (Cont.)" [Undecided,New]
15:10:15 <sandbergja> Bmagic++
15:10:26 <Bmagic> I think that's that for that
15:10:27 <mmorgan> Bmagic++
15:10:43 <Bmagic> #topic OpenSRF
15:11:17 <Bmagic> Nothing on the agenda, but if anyone has anything please go ahead
15:11:40 <berick> one thing..
15:12:26 <berick> https://bugs.launchpad.net/evergreen/+bug/2017941 -- thanks to Dyrcona for testing.  testing going well so far.  additional testing of course appreciated
15:12:26 <pinesol> Launchpad bug 2017941 in OpenSRF "Migrate from Ejabberd to Redis for OpenSRF Messaging" [Wishlist,Confirmed]
15:12:45 <berick> i've addressed the known issues, so we need more known issues! :)
15:13:03 <Bmagic> tasty!
15:13:29 <Bmagic> Anyone want to make themselves actionable for testing?
15:14:41 <Bmagic> alrighty, thanks berick. Anything else?
15:14:49 <berick> nope, thanks
15:14:53 <Bmagic> #topic Evergreen
15:15:05 <Bmagic> Again, nothing on the agenda. But please go ahead
15:15:13 <mmorgan> We have point releases on the calendar for tomorrow, can we make those happen?
15:15:22 <abneiman> any plans for point .... yes, what mmorgan said
15:15:35 <mmorgan> :)
15:15:43 <Bmagic> I'm available tomorrow
15:16:28 <sandbergja> I could pitch in
15:16:43 <Bmagic> I haven't looked, how's the release notes?
15:16:55 <abneiman> Tomorrow is tough but I can commit to release notes on Thursday
15:17:09 * mmorgan is willing to help as well.
15:17:21 <Bmagic> so, maybe Thursday instead of tomorrow?
15:17:33 <abneiman> none of them appear to be giant releases - fewer than a dozen fix-commits each
15:18:05 <abneiman> +1 to Thursday IMO
15:18:08 <sandbergja> Thursday is much more open for me as well
15:18:15 <mmorgan> +1
15:18:16 <Bmagic> cool, Thursday then!
15:18:29 <Bmagic> Not sure if that needs to be official as far as this meeting goes
15:18:35 <Bmagic> so....
15:18:39 <Bmagic> #topic Documentation
15:18:49 <abneiman> Bmagic: will you put out a message to the listserv "no more commits after Weds evening please"
15:19:02 <Bmagic> abneiman: ah, sure!
15:19:25 <Bmagic> Anything from DIG?
15:20:05 <abneiman> are docs still building overnight? I pushed a tiny fix yesterday but I don't see it
15:20:21 <dluch> Sorry, just got here!
15:20:38 <Bmagic> dluch: just in time, would you like to add anything from DIG?
15:21:01 <Bmagic> abneiman: yes, builds are nightly, I'll see what's up with that
15:21:12 <abneiman> Bmagic++ thanks
15:21:55 <dluch> DIG...has a lot going on. In addition to documentation, wiki updates/rearranging, new folks, permissions project, and...stuff.
15:22:01 <dluch> Sorry, unprepared
15:22:13 <Bmagic> dluch++ # go DIG!
15:22:30 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:22:48 <Bmagic> next
15:22:49 <Bmagic> #topic Launchpad Status (as of noon Eastern (7/11/23)
15:22:59 <Bmagic> Imma spam the stats for the meeting sakes
15:23:08 <Bmagic> #info Snapshot
15:23:09 <Bmagic> #info Open Bugs - 2948
15:23:09 <Bmagic> #info Pullrequests - 82
15:23:09 <Bmagic> #info Signedoff - 12
15:23:09 <Bmagic> #info Updates Since Last Meeting
15:23:09 <Bmagic> #info Bugs Added - 36
15:23:11 <Bmagic> #info Pullrequest tag Added - 5
15:23:14 <Bmagic> #info Signedoff tag Added - 2
15:23:16 <Bmagic> #info Fix Committed - 3
15:23:27 <Bmagic> mmorgan++
15:23:45 <mmorgan> Just FYI, I recorded those stats as of last week's normal meeting time. There have been some commits since :)
15:24:06 <Bmagic> I figured, the as-of date is there
15:24:29 <Bmagic> moving on
15:24:36 <Bmagic> #topic New Business
15:24:48 <Bmagic> #info specific tutorials and examples that would be helpful for new devs
15:24:57 <Bmagic> #info https://wiki.evergreen-ils.org/doku.php?id=newdevs:tutorials-wanted
15:25:09 <Bmagic> anyone want to comment on that?
15:25:39 <sleary> building on our discussion from last month, I pulled out a few specific things that I know people have been struggling with. Grids especially!
15:25:54 <terranm> sleary++
15:25:55 <sleary> Feel free to add to this, of course.
15:26:10 <sleary> Or rearrange the priorities.
15:26:15 <jeff> are you looking for someone to write up developer-focused docs, or present at a newdevs meeting, both, other? :-)
15:26:21 <mmorgan> sleary++
15:26:30 <sleary> either or both!
15:26:35 <dluch> sleary++
15:26:36 <Bmagic> sleary++ # new-dev wrangling
15:27:12 <sleary> also re: developer-facing docs, I have started moving the accessibility developer's guide from its Google Doc draft into the wiki. Please feel free to ping me if you would like anything to be expanded upon; I can see where some things are a bit terse now that they have their own pages. https://wiki.evergreen-ils.org/doku.php?id=accessibility:start
15:27:37 <terranm> sleary++
15:27:43 <Bmagic> sleary++
15:27:58 <terranm> Bmagic in case you didn't refresh your page, I added another bullet under New Biz
15:28:03 <Bmagic> oh thanks!
15:28:16 <terranm> I'd like to schedule the next Bug Squashing Week in August - any preferences for the week of Aug 14 or week of Aug 21?
15:28:19 <Bmagic> I guess I did because it didn't change dhwn I refreshed
15:28:32 <Bmagic> #info Next Bug Squashing Week - August?
15:29:14 <JBoyer> The week of the 21st is better for me
15:29:43 <Bmagic> that week looks good for me as well
15:29:48 <Bmagic> (21st)
15:30:08 <terranm> Barring no arguments against, I'll schedule it for the week of the 21st then. Thanks!
15:30:15 <Bmagic> terranm++
15:30:26 <mmorgan> terranm++
15:30:28 <Bmagic> anything else for new business?
15:30:46 <Bmagic> #topic Announcements
15:30:52 <Bmagic> #info Next meeting is August 8th, 2023
15:31:03 <dluch> terranm++
15:31:22 <Bmagic> that cool? I suppose I have the power to cancel the 8th meeting if the agenda is light
15:31:56 <sandbergja> could we use it to hammer out some of the documentation that sleary mentioned?
15:31:59 <sandbergja> like a working meeting?
15:32:10 <Bmagic> Hearing no non-coolness, I'll schedule it for the 8th next month
15:32:33 <Bmagic> sandbergja: yes! Stellar idea
15:32:37 <sleary> sandbergja++ that would be wonderful
15:33:11 <Bmagic> Anything else while the meeting is still in session?
15:33:13 <terranm> +1
15:33:48 <Bmagic> #endmeeting